Neu Shopware - dreischild - SEO-Plugin - Daten von JTL zum Shopware Shop exportieren - z.b. dreisc_seo_url - Wie?

n8schicht27

Gut bekanntes Mitglied
6. Oktober 2006
898
10
Bonn
Hallo zusammen,

gibt es hier jemanden, der den Shopwareshop mit dem Dreischild-Seo-Professional - Plugin betreibt?

Wie verwaltet Ihr die Seo-URL?

Ich würde diese gerne in der JTL-Wawi als Attribut verwalten.
Habe mir dafür das Attribut:
dreisc_seo_url - als Funktionsattribut angelegt.
Leider wird es nicht übertragen.

Was mache ich falsch?

Ist dies überhaupt möglich?

Ich bitte um Rückmeldung.

Danke
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
zuwas überhaupt dieses Plugin.

Ich habe das nachgebaut was Dreischild macht!

Leg ein Attribut wie im JTL Guide erklärt an das es übertragen wird. Dann passe die SEO Regeln im Shopware an.
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
Hier meine Einstellungen:

Einmal das Attribut, dieses musst du halt wie im Guide erklärt übertragen.

Danach die Einstellungen im SEO URL Kontext.

Es heißt vereinfacht gesagt: Wenn das Feld gefüllt dann nimm das Feld als URL ansonsten mache es wie (es Shopware sowieso macht)

Bei mir steht dann zb im Feld /xyz/yzx.html also alles nach domain.de

Im Beispiel www.domain.de/xyz/yzx.html
 

Anhänge

  • C2JJeKZenj.png
    C2JJeKZenj.png
    51,3 KB · Aufrufe: 56
  • wBsB8wjPO6.png
    wBsB8wjPO6.png
    3,9 KB · Aufrufe: 55

n8schicht27

Gut bekanntes Mitglied
6. Oktober 2006
898
10
Bonn
aber Dein Beitrag bezieht sich jetzt nicht auf das SEO-Professional-Plugin von Dreischild?
So wie ich das verstehe, hast Du Dir deine eigene SEO Einstellung bzw. Freitextfelder gebaut und dieses dann entsprechend im Theme angepasst.

Das meine ich aber nicht.
Ich möchte mit JTL - das SEO-Professional-Plugin von Dreischild befüllen.
Und dass geht leider nicht - wieso?
 

3po

Sehr aktives Mitglied
30. August 2011
2.567
87
das geht, du musst hier nur noch mal alle Schreibweisen (beide vollkommen identisch), freigaben für Shop usw. prüfen. Ebenso muss naturlich die Sw Version sowie Connector die mindestversion haben ab wann es unterstützt wird
 
  • Gefällt mir
Reaktionen: n8schicht27

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
das geht, du musst hier nur noch mal alle Schreibweisen (beide vollkommen identisch), freigaben für Shop usw. prüfen. Ebenso muss naturlich die Sw Version sowie Connector die mindestversion haben ab wann es unterstützt wird
Ich nutze ein ähnliches Plugin und möchte die Werte: emz_seo_headline_block_1 usw befüllen.

Ich habe das aktuelle JTL-Connector Plugin und die aktuelle 1.4.20.2 JTL-Wawi und den aktuellen Shop.

Reicht es wenn ich die Attribute in der Wawi anlege und dann übertragen lasse oder was muss ich zusätzlich machen?
 

n8schicht27

Gut bekanntes Mitglied
6. Oktober 2006
898
10
Bonn
Wenn die Felder in Shopware schon angelegt sind - dann sollte es klappen.
Wichtig ist, dass die Attribut-Felder in JTL exakt so heißen wie in Shopware.
Dann funktioniert der Abgleich.
Probier es am besten erst einmal mit einem Testartikel aus.
Bei mir hat es jedenfalls funktioniert nachdem ich den Namen korrigiert hatte.
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
Also ich habe mir den "Spaltennamen" direkt aus den Quellcode rauskopiert.
Habe das Attribute einmal als Funktionsattribut und einmal als normales Attribut angelegt.
Beide male war das vorhandene Freitextfeld bei der Kategorie nicht gefüllt. Kann nur sein das es bei den Artikeln geht und bei den Kategorien noch nicht.
Will mal hoffen das es bald bei den Kategorien kommt.
 

3po

Sehr aktives Mitglied
30. August 2011
2.567
87
Hast Du das Attribut auch in der WAWi im Bereich Kategorie angelegt und nicht bei Artikeln, schon oder?
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
Steuerst du ein vorhandenes Attribute bzw Freitextfeld in Shopware an?
Oder hast du ein neues erstellt (bsp: Attribute3)

Ich will ja ein Attributefeld aus einen Plugin ansteuern, das das Plugin erstellt hat und ich auf die Namensgebebung keinen Einfluss habe.
 

3po

Sehr aktives Mitglied
30. August 2011
2.567
87
ich habe ein neues angelegt mit bspw. block1_block2_block3 (hier ist wichtig das zuvor auch in SW als Tabelle Kategorie gewählt wurde) das hat aber keinen Einfluss auf das befüllen, also ob es selbst angelegt ist oder ein vorhandenes eines Plugins. Wir befüllen etliche Attribute die von Plugins erstellt wurden, jedoch bei Artikeln. wir verwenden keine Plugins auf Kategorie ebene
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
Ok dann teste ich das nochmal hier:
Hast du das als Funktionsattribut oder als "normales Attribute" angelegt.
Das es bei JTL sowie auch bei Shopware jeweils in den Kategorien sein muss ist selbstverständlich.
 

3po

Sehr aktives Mitglied
30. August 2011
2.567
87
ich habe es als Funktionsattribut in der WAWI angelegt. In SW erst als TEXT und dann auch als Checkbox, geht beides
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.169
112
Küps
Gerade nochmal alle Attribute aus der Wawi gelöscht und übertragen lassen. Er hat jeweils in den Kategorien was übertragen und somit denke ich hat er was gelöscht.
Die Felder in JTL Wawi eingerichtet als Funktionsattribut neu eingerichtet und den Shops usw zugewiesen.
Die Header als Kurztext die normalen als Fulltext.

Habe danach von den Globalen Daten und den Kategorien eine Komplettübertragung gemacht.

Hier der Stand sowei ich ihn hier zeigen kann. Habe in 2 Kategorien was eingetragen und übertragen lassen.
Aber ich sehe im Backend des Shops nichts

@3po welche Versionen hast du hier laufen?
 

Anhänge

  • 2019-02-22 14_48_16-GlassPanelForm.png
    2019-02-22 14_48_16-GlassPanelForm.png
    143,7 KB · Aufrufe: 22
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL Connector zu Shopware 6 gibt Fehler aus Shopware-Connector 2
Neu Shopware Connector - Felder nicht übertragen Shopware-Connector 0
Neu Shopware 6 Connector Problem beim Abgleich von Bildern Shopware-Connector 1
Neu Shopware 6 Auftrags-Import stockt Bestände auf Shopware-Connector 0
Neu JTL-WaWi <-> Shopware 5: Übertragung Timeout / Welche Daten werden übertragen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Shopware - Fehler beim Senden von Artikeln Shopware-Connector 0
Neu Shopware 6 Connector verweigert seit Verlängerung SSL-Zertifikat seinen Dienst Shopware-Connector 4
Neu Shopware 6 Connector - erweiterte Preise ab 6.4.7 möglich Shopware-Connector 0
Neu Shopware 6 - Einstellungen im Kundencenter - Standard Verkaufskanäle (kommasepariert) Shopware-Connector 0
Neu Shopware 6 Verkaufskanäle und Shopware-Connector Shopware-Connector 1
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 1
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 2
Neu JTL-Vouchers für Shopware 5 Plugin Shopware-Connector 1
Neu Sonderpreise JTL - Shopware Shopware-Connector 0
Neu Abgleichfehler: No shopware language found for language iso "" Shopware-Connector 0
Neu Wechsel von Shopware Cloud zu JTL Shop 5 Onlineshop-Anbindung 2
Neu Shopware 6 mit Custom Products - Probleme bei Auftragsimport Shopware-Connector 18
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu Suche Freelancer/Partner für WAWI & Connector Shopware 6 Dienstleistung, Jobs und Ähnliches 0
Neu Freelancer / Berater für Shopware 6 Connector & mehr gesucht Dienstleistung, Jobs und Ähnliches 0
Neu 'supplytime' an Shopware übetragen Shopware-Connector 5
Neu Sind TABS schlecht für SEO? User helfen Usern - Fragen zu JTL-Wawi 0
Neu URLs mit _s1 tilgen und mit SEO-URL gleichsetzen Allgemeine Fragen zu JTL-Shop 1
Beantwortet Plugin entfernen? SEO-Cleaner [35 Fehler: XML-Version entspricht nicht der Konvention.] Betrieb / Pflege von JTL-Shop 2
Neu Automatisch generierte SEO Titel für jede Produkt User helfen Usern - Fragen zu JTL-Wawi 1

Ähnliche Themen