Neu Shopabgleich holt keine Bestellungen ab

dampfer

Neues Mitglied
2. Oktober 2021
4
0
Moin zusammen,

ich habe JTL-Wawi 1.5.51.1 im Einsatz und einen Shopware 5 Shop.

Ich habe im Shop eine Testbestellung ausgeführt, die auch korrekt im Shop angezeigt wird. Allerdings holt die Wawi sie nicht ab. Ich habe den Worker mal neu gestartet, nix. Dann hab ich den Worker ausgeschaltet und den Shopabgleich manuell gestartet. Funktioniert ebenso nicht. Ich erhalte aber auch keine Fehlermeldung im Log, es sieht einfach so aus, als wäre die Bestellung nicht da. Wo kann ich da anfangen mit der Suche?

Viele Grüße
 

Condorraptor

Sehr aktives Mitglied
18. September 2018
383
43
Berlin
Du könntest zum Beispiel einmal checken ob unter Onlineshop -> Onlineshop Anbindung -> Verbindung testen die Verbindung fehlerfrei hergestellt werden kann. Vielleicht gibt es ja ein Problem mit dem Connector
 

NETZdinge.de

Sehr aktives Mitglied
7. April 2010
1.763
212
Versuche mal die /dbeS/mytest.php aufzurufen und schalte vorher die Fehler Ausgabe in der config ein…

wenn es ein Server ist, der auf nginx läuft muss eventuell da was für Shop 5 angepasst werden… da gibt es eine Weiterleitung, die dann nicht funktioniert, aber erforderlich ist… Mit Apache kein Problem, mit nginx muss das eingestellt werden…
 

dampfer

Neues Mitglied
2. Oktober 2021
4
0
Danke euch, die Connectorverbindung klappt, ich bekomme die Erfolgsmeldung. Wenn ich shopurl/dbeS/mytest.php oder shopurl/jtlconnector/dbeS/mytest.php aufrufe, komme ich nur auf die Hauptseite vom Shop.

Ich hab das Fehlerlogging eingeschaltet.

Wenn ich die jtlconnector-url aufrufe, bekomme ich die Fehlermeldung wie sie auf der Guide-Seite steht.

Code:
{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception 'jtl\\Connector\\Core\\Exception\\RpcException' (Code: -32600) with message 'Invalid Request' in \/var\/www\/vhosts\/shopurl\/shopurl\/engine\/Shopware\/Plugins\/Community\/Frontend\/jtlconnector\/vendor\/jtl\/connector\/src\/Core\/Rpc\/RequestPacket.php:143"},"jtlrpc":"2.0","id":"unknown"}

Ich sehe in der global Logdatei vom Connector das hier:

Code:
[2021-12-29T22:02:39.518329+01:00] global.ERROR: Exception 'jtl\Connector\Core\Exception\SessionException' (Code: 0) with message 'No session' in /var/www/vhosts/shopurl/shopurl/engine/Shopware/Plugins/Community/Frontend/jtlconnector/vendor/jtl/connector/src/Application/Application.php:634 [] []
[2021-12-29T22:09:42.296233+01:00] global.ERROR: Exception 'jtl\Connector\Core\Exception\RpcException' (Code: -32600) with message 'Invalid Request' in /var/www/vhosts/shopurl/shopurl/engine/Shopware/Plugins/Community/Frontend/jtlconnector/vendor/jtl/connector/src/Core/Rpc/RequestPacket.php:143 [] []
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu [modified shop] plötzlich Fehler beim Shopabgleich - Artikel einstellen nicht möglich Modified eCommerce-Connector 3
Neu Prestashop Shopabgleich Varkombi und Variationsbilder PrestaShop-Connector 5
Neu Fehler beim Shopabgleich WooCommerce-Connector 3
Neu Entity Manager is closed - Shopware 5 Connector / Shopabgleich Shopware-Connector 2
Neu Keine IMAP Verbindung zu Office365 mehr möglich Servicedesk (Beta) 2
Neu Workflow erstellt keine neuen Ordner User helfen Usern - Fragen zu JTL-Wawi 2
Beantwortet Nach dem Update von 1.5 auf 1.6 kein "JTL-Worker: Status" und keine Worker-Steuerung mehr JTL-Wawi - Fehler und Bugs 2
Varianten/Kindartikel Anzeige in Aufträgen/Rechnungen/etc. es werden keine Maße angezeigt JTL-Wawi 1.6 0
Vordefinierte Filter keine Daten JTL-Wawi 1.6 7
Neu Mailen: Keine Absenderadresse angegeben JTL-Wawi - Fehler und Bugs 0
Keine Blog Vorschaubilder nach Umstellen auf WebP Einrichtung JTL-Shop5 0
Neu Wir bekommen bei Amazon keine Ware mehr hochgeladen Individuelle Listenansichten in der JTL-Wawi 2
Neu Über Nacht plötzlich keine offenen Lieferscheine trotz bezahlter Bestellungen JTL-Wawi - Fehler und Bugs 4
Neu Amazon VCS Lite - Verkauf nach Norwegen - Amazon erstellt 2 Rechnungen (brutto und netto) - Wawi liest keine ein Amazon-Anbindung - Fehler und Bugs 0
Neu Keine Kategoriebilder, Produktbilder sind aber vorhanden Allgemeine Fragen zu JTL-Shop 2
Neu Google Exportformat Attribut "keine Preissuchmaschiene" Allgemeine Fragen zu JTL-Shop 2
Gelöst Paypal Checkout // Keine Variations-Übermittlung & Freitextfelder Plugins für JTL-Shop 2
Neu Shopkonfiguration Connector konfigurieren keine Auswahl möglich WooCommerce-Connector 0
Neu Keine Anzeige der Versandkosten in Spalte "Bezeichnung" Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu JTL - AMAZON - keine korrekte Anzahl an Variationen Amazon-Anbindung - Fehler und Bugs 1
Neu keine E-Mails Installation von JTL-Wawi 5
Neu Keine SCX Shops unter Artikelfilter JTL-Wawi - Fehler und Bugs 0
Neu Gutschriften zeigen keine Einheiten in den Formularen, Gutschriften werden als "3 Währungen" markiert [JTL WAWI 1.6.36.0] JTL-Wawi - Fehler und Bugs 0
Neu Connector keine Verbindung WooCommerce-Connector 1
Neu JTL Shop 5 zeigt keine Kategorien an Allgemeine Fragen zu JTL-Shop 9
Neu PayPal Checkout - aktuell keine Version verfügbar Plugins für JTL-Shop 8
Neu Ausblenden Filter/Sortieren = keine Variationen mehr sichtbar/auswählbar JTL-Shop - Fehler und Bugs 1
Neu Auftrag, extern, DB "readOnly" - keine Workflows möglich (nichtmal gesperrt) JTL-Wawi - Fehler und Bugs 0
Neu Keine Verbindung zum SQL Server User helfen Usern - Fragen zu JTL-Wawi 4
Neu Fehlermeldung statt Bestellseite - keine Bestellungen möglich ! Bezahlversion ! Allgemeine Fragen zu JTL-Shop 6
Neu Shop 5 / Fehlermeldung "Es steht keine Versandart zur Verfügung" JTL-Shop - Fehler und Bugs 2
Neu Trusted Shops Produktbewertungen - keine Rich-Suchergebnisse - keine mobile Darstellung Plugins für JTL-Shop 0
Neu Amazon nur Aufträge abrufen, aber keine Produktdaten aktualisieren Amazon-Anbindung - Ideen, Lob und Kritik 6
Neu Versand mit Packtisch+ es wird keine Rechnung per Mail geschickt Arbeitsabläufe in JTL-Wawi 1
Gelöst Keine Verbindung zur Datenbankverwaltung JTL-Wawi - Fehler und Bugs 3
Neu Suche SQL - Artikel, die auf ebay.xx nicht gelistet sind bzw. keine Vorlage haben User helfen Usern - Fragen zu JTL-Wawi 2
Neu SEIDE WOCHEN KEINE INDEXIERUNG MÖGLICH Allgemeine Fragen zu JTL-Shop 7
Neu JTL-Datenbankverwaltung findet keine BAK Datei Installation von JTL-Wawi 6
Neu Hersteller anlegen --> Absturz (keine Rückmeldung), JTL-Wawi 1.6.35.2 JTL-Wawi - Fehler und Bugs 2
In Diskussion Netto für Geschäftskunde (keine Möglichkeit) JTL-POS - Fehler und Bugs 2
Neu Repricer Logbuch seit dem 15.2.22 keine Einträge mehr JTL-Repricer für JTL-Wawi und Web 11
Neu JTLShop5.1.2 Livesearch - Error in Google Search Console /Livesuche - Keine Daten verfügbar. User helfen Usern - Fragen zu JTL-Wawi 0
In Bearbeitung Barentnahme oder Einzahlung, keine Text Eingabe möglich! JTL-POS - Fehler und Bugs 1
Neu Keine Zugangsdaten übermittelt Installation / Updates von JTL-Shop 1
Neu Keine Exportvorlage der Versandart zugeordnet (Fehler 425.001) Ebay JTL-ShippingLabels - Fehler und Bugs 0
Neu Lastschrift auftrag erstellt keine IBAN übernommen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Menge im Angebots PDF wird aufgerundet und es werden keine Nachkommastellen angezeigt. User helfen Usern - Fragen zu JTL-Wawi 7
Neu Zur Shop-Kundengruppe '27c19f8dxxxxxx' konnte keine Wawi-Kundengruppe gefunden werden. Shopware-Connector 0
Beantwortet Warenpost International (neu) Fehlermeldung sequenz enthält keine elemente JTL-ShippingLabels - Fehler und Bugs 7
Neu Keine Übertragung bei Ohne Versand abschließen WooCommerce-Connector 0

Ähnliche Themen