Abgelehnt Scanprobleme im WMS

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

HMS_IT

Sehr aktives Mitglied
29. Januar 2014
534
27
Leipzig
#1
Hallo Zusammen,

mir ist gerade an einem Kundenartikel ein Scanproblem des WMS aufgefallen und vlt. auch an anderer Stelle im Forum behandelt, aber nie so direkt...

Ich habe bei einem Artikel bspw. einen 13stelligen EAN Code: 0752454223503
Meine Scanner geben einheitlich folgendes aus: 752454223503

Die Wawi selbst ist da fehlertolerant und findet den korrekten Artikel mit 752454223503.
Das WMS jedoch findet keinen Artikel, weil es zwingend eine korrekte Eingabe erwartet, d.h. ich finde den Artikel im WMS nur, wenn ich die EAN manuell erfasse mit der führenden 0 der EAN.

Eine Abhilfe schafft die Einstellung: UPC immer als EAN13 scannen, damit liest der Scanner die führende 0 und findet den Artikel... ABER zu früh gefreut.

Denn eine 12stellige EAN bekommt dann eine weitere 0 vorangestellt und das WMS steigt wieder aus, weil es dann diese Artikel wiederum nicht findet. Ein Teufelskreis...

Daher die Frage an die Entwickler: ist es ein Bug oder ein Feature??? ;)

Daniel

PS: Ja, ich könnte alle EANs "umformatieren" und auf 13 Stellen bringen - Das ist aber prinzipiell mühsam bei mehreren 10.000 Artikeln und vor allem für die Zukunft nicht fehlertolerent genug...
 

Stephan Handke

Moderator
Mitarbeiter
2. Juli 2009
2.970
127
Hürth
#2
JTL- WMS interessiert sich halt für eindeutige Werte. Was auch gewünscht und so korrekt ist.

JTL-WMS sucht nicht nach vergleichbaren Werten - sondern nach exakten Werten. Keine Fehlertoleranz = keine Pack-/Pickfehler.

Es könnte ja auch
752454223503
7524542235032
1752454223503
0752454223503
7524542235030
geben usw..

Du solltest deine Scanner einheitlich konfigurieren und entsprechend die EAN auch einheitlich über die Scanner in JTL- Wawi einpflegen.

Fehlende führende Nullen kannst du bequem über JTL- Ameise auch für viele tausend Artikel ergänzen, indem du die EAN exportierst, mit Excel oder OpenOffice anpasst, und dann wieder importierst.

Um für die Zukunft Fehler zu vermeiden, kannst du dir einen JTL- Workflow anlegen, der bei Anlage oder Änderung eines Artikels prüft, ob im EAN-Feld eine GTIN-12 bzw. UPC-A anstelle einer EAN13 eingetragen wurde - falls ja, sende eine E-Mail an den Chef.

Also ich sehe hier für JTL keinen Handlungsbedarf.
 

HMS_IT

Sehr aktives Mitglied
29. Januar 2014
534
27
Leipzig
#3
Hallo Stephan,

danke für Dein Feedback und aus der Richtung betrachtet, stimme ich Dir absolut zu...
Ich bin eigentlich überrascht, dass ich erst jetzt über dieses Thema gestolpert bin, da bis jetzt jeder Barcode (egal ob 12 oder 13 Stellen EAN mit und ohne führender 0) problemlos sowohl in WAWI, als auch WMS verarbeitet werden konnten.

Werde jetzt mal nachdenken müssen, was das beste Procedere ist, die Händler verarbeiten ja auch nur die Infos, die sie vom Hersteller bekommen...

Daniel
 

thedrive123

Aktives Mitglied
17. Januar 2010
71
1
#4
Hallo
Wir legen in solchen Fällen in der WAWI unter Allgemein die 12 stellige UPC-A (EAN) mit einer 0 vorweg an , und unter Sonstiges fügen wir ein Gebinde hinzu und geben dort unter EAN die 12 stellige Nummer ohne 0 vorweg an.
so wird dieser Artikel auch in der WMS gefunden
 
Zustimmungen: Stephan Handke

HMS_IT

Sehr aktives Mitglied
29. Januar 2014
534
27
Leipzig
#5