Beantwortet Programm starten in C:\Program Files (x86)\JTL-Software (Ameise) - wie Pfad angeben?

  • JTL-Connect 2022: Ihr habt noch kein Ticket? Jetzt schnell sichern! Die PreConnect ist bereits ausgebucht, auch für die After-Show-Party auf der Ocean Diva sind nur noch wenige Plätze verfügbar! HIER geht es zum Ticketverkauf

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

John

Sehr aktives Mitglied
3. März 2012
1.899
291
Berlin
Hi,

ich möchte aus einem WF die Ameise starten. Leider scheitert das bei der Angabe das Pfades

C:\Program Files (x86)\JTL-Software\ JTL-wawi-ameise
"C:\Program Files (x86)\JTL-Software\JTL-wawi-ameise"
'C:\Program Files (x86)\JTL-Software\JTL-wawi-ameise'

...funktioniert alles nicht.

Was ist der Trick?

Vielen Dank

John
 

frankw75

Mitglied
7. Februar 2022
20
3
Hi,

ich möchte aus einem WF die Ameise starten. Leider scheitert das bei der Angabe das Pfades

C:\Program Files (x86)\JTL-Software\ JTL-wawi-ameise
"C:\Program Files (x86)\JTL-Software\JTL-wawi-ameise"
'C:\Program Files (x86)\JTL-Software\JTL-wawi-ameise'

...funktioniert alles nicht.

Was ist der Trick?

Vielen Dank

John
Fehlt hinter dem Pfad nicht noch die .exe?
 

tom10

Sehr aktives Mitglied
2. Oktober 2012
693
92
06774 Muldestausee
Da sich das Programm im Stammordner der WaWi befindet, reicht JTL-wawi-ameise oder JTL-wawi-ameise.exe bei Ausführen einzutragen. Ohne Anführungszeichen.
 

Gökhan Basoglu

Moderator
Mitarbeiter
15. August 2019
140
35
Hallo John,

Programm/Skript = "C:\Program Files (x86)\JTL-Software\ JTL-Wawi- ameise.exe"
Parameter = LEER
Ausführungsverzeichnis = Nicht ändern.

Ich hoffe das hilft dir weiter.
 

Gökhan Basoglu

Moderator
Mitarbeiter
15. August 2019
140
35
Hallo John,


die Leerzeichen würden automatisch angelegt weil die Wörter " JTL-Wawi" und " Ameise" mit einem Link versehen wurden.
Hier nochmal die eigentliche Version: "C:\Program Files (x86)\JTL-Software\JTL-Wawi-ameise.exe"
 

John

Sehr aktives Mitglied
3. März 2012
1.899
291
Berlin
Faszinierend. Die Fehlermeldung kommt aus dem Parameter.

Code:
--server=MEINRECHENER\JTLWAWI --database=eazybusiness --dbuser=sa --dbpass=xxx --templateid=IMP59 --inputfile=C:\tmp\Ameise.csv

Rufe ich das ganze innerhalb eine *.bat Batch Datei auf, funktioniert es.
 

Anhänge

  • Illegales Zeichen.png
    Illegales Zeichen.png
    15,5 KB · Aufrufe: 6

John

Sehr aktives Mitglied
3. März 2012
1.899
291
Berlin
Ich hab jetzt eine Batch Datei aus dem Worklfow schreiben lassen, die sich am Ende selbst löscht. Keine Lust mehr auf den Stress.

Danke trotzdem für den Ansatz.