Gelöst Nach Update auf PHP 7 nur weißer Bildschirm

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Hallo,

wenn ich von PHP 5.6.32 auf eine PHP Version ab 7 umstelle bekomme ich beim Aufruf des JTL Shops 4.05 (Build: 3) nur einen weißen Bildschirm.

Kann mir einer sagen was ich da noch machen muß ?

Ioncube loader ist installiert.

Vielen Dank

Micha
 

_simone_

Sehr aktives Mitglied
17. Februar 2013
3.245
463
Emsland
Firma
Notun Delend
Hast du alle plugins deinstalliert? Da hat es bei uns dran gelegen, weil nicht alle plugins mit PHP 7.x können.
 

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Hallo,

nein, ich hab nicht alle Plugins deinstalliert. Werde ich aber testen, Danke.
 

Mirko.Schmidt User deaktiviert

Guest
Hallo,
wenn das Errorlogging wie hier beschrieben aktiviert wird, dann werden die Fehler(Fatal Error/500er) auch angezeigt und anhand der Fehlermeldung kann dann noch besser geholfen werden.
 

Mirko.Schmidt User deaktiviert

Guest
Ich vermute mal der Edge wird genutzt? Dann ist hier nochmal ein alternativer Link.
 

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Hallo,

Danke !! Hab nun rausgefunden das ein deaktiviertes Plugin schuld war.
 

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Allerdings bekomme ich nun folgende Meldung:


Warning: RecursiveDirectoryIterator::hasChildren(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang/lang_2) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 284

Warning: RecursiveDirectoryIterator::hasChildren(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang/lang_2) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 284

Fatal error: Uncaught RuntimeException: SplFileInfo::isLink(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang/lang_2) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php:286 Stack trace: #0 /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php(286): SplFileInfo->isLink() #1 /var/www/vhosts/dendroshop.de/dendroshop/classes/class.JTL-Shop.JTLCache.php(768): cache_advancedfile->flushTags(Array) #2 /var/www/vhosts/dendroshop.de/dendroshop/classes/class.JTL-Shop.JTLCache.php(160): JTLCache->_flushTags(Array) #3 /var/www/vhosts/dendroshop.de/dendroshop/admin/pluginverwaltung.php(257): JTLCache->__call('flushTags', Array) #4 {main} thrown in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 286
 

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Wenn ich den Objekt cache löschen will bekomme ich:


Warning: RecursiveDirectoryIterator::hasChildren(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang_2.fc) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 165

Warning: RecursiveDirectoryIterator::hasChildren(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang_2.fc) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 165

Fatal error: Uncaught RuntimeException: SplFileInfo::isLink(): open_basedir restriction in effect. File(/var/www/vhosts/dendroshop.de/dendroshop/templates_c/filecache/lang_2.fc) is not within the allowed path(s): (/var/www/vhosts/dendroshop.de/:/tmp/) in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php:166 Stack trace: #0 /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php(166): SplFileInfo->isLink() #1 /var/www/vhosts/dendroshop.de/dendroshop/classes/class.JTL-Shop.JTLCache.php(785): cache_advancedfile->flushAll() #2 /var/www/vhosts/dendroshop.de/dendroshop/classes/class.JTL-Shop.JTLCache.php(160): JTLCache->_flushAll() #3 /var/www/vhosts/dendroshop.de/dendroshop/admin/cache.php(117): JTLCache->__call('flushAll', Array) #4 {main} thrown in /var/www/vhosts/dendroshop.de/dendroshop/classes/CachingMethods/class.cachingMethod.advancedfile.php on line 166


Ist das nicht ein Fehler in dem Pfad ? (/var/www/vhosts/dendroshop.de/:/tmp/) Ist der Doppelpunkt da richtig ???
 

Mirko.Schmidt User deaktiviert

Guest
Der Pfad ist nicht richtig, ich gehe davon aus, dass der noch alt ist in einer Datei. Wurde schon versucht manuell, per FTP, den Cache zu löschen? Die Pfade in der Config Datei stimmen aber?
 

ascsoft

Sehr aktives Mitglied
3. Oktober 2010
309
35
Nein, das wurde noch nicht versucht.
Ich weiß auch nicht was ich da alles löschen kann.
Wenn du mir das sagen kannst könnte ich dies machen.
 

Mirko.Schmidt User deaktiviert

Guest
Per FTP einloggen und dann in den Ordner "templates_c" nicht "templates". Im Ordner "templates_c" sollte sich dann ein filecache und Evo Ordner, oder ein anderer Template Name je nach dem welches aktiv ist, angezeigt werden. Diese einfach löschen, dann ist der Objekt-/Templatecache gelöscht.
 

Ähnliche Themen