Neu Leider kommt es wieder ein mal zu Problemen beim Abgleich nach der USt Änderung

dc-nico

Sehr aktives Mitglied
Irgendwie will mich dieser Connector jedes mal ärgern, wenn man etwas ändern muss.
Eigentlich dürfte so etwas gar nicht passieren, wenn man nichts, außer der ignoranten , überflüssigen USt Änderung vornimmt.
Nun bekomme ich beim kompletten Abgleich folgenden fehler angezeigt:

Code:
System.UnauthorizedAccessException: Der Zugriff auf den Pfad "C:\Users\XXX\Documents\Debug_Shop\Connector-Abgleich-Debug 20210107 10-18-31.txt" wurde verweigert.
   bei System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   bei System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   bei System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   bei System.IO.StreamWriter.CreateFile(String path, Boolean append, Boolean checkHost)
   bei System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding, Int32 bufferSize, Boolean checkHost)
   bei System.IO.StreamWriter..ctor(String path, Boolean append, Encoding encoding)
   bei System.IO.File.InternalAppendAllText(String path, String contents, Encoding encoding)
   bei System.IO.File.AppendAllText(String path, String contents)
   bei jtlCore.ControllerClasses.Connector.Abgleich.AbgleichSyncContext.CheckAndWriteErrors()
   bei jtlCore.ControllerClasses.Connector.Abgleich.AbgleichController.CXmdBswoaBy()
   bei jtlCore.ControllerClasses.Connector.Abgleich.AbgleichController.<AbgleichAsync>d__21.MoveNext()
--- Ende der Stapelüberwachung vom vorhergehenden Ort, an dem die Ausnahme ausgelöst wurde ---
   bei System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.<ThrowAsync>b__6_0(Object state)
Dabei läuft der Abgleich dann ins Unendliche und man muss per Tank Manager die Wawi beenden.
Sehr schöne Sache, wenn man jedes mal 2 Stunden Abgleich abwarten muss.

Ich habe den Shop auch ein mal resetet, damit alles neu abgeglichen werden kann.
Dennoch kommt es zum Fehler.
Übrigens sind die preise nun auch wieder komplett falsch im Shop.

Gruß

NICO
 

dc-nico

Sehr aktives Mitglied
Ich habe nun den 3. Abgleich zurchgeführt und bemerkt, dass Alle Artikel keiner Kategorie zugeordnet sind.
Soll die Ware die Kategorie nicht automatisch zuordnen?
War ja bisher auch so.
Es ist ärgerlich, wenn jedes mal alles kompliziert berichtigt werden muss.

Gruß

NICO
 

dc-nico

Sehr aktives Mitglied
In der TV-Sitzung mit JTL haben wir noch ein mal den Chache gelöscht.
Erst hat dies nichts gebracht.
Danach habe ich alle Artikel einer Kategorie mit der Option "für Onlineshop akivieren/deaktivieren" manuell auf aktiv gesetzt und Bilder abgleichen lassen.
Nun sind die Artikel alle wieder im Shop sichtbar.
Entweder hat das Löschen des cache dies nachträglich bewirkt, oder eben der erneute Abgleich.
Fakt ist, dass es nun wieder funktioniert.
Ich danke dem JTL Support und würde den Fall als erledikt erklären.

Gruß

NICO
 
  • Gefällt mir
Reaktionen: Immanuel
Ähnliche Themen
Titel Forum Antworten Datum
Neu Hinzufügen Merkmale bricht stetig ab - ich finde den Fehler leider nicht JTL-Ameise - Ideen, Lob und Kritik 5
Neu TSE Fehlerbehebungsbeleg (ca. 160cm lang) kommt ungefragt nach TSE Ausfall... (1.0.4.8, Epson TM m30-F) Allgemeine Fragen zu JTL-POS 0
In Diskussion Worflow wenn Artikel das erste mal ins Lager kommt JTL-Workflows - Ideen, Lob und Kritik 0
Neu Amazon Anbindung: Bei mir kommt nichts an Amazon-Anbindung - Fehler und Bugs 2
Neu OSS - kommt da ein Update seitens JTL Arbeitsabläufe in JTL-Wawi 7
Beantwortet Ab wann kommt 1.6 Wawi? User helfen Usern - Fragen zu JTL-Wawi 1
In Diskussion Android Tablet gestohlen: Daten irgendwie wieder bekommen? Einrichtung / Updates von JTL-POS 1
Neu JTL FFN - immer wieder Fehler bei Übertragung JTL-Wawi - Fehler und Bugs 0
Neu Suchen Servicepartner der uns die Bilderzuordnungen pro Plattform wieder herstellen kann Dienstleistung, Jobs und Ähnliches 0
Neu Easy Shiping - Drucker am Verpackungsplatz fliegen immer wieder raus User helfen Usern - Fragen zu JTL-Wawi 5
Neu Immer wieder Überverkäufe (auch Amazon) - wo ist das Problem? eBay-Anbindung - Fehler und Bugs 7
Neu Tickets wieder voneinander trennen Servicedesk (Beta) 3
Issue angelegt Eigenes Feld Datentyp Datum mit Ameise wieder leer setzen? JTL-Ameise - Fehler und Bugs 2
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 18
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 12
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 0
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 0
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 0
Neu SHOPABGLEICH IN VERSION 1.5.41.2 WIEDER NICHT MÖGLICH!! JTL-Wawi - Fehler und Bugs 0
Neu Immer wieder Error 503 im Forum Smalltalk 8
Neu ziemlich genervt! Update 4 auf 5 immer wieder Fehlermeldungen in der WAWI Upgrade JTL-Shop4 auf JTL-Shop5 7
Neu Versandart ps_wirepayment wird immer wieder an WaWi übertragen PrestaShop-Connector 1
In Bearbeitung JTL-POS läuft, wie komme ich nun wieder an die Demo für Schulungen? Allgemeine Fragen zu JTL-POS 6
In Diskussion Workfow: ausbuchen des einen Artikels, aufteilen auf andere Artikel und wieder einbuchen JTL-Workflows - Ideen, Lob und Kritik 0
In Bearbeitung Es wird mal wieder Zeit "Danke" zu sagen ;) JTL-POS - Ideen, Lob und Kritik 1
Neu Gambio Shop Abgleich gibt immer wieder Fehlermeldung Gambio-Connector 3
Neu Produktkategorie verschwindet (immer wieder) Allgemeine Fragen zu JTL-Shop 5

Ähnliche Themen