Neu HTTP Error 500 nachdem ich Kategoriebilder hinzugefügt habe

  • Wichtiger Hinweis Liebe Kunden, solltet Ihr den DATEV Rechnungsdatenservice 2.0 nutzen, dann müsst Ihr bis zum 30.06.2024 JTL-Wawi 1.9 installieren. Danach wird die Schnittstelle für ältere Versionen nicht mehr unterstützt.
  • JTL-Connect 2024: Ihr habt noch kein Ticket? Jetzt Early Bird Ticket zum Vorzugspreis sichern! HIER geht es zum Ticketverkauf

server_paul

Neues Mitglied
21. Juli 2020
24
0
Ich fasse mich mal kurz: Ich habe im Vorfeld ein Bild erstellt, mit 150x150px, 3KB und .jpg. Danach habe ich das zu einer Kategorie hinzugefügt und für den Shop freigegeben und den Abgleich gestartet. Wenn der aber bei "Kategoriebilder" ankommt, muss ich 3x den Fehler HTTP Error 500 wegklicken.
Hat jemand eine Idee, woran das liegen kann?
 

server_paul

Neues Mitglied
21. Juli 2020
24
0
Ich konnte ja leider gar keine Abgleich mehr machen. Ich habe die Bilder hinzugefügt und das wars, danach kam nur noch der Fehler.
Daher denke ich, dass der Browser- Cache keine Rolle spielt, aber auch das Löschen vom Cache im Shop hat nicht geholfen.
 

server_paul

Neues Mitglied
21. Juli 2020
24
0
Update: Der Abgleich hat doch funktioniert. Ich hab nur mal DPI auf 1 und Dateigröße auf 1KB reduziert.

Ich weiß, ich weiß, absolut komplett und übertrieben unrealistische Werte! Aber immerhin weiß ich ja jetzt, dass es wahrscheinlich an der Größe liegt. Ich werde jetzt mit allen möglichen Größen rumprobieren und schauen, wo das Höchste der Gefühle sein wird.
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
6.805
1.649
Berlin
Wenn ein Webhosting keine 3kb Bilder verarbeiten kann, dann hättest du ein echtes Problem das du schon früher bemerkt hättest, darum glaube ich nicht das dies der Grund ist.
Deine Produktbilder sind ja hoffentlich größer als 150px bzw. 3kb, also sollte das eigentlich nicht das Problem sein.

Ich denke eher das der Shop den cache löschen wollte und dabei ständig in einen 500er lief?
 

server_paul

Neues Mitglied
21. Juli 2020
24
0
Klar, die Prduktbilder sind relativ groß.
aber das Problem kam nur beim Abgleich.
Kann ich denn irgendwo mehr sehen? (Bin kein Experte!😅)
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.248
378
Artikelbilder und Kategoriebilder sind im Abgleich nicht wirklich vergleichbar, weil zwei Unterschiedliche Schnittstellen benutzt werden (Erst ab Shop5 benutzen alle die Shop4-Artikelbildschnittstelle), von daher ist deutlich seltener ein HTTP 500 beim Artikelbild-Abgleich zu erwarten; aber trotzdem dürfte wie @css-umsetzung gesagt hat bei der winzigen Bild-Testgröße für Kategoriebilder an allen möglichen Ecken was knallen... hast du deine Kategoriebild-Einstellungen im Backend geprüft? Nicht das da evtl. unrealistische Pixelgrößen existieren. Kategoriebilder werden in allen 4 größen inkl. ggf. eingestelltes Wasserzeichen/Branding beim Abgleich erstellt und dabei kommt es meist zu den Fehlern.
 

server_paul

Neues Mitglied
21. Juli 2020
24
0
Gute Idee mit den Einstellungen im Backend! Dort stand bei den Kategorien in der normalen Größe 150x150. Habe das auf 1500x1500 hochgeändert und danach konnte ich das Bild hochladen.
Aber es wird nicht angezeigt. Ich sehe nur das Standard-Vorschaubild.
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.248
378
Kannst du bitte einmal unter System->Wartung-> Log alle Loglevel (temporär!) aktivieren und dann das Kategoriebild nochmal neu abgleichen? Ist im Systemlog dann etwas auffälliges zu sehen?
 

JulianG

Administrator
Mitarbeiter
14. November 2013
1.248
378
@server_paul Wenn nich icht täusche, ist das eine Funktion der GD2-Library. Die muss ggf. von deinem Hostingprovider noch installiert werden (ist eigentlich ungewöhnlich, dass das nicht der Fall ist).
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu 5.3.1 HTTP Error 500 bei Bestellungen Gelöste Themen in diesem Bereich 4
Neu Fehlermeldung WordPress database error ... Table 'wp_*******.wp_wc_orders' doesn't exist WooCommerce-Connector 0
Neu [Access Violation]Native Images Error JTL-Wawi - Fehler und Bugs 25
Neu NOVA Child Aktivierung weiße Seite 500 Error Templates für JTL-Shop 0
Neu 500er error Artikel in Warenkorb JTL-Shop - Fehler und Bugs 2
Neu Plugin Upload Error Allgemeine Fragen zu JTL-Shop 2
Kein ebay Abgleich seit Update auf 1.9.4.1 - error calling EaEbayNegotiationEligibleItemPost eBay-Anbindung - Fehler und Bugs 10
Neu 500 Internal Server Error JTL-Shop - Fehler und Bugs 2
Neu Error on uploading logo image on jtl 5.3.1 JTL-Shop - Fehler und Bugs 0
Neu The remote server returned an error: (400) Bad Request. JTL-ShippingLabels - Fehler und Bugs 75
Neu Shop Error: Error executing query: INSERT INTO tsuchcachetreffer JTL-Shop - Fehler und Bugs 0
Worker Error TrackAndTrace JTL-Wawi 1.8 1
Neu Error Code = 0 bei Installation JTL-Shop 5.3.1 Einrichtung JTL-Shop5 3
Gelöst Shop 5.3.1 Fatal Error Gelöste Themen in diesem Bereich 2
Verlässlicher Error nach 30 Sekunden temporäre Filter / Filter Artikelsuche JTL-Wawi 1.7 3
In Diskussion Liquid error: Parameteranzahlkonflikt bei einer einfachen Anweisung Gelöste Themen in diesem Bereich 3
Neu JTL Exportformat Google Shopping v2.2.2 - Export bleibt bei 500 Artikeln stehen und wird nicht final durchgeführt Plugins für JTL-Shop 0
Neu Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler wir bitten Hilfe Gambio-Connector 6

Ähnliche Themen