Neu Eigenen Felder zu Shopware übertragen

eu-bay

Aktives Mitglied
11. November 2017
62
1
Hallo,

wir haben die folgende config.json:

{
"developer_logging": false,
"category": {
"mapping": false,
"push": {
"null_undefined_attributes": true
}
},
"product": {
"push": {
"enable_custom_properties": false,
"null_undefined_attributes": true,
"article_detail_preselection": false
}
},
"customer_order": {
"pull": {
"start_date": null,
"status_processing": true
}
},
"delivery_note": {
"push": {
"create_document": true
}
}
}

Leider überträgt JTL nicht die Eigenen Felder zu Shopware. Wir haben bereits einen Komplettabgleich für Globale Daten, Artikeldaten und Merkmale gesetzt aber ohne Erfolg.
Wie müssen wir vorgehen, damit die Eigenen Felder in Richtung Shopware übertragen werden?

Vielen Dank.
 

eu-bay

Aktives Mitglied
11. November 2017
62
1
Hallo,

ich hatte wohl falsch kopiert.

Im Ordner:

engine/ Shopware/Plugins/Community/Frontend/jtlconnector/config liegt eine config.json.

Diese hat denn Inhalt:


Code:
{
    "developer_logging": false,
    "category": {
        "mapping": true,
        "push": {
            "null_undefined_attributes": true
        }
    },
    "product": {
        "push": {
            "enable_custom_properties": true,
            "null_undefined_attributes": true,
            "article_detail_preselection": false
        }
    },
    "customer_order": {
        "pull": {
            "start_date": null,
            "status_processing": true
        }
    }
}

Leider funktioniert es nicht. Es tauchen keine Eigenen Felder auf. Hat jemand das schon probiert, ob es überhaupt funktioniert? Komplettabgleich wurde alles schon angestoßen aber es geht nicht.
 

McAvity

Sehr aktives Mitglied
7. September 2016
561
135
@eu-bay

Hast Du denn Die den oberen Link in meinem letzten Beitrag durchgelesen?

Mal das Logging in der Wawi und im Connector aktiviert und geprüft ob die Daten gesendet bzw. empfangen werden?

MfG

McAvity
 

eu-bay

Aktives Mitglied
11. November 2017
62
1
@eu-bay

Hast Du denn Die den oberen Link in meinem letzten Beitrag durchgelesen?

Mal das Logging in der Wawi und im Connector aktiviert und geprüft ob die Daten gesendet bzw. empfangen werden?

MfG

McAvity


Hallo,

im Connector Log kann ich sehen das dort Eigene Felder übertragen werden. Im Shop kommen die aber nicht an.

Muss man diese da vorher mit der Hand anlegen?

Ich habe deinen Beitrag gelesen. Teilweise ist der aber sehr alt und nicht mehr schlüssig mit der aktuellen JTL Wawi. Manche Felder gibt es so nicht mehr etc.
 

eu-bay

Aktives Mitglied
11. November 2017
62
1
So sieht das im JTL Connector Log aus.

Code:
{
          "id": [
            "",
            130211
          ],
          "productId": [
            "1818_1688",
            11720
          ],
          "isCustomProperty": true,
          "isTranslated": false,
          "i18ns": [
            {
              "productAttrId": [
                "",
                130211
              ],
              "languageISO": "ger",
              "name": "DP Warenpost [50mm 1000g]",
              "value": "5"
            }
          ]
        },

Das ist ein Eigenes Feld aus JTL. Das taucht aber nicht in Shopware auf. Er hat es auch noch nicht angelegt. Muss ich das irgendwie vorher anlegen bevor er das matched oder wie erfolgt das matching?
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.352
282
Hallo,

grundsätzlich sollte das Senden von eigenen Feldern zum Shop funktionieren. Dafür muss wie hier in einem Kommentar erwähnt in der config.json des Connector das Flag product.push.enable_custom_properties auf true gesetzt sein. Außerdem muss ein entsprechendes Attribut im Shop existieren.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu CSV-Export von Auftrag mit "Eigenen Felder" User helfen Usern - Fragen zu JTL-Wawi 2
Neu NOVA Template JTL Shop 5 eigenen Content-Block zwischen Footer und Produktdetailsseiten Technische Fragen zu Plugins und Templates 2
Neu Canonical Link bei Eigenen Inhaltsseiten falsch JTL-Shop - Fehler und Bugs 1
Neu Kontaktformular mit eigenen Feldern / FAQ je Betreff Plugins für JTL-Shop 3
Neu Versand aus eigenen bestimmten Lager Einrichtung und Installation von JTL-eazyAuction 0
Fehlermeldung beim Speichern von Eigenen Seiten Einrichtung JTL-Shop5 7
Neu Felder angeblich schreibgeschützt Shopware-Connector 1
Neu Wie kann ich die hinterlegte E-Mail Adresse für Rechnungsversand von "Eigene Felder" in E-Mail Vorlage abfragen? User helfen Usern - Fragen zu JTL-Wawi 8
Neu Bereiche eigener Felder User helfen Usern - Fragen zu JTL-Wawi 3
Neu Workflow Eigene Felder mit Datum User helfen Usern - Fragen zu JTL-Wawi 0
Neu Variable Eigene Felder für Versandlabel User helfen Usern - Fragen zu JTL-Wawi 0
Neu Eigene Felder innerhalb der Beschreibung ausgeben Allgemeine Fragen zu JTL-Shop 2
Neu Amazon Kategorie in Eigene Felder hinterlegen Arbeitsabläufe in JTL-Wawi 1
In Diskussion Ausgabe bestimmter Eigener Felder aus Workflow JTL-Workflows - Ideen, Lob und Kritik 4
Neu Shop5 Eigene Felder unterhalb Artikelbeschreibung einfügen Templates für JTL-Shop 2
Neu Eigene Felder mit Onpage Composer auf Artikelseite darstellen Templates für JTL-Shop 3
Neu Kunden - Eigene Felder durchsuchen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Eigene Felder in Varianten (WooCommerce) Onlineshop-Anbindung 0
Neu Wo finde ich im JTL-Guide die Definition der Felder für den Import von Lieferantenartikeln? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Stücklistenkomponent als ein Felder in Artikeldaten. JTL-Wawi - Ideen, Lob und Kritik 0
Neu Eigene Felder in Druckvorlage ausgeben Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Shopware 5 URL-Pfad passt sich nicht dem Sub-Shop an Shopware-Connector 0
Neu Shopware 6 Connector schmeißt ständig Fehlermeldung Shopware-Connector 2
Neu Shopware 6 - Probleme bei Produktbildern Shopware-Connector 1
Neu Shopware 5 Connector anmeldung nicht möglich nach Update Shopware-Connector 2
Neu Übernahme von Produktnamen aus Shopware 6 Shopware-Connector 0
Neu Shopware 6: HTML-Tags in Attributen werden nicht übertragen? Shopware-Connector 0
Neu Shopware 6 - Connector Error: Malformed UTF-8 characters Shopware-Connector 3
Gelöst Auslandsversand und Shopware Shop JTL-ShippingLabels - Fehler und Bugs 1
Neu Shopware & JTL-Wawi - Welche Aufgaben übernimmt wer? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Hilfe! WAWI abgleich mit Shopware 6 geht nicht. Shopware-Connector 1
Neu Shopware 6 - Streichpreise funktionieren nicht. Shopware-Connector 2
Neu Shopware 6 Connector Erscheinungs Datum Exportieren Shopware-Connector 0
Neu Shopware 6 - kryptische URL's für Varianten Shopware-Connector 2
Neu Shopware 6 - Thumbnail Dateinamen Shopware-Connector 6
Neu JTL Ware überschreibt Inhalte von Shopware 6 Plugin Shopware-Connector 5
Neu Shopware PayPal Plugin & Zahlungsarten in JTL Shopware-Connector 2
Neu Shopware 6: Malformed UTF-8 characters, possibly incorrectly encoded Shopware-Connector 2
Neu Shopware 6 - Preise Nachkommastellen Shopware-Connector 1
Beantwortet JTL Workflow für Bestellungen aus Shopware JTL-Workflows - Fehler und Bugs 1
Neu Shopware 6 Artikelbezeichnug nicht aus dem Shop nehmen Shopware-Connector 2
Neu Attributtyp und Datentyp nach Shopware Import Shopware-Connector 0
Neu Shopware Parent+Childs Shopware-Connector 8
In Bearbeitung Seit Connector Update: Wenn Versand gesetzt, wird kein Lieferschein über den Connector an Shopware 5 übertragen Shopware-Connector 1
Neu Shopware 6 abgleich mit vielen Errors wegen zu langen metaDescription Shopware-Connector 6
Neu Aufträge aus Onlineshop (Shopware) nicht im Filter für Versandart vorhanden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 5 alle Artikelbilder sind doppelt vorhanden Shopware-Connector 1
Gelöst Fehler bei Shopware 6 Connector Übertragung von Artikelbildern durch den Shopabgleich Shopware-Connector 17
Neu Shopware 5: Paypal Kauf auf Rechnung -> Retouren Shopware-Connector 2
Neu Kundenattribute aus JTL zu Shopware senden Shopware-Connector 1

Ähnliche Themen