Neu Artikelattribute - Eigene Attribute

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hallo zusammen,

der Komplettabgleich hat soweit funktioniert und (fast) alle Daten wurden übertragen. Die einzigen die uns noch fehlen sind die Artikelattribute. Dabei wurden 'Eigene Attribute' angelegt. Muss dafür gesondert auf etwas geachtet/eingestellt werden, so dass diese Attribute auch übertragen werden?

Liebe Grüße,

GP
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
Wo hast Du die Attribute angelegt? Nur WaWi, oder im Shop, oder in beiden?
Es müssen sowohl in WaWi als auch Shop die Attribute angelegt werden.
Gruß Joachim
 

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hi Joachim,

speziell meine ich dabei diese Attribute aus der WaWi:
1627390002516.png

Diese hier wurden übertragen (wobei ich nicht mit Sicherheit sagen kann, ob die Eigenschaften zuvor auch in Shopware angelegt wurde):
1627390048924.png

Es sollte demnach ausreichen eine Property-Gruppe in Shopware mit dem gleichen Namen zu erstellen, sehe ich das richtig? (Kann das leider nicht direkt testen, werde es aber ausprobieren und Rückmeldung geben):
1627390116658.png

Oder muss dafür eine Custom-Field-Group o.ä. angelegt werden?

Grüße,
GP
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
In der WaWi unter Attribute gibt es auch welche, die für Shopware gedacht sind. In diesem Bereich musst Du auch Deine eigenen Atribute anlegen.
Dur Braucst eine Gruppe, einen Namen und einen Wert.
In Shopware werden diese dann um Bereich der Freitexte angelegt und zwar so, das der Name identisch ist.
Ich arbeite noch mit der 5. Wie das genau in der 6 ist weiss ich nicht, aber einen großen Unterschied wirdf es wohl nicht geben.
Kannst auch mal hier reinschauen https://guide.jtl-software.de/jtl-wawi/artikel/artikelstammdaten-attribute-merkmale/
Gruß Joachim
 

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hab die Attribute nun sowohl als Property, als auch als Freitextfeld angelegt.
Letzteres ist folgend Konfiguriert:
1627394719509.png
In der Wawi sieht es nach wie vor so aus:
1627394747446.png

Vielen Dank schon mal. Ich teste das und gebe Rückmeldung. Falls jemand genaueres weiß wie das in SW6 geht, gerne melden.

VG,
GP
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
Im Freitext legst Du z.B. ein attr.4 an (Kann auch eine andere Zahl sein. Kommt auf die Anzahl deiner Attribute an) und benennst es wie Du möchtest.
In der WaWi wie schon beschrieben legts Du ebenfalls ein attr.4 an uns benennest es gleich.In Shopware kannst Du das neu8 angelegte Feld gleich in der Artikelanlage sehen. Dazu ganz nach unten scrollen.
Mehr ist das nicht.
Gruß Joachim
 

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hab die Attribute nun sowohl als Property, als auch als Freitextfeld angelegt.
Letzteres ist folgend Konfiguriert:
Den Anhang 67999 betrachten
In der Wawi sieht es nach wie vor so aus:
Den Anhang 68002 betrachten

Vielen Dank schon mal. Ich teste das und gebe Rückmeldung. Falls jemand genaueres weiß wie das in SW6 geht, gerne melden.

VG,
GP

Das hat leider nicht funktioniert. Der Import hat zwar gearbeitet, aber die Attribute tauchen nicht in Shopware auf. Zumindest wüsste ich nicht wo...
Weiß noch jemand Rat? Dürfen die Artikelattribute in der WaWi evtl. nicht unter 'Eigene Attribute' stehen?

Liebe Grüße,

GP
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
Schwierig festzustellen woran das liegt.
Vermutlich an einer falschen Einstellung, denn das ist es meistens.
Ich habe Dir das mal hier reingestellt, wie das angelegt werden muss.
In Shopware 6 wird die Anlage etwas anders aussehen, im Grunde aber nicht viel unterschiedlicher sein.

So sieht es aus wenn man das Attribut angelegt hat. Den passenden Wert kann man entweder per Ameise einlesen, oder selber nach Auswahl des Attributes hinzufügen.

Das Bild unten ist quasi bereits das Ergebnis. Wie man da hinkommt weiter unten. Ich habe das Schritt für Schritt mal reingestellt.


Attribute im Artikel.jpg


So fängt es an.
Zugang zu den Attributen

Attributen Zugang.jpg

Hier nach Shopware Attributen suchen

Attribute übersicht.jpg

Dann Dein neues Attribut Anlegen, dazu Shopware Attribute markieren, dann auf den Button Attribute hinzufügen und dann die daten wie im Bild hinzufügen und dann das ganze speichern.


Attribute anlegen.jpg

Die neuen Attribute müssen dann in Shopware angelegt werden. Das passende Attribut muss dann in der WaWi, wie im ersten Bild ausgewählt werden, damit Shopware weis welches gemeint ist.

Freitextanlage.jpg

Beim nächsten Upload sollten dann in der Artikelanlage, im Artikel selbst, weiter unten die angelegten Attribute zu finden sein.
Beachte, das für die angelegten Attribute auch die Templates entsprechend zur Anzeige vorbereitet sind. Manchmal muss man diese da anpassen wo die angezeigt werden sollen.
Wie das geht ist wieder ein anderes Problem.


Freitext im Artikel.jpg

Soweit mal das.
Gruß Joachim
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: g.proebster

HM.Stedler

Aktives Mitglied
11. Juni 2019
71
16
Hallo,

ich klicke mich hier mal ein da ich leider mit Shopware 6 diesbezüglich nicht weiter komme.
Die Einstellungen für die Attribute unter Shopware 5 werden nicht übernommen wenn man diese einfach in den Onlineshop unter Shopware 6 überspielt.

Wir haben u.a. "technische Daten" in Tabellenform unter Shopware 5 in unseren alten Shop übertragen, dort wurde die Tabellen im Frontend korrekt formatiert und ausgespielt.
Unter Shopware 6 werden jedoch alle Formatierungen entfernt und es erscheint nur ein endloser langer Text, statt einer ordentlich formatierte Tabelle.

Hat jemand einen Rat für uns wie wir unsere "technischen Daten" wieder formatiert in Shopware einspielen können!

Gruß
Michael
 

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hallo,

wenn ich so wie beschrieben in der Wawi ein Attribut anlege wird das durchaus als Custom-Field angelegt (unter custom_jtl), allerdings wird dieses nicht mit Daten befüllt. Jemand eine Idee?

LG, Gero
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
Verstehe ich das richtig.
In der WaWi das Attribut anglegt und das wird auch im jeweiligen Artikel mit den dazugehörigen Daten angezeigt?
Hast Du denn Im Artikel einen Wert für das Attribut hinterlegt?
Das Anlegen des Attributs ist ja nur eine Sache. Quasi ein Platzhalter und der muss auch in der WaWi bei den Shopware Attributen angelegt werden, ansonsten weiß die WaWi nicht, was die damit machen soll.
Dann muss man dem Artikel ja auch noch irgendeine Info zuordnen, die für jeden weiteren Artikel unterschiedlich sein kann.

Wenn Du dann einen Upload machst, dann wird das Attribut In Shopware bei dem betreffenden Artikel angezeigt, aber ohne Inhalt?

Das lässt eben vermuten, das kein Wert in der WaWi beim Artikel hinterlegt ist, oder das Attribut völlig Falsch angelegt wurde.
Das das Freitextfeld in Shopware angezeigt wird hat zunächst mal nichts mit dem Atttribut der WaWi zu tun.
Wenn in der WaWi und Shopware beide Attribut/Freitextfeld mit den gleichen Bezeichnungen angelegt wurde, erst dann kann man senden und empfangen.

Das JTL_Custom wo wird das angezeigt? Bei Shopware, wenn man ein neues Freitextfeld anlegt?
Beschreibe mal Step by Step, von der WaWi bis zu Shopware wie Die vorgehst.
Möglichst mit Bebilderung.
Gruß Joachim
 
Zuletzt bearbeitet:

g.proebster

Neues Mitglied
17. Juni 2021
17
1
Hi Joachim,

  1. Ich erstelle einen Attribut in der Wawi unter den Shopware-Attributen (und schalte dieses für den Shop frei)
  2. Ich setze einen Wert in einem Artikel bei diesem Attribut
  3. (Optional) Ich erstelle ein Zusatzfeld im Set 'custom_jtl' in Shopware
  4. Ich starte den Import
    • Jetzt wurde in Shopware das Custom-Attribut, welches ich in der WaWi angelegt habe, erstellt (automatisch, wenn nicht 3.)
    • Dieses wurde unter den Zusatzfeldern im Zusatzfeld-Set 'custom_jtl' erstellt 1631791304106.png
    • Das Zusatzfeld-Set wird für Kategorien, Produkte und Kunden verwenden; wird also entsprechend in den Produkten angezeigt.
  5. Beim betreffenden Produkt (dessen Attribut ich einen Wert zugewiesen hatte) erwartete ich, dass dieses diesen Wert zugewiesen bekommen hat; leider ist (sind) das Feld (die Felder) leer
1631791613578.png

Gerne korrigieren, falls ich da etwas vergessen hab/ falsch gemacht habe. Ansonsten vllt einfach nochmal einen Komplettabgleich starten?

LG, Gero
 

utuz

Gut bekanntes Mitglied
26. Juni 2008
474
13
Das ist die Shopware Seite.
Zeige mal die WaWi Seite.
Am Besten auch wieder Schritt für Schritt.
Gruß Joachim
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Gibt es keine "eigene Felder" für Vorgänge wie Angebot, Auftrag, Rechnung etc.? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Sichtbarkeiten und Status der Marktplätze in "!Eigene Übersichten" Individuelle Listenansichten in der JTL-Wawi 0
Neu Unter Eigene Inhalte eine Seite hinzufügen mit $session_id Allgemeine Fragen zu JTL-Shop 0
Linkgruppe ohne eigene Seite Einrichtung JTL-Shop5 1
Eigene Seiten - Link zu externen Seiten Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Seiten die in "Eigene Inhalte - Seiten" erstellt wurden, werden nicht mehr angezeigt und nicht bearbeitbar JTL-Wawi - Fehler und Bugs 0
Neu Laufende eBay+ Amazonangbote in Eigene Übersichten Individuelle Listenansichten in der JTL-Wawi 0
Neu Eigene Artikel-Sortierung in Artikelübersicht Allgemeine Fragen zu JTL-Shop 1
Neu Eigene Felder, Änderungen in Werteliste werden nicht übernommen JTL-Wawi - Fehler und Bugs 1
Neu Prüfen ob eigene Sprachvariable leer ist. Templates für JTL-Shop 2
Neu Eigene Felder in Eigene Übersichten im Auftrag (Versand) ausgeben Individuelle Listenansichten in der JTL-Wawi 2
Wawi Kategorien in Shop5 ausblenden um eigene Seiten zu nutzen (MegaMenü) geht nicht, oder? Einrichtung JTL-Shop5 1
Neu Workflow umsetzen mit Bezug auf eigene Felder - Wie möglich? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Email werden nicht an eigene Email versendet/Zugestellt JTL-Shop - Fehler und Bugs 1
Neu Wie nur bestimmte Werte in Eigene Felder zulassen? JTL-Wawi - Fehler und Bugs 1
Neu Druckvorlage Eigene Felder User helfen Usern - Fragen zu JTL-Wawi 19
Neu Massenzuweisung "Eigene Felder"? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Wie nur bestimmte Werte in Eigene Felder zulassen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Eigene .tpl erstellen und einbinden Templates für JTL-Shop 9
Neu Artikel duplizieren - Eigene Felder User helfen Usern - Fragen zu JTL-Wawi 3
Standardsortierung Eigene Seiten/Besondere Artikel-Seiten Einrichtung JTL-Shop5 1
Kategorieleiste in eigene Zeile? Einrichtung JTL-Shop5 1
Neu Debitorennummer anzeigen lassen (Eigene Übersichten) Individuelle Listenansichten in der JTL-Wawi 0
Neu Wie kann ich die hinterlegte E-Mail Adresse für Rechnungsversand von "Eigene Felder" in E-Mail Vorlage abfragen? User helfen Usern - Fragen zu JTL-Wawi 15
Neu Eigene Formulare für bestimmte Artikel per Funktionsattribut JTL-Shop - Ideen, Lob und Kritik 2
Neu Einkauf > Eigene Übersicht (Eigenes Feld aus Artikel) Individuelle Listenansichten in der JTL-Wawi 1
Neu Eigene Übersicht - ARTIKEL Individuelle Listenansichten in der JTL-Wawi 2
Neu Eigene Übersicht Verkauf Individuelle Listenansichten in der JTL-Wawi 9
Neu Workflow Eigene Felder mit Datum User helfen Usern - Fragen zu JTL-Wawi 0
Neu SQL - Eigene Übersicht Sonderpreise von Amazon Individuelle Listenansichten in der JTL-Wawi 0
Neu Attribute für Cross-Selling Shopware-Connector 2
Neu Google Shopping - lokales Inventar & Produktverfügbarkeit - Attribute: store code Plugins für JTL-Shop 5
Neu Eigenschaften und Attribute unter GX 4.5 Gambio-Connector 0
Neu Wie kann ich die in Auftragsattribute hinterlegte E-Mail Adresse und andere Attribute in E-Mail Vorlage abfragen? User helfen Usern - Fragen zu JTL-Wawi 7
Neu Variablen in Artikelbeschreibung und Attribute Arbeitsabläufe in JTL-Wawi 4
Neu Ebay Attribute in Marktplätze ändern eBay-Anbindung - Fehler und Bugs 1
Neu JTL bekommt keine Attribute vom Woocommerce WooCommerce-Connector 0
Neu Google Shopping Plugin Export Attribute verbinden Plugins für JTL-Shop 0
Neu Leere Attribute in dotliquid JTL-Wawi - Ideen, Lob und Kritik 0

Ähnliche Themen