Neu Allgemeine Farbanpassung // funktioniert nicht

Kaido

Aktives Mitglied
26. Februar 2018
56
8
Wir wollen die allgemeinen Farben in der _variables.scss ändern – z.B. das Gelb beim Hover vom Shop. Sowohl über FTP als auch über den Theme Editor werden die Farben im Child Theme nicht angenommen. Unser Child funktioniert korrekt und es wird auch die my-nova.scss ordnungsgemäß umgewandelt zum CSS.

Wir sind nach der Anleitung von JTL Shop 5 gegangen.

Gibt es eine Lösung für das Problem?


Vielen Dank!

Mit freundlichen Grüßen
Clemens
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
327
104
Hallo,

die Änderung der Primärfarbe geht bei mir ohne Probleme (https://jtl-devguide.readthedocs.io/projects/jtl-shop/de/latest/shop_templates/primary_color.html).
Das sieht in der _variables.scss vom Child-Template dann z. B. so aus:

CSS:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------


$primary: blue;


// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";
Damit wäre auch das gelb beim hovern auf Links zu einem blau umgewandelt.

Eventuell könnte man sich nochmal die aktuelle my-nova_crit.scss aus der Child-Template Vorlage holen. Aber das sollte damit eigentlich nichts zu tun haben.

Viele Grüße
Michael
 

Kaido

Aktives Mitglied
26. Februar 2018
56
8
Hi Michael!

Wie erwähnt, das funktioniert bei uns leider eben nicht. Ich habe es genau so umgesetzt, auch mit anderen Variablen versucht, keins der Variablen wird akzeptiert. Die my_nova.scss wird jedoch ohne Probleme akzeptiert. Ich weiß leider nicht wieso …

Bei uns sieht es auch so aus:

CSS:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------


$primary: red;








// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";

Viele Grüße,
Clemens.
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
327
104
kann man sich das irgendwo angucken? (also Link zum shop?)
Spontan weiß ich nicht woran das liegen kann. Der Cache scheint ja ordnungsgemäß gelöscht, wenn Änderungen in der my_nova.scss funktionieren und das Theme auch ordnungsgemäß über den Button oben rechts kompiliert..
 

Kaido

Aktives Mitglied
26. Februar 2018
56
8
kann man sich das irgendwo angucken? (also Link zum shop?)
Spontan weiß ich nicht woran das liegen kann. Der Cache scheint ja ordnungsgemäß gelöscht, wenn Änderungen in der my_nova.scss funktionieren und das Theme auch ordnungsgemäß über den Button oben rechts kompiliert..
Ich hab eben den Wartungsmodus herausgenommen: www.hel-stahlflex.de

Ich bin aktuell dabei unseren Shop neu mit JTL 5 aufzubauen. Unser aktueller JTL 4 Shop ist fast identisch, allerdings möchte ich kein Update durchführen, weil ich den Quelltext noch etwas säubern möchte und damit alles neu mache.

Danke schonmal für deine Hilfe :)
 

vekoop

Sehr aktives Mitglied
19. Juli 2013
718
84
Hatte das auch kurz, Firefox im Normalbetrieb keine Änderung. Im Private-Modus nur bedingte primary-Übernahme, nicht auf alle Elemente - trotz Cache löschen (Browser+ Shop). Selbes im Chrome. Erst im Chrome Incognito hab ich die volle Umsetzung gesehen...
 

Kaido

Aktives Mitglied
26. Februar 2018
56
8
Hatte das auch kurz, Firefox im Normalbetrieb keine Änderung. Im Private-Modus nur bedingte primary-Übernahme, nicht auf alle Elemente - trotz Cache löschen (Browser+Shop). Selbes im Chrome. Erst im Chrome Incognito hab ich die volle Umsetzung gesehen...
Da ich alles auch immer im Inkognito Modus anschaue um den Cache besser zu umgehen, kann ich auch da sagen, dass es da nicht übernommen wird :(
 

Kaido

Aktives Mitglied
26. Februar 2018
56
8
Ich kann erstmal nur empfehlen alles auf den aktuellen Stand zu bringen.
Shop 5.0.1.
Theme Editor neuste Version holen https://gitlab.com/jtl-software/jtl-shop/plugins/jtl_theme_editor.
Child Template -> my-nova_crit.scss updaten von https://gitlab.com/jtl-software/jtl-shop/child-templates/novachild .
Ist leider alles schon aktuell, da ich gestern den Shop erst aufgesetzt habe. Die GIT Seiten habe ich alle abgeklappert gehabt und der Theme Editor ist aktuell (Version 1.0.0 oder?)

Auch das Child Theme habe ich von Git, ist ebenfalls alles aktuell. So richtig weiß ich nicht was man noch machen könnte :(
 

Uwe_M

Neues Mitglied
4. Februar 2021
6
0
Ich hatte das gleiche Problem und aufgrund des Tips von MHillmann das Child Template geupdatest. Alles TIP TOP
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Allgemeine Bilder im Shop, nicht aus der Wawi, wohin damit? JTL-Shop - BETA - Feedback und Bugmeldungen 1
Neu Logo Vergrößerung, Farbanpassung, Boxenverwaltung etc. im JTL Shop Allgemeine Fragen zu JTL-Shop 4
Neu Mitlaufendes Bild (Parallax) funktioniert nicht auf Mobile JTL-Shop - Fehler und Bugs 1
Beantwortet Auftrag Mengenänderung funktioniert nicht JTL-Wawi - Fehler und Bugs 1
Neu Abgleich Funktioniert nicht / Seite langsam WooCommerce-Connector 0
Suche im Shop funktioniert nicht Einrichtung JTL-Shop5 7
Swatches Darstellung funktioniert nicht! Einrichtung JTL-Shop5 6
Neu Cross selling - JTL -> Gambio funktioniert nicht... Gambio-Connector 3
Neu Zahlungsabgleich Paypal funktioniert nicht mehr? JTL-Wawi - Fehler und Bugs 2
Neu Datev Export funktioniert nicht mehr richtig seit MwSt-Umstellung 16 auf 19% Schnittstellen Import / Export 0
Neu Shopify-Connector funktioniert seit Update auf 1.5.41.2 nicht mehr Shopify-Connector 4
Neu Eigene Artikel Felder in Druckvorlage einbinden funktioniert nicht Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 6
Beantwortet [Geloest] Worker Auto-Login funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 3
Neu Datev Rechnungsdatenservice, Übertragung funktioniert nicht JTL-Wawi - Fehler und Bugs 1
Neu 7% / 19% Berechnung funktioniert nicht mehr seit Update Connector Woocommerce WooCommerce-Connector 2
Neu WAWI 1.5.36.2 Workflow Ausliefern nach Zahlung funktioniert nicht JTL-Wawi - Fehler und Bugs 1
Neu Abgleich mit Gambio funktioniert nicht mehr nach update Gambio-Connector 2
Neu Kunden Versandmail funktioniert nicht User helfen Usern - Fragen zu JTL-Wawi 3
Gelöst Stückzahl teilbar funktioniert nur teilweise JTL-Wawi - Fehler und Bugs 5
In Bearbeitung NCR 7193 Bondrucker funktioniert nicht JTL-POS - Fragen zu Hardware 3
Neu JTL Shop 5.0.1 - NOVA - Statisch komprimieren funktioniert nicht richtig JTL-Shop - Fehler und Bugs 5
Verwiesen an Support XML Export funktioniert nicht bei Rechnungskorrekturen Arbeitsabläufe in JTL-Wawi 1
Neu Typeahead Skript funktioniert nicht Betrieb / Pflege von JTL-Shop 0
Neu JTL Shop 5 - Kunden Login funktioniert plötzlich nicht mehr JTL-Shop - Fehler und Bugs 1
Gelöst Papier Cut funktioniert nicht Einrichtung / Updates von JTL-POS 2
Beantwortet Workflow -> Artikel nach Verkauf mit Bestand kleiner 1 auf Einkaufliste -> funktioniert nur teilweise JTL-Workflows - Fehler und Bugs 1
Neu SHOP5: Zahlungsart Lastschrift funktioniert nicht JTL-Shop - Fehler und Bugs 2
Neu Testversion funktioniert nicht Allgemeine Fragen zu JTL-Shop 7
Neu Verfügbarkeitsanfragen funktioniert nicht Betrieb / Pflege von JTL-Shop 10
Gelöst Import Mediendateien funktioniert nicht JTL-Ameise - Fehler und Bugs 11
Issue angelegt Bildimport mit der Ameise funktioniert nicht wirklich !!! JTL-Ameise - Fehler und Bugs 10
Neu Newsletter Versand funktioniert nicht JTL Shop 5.0 JTL-Shop - Fehler und Bugs 2
Neu Händlerbund funktioniert nicht Plugins für JTL-Shop 3
Neu Shopabgleich über den Worker funktioniert nicht mehr Onlineshop-Anbindung 4
Neu S360 - Amazon Pay Plugin funktioniert nicht im 5er Shop Plugins für JTL-Shop 3
Neu JTL Search funktioniert im 5er Shop nicht Plugins für JTL-Shop 1
Neu Einloggen bei JTL WAWI funktioniert nicht Installation von JTL-Wawi 7
Gelöst WaWi Suche funktioniert nicht mehr richtig, 1.5.37.0 Gelöste Themen in diesem Bereich 2
Neu Versandbenachrichtigung bei Bestellung Versand funktioniert nicht mehr User helfen Usern - Fragen zu JTL-Wawi 2
Gelöst Ausliefern funktioniert nicht Gelöste Themen in diesem Bereich 1
In Bearbeitung funktioniert Epson TM-T88IV Bon Drucker mit Łan mit JTL POS? JTL-POS - Fragen zu Hardware 2
Gelöst Eigenes Javascript funktioniert nicht Templates für JTL-Shop 3
Neu Newsletter Abonnieren funktioniert nicht Allgemeine Fragen zu JTL-Shop 6
Neu bildverwaltung.php funktioniert nicht. (Shop 5) Einrichtung von JTL-Shop4 0
Beantwortet Inventur für großes Ladenlokal in einem WMS-Lager funktioniert schlecht JTL-WMS / JTL-Packtisch+ - Ideen, Lob und Kritik 4
In Bearbeitung Repricer funktioniert nicht mehr, deaktiviert, aktivieren unmöglich! JTL-Repricer für JTL-Wawi und Web 2
Neu Wawi Sicherung mit Batch-Script funktioniert nicht bei "0 Uhr-irgendwas", also kurz nach Mitternacht User helfen Usern - Fragen zu JTL-Wawi 1

Ähnliche Themen