Neu Allgemeine Farbanpassung // funktioniert nicht

Kaido

Aktives Mitglied
26. Februar 2018
58
9
Wir wollen die allgemeinen Farben in der _variables.scss ändern – z.B. das Gelb beim Hover vom Shop. Sowohl über FTP als auch über den Theme Editor werden die Farben im Child Theme nicht angenommen. Unser Child funktioniert korrekt und es wird auch die my-nova.scss ordnungsgemäß umgewandelt zum CSS.

Wir sind nach der Anleitung von JTL Shop 5 gegangen.

Gibt es eine Lösung für das Problem?


Vielen Dank!

Mit freundlichen Grüßen
Clemens
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
570
163
Hallo,

die Änderung der Primärfarbe geht bei mir ohne Probleme (https://jtl-devguide.readthedocs.io/projects/jtl-shop/de/latest/shop_templates/primary_color.html).
Das sieht in der _variables.scss vom Child-Template dann z. B. so aus:

CSS:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------


$primary: blue;


// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";

Damit wäre auch das gelb beim hovern auf Links zu einem blau umgewandelt.

Eventuell könnte man sich nochmal die aktuelle my-nova_crit.scss aus der Child-Template Vorlage holen. Aber das sollte damit eigentlich nichts zu tun haben.

Viele Grüße
Michael
 

Kaido

Aktives Mitglied
26. Februar 2018
58
9
Hi Michael!

Wie erwähnt, das funktioniert bei uns leider eben nicht. Ich habe es genau so umgesetzt, auch mit anderen Variablen versucht, keins der Variablen wird akzeptiert. Die my_nova.scss wird jedoch ohne Probleme akzeptiert. Ich weiß leider nicht wieso …

Bei uns sieht es auch so aus:

CSS:
//
// Platz für eigene Variablen in SCSS-Notation
//
// Alle Änderungen hier müssen anschließend mit einem SCSS-Compiler
// (z.B. dem JTL-Theme-Editor Plugin) nach my-nova.css kompiliert werden
// --------------------------------------------------

// my-nova Theme
// Hier können alle Variablen notiert werden, die nur Auswirkungen auf dieses Theme haben
// -------------------Beginn eigene Variablen----------------------------------


$primary: red;








// -------------------Ende eigene Variablen----------------------------------

// Lädt clear-Variablen
@import '../../../../NOVA/themes/clear/sass/variables';

// passt die Pfade an
$nova-theme-path:                   "../../../NOVA/themes";
$fa-font-path:                      "../../../NOVA/themes/base/fontawesome/webfonts";


Viele Grüße,
Clemens.
 

MHillmann

Moderator
Mitarbeiter
11. Oktober 2018
570
163
kann man sich das irgendwo angucken? (also Link zum shop?)
Spontan weiß ich nicht woran das liegen kann. Der Cache scheint ja ordnungsgemäß gelöscht, wenn Änderungen in der my_nova.scss funktionieren und das Theme auch ordnungsgemäß über den Button oben rechts kompiliert..
 

Kaido

Aktives Mitglied
26. Februar 2018
58
9
kann man sich das irgendwo angucken? (also Link zum shop?)
Spontan weiß ich nicht woran das liegen kann. Der Cache scheint ja ordnungsgemäß gelöscht, wenn Änderungen in der my_nova.scss funktionieren und das Theme auch ordnungsgemäß über den Button oben rechts kompiliert..

Ich hab eben den Wartungsmodus herausgenommen: www.hel-stahlflex.de

Ich bin aktuell dabei unseren Shop neu mit JTL 5 aufzubauen. Unser aktueller JTL 4 Shop ist fast identisch, allerdings möchte ich kein Update durchführen, weil ich den Quelltext noch etwas säubern möchte und damit alles neu mache.

Danke schonmal für deine Hilfe :)
 

vekoop

Sehr aktives Mitglied
19. Juli 2013
753
106
Hatte das auch kurz, Firefox im Normalbetrieb keine Änderung. Im Private-Modus nur bedingte primary-Übernahme, nicht auf alle Elemente - trotz Cache löschen (Browser+ Shop). Selbes im Chrome. Erst im Chrome Incognito hab ich die volle Umsetzung gesehen...
 

Kaido

Aktives Mitglied
26. Februar 2018
58
9
Hatte das auch kurz, Firefox im Normalbetrieb keine Änderung. Im Private-Modus nur bedingte primary-Übernahme, nicht auf alle Elemente - trotz Cache löschen (Browser+Shop). Selbes im Chrome. Erst im Chrome Incognito hab ich die volle Umsetzung gesehen...

Da ich alles auch immer im Inkognito Modus anschaue um den Cache besser zu umgehen, kann ich auch da sagen, dass es da nicht übernommen wird :(
 

Kaido

Aktives Mitglied
26. Februar 2018
58
9
Ich kann erstmal nur empfehlen alles auf den aktuellen Stand zu bringen.
Shop 5.0.1.
Theme Editor neuste Version holen https://gitlab.com/jtl-software/jtl-shop/plugins/jtl_theme_editor.
Child Template -> my-nova_crit.scss updaten von https://gitlab.com/jtl-software/jtl-shop/child-templates/novachild .

Ist leider alles schon aktuell, da ich gestern den Shop erst aufgesetzt habe. Die GIT Seiten habe ich alle abgeklappert gehabt und der Theme Editor ist aktuell (Version 1.0.0 oder?)

Auch das Child Theme habe ich von Git, ist ebenfalls alles aktuell. So richtig weiß ich nicht was man noch machen könnte :(
 

Uwe_M

Neues Mitglied
4. Februar 2021
7
0
Ich hatte das gleiche Problem und aufgrund des Tips von MHillmann das Child Template geupdatest. Alles TIP TOP
 
Ähnliche Themen
Titel Forum Antworten Datum
In Diskussion Abfrage Passwort funktioniert nicht Einrichtung / Updates von JTL-POS 2
Neu HILFE Abgleich funktioniert nicht mehr. WooCommerce-Connector 0
Beantwortet DPD nach Nordirland funktioniert nicht? JTL-ShippingLabels - Fehler und Bugs 1
Neu Warum funktioniert diese RegEx auf regex101.com aber nicht in der WaWi als Workflow? User helfen Usern - Fragen zu JTL-Wawi 5
Neu Checkbox E-Mail Benachrichtigung funktioniert nicht JTL-Shop - Fehler und Bugs 3
Gelöst ebay Abgleich funktioniert nicht mehr eBay-Anbindung - Ideen, Lob und Kritik 5
Neu Suche in "Selbsterstellte Produktseiten" funktioniert nicht Amazon-Lister - Fehler und Bugs 0
In Diskussion DHL Tracking link funktioniert nicht mehr JTL-ShippingLabels - Fehler und Bugs 17
Neu OSS ebay funktioniert nicht! ebay rechnet den MwSt Preis nicht um für Verkauf nach Ungarn! User helfen Usern 3
Neu XML Auftragsdaten Import funktioniert nicht mehr JTL-Wawi - Fehler und Bugs 0
Neu Ebay: Abgleich funktioniert nicht, holt keine Bestellungen ab. eBay-Anbindung - Fehler und Bugs 14
Neu jump-to-votes-tab funktioniert in mobilen Version nicht JTL-Shop - Fehler und Bugs 1
Neu JTL Debug funktioniert nicht richtig Technische Fragen zu Plugins und Templates 0
Update 4.06 B17 auf 5.01 > Error 500 und Fehlerausgabe funktioniert nicht Upgrade JTL-Shop4 auf JTL-Shop5 2
In Bearbeitung Favoriten Artikelsuche funktioniert nicht JTL-POS - Fehler und Bugs 1
Neu Schleife in JTL Exportvorlage funktioniert nicht Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Weiterleitung funktioniert nicht Allgemeine Fragen zu JTL-Shop 2
Gelöst Workflow funktioniert nur in der Simulation JTL-Workflows - Fehler und Bugs 3
Gelöst Verbindung zur Wawi funktioniert nicht mehr JTL-POS - Fehler und Bugs 4
Gelöst Anbindung FirstCash Terminal funktioniert nicht Einrichtung / Updates von JTL-POS 6
Neu $isTablet funktioniert nicht in iPad JTL-Shop - BETA - Feedback und Bugmeldungen 1
Neu Captcha Plugin funktioniert nicht Plugins für JTL-Shop 0
Neu Erster Amazon Abgleich funktioniert nicht Amazon-Anbindung - Fehler und Bugs 6
Neu Newsletter-Versand funktioniert nicht Betrieb / Pflege von JTL-Shop 0
Neu Nach Update auf Shop 5: Kundendaten an Shop senden funktioniert nicht mehr Allgemeine Fragen zu JTL-Shop 4
Neu Zusätzliche Bearbeitungszeit funktioniert nicht bei Stücklistenartikeln JTL-Wawi - Fehler und Bugs 14
Neu Conversion Tracking mit Webstollen PlugIn "Google Tracking" funktioniert nur sporadisch Plugins für JTL-Shop 2

Ähnliche Themen