Neu 1.1.3.0: Worker + Manueller Abgleich -> UNIQUE KEY-Einschränkung

Status
Es sind keine weiteren Antworten möglich.

Guybrush

Sehr aktives Mitglied
4. September 2015
347
38
Hallo,

es gab bei uns kürzlich das Problem, dass der Worker div. Amazon Bestellungen nicht mehr eingelesen hat - auch ein Neustart hatte hier nicht geholfen, so dass einige Bestellungen offen blieben und gar nicht erst eingelesen wurden.

Abhilfe hatte dann ein manueller Amazon-Abgleich gebracht, der jedoch auch zu folgendem Fehler führte:
--- BOF ---
Ein Fehler ist aufgetreten, bitte beim JTL-Support melden: Verletzung der UNIQUE KEY-Einschränkung 'UQ_pf_amazon_bestellung_kMessageId'. Ein doppelter Schlüssel kann in das dbo.pf_amazon_bestellung-Objekt nicht eingefügt werden. Der doppelte Schlüsselwert ist (159890545).

Die Anweisung wurde beendet.
--- EOF ---

Es lief also vermutlich der Worker zeitgleich mit dem manuellen Abgleich und beide haben die gleiche Bestellung speichern wollen -> geht natürlich nicht, DB Design sei Dank.

Mögliche Lösungen:
- Manueller Abgleich unterbindet den automatischen Abgleich durch den Worker für diesen einen Lauf und Mandanten/Amazon Account bzw. der Worker registriert, dass bereits ein Abgleich läuft und startet nicht noch einen Abgleich
- Manueller Abgleich funktioniert nicht parallel mit dem Worker und bringt einen entsprechenden Hinweis -> "Bitte vor dem manuellen Abgleich den Worker beenden" oder sowas

Ansonten konnte soweit kein Fehler festgestellt werden.
 
Status
Es sind keine weiteren Antworten möglich.

Ähnliche Themen