Neu Umlaute Problem - UTF-8

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

Batman777

Aktives Mitglied
17. August 2017
24
0
Hallo,
nach einem Upgrade des modified shops auf die aktuelle Version 2.0.5.1 gibt es Probleme mit den Umlauten beim Abgleich.
Momentan weiß ich nicht mehr wo ich suchen soll.
Was habe ich gemacht.

1. configure.php angepasst
"define('DB_SERVER_CHARSET', 'utf8'); // set db charset 'utf8' or 'latin1'"

2. htaccess angepasst
##-- Default charset
AddDefaultCharset UTF-8
#AddDefaultCharset ISO-8859-15

3. DB Export (UTF-8), Tabellen gelöscht und Reimport (wobei ich glaube das bringt nicht viel)

4. Im Menü Land/Steuer - Sprachen auswählen
und jede Sprache auf Charset: utf-8 umgestellt

5. Ein Convertierungsscript gefunden welches alle Tabellen auf UTF-8 umstellt hat.

6. jtlconnector/config.json kontrolliert " "utf8": "0","
Konnte nirgends finden ob dies richtig ist?

Auch finde ich keinen Hinweis ob es im WaWi selbst einen Switch für UTF-8 gibt?

Anstatt "Bücher" bekomme ich "Bücher".

Jemand eine helfende Idee hierzu?
 

Batman777

Aktives Mitglied
17. August 2017
24
0
Habe jetzt trotz wiedersprüchlicher Angaben in der config.json "utf8": "1",
gesetzt. Nun funktioniert es :).
Könnte mir jmd. evtl. noch bestätigen das die "1" hier für UTF-8 Aktivierung steht?
 

Batman777

Aktives Mitglied
17. August 2017
24
0
Hi Immanuel,

danke. Konnte es wirklich nirgends finden. Im Gegenteil - es war so formuliert das mann bei UTF-8 kontrollieren solle ob in der config.json folgender Eintrag "utf8": "0", vorhanden wäre.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
743
133
Beim modified Connector gibt es auch keinen richtigen Weg. Bei manchen muss utf-8 auf 0 und bei anderen auf 1 stehen. An welche Bedingungen das geknüpft ist, weiß ich bis heute nicht.^^
 
Zuletzt bearbeitet:
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Neu Probleme mit Umlaute bei Shop 4.06 Allgemeine Fragen zu JTL-Shop 6
Neu Problem Bildimport - Mehrfachupload von ein und dem selben Bild JTL-Ameise - Fehler und Bugs 0
Neu PROBLEM: Import durch Ameise Indiv. VK-Brutto User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem beim Update der Vorlagen für eBay eBay-Designvorlagen - Fehler und Bugs 8
Offen Problem mit Grundpreis Gambio-Connector 1
Neu Bonuspunkte Position ( Versendet aber nicht gepickt Problem) User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem mit Bildern Ebay Variationsartikel Arbeitsabläufe in JTL-Wawi 8
Offen WMS Mobil auf Apple Ipad mit kleinem Problem JTL-WMS - Fehler und Bugs 3
Neu JTL Shopify Connector - Steuer Problem Shopify-Connector 6
Neu Riesen Problem mit neuem Connector Gambio-Connector 29
Neu Editor-Problem und Darstellungsproblem in der Artikelübersicht JTL-Wawi - Fehler und Bugs 0
Neu Problem mit Plugin, kann mir jemand sagen was der Fehler bedeutet? Plugins für JTL-Shop 4
Neu LS-POS - RAW Druckvorlage problem mit @Logo1 Fragen rund um LS-POS 3
Neu Problem mit Lizenzierung JTL-Wawi User helfen Usern - Fragen zu JTL-Wawi 2
Neu (gelöst) Problem mit Variationsbox/Variationsauswahl Gelöste Themen in diesem Bereich 0
Neu Mwst Problem im Warenkorb WooCommerce-Connector 3
Gelöst Problem Anbindung WooCommerce 4 Gelöste Themen in diesem Bereich 1
Neu Reservierte Produkte in Aufträgen Problem! User helfen Usern - Fragen zu JTL-Wawi 1
Neu Problem mit Lieferzeit als Werktage - System-Lieferzeit ist falsch Betrieb / Pflege von JTL-Shop 1