Neu Theme-Editor meldet "CSRF-Token fehlt"

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

HelmaSpona

Gut bekanntes Mitglied
7. Dezember 2012
579
10
Kerken
#1
Ich habe gestern und heute bei 4 Shops das Update auf 4.06.11 installiert. Bei dreien funktioniert seit dem der Themeeditor nicht. Egal welches Theme man auswählt, er meldet "CSRF-Token fehlt". Was tun?

Bei einem Shop, bei dem es ebenso diesen FEhler gibt, wurden auf einmal keine Bilder mehr angezeigt. Beim Blick ins Fehlerprotokoll musste ich feststellen, dass es die .htaccess im media-Verzeichnis war. Da steht drin option -index und DAs Fehlerprotokoll sagt "Option not allowed here".

Ich habe da die .htaccess erst mal deaktiviert. Danach waren die Bilder wieder da. Hat jemand eine Idee?
 

HelmaSpona

Gut bekanntes Mitglied
7. Dezember 2012
579
10
Kerken
#2
Also das mit Theme-Editor habe ich herausgefunden, geht nämlich nur bei firefox nicht. Verstehe ich aber dennoch nicht. Ich abe einen nagelneuen Rechner gerade installiert, Firefox ist frisch drauf mit STandardeinstellungen. Cookies werden akzeptiert.
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
994
194
Halle
#3
Hallo,
Beim Blick ins Fehlerprotokoll musste ich feststellen, dass es die .htaccess im media-Verzeichnis war. Da steht drin option -index und DAs Fehlerprotokoll sagt "Option not allowed here".

Ich habe da die .htaccess erst mal deaktiviert. Danach waren die Bilder wieder da. Hat jemand eine Idee?
Das deaktivieren der Index-Anzeige für das Media-Verzeichnis ist eine Sicherheitseinstellung. Man kann jedoch über die Serverkonfiguration mit einem "AllowOverride" festlegen, welche Konfigurationsoptionen per .htaccess änderbar sind und welche nicht. Offensichtlich ist bei dem betroffenen Server das "option" für eine Verwendung in der .htaccess nicht erlaubt. Hier sollte dann das option -index für das Media-Verzeichnis direkt in der Server-Konfiguration gemacht und aus der .htaccess entfernt werden.