Neu Super-GAU, Systemlaufwerk (SSD) vom Server-Rechner kaputt

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Hallo,

bei mir hat das Systemlaufwerk (SSD) vom Wawi-Hauptrechner (Win7-64) urplötzlich den Geist aufgegeben. Selbst ein Live-Linux findet kein Dateisystem mehr, also ist vermutlich der SSD-Controller defekt. Vor kurzem hatte ich noch die SMART-Werte gecheckt, da war noch alles ok.

Auf dem Systemlaufwerk waren neben Windows und sonstigen Programmen die Wawi 0.99923 und der MSSQL-Server Express 2008-R2 (das "R2" kam mal irgendwann als Update) installiert.

Für "Daten" gibt es eine seperate Festplatte und die Datenbanken der Wawi befinden sich auf einer extra Partition (Laufwerk "S"), diese Festplatte ist in Ordnung!

Nun habe ich erstmal auf einer neuen SSD das Windows 7-64 incl. Patches wieder installiert.

Wie muss ich weiter vorgehen, wenn ich das "neue" Windows bzw. die neu zu installierende Wawi mit der vorhandenen Datenbank "verheiraten" will?
Die Wawi 0.99923 habe ich schon runtergeladen. Könnte man evtl. gleich auf einen MSSQL-Server 2012 Express gehen?

Sorry für die vllt. unqualifizierten Fragen, bin leider kein Profi, nur ein "Benutzer".
Hatte die Wawi mal vor einigen (vielen?) Jahren aufgesetzt und seitdem hatte sie klaglos funktioniert.

Notfalls habe ich auch noch Sicherungen von "eazybusiness" und den zwei produktiv genutzen Mandanten (die Sicherung wurde täglich automatisch mit einem Batch-Script erzeugt).

Gruß Andreas
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.340
537
Also wenn du eine aktuelle .bak (Datensicherung) hast die du verwenden könntest:

Installiere die WAWI 1.0 - das geht sehr einfach.
- Oder die 0.923 mit leerer DB, mach einen Update auf 1.0
Dort spielst du deine .bak ein.
Die Konvertierung startet.
Dann installiere eine WAWI 1.5

Das wäre der schnelle einfache Weg und du wärst auch mit der WAWI wieder aktuell.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Ich habe drei ".bak's". Einmal "Eazy" und eine je Mandant.
Wie müsste ich da vorgehen?

Ein Upgrade der Wawi würde ich vorerst nicht machen wollen.
Bei den neuen Versionen hat sich sicherlich sehr viel verändert, was vermutlich auch Anpassungen in Formularen und Arbeitsabläufen erfordert. Da habe ich jetzt keinen Nerv dafür.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.340
537
Sorry, habe nur 1 Mandanten, kenne mich da nicht aus.

Stolperstein ist wie hier im Forum öfters nachzulesen ist immer wieder der SQL-Server, wenn man alte Versionen neu installieren will.
Da muss man ggf. den Weg gehen die .bak über den SQL-Server zu restoren.

Ist man auf einer WAWI 1.x geht das alles super über den DB-Manager, da hat JTL Vieles sehr viel einfacher gemacht.
Man kann sehr gut auch mehrere Mandanten verwalten.

Formulare - die werden weiterhin unterstützt, ich hatte da keine Probleme damit, bin auch erst sehr spät auf eine 1.3 gewechselt von 0.9923.
Nur der ganze Auslieferungsprozess ist völlig anders und wir mussten unseren "alten" Weg in den neuen Möglichkeiten suchen, arbeiten aber letztlich bis heute so gut wie gleich wie mit der 0.9923.

Aber es stimmt, das kann alles etwas viel sein, wenn man updaten will/muss in einer Zwangslage.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.340
537
Ach ja, mach IMMER einen Wiederherstellungspunkt beim neuen Rechner, damit du wenn alles versaut ist auf einen sauberen Windows-Stand zurückkehren kannst und keine Datenleichen vom SQL-Server oder WAWI auf dem Rechner hast die dir Folgeprobleme machen, wenn du das gleiche nochmals machen willst, aber doch anders.
 

_simone_

Sehr aktives Mitglied
17. Februar 2013
2.973
308
Emsland
Was für die Zukunft noch helfen könnte:
Ab und zu ein Clon von der Systemplatte machen. (bsp. mit "clonzilla") Damit kannst du dann in ein paar Minuten auf eine neue SSD das System neu erstellen.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Vielen Dank für eure Tipps, doch die helfen mir im Moment nur sehr eingeschränkt weiter.

Deshalb will ich mein Problem nochmal präzisieren.

1. Wie kann ich die neu installierte Wawi mit neu installiertem MSSQL-Server an die vorhandene (intakte) Datenbank andocken bzw. die vorhandene Datenbank in die neu installierte Wawi + SQL-Server einbinden?

2. Falls das überhaupt nicht funktionieren sollte - wie müsste ich die vorhandenen Sicherungen einpflegen?
Wawi und MSSQL-Server installieren, dann die Mandanten anlegen und dann die jeweilige Sicherung einspielen?
Oder sind die Mandanten (und sonstige Einstellungen) in der "Eazybusiness" enthalten?
Dann müsste ich zuerst die Eazybusiness einspielen und dann die einzelnen Mandanten?

Wie schon oben geschrieben - ich habe 3 .bak Dateien in jeder Sicherung (Eazy, Mandant_2, Mandant_3 (das sind alle aktiv benutzten)).
Das machte ein Batch-Script täglich, welches ich vor Jahren aus einer Anleitung von JTL kopiert und entsprechend angepasst hatte.

Leider stecke ich nicht so in der Materie drin, dass ich dieses Problem selber lösen könnte.
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.340
537
Also, wenn du eine intakte WAWI und SQL-Server hast, also mit einer leeren DB, dann müsstest du doch nur die .baks importieren über die WAWI ?
Wie sollte es anders sein ? In den .baks ist alles drin, was die WAWI braucht, die WAWI hätte dann ja schon eine lauffähige DB nur ohne deine Daten - sonst wäre eine Datensicherung als .bak sinnlos.

PS: die Meisten scheitern eben daran eine leere WAWI 0.923 lauffähig zu installieren, sorry, wenn ich dich damit verwirrt hatte.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Nun, das Installieren hatte ich damals ja auch hinbekommen, ist allerdings schon Jahre, also eine gefühlte "Ewigkeit" her.
Allerdings weiß ich auch noch, dass es eine ganze menge Fallstricke gab, z.B. die ODBC-Verbindung und einiges anderes.
Leider sind bei JTL alle Wikis und Hilfen zur Installation der "alten" Versionen komplett verschwunden.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Ich nutze derzeit noch Win7, Win10 ist mir ein Graus...

Habe jetzt die Wawi 99923 und den MSSQL Server 2012 Express installiert.
Konnte die Wawi dann auch öffnen und habe die .bak der "eazybusiness" eingespielt.

Jetzt sind auch die vorherigen Benutzer wieder aktiv und unter "Mandanten" sehe ich auch alle früher vorhandenen.

Nur eine Rücksicherung der einzelnen Mandanten (da sind ja die wirklich wichtigen "Arbeitsdaten" drin) gelingt mir nicht.

Bei JTL-Wawi -> Mandanten -> Mandant auswählen -> Datenbank importieren kommt immer "Datenbank nicht gefunden".

Wenn ich versuche mich bei einem Mandanten anzumelden, kommt auch ein Fehler und die Wawi schließt sich.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Weiß denn wirklich keiner mehr, wie man bei der 99923 die Sicherungen der einzelnen Mandanten wieder in eine neu installierte Wawi einspielen kann?

Vielleicht müsste ich ja zuerst noch leere Datenbanken für die einzelnen Mandanten erzeugen? Wenn ja, wie müsste ich das machen?
 

MichaelH

Sehr aktives Mitglied
17. November 2008
11.340
537
Ruf doch mal beim JTL-Support an, das ist eine klare Frage und ggf. sehr einfach am Telefon zu beantworten.

-> WAWI neu installiert (alte Version), wie restore ich mehrere Mandanten ?
 
  • Gefällt mir
Reaktionen: Condorraptor

JohannP

Offizieller Servicepartner
SPBanner
27. Juli 2015
168
31
Flensburg
@dreamer Die .bak Dateien können mit dem SQL Management Studio eingespielt werden, wenn die dazugehörigen Datenbanken nicht existieren.
Danach kann dann mit der Wawi drauf zugegriffen werden.

Falls du es nicht selbst testen möchtest, könnte ich dir heute am frühen Abend (ca. 17:30) per Teamviewer helfen. Wenn gewünscht, einfach Kontaktdaten per Privater Nachricht oder an info@plath-it.de schicken.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
@JohannP

Vielen Dank für dein Angebot, aber du hast mir auch schon so weitergeholfen, das war nämlich der entscheidende Hinweis.

Habe mit dem Management Studio die Datenbanken "mandant_2" und "mandant_3" angelegt. Danach konnte ich dann in der Wawi die .bak's der beiden Mandanten einspielen. Scheint funktioniert zu haben, denn die Mandanten lassen sich öffnen und haben die entsprechenden Daten.

Nun muss ich mich nur noch um die Client-Anbindung (ODBC Verbindung) kümmern und dann nochmals alles checken (Drucker u.s.w.).

Ach ja, mit ODBC war doch auch noch was. Das gabs doch bei 64 Bit Windows an zwei Stellen aber nur eins war das richtige! Weiß jemand noch welches?

(Ein Upgrade (Windows und JTL) ist eine andere Baustelle, das mache ich später wenn ich mehr Zeit habe. Erst muss ich die liegengebliebenen Aufträge erledigen.)
 

JohannP

Offizieller Servicepartner
SPBanner
27. Juli 2015
168
31
Flensburg
Ich meine, bitte nagel mich nicht darauf fest, dass es die ODBC unter c:\windows\Syswow64\odbcad32.exe war.
Diese Angabe ist ohne Gewähr ;)
 

wawi-dl

Sehr aktives Mitglied
29. April 2008
4.682
196
Ich meine auch es war die 32Bit ODBC, aber am besten auch mal prüfen ob du für deine SQL Version auch die passenden Treiber drauf hast, bzw. bei den Clients.

Firewall/Virenscan ausmachen, Verbindung aufbauen, dann wieder aktivieren.
 

dreamer

Aktives Mitglied
13. Februar 2014
64
2
Vielen Dank an alle, die mit hilfreichen Tipps und Denkanstößen behilflich waren.

Habe jetzt erstmal den Server-Rechner und einen Client wieder am laufen und arbeite erstmal den Auftragsstau ab.