Neu Shopware 6: Malformed UTF-8 characters, possibly incorrectly encoded

karabey

Gut bekanntes Mitglied
28. November 2012
762
23
Hallo,

Hab Shopware 6 installiert und hab das Problem mit "Malformed UTF-8 characters, possibly incorrectly encoded".

Lösungen dafür habe ich nicht finden können. Die Tabellen haben utf8mb4_unicode_ci Kollation

Code:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Shopware Test'.
Gesendet: Kategorien (3 Stück)
Onlineshop-Abgleich beendet für 'Shopware Test'.


Fehler:
Exception: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded
Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"jtlrpc":"2.0","id":"0e338a1eeb4c45faa857e36186b414df","result":null,"error":{"code":500,"message":"Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [e336f8b7-8705-450b-8920-e9a2fadfc76b] The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:99"}}
Exception bei product.push: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"jtlrpc":"2.0","id":"a0ed2f23074347ee962c0177368fdc23","result":null,"error":{"code":500,"message":"Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:99"}}
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gj57Nrp1S60(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.Y6W7NisJERx(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gj57Nrp1S60(String  , Object  , Boolean  , NetworkCredential  )
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: HeadCo

HeadCo

Neues Mitglied
4. Juni 2021
1
0
Hallo,

wir haben leider das gleiche Problem und sind noch zu keiner Lösung gekommen.

Es handelt sich dabei um Variantenartikel. Varianten mit "ü" oder "ß" habe ich bereits rausgenommen, jedoch taucht der Fehler weiterhin auf.
 

Anhänge

  • log.txt
    410,5 KB · Aufrufe: 3
Zuletzt bearbeitet:

Daniel.199

Neues Mitglied
29. Juli 2021
8
3
Coburg
Bei mir tritt genau das selbe Problem auf - allerdings betriefft es neben den ä,ö,ü und ß auch weitere Sonderzeichen wie Ø
Komplettabgleich neu gestartet hat bislang auch noch nicht zu einem Ergebnis geführt

Welche Möglichkeiten gibt es denn noch, diese Daten auf einem vernünftigen Weg in ein UTF-8 konformes Format zu bekommen?
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
Bei mir tritt genau das selbe Problem auf - allerdings betriefft es neben den ä,ö,ü und ß auch weitere Sonderzeichen wie Ø
Komplettabgleich neu gestartet hat bislang auch noch nicht zu einem Ergebnis geführt

Welche Möglichkeiten gibt es denn noch, diese Daten auf einem vernünftigen Weg in ein UTF-8 konformes Format zu bekommen?
Hallo @Daniel.199,

Die Shopware API gibt diese Meldung oft fälschlicherweise zurück. Eigentliches Problem sind meistens die Angabe von nicht (mehr) existierenden Relationen. Relationen sind zB. Verknüpfungen zwischen einem Produkt und Kategorien, Eigenschaften, etc. Wenn ein Komplettabgleich nicht geholfen hat, dann liegt es mit hoher Wahrscheinlichkeit an "doppelten" Merkmalen in JTL-Wawi. Doppelte Merkmale sind Merkmale, welche denselben Namen besitzen. Lösung ist die doppelten Merkmale zusammenzuführen, sodass in JTL-Wawi nur noch ein Merkmal mit diesem Namen existiert.
 
  • Gefällt mir
Reaktionen: Daniel.199

Daniel.199

Neues Mitglied
29. Juli 2021
8
3
Coburg
Hallo @Immanuel

genau das war das Problem - doppelte Merkmale waren ein paar Vorhanden - auf diesen Lösungsansatz wäre ich beim Besten Willen nicht gekommen.
Aber das Shopware in manchen Momenten komisch reagiert, weiß jeder, der sich auf Shopware eingelassen hat :)

Danke für die schnelle Hilfe!
 

haneu

Mitglied
10. März 2021
4
1
Hallo @Daniel.199,

Die Shopware API gibt diese Meldung oft fälschlicherweise zurück. Eigentliches Problem sind meistens die Angabe von nicht (mehr) existierenden Relationen. Relationen sind zB. Verknüpfungen zwischen einem Produkt und Kategorien, Eigenschaften, etc. Wenn ein Komplettabgleich nicht geholfen hat, dann liegt es mit hoher Wahrscheinlichkeit an "doppelten" Merkmalen in JTL-Wawi. Doppelte Merkmale sind Merkmale, welche denselben Namen besitzen. Lösung ist die doppelten Merkmale zusammenzuführen, sodass in JTL-Wawi nur noch ein Merkmal mit diesem Namen existiert.
Hallo Immanuel,

ich bin jetzt nochmal alle Merkmale durchgegangen und wir haben keine doppelte Bezeichnungen dabei. Ein Komplettabgleich hilft nicht weiter, zumal wir 110.000 Produkte übertragen, was leider schon Tage dauert. Kann es sonst noch was sein, warum der Abgleich abbricht? Kann ich das in einem Shopware- Log sehen? Wir haben jetzt noch einen zweiten Shopware 6- Shop aufgesetzt, der komplett leer war aber auch da bricht es bei den gleichen Produkten ab.

Über einen Tipp würde ich mich sehr freuen.
 

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
Hallo Immanuel,

ich bin jetzt nochmal alle Merkmale durchgegangen und wir haben keine doppelte Bezeichnungen dabei. Ein Komplettabgleich hilft nicht weiter, zumal wir 110.000 Produkte übertragen, was leider schon Tage dauert. Kann es sonst noch was sein, warum der Abgleich abbricht? Kann ich das in einem Shopware- Log sehen? Wir haben jetzt noch einen zweiten Shopware 6- Shop aufgesetzt, der komplett leer war aber auch da bricht es bei den gleichen Produkten ab.

Über einen Tipp würde ich mich sehr freuen.
Hallo @haneu,

schick mir bitte die Fehlermeldung per PM. Dann schaue ich ob ich was dazu in den Server Logs finde.
 

pmart

Mitglied
7. Juni 2021
27
3
Hallo @Immanuel ,

falls es hier zu einer Lösung gekommen ist, wäre ich sehr dankbar, wenn du die hier posten könntest. Wir stehen derzeit vor demselben Problem. Doppelte Merkmale existieren nicht. Er bricht immer beim selben Artikel mit dem demselben Error ab, wie er hier im Threadtitel steht. Wir kommen so nicht weiter...
 

haneu

Mitglied
10. März 2021
4
1
Hi,

bei uns war es am Ende die META Description. Ich hatte die auf 250 Zeichen gekürzt, aber erst bei 100 Zeichen waren die Fehler weg.

Ich würde es Mal versuchen.

Viele Grüße, HANEU.de
 

pmart

Mitglied
7. Juni 2021
27
3
Hallo Haneu,

danke für deine Antwort. Dass es daran liegt kann ich mittlerweile ausschließen. Ich bin mir sicher den Fehler gefunden zu haben. Aber weder Ursache noch Lösung ist in Sicht. Ich werde einen Thread hierfür eröffnen.

VG
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL Connector zu Shopware 6 gibt Fehler aus Shopware-Connector 2
Neu Shopware Connector - Felder nicht übertragen Shopware-Connector 0
Neu Shopware 6 Connector Problem beim Abgleich von Bildern Shopware-Connector 1
Neu Shopware 6 Auftrags-Import stockt Bestände auf Shopware-Connector 0
Neu JTL-WaWi <-> Shopware 5: Übertragung Timeout / Welche Daten werden übertragen? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Shopware - Fehler beim Senden von Artikeln Shopware-Connector 0
Neu Shopware 6 Connector verweigert seit Verlängerung SSL-Zertifikat seinen Dienst Shopware-Connector 4
Neu Shopware 6 Connector - erweiterte Preise ab 6.4.7 möglich Shopware-Connector 0
Neu Shopware 6 - Einstellungen im Kundencenter - Standard Verkaufskanäle (kommasepariert) Shopware-Connector 0
Neu Shopware 6 Verkaufskanäle und Shopware-Connector Shopware-Connector 1
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 1
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 2
Neu JTL-Vouchers für Shopware 5 Plugin Shopware-Connector 1
Neu Sonderpreise JTL - Shopware Shopware-Connector 0
Neu Abgleichfehler: No shopware language found for language iso "" Shopware-Connector 0
Neu Wechsel von Shopware Cloud zu JTL Shop 5 Onlineshop-Anbindung 2
Neu Shopware 6 mit Custom Products - Probleme bei Auftragsimport Shopware-Connector 18
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu Suche Freelancer/Partner für WAWI & Connector Shopware 6 Dienstleistung, Jobs und Ähnliches 0
Neu Freelancer / Berater für Shopware 6 Connector & mehr gesucht Dienstleistung, Jobs und Ähnliches 0
Neu 'supplytime' an Shopware übetragen Shopware-Connector 5
Neu JTL Ameise Rechnungsexport mit UTF-8 Encoding JTL-Ameise - Ideen, Lob und Kritik 1

Ähnliche Themen