Neu Shopware 6: Malformed UTF-8 characters, possibly incorrectly encoded

karabey

Gut bekanntes Mitglied
28. November 2012
730
20
Hallo,

Hab Shopware 6 installiert und hab das Problem mit "Malformed UTF-8 characters, possibly incorrectly encoded".

Lösungen dafür habe ich nicht finden können. Die Tabellen haben utf8mb4_unicode_ci Kollation

Code:
Abgleich-Protokoll:
Bitte beachten Sie, dass JTL-Wawi federführend ist!
Im Shop-Backend vorgenommene Änderungen können nicht mehr automatisiert abgeglichen werden und führen somit zu Datenverlust.
Prüfe Endpointkonfiguration.
Abgleich gestartet für 'Shopware Test'.
Gesendet: Kategorien (3 Stück)
Onlineshop-Abgleich beendet für 'Shopware Test'.


Fehler:
Exception: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded
Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded
Artikel-Senden-Fehler: Bitte beachten Sie, dass zur Fehler-Diagnose ebenfalls die Log-Datei des Servers und das Abgleich-Log der JTL-Wawi notwendig sind!
Exception bei product.push: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"jtlrpc":"2.0","id":"0e338a1eeb4c45faa857e36186b414df","result":null,"error":{"code":500,"message":"Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [e336f8b7-8705-450b-8920-e9a2fadfc76b] The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:99"}}
Exception bei product.push: Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [67db12b0-39b3-4902-a2ed-69c1a936465a] The Shopware 6 Admin API responded with an error:
Code = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded

Response: {"jtlrpc":"2.0","id":"a0ed2f23074347ee962c0177368fdc23","result":null,"error":{"code":500,"message":"Controller = Product | Action = push | JTL-Wawi PK = 1282 | SKU = WET54039 | Name = Knopfzelle Lithium CR2016 | [06c0f70e-32fc-4601-a083-7d57d8fb83b5] The Shopware 6 Admin API responded with an error: \nCode = 0 | Status = 500 | Detail = Malformed UTF-8 characters, possibly incorrectly encoded","data":"Jtl\\Shopware6\\Client\\Exception\\ClientException (Code: 500) in ...\/ClientException.php:99"}}
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gj57Nrp1S60(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.Y6W7NisJERx(String  , Object  , Boolean  , NetworkCredential  )
   bei jtlCore.ControllerClasses.Connector.Abgleich.Connector.gj57Nrp1S60(String  , Object  , Boolean  , NetworkCredential  )
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: HeadCo

HeadCo

Neues Mitglied
4. Juni 2021
1
0
Hallo,

wir haben leider das gleiche Problem und sind noch zu keiner Lösung gekommen.

Es handelt sich dabei um Variantenartikel. Varianten mit "ü" oder "ß" habe ich bereits rausgenommen, jedoch taucht der Fehler weiterhin auf.
 

Anhänge

  • log.txt
    410,5 KB · Aufrufe: 3
Zuletzt bearbeitet:

Daniel.199

Neues Mitglied
29. Juli 2021
8
3
Coburg
Bei mir tritt genau das selbe Problem auf - allerdings betriefft es neben den ä,ö,ü und ß auch weitere Sonderzeichen wie Ø
Komplettabgleich neu gestartet hat bislang auch noch nicht zu einem Ergebnis geführt

Welche Möglichkeiten gibt es denn noch, diese Daten auf einem vernünftigen Weg in ein UTF-8 konformes Format zu bekommen?
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.434
299
Bei mir tritt genau das selbe Problem auf - allerdings betriefft es neben den ä,ö,ü und ß auch weitere Sonderzeichen wie Ø
Komplettabgleich neu gestartet hat bislang auch noch nicht zu einem Ergebnis geführt

Welche Möglichkeiten gibt es denn noch, diese Daten auf einem vernünftigen Weg in ein UTF-8 konformes Format zu bekommen?
Hallo @Daniel.199,

Die Shopware API gibt diese Meldung oft fälschlicherweise zurück. Eigentliches Problem sind meistens die Angabe von nicht (mehr) existierenden Relationen. Relationen sind zB. Verknüpfungen zwischen einem Produkt und Kategorien, Eigenschaften, etc. Wenn ein Komplettabgleich nicht geholfen hat, dann liegt es mit hoher Wahrscheinlichkeit an "doppelten" Merkmalen in JTL-Wawi. Doppelte Merkmale sind Merkmale, welche denselben Namen besitzen. Lösung ist die doppelten Merkmale zusammenzuführen, sodass in JTL-Wawi nur noch ein Merkmal mit diesem Namen existiert.
 
  • Gefällt mir
Reaktionen: Daniel.199

Daniel.199

Neues Mitglied
29. Juli 2021
8
3
Coburg
Hallo @Immanuel

genau das war das Problem - doppelte Merkmale waren ein paar Vorhanden - auf diesen Lösungsansatz wäre ich beim Besten Willen nicht gekommen.
Aber das Shopware in manchen Momenten komisch reagiert, weiß jeder, der sich auf Shopware eingelassen hat :)

Danke für die schnelle Hilfe!
 

haneu

Mitglied
10. März 2021
4
1
Hallo @Daniel.199,

Die Shopware API gibt diese Meldung oft fälschlicherweise zurück. Eigentliches Problem sind meistens die Angabe von nicht (mehr) existierenden Relationen. Relationen sind zB. Verknüpfungen zwischen einem Produkt und Kategorien, Eigenschaften, etc. Wenn ein Komplettabgleich nicht geholfen hat, dann liegt es mit hoher Wahrscheinlichkeit an "doppelten" Merkmalen in JTL-Wawi. Doppelte Merkmale sind Merkmale, welche denselben Namen besitzen. Lösung ist die doppelten Merkmale zusammenzuführen, sodass in JTL-Wawi nur noch ein Merkmal mit diesem Namen existiert.
Hallo Immanuel,

ich bin jetzt nochmal alle Merkmale durchgegangen und wir haben keine doppelte Bezeichnungen dabei. Ein Komplettabgleich hilft nicht weiter, zumal wir 110.000 Produkte übertragen, was leider schon Tage dauert. Kann es sonst noch was sein, warum der Abgleich abbricht? Kann ich das in einem Shopware- Log sehen? Wir haben jetzt noch einen zweiten Shopware 6- Shop aufgesetzt, der komplett leer war aber auch da bricht es bei den gleichen Produkten ab.

Über einen Tipp würde ich mich sehr freuen.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.434
299
Hallo Immanuel,

ich bin jetzt nochmal alle Merkmale durchgegangen und wir haben keine doppelte Bezeichnungen dabei. Ein Komplettabgleich hilft nicht weiter, zumal wir 110.000 Produkte übertragen, was leider schon Tage dauert. Kann es sonst noch was sein, warum der Abgleich abbricht? Kann ich das in einem Shopware- Log sehen? Wir haben jetzt noch einen zweiten Shopware 6- Shop aufgesetzt, der komplett leer war aber auch da bricht es bei den gleichen Produkten ab.

Über einen Tipp würde ich mich sehr freuen.
Hallo @haneu,

schick mir bitte die Fehlermeldung per PM. Dann schaue ich ob ich was dazu in den Server Logs finde.
 

pmart

Neues Mitglied
7. Juni 2021
19
3
Hallo @Immanuel ,

falls es hier zu einer Lösung gekommen ist, wäre ich sehr dankbar, wenn du die hier posten könntest. Wir stehen derzeit vor demselben Problem. Doppelte Merkmale existieren nicht. Er bricht immer beim selben Artikel mit dem demselben Error ab, wie er hier im Threadtitel steht. Wir kommen so nicht weiter...
 

haneu

Mitglied
10. März 2021
4
1
Hi,

bei uns war es am Ende die META Description. Ich hatte die auf 250 Zeichen gekürzt, aber erst bei 100 Zeichen waren die Fehler weg.

Ich würde es Mal versuchen.

Viele Grüße, HANEU.de
 

pmart

Neues Mitglied
7. Juni 2021
19
3
Hallo Haneu,

danke für deine Antwort. Dass es daran liegt kann ich mittlerweile ausschließen. Ich bin mir sicher den Fehler gefunden zu haben. Aber weder Ursache noch Lösung ist in Sicht. Ich werde einen Thread hierfür eröffnen.

VG
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Shopware 6 - Connector Error: Malformed UTF-8 characters Shopware-Connector 3
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 0
Neu Hilfe bei Shopware Update 5.5 auf 5.6.10 gesucht (inkl. Plugins) User helfen Usern 0
Verwiesen an Support Händlerpreise werden nicht an Shopware übergeben Shopware-Connector 2
Beantwortet JTL an Shopware 6 angebunden - EAN, Artikelnummer nicht übermittelt zu JTL Shopware-Connector 4
Neu Fehler bei der Synchronisierung mit Shopware Starten mit JTL: Projektabwicklung & Migration 2
Neu Problem beim Shopware Abgleich/Artikel werden nicht übertragen Shopware-Connector 0
Neu Shopware 6 / Artikelbilder Upload Probleme Shopware-Connector 1
Neu Shopware 6 - Erweiterte Preise Shopware-Connector 1
Neu Shopware und JTL - Agentur - Betreuung gesucht User helfen Usern 2
Neu [Shopware 6] Kein Clean-Up von Attritbuten Shopware-Connector 0
Neu Shopware 6 Connector User helfen Usern 0
Neu Shopware 6 - Abgleich von Belegen zur Bestellung Shopware-Connector 0
Neu Shopware 6 - Priorität im Rule Builder bei Sonderpreisen Shopware-Connector 0
Neu Kunde möchte Sicherheitsupdate Shopware durchführen Shopware-Connector 2
Neu Zulauf von Artikel (Menge und Datum) in Shopware übertragen Shopware-Connector 6
Neu Shopware 6 Connector - API error .. "Dieser Wert sollte nicht leer sein" Shopware-Connector 3
Neu Web Developer / Webentwickler JTL Shopware - freiberuflich (m/w/d) gesucht Dienstleistung, Jobs und Ähnliches 0
Neu Shopware 5 URL-Pfad passt sich nicht dem Sub-Shop an Shopware-Connector 0
Neu Shopware 6 Connector schmeißt ständig Fehlermeldung Shopware-Connector 4
Neu Shopware 6 - Probleme bei Produktbildern Shopware-Connector 1
Neu Shopware 5 Connector anmeldung nicht möglich nach Update Shopware-Connector 2
Neu Übernahme von Produktnamen aus Shopware 6 Shopware-Connector 0
Neu Shopware 6: HTML-Tags in Attributen werden nicht übertragen? Shopware-Connector 2
Gelöst Auslandsversand und Shopware Shop JTL-ShippingLabels - Fehler und Bugs 1
Neu Shopware & JTL-Wawi - Welche Aufgaben übernimmt wer? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Hilfe! WAWI abgleich mit Shopware 6 geht nicht. Shopware-Connector 1
weiße Seite HTTP ERROR 500 bei Schritt 4: Migration auf InnoDB/UTF-8 vornehmen Upgrade JTL-Shop4 auf JTL-Shop5 16
Neu UNICODE, HTML und UTF-8 Zeichen (ASCII Zeichen) als Amazon Bullet Point Sonderzeichen User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen