Neu Provider hat MySQL 8

sventimo

Gut bekanntes Mitglied
7. Juli 2010
134
1
Hallo,
wir wollen den Shop 5 installieren, unser Provider hat allerdings inzwischen MySQL 8.0.19 im Einsatz und hat Befürchtungen, dass Shop 5 unter Umständen mit der MySQL 8er Version haben könnte.
Können wir den Shop 5 trotzdem darauf installieren (lassen) und läuft er dann stabil? - Oder habt Ihr andere Vorschläge für uns?

Vielen Dank
Andreas
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
1.509
359
Halle
Hallo,
MySQL 8 bringt eine Menge Änderungen die für Administration (aber weniger für den Shop) relevant sind. Inkompatible SQL-Änderungen die für den Shop relevant wären gibt es nur insofern, dass MySQL 8 eine Menge neue reservierte Wörter definiert. u.a: DESCRIPTION, HISTORY, INVISIBLE, VISIBLE, ...) Hier kann nicht ausgeschlossen werden, dass es Abfragen im Shop oder in Plugins gibt, die dann aufgrund fehlender Maskierung Fehler verursachen.
Aus diesem Grund haben wir für die aktuellen Versionen von JTL-Shop noch keine Freigabe für MySQL 8.
 

hula1499

Sehr aktives Mitglied
22. Juni 2011
4.339
753
Voten hat den gleichen Stellenwert und eine ähnliche Chance auf "Gewinn", wie einen Lottoschein daheim ausfüllen und nicht aufgeben....
 
  • Gefällt mir
Reaktionen: SebiW

Ähnliche Themen