Neu Problem: Sysgrade ecommerce Integrator - Magento 2.4 API-Verbindung Einstellungen

mort

Neues Mitglied
20. März 2021
5
1
Moin moin,

und ein freundliches Hallo! Bin neu hier im Universum, aber ich frage gleich mal ganz konkret. :)
Ich möchte über den Sysgrade E-Commerce Integrator meinen Magento 2.4 Shop anbinden. In der Doku finde ich dazu folgenden Absatz:
JTL: 1.5.41.3, Magento 2.4.1, ecommerce Integrator Build 5388, Version 2020.9.0)

API-Verbindung
Vervollständige nun die Informationen zur Verbindung mit der eCI-API des Webshops:

  • Shop-Adresse. Die Adresse, unter der dein Webshop erreichbar ist, also beispielsweise http://www.beispiel.de (die Angabe benötigt zwingend das Präfix http:// oder https:// an dieser Stelle). Bitte beachte, dass die Verwendung von https:// abhängig von deiner Serverkonfiguration ggf. nicht möglich ist; kontaktiere in diesem Fall bitte deinen Serveradministrator.
  • Api-Benutzer. Der Name des Benutzers zum Zugriff auf die API des Shops. Dieser Benutzer ist in den eCI Shopmodul-Einstellungen unter REST API → Nutzername zu finden und konfigurierbar.
  • Api-Schlüssel. Der Schlüssel wurde bei der Installation des eCI-Moduls in Ihrem Shop erzeugt und kann im Shop eingesehen werden. Dieser findet sich in Ihrem Magento-Backend unter dem Menüpunkt REST API → API Schlüssel

Sysgrade hat bei der Plugin Installation im Magento einen normalen User angelegt, der eine eigene Rolle hat.
1616254290905.png

Laut Beschreibung sollte mit Plugin Installation ein API User angelegt worden sein, war aber nicht.

Also habe ich selbst einen erstellt:
1616254387419.png

Dieser hat von mir auch erst einmal alle API Rechte bekommen.
Nun versuche ich, mit diesen Daten eine Verbbindung herzustellen (reale Daten mal unkenntlich gemacht).

1616254804962.png

Hat das jemand zum laufen bekommen?
Hab es mit den verschieden Usern (der angelegte Systemunser und meinem API User probiert), mit dem Access Token und auch dem User Key des generierten Magento API Users.
Egal wie - "Verbindung konnte nicht hergestellt werden"

Vielen Dank, Martin
 

Anhänge

  • 1616254621652.png
    1616254621652.png
    995,7 KB · Aufrufe: 0
Ähnliche Themen
Titel Forum Antworten Datum
Neu Der Artikel besitzt nicht die korrekte Anzahl von Variationen - Amazon Lister Problem Amazon-Lister - Fehler und Bugs 0
Neu Kurioses Problem bei Artikeln mit Freitext Variationen Allgemeine Fragen zu JTL-Shop 1
Neu Problem bei der Preisanzeige User helfen Usern - Fragen zu JTL-Wawi 1
Beantwortet Problem mit Teilversand und nicht mehr lieferbar Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Problem mit 1.5.47.0 JTL-Wawi - Fehler und Bugs 7
Neu Problem mit Waage CAS ER Junior User helfen Usern 0
Neu Nach Update auf 1.5.46.4 Bilder Sync-Problem mit Woocommerce WooCommerce-Connector 1
Neu Problem mit Wawi / Ameise. Händler anlegen, aber keine MwSt usw. Schnittstellen Import / Export 0
Neu Problem mit Wawi / Ameise. Händler anlegen, aber keine MwSt usw. User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem bei Amazon / Amazon erstellt Rechnung / Kein VCS aktiviert Amazon-Anbindung - Fehler und Bugs 5
Neu Problem mit Update Version 1.5.46.0 und folgende Gelöste Themen in diesem Bereich 6
Beantwortet Amazon Problem API Erstellung Einrichtung JTL-Shop5 1
Neu Problem mit Update (Version 1.5.46.0) JTL-Wawi - Fehler und Bugs 2
Neu Ein Artikel zwei Steuersätze. Wie löse ich das Problem? Arbeitsabläufe in JTL-Wawi 3
Neu Homepage (https://www.jtl-software.de/) / Webserver down? 505 - Joisten, wir haben ein Problem! Smalltalk 2
In Bearbeitung Sunmi T2 + Kundendisplay => Problem JTL-POS - Fehler und Bugs 8
Neu Google Problem - noindex in robots.tt Allgemeine Fragen zu JTL-Shop 1
Nach Update .htaccess Problem Upgrade JTL-Shop4 auf JTL-Shop5 2
Neu Varikombis - Problem mit Vaterartikel oder falsche Denkweise? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Problem beim Listen in Produkttyp "shirt": Some attributes are missing for SKU Amazon-Lister - Fehler und Bugs 5
Neu Problem mit Artikel die für andere Länder/Sprachen gedacht sind... Modified eCommerce-Connector 0
Neu Email Versand Problem (Timeout?) bei Lieferantenbestellung JTL-Wawi - Fehler und Bugs 0

Ähnliche Themen