Neu [OPC] OnPage Composer wird nicht geladen

  • JTL-Connect 2024: Ihr habt noch kein Ticket? Jetzt Early Bird Ticket zum Vorzugspreis sichern! HIER geht es zum Ticketverkauf

  • Wartungsarbeiten - Kundencenter: Vom 23.07.24 ab 21 Uhr bis 24.07.24 vormittags. Das Kundencenter wird in dieser Zeit nicht erreichbar sein.

Neco

Aktives Mitglied
17. Januar 2018
10
1
Hi

Ich bekommen seit kurzem ein Fehler beim bearbeiten der Seiten mittels [OPC] OnPage Composer.
Ich habe nun folgendes schon probiert:

- Standart NOVA template aktiviert
- Alle plugins sind deinstalliert

Leider kein Erfolg.
Chrome gibt folgende Fehlermeldung:

Uncaught (in promise) TypeError: this.jq is not a function at Iframe.js:5

Hat jemand eine Idee woran das liegen könnte?

Nachtrag: ich habe vor kurzem die hauptdomain über die config datei geändert und cache komplett geleert, alles funktioniert nur opc nicht mehr.
Nachtrag2: wenn ich die Domain zurück ändere dann funktioniert das OPC wieder ganz normal. muss man die domain noch wo anders eintragen? In der Datenbank sind keine alten domains mehr zu finden...
 

Anhänge

  • Bildschirmfoto 2021-06-14 um 23.57.29.png
    Bildschirmfoto 2021-06-14 um 23.57.29.png
    605,1 KB · Aufrufe: 35
Zuletzt bearbeitet:

artm

Sehr aktives Mitglied
22. Februar 2021
107
25
Uncaught (in promise) TypeError: this.jq is not a function at Iframe.js:5

Hat jemand eine Idee woran das liegen könnte?

Nachtrag: ich habe vor kurzem die hauptdomain über die config datei geändert und cache komplett geleert, alles funktioniert nur opc nicht mehr.
Nachtrag2: wenn ich die Domain zurück ändere dann funktioniert das OPC wieder ganz normal. muss man die domain noch wo anders eintragen? In der Datenbank sind keine alten domains mehr zu finden...
man muss prüfen wieso neue Domain jQuery nicht laden kann oder das könnte auch an SSL liegen
 

Neco

Aktives Mitglied
17. Januar 2018
10
1
man muss prüfen wieso neue Domain jQuery nicht laden kann oder das könnte auch an SSL liegen

jQuery wird im header geladen und ist auch erreichbar.
SSL Zertifikat habe ich erneuert, keine Besserung

Die Dateien sind die selben, alles im selben Ordner nur die Erreichbarkeit des Shop wird nun über einen anderen shop geleitet.
die alte Domain muss noch irgendwo anders gespeichert sein?!

<html lang="en" class="ready"><head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>OnPage Composer</title>
<link rel="stylesheet" href="https://p13.shop/templates/NOVA/themes/base/bootstrap/bootstrap.css">
<link rel="stylesheet" href="https://p13.shop/admin/templates/bootstrap/css/bootstrap-theme.min.css">
<link rel="stylesheet" href="https://p13.shop/templates/NOVA/themes/base/fontawesome/css/all.min.css">
<link rel="stylesheet" href="https://p13.shop/admin/templates/bootstrap/css/bootstrap-colorpicker.min.css">
<link rel="stylesheet" href="https://p13.shop/admin/templates/bootstrap/css/typeaheadjs.css">
<link rel="stylesheet" href="https://p13.shop/admin/templates/bootstrap/css/tempusdominus-bootstrap-4.min.css">
<link rel="stylesheet" href="https://p13.shop/admin/templates/bootstrap/css/fontawesome-iconpicker.min.css">
<link rel="stylesheet" href="https://p13.shop/admin/opc/css/editor.css">
<script src="https://p13.shop/admin/templates/bootstrap/js/jquery-3.5.1.min.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/jquery-ui.min.js" type="text/javascript"></script>
<script src="https://p13.shop/templates/NOVA/js/bootstrap.bundle.min.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/global.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/searchpicker.js" type="text/javascript"></script>
<script src="https://p13.shop/includes/libs/ckeditor/ckeditor.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/bootstrap-colorpicker.min.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/moment-with-locales.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/download.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/typeahead.bundle.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/tempusdominus-bootstrap-4.min.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/templates/bootstrap/js/fontawesome-iconpicker.min.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/utils.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/OPC.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/GUI.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/Iframe.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/Page.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/IO.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/Tutorial.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/PageTree.js" type="text/javascript"></script>
<script src="https://p13.shop/admin/opc/js/PreviewFrame.js" type="text/javascript"></script>
<script type="text/javascript">
window.opc = new OPC({
jtlToken: 'XXXXXXXXXXXXXXXXXXXXXXX',
shopUrl: 'https://p13.shop',
templateUrl: 'https://p13.shop/admin/templates/bootstrap/',
pageKey: 1,
error: null,
messages: {"....
 

artm

Sehr aktives Mitglied
22. Februar 2021
107
25
jQuery wird im header geladen und ist auch erreichbar.
SSL Zertifikat habe ich erneuert, keine Besserung
Während OPC-Bearbeitung geprüft oder einfach auf der Seite? Ich meinte aber nicht nur Zertifikat, sondern auch Weiterleitungen von http auf https (z.B. unter Shop-Einstellungen). Da muss schon etwas sein, Browser muss schon was ausspucken, irgendwelche Ladeprobleme oder vermutlich CORS-Fehler.