Neu Lieferzeiten Shopware Falsch Bestandsführung Bestellung Im Zulauf

bullit134

Aktives Mitglied
4. August 2019
5
0
Liebe Gemeinde,

zunächst:
JTL WaWi 1.5.26.0
Shopware 5.6.7
Connector Version = JTL Shopware 5 Connector 2.6.0

Wir pflegen jeden Artikel in Einkauf (F3) mit den korrekten Lieferzeiten.
Im Artikel ist die Bestandsführung aktiv.
In den Lageroptionen ist bei "Tage bis Versand" Automatisch ermitteln aktiviert.

Trotzdem wird beim Artikel in Shopware die Standard Lieferzeit (beim Lieferanten hinterlegt) angezeigt, ... nicht die im Einkauf gepflegten Zeiten der Lieferungen je Artikel.

So müssen wir aktuell auf manuelle Bearbeitung ausweichen und nächste Artikel-Ankünfte manuell mit "Erscheint am: dd.mm.yyyy" angeben.

Bis vor einigen Wochen hat die Aktualisierung der Lieferzeiten reibungslos funktioniert.

Wird dieser scheinbare Bug bald gelöst und das Fix in einem Update verfügbar sein?

Beste Grüße aus Münster,
Lars Rensing - Purmax Logistics Europe GmbH - www.purmax.de
 
Zuletzt bearbeitet:

Immanuel

Moderator
Mitarbeiter
24. August 2016
1.542
322
Hallo Lars,

JTL-Wawi sendet seit kurzem in dem Product Property supplierDeliveryTime nur noch die Standard Lieferantenlieferzeit zum Shop. Daher hat sich das Verhalten wie von dir geschildert geändert. Wir werden das Problem im Team Connector besprechen. Melde mich sobald es was neues gibt.
 

3po

Sehr aktives Mitglied
30. August 2011
2.565
86
Das ist doch Mist und habe ich schon zig mal bemängelt :( Aktuell zeigt man bei Artikeln die keinen Lagerbestand haben und auf einer Lieferantenbestellung sind falsche Lieferzeiten an, das ist Abmahnbar. Wenn der Artikel dann plötzlich eine längere Lieferzeit hat als die standardlieferzeit beim Hersteller wird es richtig böse. Früher haben wir hier einfach die Lieferzeit in der Lieferantenbestellung geändert und dann wurde dies an den Shop übertragen. ebenso wurde jeden Tag ein Tag abgezogen und nicht sturr xx Tage angezeigt. Nehmen wir an der Artikel ist bestellt und hat eine Lieferzeit von 21 Tage, dann wird nun 3 Wochen lang als lieferzeit 21 Tage angezeit auch wenn nach 20 Tagen der Artikel in einem Tag eintrifft, also keine 21 Tage Lieferzeit mehr hat!

Des Weiteren ist es auch die falsche Lieferzeit angezeigt wenn man überverkäufe mit Hinweis aktiviert hat, da aktuell nicht IMMER die Standardlieferzeit beim Artikel hinterlegt ist sondern hier 0 drinn steht. Das macht überhaupt keinen Sinn, nehmen wir an 1 Artikel ist noch auf Lager, dann wird bei SW der Standartext angezeigt (z.b. 1-.2 Tage Lieferzeit) beim 2'ten Artikel steht dann etwas wie "wir können nich tin ausreichender menge liefern der 2te Artikel hat eine Lieferzeit von 1 Tag" also kürzer als der Artikel der auf Lager ist, weil eben nicht die Standardlieferzeit hinterlegt ist. Diese muss IMMER hinterlegt sein.

Dieses Thema habe ich sehr oft und ausführlich hier im Forum mit Connector Entwicklern besprochen (glaube Daniel war es Damals), dann wurde es umgesetzt und lief so sehr lange!
 
  • Gefällt mir
Reaktionen: dolfy

3po

Sehr aktives Mitglied
30. August 2011
2.565
86
Ich bitte um Rückmeldung wie es hier weiter gehen soll, so wie es ist zeigen wir derzeit massig falsche Lieferzeiten im Shop an!
 

musikfast

Mitglied
3. Juli 2020
83
12
Ich muss mich auch ein klinken, weil ich unbedingt die Bearbeitungszeit mit der Lieferzeit addiert angezeigt brauche. Wie sieht es aus?
 

musikfast

Mitglied
3. Juli 2020
83
12
Ich habs bei mir gefunden, es lag nicht am Connector, sondern am Frontend von Shopware. Falls jemand da Hilfe brauch, kann ich es mal aufschreiben. Ist eigentlich nicht schwer.
 

3po

Sehr aktives Mitglied
30. August 2011
2.565
86
Ich habs bei mir gefunden, es lag nicht am Connector, sondern am Frontend von Shopware. Falls jemand da Hilfe brauch, kann ich es mal aufschreiben. Ist eigentlich nicht schwer.
Der Connector wurde aktualisiert, nun soll die Funktion wieder integriert sein, habe es aber noch nicht getestet. Das es am Frontend gelegen haben soll bezweifle ich, da die benötigten Daten erst gar nicht an den Shop übermittelt worden sind. Du kannst aber gerne beschreiben was Du gemacht hast.
 

musikfast

Mitglied
3. Juli 2020
83
12
Hallo

gerne erkläre ich meinen Weg.
Die Lieferzeiten werden übertragen:
Screenshot 2020-10-14 085809.jpg

Nach etwas Suchen in diesem Internet kam ich auf diesen Weg:

Bei den Textbausteinen ( Shopware-Backend > Einstellungen > Textbausteine) folgenden Pfad aufsuchen:

> frontend > plugins > index > delivery_informations

den Baustein "DetailDataInfoStock" ändern
Screenshot 2020-10-14 090027.jpg

Ich habe kompletten Text geändert, aber wichtig ist der Platzhalter: {$sArticle.shippingtime} an der richtigen Stelle.
Screenshot 2020-10-14 090047.jpg

Jetzt zeigt bei das Frontend auch die Bearbeitungszeit als Lieferzeit an.
Screenshot 2020-10-14 090129.jpg

Wie man allerdings weitere Einstellungen macht, um ein die Lieferzeit anzugeben, wann der Artikel wieder lieferbar ist, weil er im Zulauf ist, weiß ich noch nicht. Ich hatte noch nicht den Bedarf dazu gehabt.
Falls weitere Fragen sind, bitte einfach melden, vielleicht finde ich etwas Zeit und kann noch was anderes ausprobieren.

Ich hoffe, dass bei einem weiteren Update es nicht überschrieben, bzw. kaputt geändert wird.

Liebe Grüße aus Oberfranken
Benjamin
 
  • Gefällt mir
Reaktionen: BenTikz

musikfast

Mitglied
3. Juli 2020
83
12
Aktuell ist es so, das sobald der Artikel auf Lager ist die 40 entfernt werden und 0 drin steht!

Ok ?? Ich habe im Feld Bearbeitungszeit etwas reingeschrieben
> JTL-Wawi:
Screenshot 2020-10-14 101558.jpg

und:

Screenshot 2020-10-14 101613.jpg

Bei mir haben gebrauchte Instrumente keine Beschaffungszeit, aber eine Bearbeitungszeit.

Darf ich was testen? Kannst du mir vielleicht ein Szenario genauer beschreiben? Dann teste ich es mal bei mir, vielleicht komme ich auf eine Idee.
 

musikfast

Mitglied
3. Juli 2020
83
12
@3po
Es tut mir leid, ich habe glaube am Thema vorbei geredet. Ich habe in so vielen Threads nach einer Lösung meines Problems gesucht, dass ich im falschen Thread meine Antwort gesetzt habe. Ich saß gestern bis kurz vor 1 Uhr nachts am Rechner.
Aber trotzdem werde ich mal schauen, ob ich dir irgendwie helfen kann.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Lieferzeiten werden nicht mehr angezeigt (German Market) WooCommerce-Connector 0
Neu Lieferzeiten richtig einstellen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Variationsartikel haben andere Lieferzeiten und Beschreibung wird eingeblendet Onlineshop-Anbindung 0
Neu Keine Lieferzeiten im Shop | JTL kann keine Lieferzeiten an Woocommerce übertragen und überschreibt auch jede Änderung im backend von Woocommerce WooCommerce-Connector 2
Neu Bestellvorschläge nicht möglich bei Bezug per See- und Luftfracht? (unterschiedliche Lieferzeiten) Arbeitsabläufe in JTL-Wawi 2
Neu Lieferzeiten Anzeige Allgemeine Fragen zu JTL-Shop 0
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 0
Neu Shopware 5 Bilder werden nicht aktualisiert bzw. falsche zugeordnet Shopware-Connector 0
Neu JTL-Vouchers für Shopware 5 Plugin Shopware-Connector 1
Neu Sonderpreise JTL - Shopware Shopware-Connector 0
Neu Abgleichfehler: No shopware language found for language iso "" Shopware-Connector 0
Neu Wechsel von Shopware Cloud zu JTL Shop 5 Onlineshop-Anbindung 2
Neu Shopware 6 mit Custom Products - Probleme bei Auftragsimport Shopware-Connector 18
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu Suche Freelancer/Partner für WAWI & Connector Shopware 6 Dienstleistung, Jobs und Ähnliches 0
Neu Freelancer / Berater für Shopware 6 Connector & mehr gesucht Dienstleistung, Jobs und Ähnliches 0
Neu 'supplytime' an Shopware übetragen Shopware-Connector 5
Neu Vorraussichtliches Lieferdatum bei "Im Zulauf" nicht an Shopware übertragen Shopware-Connector 0
Neu Shopware 6 Connector - Über die JTL-Wawi Funktionsattribute die Shop-Funktionen steuern Shopware-Connector 1
Neu Shopware Anbindung Bilder Reihenfolge falsch - falsches Vorschaubild Onlineshop-Anbindung 4
Neu [Shopware 6] Erstelltes Menu im JTL-Wawi kann im Shop keinem Layout zugewiesen und gespeichert werden Shopware-Connector 5
Neu Connector hat mal wieder den Shopware Shop zerschosssen - Kotzanfall! JTL-Wawi - Fehler und Bugs 0
Neu Shopware - UST-ID (Pflicht)Angabe für einzelne Länder möglich ? Shopware-Connector 2
Neu [Shopware] Connector - Artikelbilder vor jedem Bildimport löschen Shopware-Connector 0
Neu Online-Shop Abgleich löscht Filter-Suche in Shopware 5 Shopware-Connector 0
Neu Keine Artikeldaten an Shopware übermitteln? Nur Bestellungen und Bestände Shopware-Connector 0
Neu Hilfe bei Shopware Update 5.5 auf 5.6.10 gesucht (inkl. Plugins) User helfen Usern 0
Verwiesen an Support Händlerpreise werden nicht an Shopware übergeben Shopware-Connector 2
Beantwortet JTL an Shopware 6 angebunden - EAN, Artikelnummer nicht übermittelt zu JTL Shopware-Connector 4
Neu Fehler bei der Synchronisierung mit Shopware Starten mit JTL: Projektabwicklung & Migration 2
Neu Problem beim Shopware Abgleich/Artikel werden nicht übertragen Shopware-Connector 0
Neu Shopware 6 / Artikelbilder Upload Probleme Shopware-Connector 4
Neu Verkaufspreis falsch synchonisiert. WooCommerce-Connector 0
Neu Lister gibt Daten falsch nach Amazon, Nakommaproblem und werden nicht gelistet Amazon-Lister - Fehler und Bugs 1
Neu Zahlungsbedingungen in der 1.6.32.0 falsch eingerichtet JTL-Wawi - Ideen, Lob und Kritik 20
Neu Versandkosten falsch importiert! Amazon-Anbindung - Fehler und Bugs 9
Neu Änderung des Firmensitzes - nun ist die MWST Berechnung falsch JTL-Wawi - Fehler und Bugs 6
Neu Rechnungsbeträge in der Statistik falsch JTL-Wawi - Fehler und Bugs 4
Neu Artikel Umlagern, was mache ich Falsch? User helfen Usern - Fragen zu JTL-Wawi 3
Neu Grundpreise alle paar Tage falsch WooCommerce-Connector 2
Neu WAWI 1.5.50.0 Ameise exportiert USt. falsch JTL-Ameise - Fehler und Bugs 2
Neu Steuerklassen der Produkte falsch übergeben PrestaShop-Connector 8
Neu Printlogs auf dem Desktop... Was ist falsch? User helfen Usern - Fragen zu JTL-Wawi 0
Nach Upload der Shopdaten Admin passwort falsch Upgrade JTL-Shop4 auf JTL-Shop5 2
Preisanzeige Liste zu Artikeldetails falsch ? Einrichtung JTL-Shop5 2
Neu Steuern werden falsch in die Wawi importiert Shopware-Connector 1
Neu Feld falsch verknüpft - Wawi stürzt ab Amazon-Lister - Fehler und Bugs 1
Neu Wawi Bereich "Verkauf" in JTL5 ->Kundendaten werden falsch angezeigt und sogar falsch generiert JTL-Wawi - Fehler und Bugs 1
utf8mb3_unicode_ci - MariaDB 10.6.4 - Kollationsprüfung ist falsch Einrichtung JTL-Shop5 5
Neu Redundanter Bon - Tagesabschluss falsch Allgemeine Fragen zu JTL-POS 2

Ähnliche Themen