Neu Ich weis garnicht wie ich es beschreiben soll.

  • Temporäre Senkung der Mehrwertsteuer Hier findet ihr gesammelt alle Informationen, Videos und Fragen inkl. Antworten: https://forum.jtl-software.de/threads/mehrwertsteuer-senkung-vom-01-07-31-12-2020-offizieller-diskussionthread-video.129542/

RuggyRaw

Neues Mitglied
2. April 2020
17
0
Hallo Forum

ich haben mir den JTL Shop geholt und auch auf einen 1und1 webspace installiert.
Soweit so gut WAWI ist auch verbunden mit dem Shop, und dann geht die Fehlersuche zu einen mir unbeschreibbaren Fehler los.
Grob gesagt lädt WAWI was in den webshop aber es wird da nichts wirklich angezeigt ausser die Startseite.
wenn ich auf ein Link gehe kommt internal error.
Ich habe schon einige Dinge hier aus dem Forum probiert aber blicke jetzt nicht mehr durch,
wie wo was noch. mich bestrebt es nicht aufzugeben aber solangsam bin ich mit meinen Latein am Ende.

nutritionpower.de

ist die Adresse vom Webshop wenn einer Lust und Zeit hat würde ich mich freuen wenn er dort mal rüber schaut und mir evtl ein Tip geben kann.

vielen Dank
 

Roddi

Gut bekanntes Mitglied
14. Juli 2012
366
12
Also ich habe mein Shop auch bei 1und1 bzw. ionos jetzt und stelle mir gerade die Frage: Hast Du die die .htaccess im Root-Verzeichniss auf deine Bedürfnisse angepasst? Und in den Shop-Einstellung wie mit SSL umgegangen werden soll auch richtig gesetzt?

SSL.PNG
 
  • Gefällt mir
Reaktionen: RuggyRaw

MBesancon

Sehr aktives Mitglied
Mitarbeiter
1. Oktober 2010
1.958
139
Erkelenz
Roddi hat recht. Du musst wahrscheinlich die .htaccess anpassen. Bei 1und1 muss in der Regel die RewriteBase gesetzt werden. Ein kurzer Auszug aus dem JTL-Guide:

1587664837331.png

Der Rest des Guides ist hier für den Shop4 nicht mehr ganz aktuell. Daher nur dieser Screenshot ;)
 
  • Gefällt mir
Reaktionen: RuggyRaw

RuggyRaw

Neues Mitglied
2. April 2020
17
0
Ich denke darin wird das Problem liegen. Immer wenn ich da mit mein Talent drin rumschreibe geht nix mehr.
Hab da einiges aus der Anleitung reinkopiert aber nix hilft.
 

Roddi

Gut bekanntes Mitglied
14. Juli 2012
366
12
@MBesancon
Das mit dem / ist bei mir so wie das zweite in deinem Beitrag.
Weiter unten kommt dann (Zeile 121 - 130)

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

#RewriteEngine On
RewriteCond %{SERVER_PORT} !=443
RewriteRule ^(.*)$ https://www.hierstehtmeinedomain.de/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^www.hierstehtmeinedomain.de
RewriteRule ^(.*)$ http://undhierauchmeinedomain.de/$1 [r=301,L]

Funktioniert so bei mir seit Jahren (überlegkurz 2013) ohne Probleme bis jetzt...Toi Toi Toi....aufHolzklopf...
 
  • Gefällt mir
Reaktionen: RuggyRaw

RuggyRaw

Neues Mitglied
2. April 2020
17
0
@MBesancon
Das mit dem / ist bei mir so wie das zweite in deinem Beitrag.
Weiter unten kommt dann (Zeile 121 - 130)

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

#RewriteEngine On
RewriteCond %{SERVER_PORT} !=443
RewriteRule ^(.*)$ https://www.hierstehtmeinedomain.de/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^www.hierstehtmeinedomain.de
RewriteRule ^(.*)$ http://undhierauchmeinedomain.de/$1 [r=301,L]

Funktioniert so bei mir seit Jahren (überlegkurz 2013) ohne Probleme bis jetzt...Toi Toi Toi....aufHolzklopf...



Hab das mal eingefügt ändert sich nichts augenscheinlich. 1te Bild Landigpage. 2te wenn ich auf ein link gehe.
 

Anhänge

RuggyRaw

Neues Mitglied
2. April 2020
17
0
Bitte poste einmal deine .htaccess in einem Code Blog, denn ich (sorry) glaube das du das mit dem RewriteBase nicht richtig gemacht hast.
So sieht das da aus. Ich denke auch das da was falsch ist. Das ist zeile 80 bis 123.
>
</IfModule>

<IfModule mod_rewrite.c>
RewriteEngine on

#REWRITE ANPASSUNG 1 (REWRITEBASE)
#Wenn Ihr Shop in einem Unterverzeichnis (also z.B. meinedomain.de/meinverzeichnis) installiert ist, so kommentieren Sie die kommende Zeile aus und passen Sie den Verzeichnisnamen an
#RewriteBase /

#REWRITE ANPASSUNG 2 (auf www.meinedomain.de umleiten)
#Ihr Shop sollte nicht unter www.meinedomain.de und nur meinedomain.de erreichbar sein, siehe: http://guide.jtl-software.de/index....tion#4._Einrichtung_einer_Domainweiterleitung
#RewriteCond %{HTTP_HOST} ^nutritionpower.de.
#RewriteRule ^(.*)$ https://www.nutritionpower.de/$1 [r=301,L]

RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

#RewriteEngine On
RewriteCond %{SERVER_PORT} !=443
RewriteRule ^(.*)$ https://www.nutritionpower.de/$1 [R=301,L]

RewriteCond %{HTTP_HOST} ^www.nutritionpower.de
RewriteRule ^(.*)$ http://nutritionpower.de/$1 [r=301,L]


#REWRITE ANPASSUNG 3 (Entfernt abschließenden Slash per 301-Redirect)
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(.*)/$
#RewriteRule ^. %1 [L,R=301]

#Rewrite der JTL-Shop-URLs
#Aendern Sie an diesen Zeilen nichts!
RewriteRule ^templates_c/filecache/.*$ - [R=403,NC,L]
RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ includes/sitemap.php?datei=$1 [L]
RewriteRule ^export/((sitemap_).*\.(xml|txt)(\.gz)?)$ $1 [L]
RewriteRule ^asset/(.*)$ includes/libs/minify/?g=$1 [L]
RewriteRule ^robots.txt$ robots.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^. index.php [L]
</IfModule>

FileETag None
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.611
741
Berlin
Gut, dann entferne bitte das # Zeichen vor dem Wort Rewritebase, dann ist alles gut....
Oder auch nicht, weil du mit einem 1und1 Hosting auf Dauer nicht glücklich wirst.
 
  • Gefällt mir
Reaktionen: RuggyRaw

RuggyRaw

Neues Mitglied
2. April 2020
17
0
Gut, dann entferne bitte das # Zeichen vor dem Wort Rewritebase, dann ist alles gut....
Oder auch nicht, weil du mit einem 1und1 Hosting auf Dauer nicht glücklich wirst.


Wow mega danke hat geklappt. Dann kann ich ja jetzt mit den Rest weitermachen Bilder mit wawi importieren und Preise und das Zeug.

Warum ist 1und1 nicht gut? Was gibt es da für Probleme?
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.611
741
Berlin
Du hast nur die Möglichkeit den Datei Cache zu nutzen, der generiert aber unter Umständen zu viele Dateien wodurch der Shop dann nicht mehr richtig funktionieren wird.

Such dir lieber auf der JTL Seite einen Anbieter der JTL zu 100% unterstützt
 

igel-max

Sehr aktives Mitglied
3. August 2009
2.757
38
Was Herr Petermann sagt ist leider richtig...

Ich hatte mein Shop bei Strato Installieret (zugegeben nur als Probe).

ES ist ja sogar schneller gelaufen als bei JTL Hosting..

Nun leider bis die erste Bestellungen kamen- dann läuft nichts mehr- total überlastet.
 

RuggyRaw

Neues Mitglied
2. April 2020
17
0
Ja von Strato bin ich auch weg. Und eine bekannte hat mich dann zu JTL gebracht und 1und 1 da die kombi bei ihr gut und lange läuft.
Ist für mich quasi beides Premiere. Aber das JTL ist ist mal mächtig und der Hammer.
Blick zwar viele Sachen noch nicht ganz aber das wird noch. Im Notfall bevor die Haare raus gehen schreib ich wieder hier und frag euch um Rat.
 
Ähnliche Themen Forum Antworten Erstelldatum des Themas
Gelöst HILFE WAS HABE ICH GEMACHT Gelöste Themen in diesem Bereich 4
Neu Wie Exporte ich nur bestimmte Artikel unter den Filterregeln? JTL-Ameise - Ideen, Lob und Kritik 3
Neu HTTP Error 500 nachdem ich Kategoriebilder hinzugefügt habe Onlineshop-Anbindung 11
Neu Artikel wird immer wieder bei Ebay gestoppt - wie kann ich feststellen warum - workflow User helfen Usern - Fragen zu JTL-Wawi 6
Neu Meine Firmendaten hatte ich 2016 geändert. Jetzt haben alle Rechnungen vor 2016 auch die neue Firmenadresse drin Arbeitsabläufe in JTL-Wawi 11
Neu Wie lösche ich alle Attribute mit "keine preissuchmaschinen" bei allen Artikeln mit Ameise ? JTL-Ameise - Fehler und Bugs 1
Neu Hallo irgendwie wurde ein Angebot doppelt bei Ebay hochgeladen abwohl ich nur eine Vorlage erstellt habe eBay-Anbindung - Fehler und Bugs 1
Neu Wie kann ich eine Gutschrift stornieren? User helfen Usern - Fragen zu JTL-Wawi 4
Neu Beim FedEx Import der Sendungsnummer bekomme ich Fehler JTL-ShippingLabels - Fehler und Bugs 3
Gelöst Export für FedEx kann ich da ... JTL-ShippingLabels - Ideen, Lob und Kritik 2
Neu Versandart ändern per Workflow - krieg ich nicht hin :( Arbeitsabläufe in JTL-Wawi 2
Neu Attribute vs. Merkmale Was nutze ich für was? User helfen Usern - Fragen zu JTL-Wawi 4
In Diskussion Gibt es einen Dienstleister mit 100 Paketen im Jahr welchen ich einbinden kann ? JTL-ShippingLabels - Ideen, Lob und Kritik 2
Neu Wo gebe ich die Synonyme für meine Artikel ein? Modified eCommerce-Connector 4
Neu Versandarten: Artikel "A" 1 St. per Maxibrief, ab 2 St. per DHL-Paket versenden. Wie realisiere ich das? Arbeitsabläufe in JTL-Wawi 2
Gelöst Wo kann ich den Inhalt für "Weitere Hinweise" hinterlegen? eBay-Designvorlagen - Fehler und Bugs 1
Neu Spezialseite "Information zum Versand" wo finde ich den Inhalt dieser Seite? Betrieb / Pflege von JTL-Shop 2
In Bearbeitung Bestand auf Lagerplatz den es garnicht mehr gibt JTL-Wawi - Fehler und Bugs 1
Ähnliche Themen