Neu Htacess weiterleitung probleme 2. beitrag beachten

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
16. Mai 2019
7
0
#1
Servus Community,

ich habe ein Problem laut einer Seo Onpage Tool bekam ich folgende Fehlermeldung:

"Die Seite leitet URLs mit und ohne "www." nicht einheitlich weiter. Dies kann zu "Duplicate Content" und falsch gesetzten Links führen. "

daraufhin habe ich etwas im htacess rumprobiert nach dem ich den Fehler nicht beheben konnte (laut seo tool) habe ich alles wieder in original hergestellt aber seit dem funktioniert es nicht mehr.

Wenn ich egal mit oder ohne www oder https (egal was ) eingebe leitet der mich auf www.meinedomain.de weiter so sieht der htacess bereich bei mir aus

<IfModule mod_rewrite.c>
RewriteEngine on

#REWRITE ANPASSUNG 1 (REWRITEBASE)
#Wenn Ihr Shop in einem Unterverzeichnis (also z.B. meinedomain.de/meinverzeichnis) installiert ist, so kommentieren Sie die kommende Zeile aus und passen Sie den Verzeichnisnamen an
#RewriteBase /

#REWRITE ANPASSUNG 2 (auf www.meinedomain.de umleiten)
#Ihr Shop sollte nicht unter www.meinedomain.de und nur meinedomain.de erreichbar sein, siehe: http://guide.jtl-software.de/index....tion#4._Einrichtung_einer_Domainweiterleitung
#RewriteCond %{HTTP_HOST} ^meinedomain.de
#RewriteRule ^(.*)$ http://www.meinedomain.de/$1 [r=301,L]

#REWRITE ANPASSUNG 3 (Entfernt abschließenden Slash per 301-Redirect)
#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_URI} ^(.*)/$
#RewriteRule ^. %1 [L,R=301]

#Rewrite der JTL-Shop-URLs
#Aendern Sie an diesen Zeilen nichts!
RewriteRule ^templates_c/filecache/.*$ - [R=403,NC,L]
RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ includes/sitemap.php?datei=$1 [L]
RewriteRule ^export/((sitemap_).*\.(xml|txt)(\.gz)?)$ $1 [L]
RewriteRule ^asset/(.*)$ includes/libs/minify/?g=$1 [L]
RewriteRule ^robots.txt$ robots.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^. index.php [L]
</IfModule>


Bitte um Hilfe

Grüße Sezer
 
16. Mai 2019
7
0
#2
Problem beseitigt war nur der browser cache, allerdings meldet der Seo Tool weiterhin die selbe fehlermeldung könnt ihr da bitte weiter helfen ?

Fehlermeldung vom seo tool

"Die Seite leitet URLs mit und ohne "www." nicht einheitlich weiter. Dies kann zu "Duplicate Content" und falsch gesetzten Links führen. "
 
Zuletzt bearbeitet: