Gelöst [Gelöst] Auftrag Attribute Fehlermeldung

schwadda100

Aktives Mitglied
4. Mai 2017
2
0
Guten Tag,
beim Werte setzen in den Attributen im Auftrag bekomme ich immer eine Fehlermeldung, habe mich schon dusselig gesucht aber leider keine Lösung gefunden.
Anscheinend bin ich der einzige mit diesem Fehler.
Bin folgendermaßen vorgegangen:
1. Verkauf -> Anlegen: -> Auftragsattribute
2. Im Auftrag die Attribute aufgerufen um Werte einzugeben, beim schließen des Auftrags kommt dann die Fehlermeldung (Bilder).
auftrag-attribute.PNG auftrag-attribute-fehler.PNG

Kann das jemand von euch auch reproduzieren?

JTL Wawi Version 1.2.2.1
 
Zuletzt bearbeitet:

gutberle

Sehr aktives Mitglied
29. März 2011
1.295
407
Da läuft irgendetwas massiv schief, denn die Fehlermeldung besagt, dass die Wawi aus irgendeinem Grund ein zweites Mal versuchen würde, einen Eintrag in Tabelle tBestellungAttribute mi tdem Wert "0" in der Tabellenspalte kBestellungAttribute zu speichern, die das als PrimaryKey der Tabelle natürlich nicht zuläßt. - Allerdings kommt bei mir der Wert 0 auch überhaupt nicht vor, sondern der Index beginnt bei 1, die DDL gibt allerdings nicht her, dass das auch so sein muß.

Kann es sein, dass die 1.2.2.1 die erste Wawi Version ist, die Du installiert hast, Du also beim Update keine "historischen" Auftragsattribute hattest, die bei einem Update auf 1.2.2.1 übernommen wurden? Das wäre ein Ansatz, denn vielleicht ist das Anlegen der Auftragsattribute in der 1.2.x.x defekt und ich sehen das nicht, weil meine Attribute von <2015 stammen und damit noch aus der 0.9er Version.

Lass mal hören wann und in welcher Version Du die Attribute angelegt hast und falls sich daraus ein Ansatz ergibt, schaue ich mir das mal mit einer neuen SQL Server Instanz an.
 

Manuel Pietzsch

JTL-Wawi
Mitarbeiter
2. Januar 2012
2.895
1.074
Hückelhoven
Hi,

der Fehler ist bekannt und wird kurzfristig behoben. Sofern es dringend ist, können wir durch einen DB Eingriff helfen, einfach unseren Support kontaktieren.

Gruß

Manuel
 

schwadda100

Aktives Mitglied
4. Mai 2017
2
0
Danke für die Hilfe,
@gutberle, Ja in der Vorgängerversion hatten wir keine Auftragsattribute diese haben oder wollten wir erst in der 1.2.2.1 anlegen.
Wir haben gestern noch ein Update auf die 1.2.2.5 gemacht und siehe da, es funzt jetzt.

@ManuelP, Danke aber durch das Update ist anscheinend kein Eingriff in die DB nötig.
 

Ähnliche Themen