Gelöst [CO-340]Leidiges Thema Bilder in Shopware

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
24. Juli 2017
62
1
#1
Hallo zusammen,

dies ist in erster Linie eine Frage an die Moderatoren/Entwickler/Macher von JTL/ Connector.
Gegeben ist sowohl JTL als auch Shopware immer in der aktuellsten Version inkl Updates/Patches.

Und zwar hätte ich gerne mal gewusst ob das Problem mit den verschwindenden Bildern irgendwann mal in den Griff bekommen wird?
Ich bin momentan fast täglich mehr damit beschäftigt Bilder wieder hoch zu laden die schon da waren, als damit neue Artikel einpflegen zu können.

Und nein, das passiert nicht nach einem festen Muster, und nein es sind dann auch nicht immer alle Bilder einer Kategorie betroffen und nein das ist auf Dauer auch keine Lösung die Bilder dann einfach neu zu übertragen, denn ein Übertragen von zb allen Bildern in meinem Shop kostet mich ca 3 Std Upload-Zeit in der ich dann nichts mehr in der Wawi machen kann und die meinen Rechner extrem auslastet.

Das Problem existiert ja schon seit ewigen Zeiten und wird irgendwie nicht angegangen und/oder gelöst und ich finde das kann nicht angehen das ich täglich bis zu 2000 Bilder neu laden muss. Das geht auf keine Kuhhaut drauf.

MfG
Pirmin Jenfer
 
Zuletzt bearbeitet:
24. Juli 2017
62
1
#3
Hallo,

ich kann die Bildproblematik bestätigen. Connector 2.1.18 mit Shopware 5.4.2.

MfG Gunther Lange
Die Probleme hab ich leider schon seit 1,5 Jahren, nur mit wachsendem Shop werden die immer gravierender.
Aktuell bin ich bei ca 1000-1500 Bilder pro Tag die der Connector killt. Manchmal sogar so heftig das der Artikel gleich mit gekillt wird und man eine 500er Error Seite bekommt, wenn man versucht den Artikel aufzurufen.
 
13. Juni 2018
5
1
#5
Hallo nochmal,
ich konnte mir heute vorerst helfen, indem ich in Shopware unter Inhalte > Medienverwaltung > Artikel das Zahnrad zum Bearbeiten und Thumbnails erstellen geklickt habe. Shopware hat dann für alle Ansichten die nötigen Bildgrößen erstellt. Die Aktion hat für ca. 800 Artikel 15 Minuten gedauert. Jetzt sind die Bilder erstmal alle wieder da (wenn sie in Originalgröße in Datenbank vorlagen).
Ich hoffe das hilft auch Euch für den Moment weiter.
MfG Gunther
 
24. Juli 2017
62
1
#6
Hallo nochmal,
ich konnte mir heute vorerst helfen, indem ich in Shopware unter Inhalte > Medienverwaltung > Artikel das Zahnrad zum Bearbeiten und Thumbnails erstellen geklickt habe. Shopware hat dann für alle Ansichten die nötigen Bildgrößen erstellt. Die Aktion hat für ca. 800 Artikel 15 Minuten gedauert. Jetzt sind die Bilder erstmal alle wieder da (wenn sie in Originalgröße in Datenbank vorlagen).
Ich hoffe das hilft auch Euch für den Moment weiter.
MfG Gunther
Ich weiß nicht ob ich das Risiko eingehen kann das mal auszuprobieren, denn meine Erfahrung zeigt das sobald man in Shopware selber im Backend was verändert klappt die Syncronisation nicht mehr sauber.
Und bevor ich alle 3000 Artikel und 10000 Bilder wieder neu hochlade bin ich da etwas skeptisch.
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
265
45
#7
Wir haben den Bild Upload im Shopware Connector komplett überarbeitet und suchen nun Pilot Tester.

Edit: Wir haben dazu ein Ticket in unserem Issue Tracker angelegt. Dort steht was getestet werden muss sowie der Download Link zur Test Version: https://issues.jtl-software.de/issues/CO-361.

Es kann sein, dass noch weiteres getestet werden muss. Das werden wir dann entsprechend am Ticket ergänzen.
 
Zuletzt bearbeitet:

Jens31

Gut bekanntes Mitglied
30. Januar 2014
122
0
#8
Hallo,

war das nicht so, dass die Bilder für Stückliste aus den einzelnen Artikel übernommen wurden?

LG
 
Zuletzt bearbeitet:
3. August 2017
39
9
#11
Hallo Immanuel,

es freut mich, dass das Bilder-Thema nun angegangen wurde und hoffentlich auch bald nachhaltig gelöst sein wird.

Den Punkten der Testversion des neuen Connectors (Version 2.1.19, https://issues.jtl-software.de/issues/CO-361) zufolge, sollen die Steuerung der Vorauswahl, die Sortierung und die Alternativ-Texte nur über die Bilder des Vaterartikels erfolgen.

Um diese Funktionen zu nutzen, müssten also alle aktuellen Bilder der Kindartikel auch dem jeweiligen Vater zugewiesen sein. Falls nicht, und das ist bei uns der Fall, müssten zunächst alle Bilder der Kindartikel zu den Vaterartikeln kopiert werden.

Darüber hinaus wird es bei allen Nutzern so sein, dass sobald eine Farbvariante aus dem Sortiment genommen (abverkauft) wird, die Bilder aus dem Vaterartikel gelöscht und sobald neue Farben hinzukommen, diese neu zugeordnet werden müssen.

Diesen initialen Arbeitsaufwand plus die Folgearbeiten können wir nicht bewerkstelligen. Daher müssen wir wohl oder übel auf die Funktionen verzichten.

Damit wir weiterhin Updates des Connectors machen können, sollten die Grundfunktionen auch weiterhin abgedeckt werden, sofern die Bilder nur den Kinderartikeln zugeordnet sind.

Meine Fragen hierzu:

  • Müssen generell Bilder beim Vater hinterlegt sein?
  • Falls nur ein Bild z.B. einer bereits nicht mehr verkauften Farbe beim Vater hinterlegt ist, wird dieses dann zwangsweise ausgesteuert? Falls ja, kann das deaktiviert werden?
  • Was passiert beim Ersetzen von Bildern bei Kindartikeln?
    • Was passiert insbesondere mit der Sortierposition des ersetzten Bildes?
  • Um die Bilder der Kindartikel zu sortieren, müssen alle Bilder des Kindartikels gelöscht, der Shopabgleich durchgeführt und die Bilder dann erneut zugewiesen werden?

Gruß
 

Immanuel

Moderator
Mitarbeiter
24. August 2016
265
45
#12
Hallo @emra,

Müssen generell Bilder beim Vater hinterlegt sein?
die Bilder müssen nicht am Vater hinterlegt sein. Das wird nur benötigt, wenn die Reihenfolge des Bildes am Vater und/oder das vorausgewählte Bild von der Wawi aus gesteuert werden soll.

Falls nur ein Bild z.B. einer bereits nicht mehr verkauften Farbe beim Vater hinterlegt ist, wird dieses dann zwangsweise ausgesteuert? Falls ja, kann das deaktiviert werden?
Sobald ein Bild auch an einem Kind hängt, werden die entsprechenden Konfiugurationsoptionen (ie blau, xl, whatever) der Variation berücksichtigt.

Was passiert beim Ersetzen von Bildern bei Kindartikeln? => Was passiert insbesondere mit der Sortierposition des ersetzten Bildes?
Aktuell besteht das Ersetzen eines Bildes über den Connector aus dem Löschen das alten - und Hinzufügen des neuen Bildes. Wenn das Bild nur an einem Kind hinterlegt war, wird das neue Bild von der Sortierung her am Vater hinten angefügt. Ist es in der Wawi auch am Vater hinterlegt, bleibt die Sortierung bestehen (siehe Punkt 1).

Um die Bilder der Kindartikel zu sortieren, müssen alle Bilder des Kindartikels gelöscht, der Shopabgleich durchgeführt und die Bilder dann erneut zugewiesen werden?
Grundsätzlich muss unterschieden werden zwischen der Sortierung von Bildern am Vater und der Sortierung von Bildern an einem Kind. Die Sortierung der Bilder an einem Kind sollte grundsätzlich gewährleistet sein. Zumindest auf Datenbank Ebene (Dummy Bilder in s_articles_img, die eine parent_id und eine article_detail_id besitzen). Wie das Template seitig von Shopware ausgewertet wird, weiß ich allerdings nicht.


PS. Die Version 2.1.19 ist noch in der Test Phase und es müssen noch ein paar Dinge gefixed werden, bevor sie released wird.
 
Zustimmungen: emra

3po

Sehr aktives Mitglied
30. August 2011
2.340
44
#13
Aktuell besteht das Ersetzen eines Bildes über den Connector aus dem Löschen das alten - und Hinzufügen des neuen Bildes. Wenn das Bild nur an einem Kind hinterlegt war, wird das neue Bild von der Sortierung her am Vater hinten angefügt. Ist es in der Wawi auch am Vater hinterlegt, bleibt die Sortierung bestehen (siehe Punkt 1).
Gruß
Hier sollte dringend auch die Bilder ersetzen Funktion von Shopware integriert werden! (zb. aus SEO Sicht ist ein löschen nicht von Vorteil --> toter link zur Seite)
 

Ähnliche Themen