Beantwortet Attribute importieren führt plötzlich zu fehlern

Mechler

Aktives Mitglied
18. November 2020
5
0
Hallo,
seit diesem Wochenende führt der Attributsimport über die Komandozeile plötzlich zu einem Fehler. Über die UI lässt sich die Datei dann importieren.

Einen Fehler in dem Befehl kann ich ausschließen, da dieser schon hundertfach gelaufen ist und mit anderen Dateien (Artikeldaten, Eigene Felder..) funktioniert (natürlich mit anderer Importvorlage).

Folgende Fehlermeldung wird von der Ameise abgelegt:
Unbehandelte Ausnahme #55DD04A8F5DA2D91 vom Typ System.Collections.Generic.KeyNotFoundException in TValue get_Item(TKey)
System.Collections.Generic.KeyNotFoundException: Der angegebene Schlüssel war nicht im Wörterbuch angegeben.
bei System.Collections.Generic.Dictionary`2.get_Item(TKey key)
bei ameise.importer.Importer_ArtikelAttribute.PruefeGewaehlteShops(AttributProxy dboAttribut, Int32 kArtikel)
bei ameise.importer.Importer_ArtikelAttribute.doWork()
bei ameise.import_cmd.DoImportOneRow()

Zeitstempel: 2022-10-04T17:43:05
Locale: German (Germany)
Locale: German (Germany)
Version: 1.5.54.0
Plattform: Ameise
WawiSeed: 5.8.03772.71201
Prozessname: JTL-wawi-ameise
Physikalischer Speicher: 72486912 / Peak: 72491008
Basispriorität: 8
Prioritätsklasse: Normal
CPU-Zeit (User): 0:00:00,59375
CPU-Zeit (System): 0:00:00,25
Page-Size (Sytem): 869536 / Peak: 73703424
Page-Size: 73703424 / Peak: 73703424
Offene Handles: 979

Hat irgendjemand einen Rat hierzu?
 

John

Sehr aktives Mitglied
3. März 2012
2.058
335
Berlin
Vermutlich hast Du einen Onlineshop in der Wawi neu hinzugefügt, entfernt oder umbenannt. In der Vorlage sind aber noch die alten Shops gespeichert und einen davon gibts nicht mehr.
Oder Du hast die Importvorlage aus einer anderen Wawi, in der andere Shops voranden waren importiert.

Ruf mal die GUI der Ameise auf und lade die Vorlage. Prüfe die Einstellungen uns speichere sie neu ab.

Danach sollte es wieder laufen.
 

Mechler

Aktives Mitglied
18. November 2020
5
0
Vermutlich hast Du einen Onlineshop in der Wawi neu hinzugefügt, entfernt oder umbenannt. In der Vorlage sind aber noch die alten Shops gespeichert und einen davon gibts nicht mehr.
Oder Du hast die Importvorlage aus einer anderen Wawi, in der andere Shops voranden waren importiert.

Ruf mal die GUI der Ameise auf und lade die Vorlage. Prüfe die Einstellungen uns speichere sie neu ab.

Danach sollte es wieder laufen.
Vielen Dank, genau das war es.
Wir haben endlich auf Shop5 geupdated 🙏
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Attribute / Merkmale Filter + auf Produktseite Allgemeine Fragen zu JTL-Shop 3
Artikel Attribute - keine Werteliste JTL-Wawi 1.7 0
Neu Attribute / Merkmale Filter und Ausgabe auf Produktseite User helfen Usern - Fragen zu JTL-Wawi 0
Neu Eigene Felder oder Attribute im Shop anzeigen Betrieb / Pflege von JTL-Shop 4
Neu #Angebot "{0}" kann nicht hochgeladen werden, da keine Attribute der Fahrzeugverwendungsliste ermittelt werden konnten eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Attribute des Artikels auf der Übersichtskarte Allgemeine Fragen zu JTL-Shop 1
Merkmale in Attribute umwandeln - wie geht das? JTL-Wawi 1.6 1
Neu Preselect Attribute ohne Funktion WooCommerce-Connector 2
Neu Mindestens ein Attribut hat keinen Namen - Artikel Attribute ohne Übersetzung - kein Bearbeiten/Hinzufügen möglich JTL-Wawi - Fehler und Bugs 1
Neu Alle Artikel exportieren mit Attribute/Felder/Merkmale Typ eigenes Feld möglich? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bilder Importieren geht nicht JTL-Ameise - Fehler und Bugs 1
Neu Wie "Neu im Sortiment" mit Ameise importieren? User helfen Usern - Fragen zu JTL-Wawi 2
Neu Content aus Plenty in JTL Shop importieren Umstieg auf JTL-Shop 4
Neu Ameise - Mindestbestand/Maximalbestand - Wo Importieren? JTL-Ameise - Ideen, Lob und Kritik 1
Neu Bestellungen aus einem NICHT-JTL Shop in die WaWi importieren Onlineshop-Anbindung 0
Neu DFI Bilder importieren JTL-Ameise - Ideen, Lob und Kritik 1
In Diskussion Kundendaten importieren Allgemeine Fragen zu JTL-POS 4

Ähnliche Themen