Neu Anpassung Druckvorlagen - ziemlich buggy?

HelmaSpona

Gut bekanntes Mitglied
7. Dezember 2012
642
12
Kerken
Ich habe bei mehreren Kunden mit WAWI 1.5.35.x und 1.5.36.2 diverse Probleme mit den Druck/Mail-Vorlagen.

1. Auf mehreren Kundenrechnern und auch auf meinem: Eine vorhandene Vorlage wird angepasst und gespeichert, die Vorschau ist in Ordnung, man schließt den Dialog für die Dokumentvorlagen und kehrt zur WAWI zurück, dann öffnet man die Vorlagenverwaltung erneut und die Änderung an der Vorlage ist weg oder gleich die ganze Vorlage! Ganz häufig kommt letzeres vor, wenn die Vorlage erst zuvor aus einer Datei importiert wurde. WORKAROUND der fast immer funktioniert: Wenn man die Dokumentvorlage nach dem bearbeiten direkt wieder exportiert, dann scheint die WAWI fast immer, auch die Änderungen zu übernehmen.

2. Ich exportiere auf dem Kundenrechner die Vorlage um sie bei mir zu bearbeiten (gleiche WAWI-Version). Ich kann sie importieren, bearbeiten (mit den Einschränkungen von pUnkt 1) dann speichere und exportiere ich die Vorlage als Datei. kann sie bei mir auch wieder importieren und alle Änderungen sind da. Übertrage ich die Datei dann auf den Kundenrechner und importiere sie dort in die WAWI, dann sind meine Änderungen weg, oft ist dann auch das falsche Logo drin, das bei mir auf dem Rechner aber richtig war!. Exportiere ich dort die Vorlage für "Drucken" und will sie in "Mailen" oder "Speichern" importieren, lässt sie sich nciht importieren, Fehlermeldung. Ich muss dann alle Änderungen für alle Ausgabwege einzeln vornehmen. Aber selbst wenn ich auf diesem Rechner die Vorlage für "speichern" exportiere oder die für "Drucken" kann ich sie auf dem gleichen Rechner nicht mehr importieren, auch nicht für den gleichen Ausgabeweg.

3. Anderer Kunde: Ich ändere in der Auftragsvorlage für die Mail-Ausgabe den einleitenden Text vor der Positionsliste. In der Vorschau (Text und HTML) wird mir bei Auwahl des passenden Auftrags auch alles richtig ausgewählt.
Verschickt der Kunde dann die AUftragsbestätigung per Mail wird jedoch der Standardtext verwendet. Es gibt nur eine Firma und eine Platform. Die Vorlage ist eingestellt für alle Firmen, alle Kundengruppen, alle Plattformen.

Das waren jetzt die wichtigstens Sachen. irgendwie erscheint mir das mit den Druckvorlagen in den letzten WAWI-Version sehr fehlerhaft zu sein. Und es kann nicht in jedem FAll an der Vorlagendatei selbst liegen. Ich kann auch eine neue Vorlage aus einer STandardvorlage erzeugen, anpassen, speichern und beim nächsten Aufruf ist die komplett weg, oder zumindest die vorgenommenen Änderungen. Wenn ich mir die Posts zu dem Thema vom 1.3. ansehe, finde ich micht dort wieder. Es scheint also mehreren Nutzern so zu gehen.
 

Ähnliche Themen