1. Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.
    Information ausblenden

Gelöst Alle Links 404 Not Found

Dieses Thema im Forum "Gelöste Themen Installation / Updates von JTL-Shop" wurde erstellt von mkensch, 4. Oktober 2017.

  1. mkensch

    mkensch Neues Mitglied

    Registriert seit:
    4. Oktober 2017
    Beiträge:
    3
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Sorry, beim Absenden ist es mir wie Schuppen von den Augen gefallen - der Vollständigkeit halber die Lösung für alle nach mir:

    Lösung:

    Stichwort: Apache-Directory-Konfiguration/Direktive "AllowOverride".
    Dort wird natürlich gesteuert, ob eine .htaccess-Datei überhaupt globale Apache-Einstellungen für sein persönliches Verzeichnis verändern darf.
    Standardmässig sieht die vhost-Konfiguration das nicht vor.
    Also wurde folgendes in der "default.conf" ergänzt:
    Code:
    <Directory /var/www/jtl-shop/>
            AllowOverride All
    </Directory>
    https://httpd.apache.org/docs/2.4/de/mod/core.html#allowoverride


    ======================================================

    Hallo zusammen,

    ich weiß, das Thema ist nicht neu - ich habe aber für mich keine passende Lösung bei euch oder im Netz gefunden:
    Alle Verweise, die hinter die Domain gesetzt werden (/Impressum, /Kategorie1, /Artikel44, etc.) werden mit 404-Fehler beendet:
    • Es wurde ein frischer, neuer JTL-Shop 4.05 installiert.
      • Startseite + Admin funktionieren
    • Neuer Dedizierter vServer (Debian 9) wird benutzt (=Testshop, um uns von JTL zu überzeugen)
      • Aktuellste Softwareversionen benutzt (php7, MySQL, etc.)
    • Konfigurationen und Voraussetzungen sind auch erfüllt:
      • mod_rewrite ist geladen: mod_rewrite.png
      • config.JTL-Shop.ini.php ist korrekt (Anhang)
      • .htaccess ist korrekt und vorhanden
    Ich weiß mir leider nicht zu helfen, obwohl ich bisher dachte, dass ich von Web- und Serveradministration gute Kenntnisse habe.
     

    Anhänge:

  2. Rico Giesler

    Rico Giesler Super-Moderator Mitarbeiter

    Registriert seit:
    10. Mai 2017
    Beiträge:
    4.349
    Zustimmungen:
    301
    Punkte für Erfolge:
    83
    Danke für deine Frage und gleichzeitige Lösung. :)
    Dann schließe ich hier.
     
  3. lmassidda

    lmassidda Neues Mitglied

    Registriert seit:
    3. Januar 2018
    Beiträge:
    1
    Zustimmungen:
    0
    Punkte für Erfolge:
    1
    Hallo

    habe heute genau das selbe Problem.

    Habe es auch mit dem Lösungsvorschlag:

    AllowOverride All

    versucht aber leider ohne Erfolg.

    Genau wie oben sind alle Voraussetzungen gegeben.


    EDIT:

    OH MAN WAR ICH BLÖD :D

    Lösung:

    a2enmod rewrite

    Über Terminal und Apache2 restarted, problem gelöst.
     

    Anhänge:

    Zuletzt bearbeitet: 3. Januar 2018

Diese Seite empfehlen

Verstanden Weitere Informationen

JTL-Software benutzt Cookies, teilweise von Drittanbietern, um Funktionalitäten auf unseren Webseiten zu ermöglichen.