Zahlreiche Fehler Bilderanzeige 4.03 evo

  • JTL-Connect 2024: Ihr habt noch kein Ticket? Jetzt Early Bird Ticket zum Vorzugspreis sichern! HIER geht es zum Ticketverkauf

  • Wartungsarbeiten - Kundencenter: Vom 23.07.24 ab 21 Uhr bis 24.07.24 vormittags. Das Kundencenter wird in dieser Zeit nicht erreichbar sein.

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
115
0
Hallo
Ich hatte gehofft nach etlichen langen Monaten Wartezeit nun ein ganz tolles und perfektes Shopsystem zu erhalten, leider finden sich sofort die ersten groben Schnitzer..

1.Bilderanzeige Artikelbild lg
Leider werden aus irgendeinen für mich vollkommen idiotischen (Sorry) Grund sämtliche Bilder auf die eingestellten Bildabmessungen im Adminbereich eingestellt und die freien Flächen mit einem Zwangshintergrund versehen.
Früher: Bild 600*800 wird in 600*800 angezeigt.
Heute: Bild 600*800 bekommt einen weißen Rand drumherum und hat nun 800*800, also 100px oben und unten weiße Fläche. Wäre ansich noch OK wenn die Funktion Wasserzeichen das auch wissen würde. Sprich: Das Wasserzeichen befindet sich nicht über dem Bild sondern im weißen dazuaddiertem Feld unter dem Bild. Genial.

http://forum.jtl-software.de/attachment.php?attachmentid=18918&stc=1&thumb=1&d=1462835564


2. Artikelansicht mit ohne Symbolen:
Vorher waren die Bilder (bei einigen Artikeln haben wir 10 Artikelbilder) brav in Reihe nebeneinander angeordnet. Also 4 Bilder nebeneinander in 3 untereinanderliegenden Reihen. Nun fand es irgendjemand wohl ganz toll das einfache und gute funktionierende Bildsystem technisch mit einer unnützen Spielerei aufwerten zu wollen. Ergebnis: 5 Bilder nebeneinander und der User muss nun auf eine Fläche klicken um die Bilderlinie nach links zu scrollen um die Bilder zu sehen. Abgesehen davon das das wohl kaum ein User machen wird, die User sind ja immer recht schnell im Netz unterwegs und wollen nicht erst langsam scrollen, ist es so genial umgesetzt das ein leeres viereckiges Feld die Schaltfläche zum scrollen sein soll, jedenfalls beim Safari Browser.
http://forum.jtl-software.de/attachment.php?attachmentid=18916&stc=1&thumb=1&d=1462835544



3. Das gleiche bei Firefox
Auch hier fand es jemand ganz wichtig ein bisher gut funktionierendes System durch ein nervendes Scrollen zu ersetzen. Gleicher Fall, 10 Bilder in 3 Reihen bisher sofort dargestellt, nun soll der User wieder scrollen. Beim Firefox ist das aber noch unscheinbarer gelöst. Es ist nicht ein leerer weißer Kasten den man noch etwas erkennen könnte mit suchen, sondern diesmal ist es ein kleiner unscheinbarer Strich mit dem man navigieren kann. Nicht sehr dick, erinnert an ein Haar.

http://forum.jtl-software.de/attachment.php?attachmentid=18917&stc=1&thumb=1&d=1462835555


4. Wie bei Punkt 2 und 3 zu sehen werden gleichzeitig auch die mini Vorschaubilder unten angeschnitten, sieht nicht sehr schön aus. Ferner ist mir bei zB Firefox aufgefallen das beim ersten Seitenaufruf der Seite wo die Bilder noch nicht generiert worden sind die kleinen Vorschaubilder überhaupt nicht zu sehen sind, diese sind erst nach einem Refresh zu sehen. Ideal also um bei neuen Artikeln die Kunden zu ärgern..

Ja, wie bekomme ich nun eine funktionierende vernünftige Artikelseite, die ich vorher hatte, zurück und kann den neuen, für mich Quatsch, abschalten?
Danke
 

Anhänge

  • Bildschirmfoto 2016-05-10 um 01.01.54.jpg
    Bildschirmfoto 2016-05-10 um 01.01.54.jpg
    74,5 KB · Aufrufe: 75
  • Bildschirmfoto 2016-05-10 um 01.04.59.jpg
    Bildschirmfoto 2016-05-10 um 01.04.59.jpg
    78,2 KB · Aufrufe: 50
  • 1Bildschirmfoto 2016-05-10 um 00.55.54.jpg
    1Bildschirmfoto 2016-05-10 um 00.55.54.jpg
    23,1 KB · Aufrufe: 63
Zuletzt von einem Moderator bearbeitet:

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
115
0
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Und der nächste Fehler:
Beim Aufruf des Shops im mobilen Chrome-Browser werden fast alle Artikelbilder in der Großansicht deutlich verzerrt um auf der längsten oder breitesten Bildseite bis an den Bildschirmrand zu kommen. Also statt als Beispiel 800*800px wird das Bild auf 1000*800px verzerrt, das sieht Scheiße aus. Werte sind Beispielwerte um es zu verdeutlichen. Diesen Fehler konnte ich auch im Firefox auf meinem Mac reproduzieren wenn ich mein Browserfenster so zusammengeschoben habe um ein Smartphone zu simulieren. Also ein allgemeiner Fehler, kein Browserfehler von Chrome..
Nun ist die Bilderfunktion mit den diversen Fehlern fast unbrauchbarer als die 4.02 Version. Schade.
 

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
115
0
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Berichtigung zweiter Beitrag von 02.07h
Das hängt wohl damit zusammen das wohl "Containergröße verwenden" auf Ja eingestellt ist, eine Funktion die ich nie verwendet hatte und wohl auch nicht funktionierte. Das sollte man aber besser klar bei einem Update hinzuschreiben das es diese Funktion gibt (wozu ist es gut das Bilder verzerrt werden sollen?) damit nicht andere das eventuell nicht wissen und Kunden durch verzogene Grafiken abgeschreckt werden..

Berichtigung erster Beitrag von 01.41h
Zu Punkt 1: Das hängt wohl auch mit dieser komischen Verzerrungsfunktion zusammen, nachdem ich die vorher von mir nie aktivierte Funktion, die nach dem Update plötzlich eingeschaltet wurde, von mir abgeschaltet wurde sind die Bilder nun auch ohne den nervenden weißen Rand und mit Overlay an der richtigen Stelle.

Sind nur noch Punkt 2, 3 und 4 im ersten Beitrag zu bemängeln. Alles andere hat sich dank nicht vorhandener Infos nun erledigt..
 

Mirko.Schmidt User deaktiviert

Guest
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Der Slider für die zusätzlichen Produktbilder wurde eingebaut, damit bei vielen Bildern diese nicht bis in die Beschreibung hinein gehen. Dieser Slider sollte aber Standardmäßig links vom Produktbild sein und wie in den Angehängten Bildern(1. Chrome Ansicht, 2. Firefox Ansicht) aussehen. Beim Firefox wird dabei noch das oberste und unterste Bild abgeschnitten im Slider, dies gebe ich so weiter. Genauso wie die Einstellung "Containergröße verwenden", dass diese nicht automatisch aktiviert sein soll.
 

Anhänge

  • Produktbild_Slider.JPG
    Produktbild_Slider.JPG
    58,9 KB · Aufrufe: 55
  • Produktbild_Slider_FF.JPG
    Produktbild_Slider_FF.JPG
    53,7 KB · Aufrufe: 46

Point13

Gut bekanntes Mitglied
1. Dezember 2015
116
2
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Der Slider für die zusätzlichen Produktbilder wurde eingebaut, damit bei vielen Bildern diese nicht bis in die Beschreibung hinein gehen. Dieser Slider sollte aber Standardmäßig links vom Produktbild sein und wie in den Angehängten Bildern(1. Chrome Ansicht, 2. Firefox Ansicht) aussehen. Beim Firefox wird dabei noch das oberste und unterste Bild abgeschnitten im Slider, dies gebe ich so weiter. Genauso wie die Einstellung "Containergröße verwenden", dass diese nicht automatisch aktiviert sein soll.
Kann es sein, dass Firefox in der Richtung ein Rendering-Problem hat? Bei mir wird z.B. manchmal nur die Hälfte des ersten Thumbs angezeigt und die anderen Thumbs gar nicht. Per F5 klappt es dann wieder. Strg+F5 holt das Problem wieder nach oben.
 

Mirko.Schmidt User deaktiviert

Guest
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Im FF werden von den image-thumbs die falsche Höhe geholt zuerst, sobald aber die Größe des Browsers geändert wird, dann wird auch alles richtig angezeigt. Ist derzeit in Bearbeitung.
 

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
115
0
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Im FF werden von den image-thumbs die falsche Höhe geholt zuerst, sobald aber die Größe des Browsers geändert wird, dann wird auch alles richtig angezeigt. Ist derzeit in Bearbeitung.

Das sollte dann aber bitte Fix passieren, FF ist ja nicht grade ein kleiner Browser, von der Nutzeranzahl her, und wenn der User beim aufrufen des Produkts keine weiteren Artikelbilder sieht und enttäuscht weiterklickt weil er nicht weiß das er die Seite aktualisieren muss um was zu sehen, dann ist das nicht unbedingt sinnvoll.
 

Entenfurz

Gut bekanntes Mitglied
28. Januar 2016
115
0
AW: Zahlreiche Fehler Bilderanzeige 4.03 evo

Der Slider für die zusätzlichen Produktbilder wurde eingebaut, damit bei vielen Bildern diese nicht bis in die Beschreibung hinein gehen. Dieser Slider sollte aber Standardmäßig links vom Produktbild sein und wie in den Angehängten Bildern(1. Chrome Ansicht, 2. Firefox Ansicht) aussehen. Beim Firefox wird dabei noch das oberste und unterste Bild abgeschnitten im Slider, dies gebe ich so weiter. Genauso wie die Einstellung "Containergröße verwenden", dass diese nicht automatisch aktiviert sein soll.

Für das Problem das die Bilder in die Produktbeschreibung gab es hier im Forum ein viel besseres Problem ohne den unnötigen Quatsch (Sorry) das der User einen Button benutzen muss um mehr Bilder zu sehen. Mit ein paar Codezeilen wurden die Artikelbilder einfach quer unters Hauptartikelbild in mehreren Reihen gepackt, so klappte alles und die User werden nicht vergrault weil sie zeitraubend auf einen Button drücken müssen um mehr zu sehen. Warum setzt man nicht das einfache nicht einfach um sondern macht es kompliziert und nicht Käuferfreundlich?
Danke
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler bei Installation von JTL Shop (Community Free Edition) JTL-Shop - Fehler und Bugs 0
schwerwiegender JTL-Vouchers Fehler in Ihrem Shop JTL-Vouchers - Fehler und Bugs 3
Neu Update auf 5.3.3 - JTL Widgets erzeugt Fehler in CampaingController.php JTL-Shop - Fehler und Bugs 2
[BUG]🪲 -Auftrag nicht mehr Speicherbar- Fehler bei Auslieferung einer Stückliste über mehrere Lieferanten JTL-Wawi 1.9 4
Neu Amazon Fehler: "Listenpreis mit Steuern" Amazon-Lister - Fehler und Bugs 2
Lizenzabruf Fehler 1.9.4.6 JTL-Wawi 1.9 4
Neu Fehler in Abonenntensuche Newsletter JTL-Shop - Fehler und Bugs 0
Neu email smtp Fehler Allgemeine Fragen zu JTL-Shop 0
Neu Kategorie Beschreibung Import für andere Sprachen Fehler JTL-Ameise - Fehler und Bugs 2
Neu Fehler bei SQL-Abfrage durch Aufgabenplanung Gelöste Themen in diesem Bereich 12
Neu 5.2.3 ADMINISTRATION -> sitemap -> sitemap_0.xml.gz -> in ArtikelURL Fehler JTL-Shop - Fehler und Bugs 0
Neu TSE Fehler PIN_BLOCKED JTL-POS - Fehler und Bugs 1
Neu Einbindung von Videos führt zu 500 Fehler JTL-Shop - Fehler und Bugs 5
Neu CSS Gutschein Premium - Einzweckgutscheine - Fehler beim Einlösen Plugins für JTL-Shop 1
Gelöst Fehler in den Steuereinstellungen Allgemeine Fragen zu JTL-POS 3
[Error][Code:21920380] wir erhalten diesen Fehler eBay-Anbindung - Fehler und Bugs 1
Neu 26.06.2024 Abgleich Fehler Amazon-Anbindung - Fehler und Bugs 43
Neu amazon / Ein Fehler ist aufgetreten, bitte beim JTL-Support melden JTL-Wawi - Fehler und Bugs 295
Neu Fehler bei der Anlage einer Ebay-Angebotsvorlage - Nicht genug Quoten verfügbar um Befehl zu verarbeiten... JTL-Wawi - Fehler und Bugs 1
Beantwortet Fehler im Workflow Bei Speichern Lieferschein JTL-Workflows - Fehler und Bugs 1
Fehler beim ShippingLabels JTL-Wawi 1.9 1
Neu Fehler beim Zahlungsabgleich - Zahlungsmodul - Wawi 1.5.55.5 Deutsche Bank JTL-Wawi - Fehler und Bugs 3
Neu JTL-Connector bricht Bilderabgleich mit Fehler ab WooCommerce-Connector 0
Neu SHOP 5.1.5. | Fehler bei Aufpreis Versandarten | sollte OHNE Mehrwertsteuer sein JTL-Shop - Fehler und Bugs 0
Fehler bei der verbindung der server anfrage am Arbeitzplatz JTL-Wawi 1.9 2
Neu Fehler Abgleich Shopware 6 Shopware-Connector 3
Neu Google-Shopping-Plugin Fehler Plugins für JTL-Shop 0
Neu Shop update vom 5.2.4 auf 5.3.1 - Fehler Kampagne JTL-Shop - Fehler und Bugs 0
Neu Umstellung 4.05 auf 5.2.5 - div. Fehler JTL-Shop - Fehler und Bugs 4
Neu SQL Fehler - Woher stammt diese Abfrage JTL-Shop - Fehler und Bugs 7
Neu Fehler beim Artikelimport Sondertyp JTL-Ameise - Fehler und Bugs 3
[WAWI-API] Fehler beim Updaten eines Item-Customfield JTL-Wawi 1.8 2
Neu Benachrichtigung anfordern - Fehler: Der eingegebene Bestätigungscode ist nicht bekannt JTL-Shop - Fehler und Bugs 0
Neu ebay Fehler 240 - nicht öffentliche Bieter-/Käuferliste eBay-Anbindung - Fehler und Bugs 5
Neu Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler wir bitten Hilfe Gambio-Connector 6
Neu Fehler beim Import (Ameise) von Brutto-VK JTL-Ameise - Ideen, Lob und Kritik 9
JTL WAWI 1.8.12.2 Shopware 6 / Connector Abgleich Fehler Gelöste Themen in diesem Bereich 3
Neu PLZ Prüfung Fehler - Shop 5.3.1 JTL-Shop - Fehler und Bugs 2
Neu Fehler JTL\\Catalog\\Category\\MenuItem::getImageWidth(): Return value must be of type int, null returned JTL-Shop - Fehler und Bugs 3
Neu Sitemap ist HTML - Sitemap kann gelesen werden, enthält aber Fehler / Google Web Master Tool Allgemeine Fragen zu JTL-Shop 6
Neu Fehler beim Hochladen der Datei JTL-Shop - Fehler und Bugs 0
Barcodescanner Fehler mit ein "U" am Ende JTL-Wawi 1.8 0

Ähnliche Themen