Gelöst Versandmail HTML bei mehreren Paketen kaputt in der Vorlage?!

Status
Es sind keine weiteren Antworten möglich.

Nickel12

Aktives Mitglied
12. Februar 2013
15
1
JTL Wawi 1.4.22.1 plus Shop

Liebes Forum,

ich habe das Problem, dass bei Versandmails, wo mehrere Pakete angegeben sind die Vorlage nicht stimmt. Es scheint mir so, als wäre was mit der Tabelle im HTML Code kaputt. Geht das noch jemanden so? Ich konnte mit meinem Halbwissen im HTML nichts auffälliges finden. Das Problem ist mir vor einer ganzen Weile schonmal aufgefallen, jedoch wieder in Vergessenheit geraten. Hat jemand einen Tipp?? Vielen Dank!
HTML:
  <!-- BEGIN PAKETE // -->
                                                    <h3>Die Lieferung besteht aus folgenden Teilen</h3>
                                                    <hr />
                                                    <table border="0" cellpadding="0" cellspacing="0" width="100%" class="bodyPositions">
                                                    <thead>
                                                        <tr>
                                                            <th width="25%">Versandart</th>
                                                            <th width="40%">Sendungsverfolgung</th>
                                                            <th width="35%">Hinweis</th>
                                                        </tr>
                                                    </thead>
                                                    <tbody>
                                                        {% for paket in Vorgang.Pakete -%}                                                       
                                                        <tr>
                                                            <td>{{ paket.Versandart.Name }}</td>
                                                            <td class="PositionDescription">
                                                                {% capture trackingid -%}{% if paket.TrackingID != empty -%}{{ paket.TrackingID }}{% else %}Keine Tracking-ID vorhanden{% endif %}{% endcapture %}
                                                                {% if paket.TrackingURL != empty -%}                                                                   
                                                                    <a href="{{paket.TrackingURL}}">{{ trackingid }}</a>
                                                                {% else -%}
                                                                    {{ trackingid }}
                                                                {% endif -%}
                                                            </td>
                                                            <td>{{ paket.Hinweis }}</td>
                                                        </tr>
                                                    </tbody>
                                                    </table>
                                                    <p>Hinweis: Es kann bis zu 24h dauern, bis die Daten zur Sendungsverfolgung beim Dienstleister abgerufen werden können.</p>
                                                        {% endfor -%}
                                                <!-- END PAKETE // -->
 

Anhänge

  • versandmail.png
    versandmail.png
    21,5 KB · Aufrufe: 9

derjoe

Gut bekanntes Mitglied
4. Januar 2007
520
16
Hamburg
Die Schleife {% for paket in Vorgang.Pakete -%} {% endfor -%} ist auf jeden Fall falsch.
Das {% endfor -%} muss weiter hoch, sonst wird nach jedem Paket die Tabelle beendet.
Mach mal hinter das Table row </tr> Dann gibt es für jedes Paket eine Zeile.
 
Status
Es sind keine weiteren Antworten möglich.
Ähnliche Themen
Titel Forum Antworten Datum
Neu Versandart - Abholung im Laden - Versandmail deaktiviert, wird td. gesendet. User helfen Usern - Fragen zu JTL-Wawi 0
Neu Child Template HTML Code mit CSS Dateien anzeigen lassen Templates für JTL-Shop 3
Neu Exportformat - Beschreibung mit HTML-Code Einrichtung von JTL-Shop4 1
Neu Textausrichtung in Html Mail Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu UNICODE, HTML und UTF-8 Zeichen (ASCII Zeichen) als Amazon Bullet Point Sonderzeichen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Zeilenumbruch beim Positionspreis im HTML-Editor Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Komprimierung des HTML-Ausgabedokuments / Template Einstellung fehlt JTL Shop5 ? Einrichtung JTL-Shop5 0
Neu Einstellung JTL Shop für google bei verkauften Artikeln Allgemeine Fragen zu JTL-Shop 1
Neu Welche Attribute bei Kategorien? Gambio-Connector 2
In Bearbeitung Automatisches Ausliefern -> Versanddatenexport + Lieferschein speichern bei Fulfillmentlagern JTL-Workflows - Ideen, Lob und Kritik 1
Gelöst Netzwerkfehler bei Neu-Installation Shop 5.1 Installation / Updates von JTL-Shop 2
Beantwortet 1.5.50.1 - funktioniert bei Euch das Amazon anhängen? Gelöste Themen in diesem Bereich 0
Neu Bei automatischer Anmeldung stürzt WAWI und Worker nach Start ab JTL-Wawi - Fehler und Bugs 0
Neu [Workflow] Bei Aufträge zusammenfassen alte Auftrags- und ext. Auftragsnummern erhalten User helfen Usern - Fragen zu JTL-Wawi 0
Neu Rechnungskorrektur bei veränderter MwSt. User helfen Usern - Fragen zu JTL-Wawi 1
Neu Vorraussichtliches Lieferdatum bei "Im Zulauf" nicht an Shopware übertragen Shopware-Connector 0
Neu Artikelname Updaten bei eBay eBay-Anbindung - Fehler und Bugs 3
Neu Falsche Abrechnungen von eBay bei Verkäufen auf ebay.co.uk nach UK eBay-Anbindung - Fehler und Bugs 0
Neu Automatisch setzten der Zahlung bei Rechnungskorrektur / Retoure Arbeitsabläufe in JTL-Wawi 0
Neu Briefpapier wird bei Dokumentausgabe nicht mehr korrekt dargestellt User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler bei Update bei 1.5.30 JTL-Wawi - Fehler und Bugs 1
Neu Versandbenachrichtigungen bei nicht versendeten Aufträgen raus. Shopify-Connector 5
Neu JTL-Shop-Attribute bei Gambio-Artikeln Gambio-Connector 1
Neu WAWI Fehler bei Statistik - eigene Vorlage JTL-Wawi - Fehler und Bugs 1
Neu Vorauswahl Produktkategorien zeigt nicht die Kats die bei Einzelartikel auswählen kann. Amazon-Anbindung - Fehler und Bugs 0
Neu Geisterschriften bei Windows 11 JTL-Wawi - Fehler und Bugs 5
Neu Wie schalte ich die Email an den Kunden bei Zahlungseingang ab? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
In Diskussion Bei Änderung des Lagerstands Email + Merkmal setzen JTL-Workflows - Ideen, Lob und Kritik 2
Neu Lieferzeit bei Überverkauf einstellen Allgemeine Fragen zu JTL-Shop 0
Issue angelegt Workflow: Artikel regelmäßig neu bei eBay einstellen JTL-Workflows - Ideen, Lob und Kritik 2
Neu "In den Warenkorb" bei IOS, neue Generation ab iPhone 11, mehrmals drücken JTL-Shop - Fehler und Bugs 1
Neu Bei LS-POS Zahlung, Rechnung nur erstellen, wenn nicht vorhanden, sonst als bezahlt markieren Fragen rund um LS-POS 2
Neu max_execution_time bei PHP 8 ändern ? Betrieb / Pflege von JTL-Shop 1
Neu Angebot und Auftrag zeigt bei Gewinn regulären Artikel VK JTL-Wawi - Fehler und Bugs 2
Neu Workflow AB Mailer bei Händlern aussetzen User helfen Usern - Fragen zu JTL-Wawi 2
Neu TARIC-Code fehlerhaft bei DHL 3.0 Shipping JTL-ShippingLabels - Fehler und Bugs 1
Neu Bei Globalen Vorlagen für den Lieferschein die Bankdaten ausblenden Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Issue angelegt Hinweis bei neuem Packauftrag möglich [WAWI-33642] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 2
Neu Amazon carriercode wird nicht übertragen + Email Adresse fehlt bei DHL nach übertrag der Daten des Kunden. JTL-ShippingLabels - Fehler und Bugs 0
Neu PHP Fatal error bei Blogbeiträgen Allgemeine Fragen zu JTL-Shop 9
In Bearbeitung Chromebox: Probleme mit Autofill bei Eingabefeldern JTL-POS - Fragen zu Hardware 2
In Bearbeitung [Gelöst] Seitenverhältnis bei Kundendisplay JTL-POS - Fragen zu Hardware 1
Neu Fehler in der Konfiguration bei Artikel in Warenkorb Allgemeine Fragen zu JTL-Shop 0
Neu Retoure anlegen immer mit Häkchen bei Versandkosten setzen & Bestand Buchen deaktivieren - möglich? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Verkauf bei Amazon ist auf Status "Verpackt versendet" was nicht stimmt User helfen Usern - Fragen zu JTL-Wawi 2
Neu Verbindung Shop 5.1 mit WAWI hat bei Umlauten Probleme JTL-Wawi - Fehler und Bugs 1
Neu InvalidShippingServieOfferId Fehlermeldung bei zwei Österreich Aufträgen (Amazon) JTL-ShippingLabels - Fehler und Bugs 12
Neu Syntaxfehler bei Rechnungskorrektur Arbeitsabläufe in JTL-Wawi 8
Neu Attribut "keine Preissuchmaschinen" bei Google Shopping Plugin Onlineshop-Anbindung 0
Neu Email Zahlungseingang auch bei manuellen Aufträgen Arbeitsabläufe in JTL-Wawi 2

Ähnliche Themen