Variantenbildende Merkmale werden nicht sauber übertragen

und-aus

Aktives Mitglied
5. April 2019
69
9
Hallo,
ich mappe Varianten, lege die Variatonswerte usw. und stelle dann Angebote mit Größen und Farbvarianten ein. Meist funktioniert das sauber. Wenn es dann aber eine Änderung am Artikel gibt haut mir Otto Fehler raus, dass variantenbildende Merkmale nicht vorhanden sind. Komisch ist, dass das Angebot beim ersten mal super drin ist und bei einer Änderung dann Fehler kommen.

jtl-wawi.jpg


So sieht das bei mir in der WaWi aus, auch bei Größe steht der Wert in grau drin. Alles korrekt soweit.



portal.otto.market.jpeg

und so sieht es dann bei Otto aus.
Wenn ich nun in der Wawi "Angebot aktualisieren" klicke passiert nichts bei Otto.
Wenn ich die hellgrauen Werte in der WaWi per Hand überschreibe und das Angebot speichere,
dann gehen diese Fehler weg bei Otto. Ich will aber keinesfalls die vielen Fehler jeden Tag per Hand überschreiben.
Mach ich irgendwas falsch, dass die grauen Werte bei einer Aktualisierung nicht übermittelt werden bzw. falsch übermittelt werden?

Für Hinweise wäre ich sehr dankbar.

Viele Grüße
Hansi
 

Metal Kids

Mitglied
17. Februar 2023
16
1
Haben das selbe Problem, bei uns läuft die erste Übertragung meist sauber durch, Felder wie Ausgabegröße, Material und Materialart sind dann für alle Varianten geflegt.

Einige Tage später verschwindet die Ausgabegröße aus den Artikeln und die Produkte melden bei Otto den Fehler, dass sich die Variantenbildenden Merkmale nicht unterscheiden. Ein erneutes Übertragen aus der Wawi löst das Problem dann mit Lücken wodurch sich ein ähnliches Bild wie bei dir ergibt.

Wir nutzen aktuell noch Wawi 1.8.12.2 - ich versuche morgen mal auf die neue Version zu aktualisieren und hoffe damit das Problem zu lösen.
 
Zuletzt bearbeitet:

und-aus

Aktives Mitglied
5. April 2019
69
9
Haben das selbe Problem, bei uns läuft die erste Übertragung meist suaber durch, Felder wie Ausgabegröße, Material und Materialart sind dann für alle Varianten geflegt.

Einige Tage später verschwindet die Ausgabegröße aus den Artikeln und die Produkte melden bei Otto den Fehler, dass sie die variantenbildenden Merkmale nicht unterscheiden. Ein erneutes übertragen aus der WAwi löst das Problem dann mit Lücken wodurch ich ein ähnliches Bild wie bei dir ergibt.

Wir nutzen aktuell noch Wawi 1.8.12.2 - ich versuche morgen mal auf die neue Version zu aktualisieren und hoffe damit das Problem zu lösen.
Schreibst du mal rein, ob ein Update was bring?
 

Metal Kids

Mitglied
17. Februar 2023
16
1
Schreibst du mal rein, ob ein Update was bring?
Moin,

Ich habe das Update vorhin bei uns installiert und testweise einen der Artikel nochmal übermittelt.
Sieht soweit gut aus, die Reihenfolge der Varianten is tzwar etwas durchwürfelt, aber das ist erstmal Nebensache.

Ich warte mal ab wie es morgen aussieht, bin aber erstmal vorsichtig optimistisch.

EDIT:
Die Ausgabegröße ist schon wieder Futsch. Warum auch immer.
 
Zuletzt bearbeitet:

Metal Kids

Mitglied
17. Februar 2023
16
1
Ich habe heute nochmal einen Versuch gestartet um das ganze zu Dokumentieren.

Heute früh um ca 9:15 war der Artikel wieder Fehlerfrei in Otto zu sehen. Etwa eine Studne später erschien der Fehler erneut. Ich habe die fehlenden Informationen im Partner Portal nachgetragen, gespeichert und dann gescreenshotted. Das war um 10:59.
24-07-05-1059.png
Alle Produkte der Familie 429.25 sind hier korrekt mit der richtigen Ausgabegröße bei Otto gelistet. Im Verlauf der nächsten Stunde habe ich immer wieder die Seite aktualisiert. Dazwischen habe ich gelegentlich - den Maximalbestand der Artikel angepasst um ein erneutes übermitteln des Artikels auszulösen. Nach einigem hin und her war es dann um 11:40 wieder so weit!

24-07-05-1140.png
Bei den Größen 116, 140, 92 und 152 hat sich die Eintragung für die Ausgabegröße verabschiedet.
24-07-05-1140_Otto_Detail.png
Zur Kontrolle habe ich dann nochmal die Daten der Artikel in der Wawi überprüft. Hier sollen die Artikel Fehlerfrei eingestellt worden sein. Im Artikel "429.25.8.999.116" ist auch die Ausgabegröße laut Wawi über die Variationenverknüpfung hinterlegt. Ebenso für die anderen betroffenen Größen. Heute morgen als ich den Fehler manuell korrigiert habe, war nur die Größe der SKU "429.25.8.999.128" verschwunden. Es wechseln also auch die Artikel bei denen der Fehler auftritt immer wieder.
24-07-05-1140_Wawi.png

Ich weiß nicht was wir noch machen sollen, so können wir nicht im großen Stil starten Produkte bei Otto zu listen und zu verkaufen. Aktuell gehen in Unregelmäßigen Zeitabständen immer wieder Teile von Artikeldatensätzen flöten.

Aber das ist auch nicht alles. In einem Fall hat es die WAwi geschafft eine Produktreferenz doppelt zu listen und eine Produkt SKU zu klonen indem eine neue Variante mit der zweifachen SKU angelegt wurde:
Duplikatfehler.png
Nach unserem Wissensstand sollte das von Seiten Otto aus gar nicht möglich sein. Aktuell sieht es für uns so aus als wäre die Schnittstelle zur Anlage und Pflege von Artikeln kaum nutzbar.

Ggf. liegt das Problem hier in einzelnen Produktkategorien, zumindest verkaufen wir in diesem Thread beide Textilartikel @und-aus. So oder so gebe ich diesen Thread jetzt mal in einem Ticket an den Support weiter.
 

Marcel Köhler

Mitglied
Mitarbeiter
5. September 2022
4
3
Hallo zusammen,

das Verschwinden der Variationswerte hängt vermutlich mit Updates oder Ameisenimporten für einzelne Kindartikel zusammen, bspw. Lieferantenbestände. Dies löst eine Aktualisierung des Angebots vom Kindartikel aus, jedoch nicht vom Vater (ist in Importen nicht vorhanden). Wenn die Kinder ohne Vater aktualisiert werden sendet die Schnittstelle die Variationswerte nicht mit und Otto entfernt sie dann entsprechend.

Das Ganze wird hiermit https://issues.jtl-software.de/issues/WAWI-77043 optimiert.

Als Workaround müsst ihr im Moment bei Aktualisierungen oder Importen von Kindartikeln immer die Väter mit einbeziehen oder im Anschluss den Vater mit den Kindern zusammen aktualisieren.
 

Metal Kids

Mitglied
17. Februar 2023
16
1
Hallo zusammen,

das Verschwinden der Variationswerte hängt vermutlich mit Updates oder Ameisenimporten für einzelne Kindartikel zusammen, bspw. Lieferantenbestände. Dies löst eine Aktualisierung des Angebots vom Kindartikel aus, jedoch nicht vom Vater (ist in Importen nicht vorhanden). Wenn die Kinder ohne Vater aktualisiert werden sendet die Schnittstelle die Variationswerte nicht mit und Otto entfernt sie dann entsprechend.

Das Ganze wird hiermit https://issues.jtl-software.de/issues/WAWI-77043 optimiert.

Als Workaround müsst ihr im Moment bei Aktualisierungen oder Importen von Kindartikeln immer die Väter mit einbeziehen oder im Anschluss den Vater mit den Kindern zusammen aktualisieren.
Könnte ein alternativer Workaround die Anlage der Variationsbildenden Felder wie z.b. der Ausgabegröße als Merkmal sein?
In dem Fall könnte das Merkmal über die Kategoriefelder verknüpft und direkt vom Kindartikel bezogen werden. So funktioniert es bei uns aktuell ja auch mit den Feldern Material & Materialart.

Da wir stündlich Änderungen im produzierbaren Bestand unseres Print On Demand Partners für betroffene Sku importieren wäre das für uns wahrscheinlich die einfachere Lösung.
 

Robin Hoheisel

Mitglied
27. April 2023
3
0
Wir haben für uns eine brauchbare Lösung gefunden.

Wir haben unsere Variantenattribute nochmal als Merkmale an die jeweiligen Artikel gehangen und dann über die Verkaufskanalfelder Zuordnung gematched. So sparen wir uns auch alle unsere Variationswerte und Felder im Variationsmapping für jede Kategorie zu hinterlegen. otto findet selbnst welche der hinterlegten Informationen sich unterscheiden und bildet daraus die entsprechenden Varianten.

Die Konfiguration sieht damit jetzt so aus:

Variationen.jpg
Variationswerte.jpg
Felder.jpg

Die Pfade der Merkmale werden bei euch wahrscheinlich anders aussehen - aber so weit funktioniert alles bei uns. Die Produkte kommen jetzt mit den wichtigen Farb & Größen Informationen bei Otto an. Nur der UVP geht leider weiterhin bei einzelnen Varianten flöten - aber damit können wir leben.

Otto.jpg

Das Produkt erscheint damit auch auf dem Marktplatz so wie wir es gerne hätten:
https://www.otto.de/p/metal-kids-t-...uer-kinder-S0DBF0WP/#variationId=S0DBF0WP0Y0G

Ich hoffe die hier gesammelten Informationen helfen euch weiter! @und-aus

Grüße,
Robin von Metal Kids
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Merkmale & Cross Selling Artikel auf Kindartikel übertragen - Mit manuellen Workflow Ereignis auslösen möglich? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Merkmale bei Varianten korrekt übertragen Shopware-Connector 1
Neu Merkmale Filter JTL Shop 5 benutzerdefiniert anzeigen Allgemeine Fragen zu JTL-Shop 0
Merkmale für "Verordnung über die allgemeine Produktsicherheit (EU)" Otto.de - Anbindung (SCX) 2
Neu Kind-Merkmale bei Vaterartikel JTL-Wawi - Fehler und Bugs 5
Neu Merkmale werden nicht übertragen. Artikel werden nicht den Merkmalen zugeordneten. Gelöste Themen in diesem Bereich 15
Neu Dotliquid Otto Merkmale aus eBay Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Datenmigration-Artikel werden nicht angezeigt Starten mit JTL: Projektabwicklung & Migration 0
Neu Meta-Daten vom Artikel werden von Google nicht genutzt Allgemeine Fragen zu JTL-Shop 3
Update 1.9.4.6 Fehlerhafte Adresse von Amazon kann nicht mehr bearbeitet werden. JTL-Wawi 1.9 3
Neu Welche Artikel werden zu Shopify übertragen? Alle? Shopify-Connector 5
Neu Staffelpreise werden von JTL-Connector nicht zu Shopify übertragen Shopify-Connector 0
Neu Versanddaten werden nicht Übermittelt. Amazon-Anbindung - Fehler und Bugs 2
Neu Änderungen in Template werden nicht angezeigt Templates für JTL-Shop 1
Neu Payone Plugin Zahlungen werden abgebucht aber keine Aufträge erstellt Plugins für JTL-Shop 0
Listenansicht kann nicht mehr eingestellt werden (außer für Admins) JTL-Wawi 1.9 0
Listenansicht Verkauf >> Angebote muss nach jedem Neustart neu sortiert werden JTL-Wawi 1.9 1
Neu Aktualisierung konnte nicht durchgeführt werden. Fehlercode 8 - Der Installationsknoten ist nicht vorhanden. Gelöste Themen in diesem Bereich 4
Auftragsnummer werden mit Unterstrich _ übernommen. JTL-Wawi 1.7 0
Neu Zahlungsmöglichkeiten werden nach PayPal Update nicht angezeigt Gelöste Themen in diesem Bereich 24
Neu DropShipping - Artikel kann nicht geliefert werden - aus Bestellung entfernen User helfen Usern - Fragen zu JTL-Wawi 0
Steuerschlüssel werden bei IGL-Aufträgen nicht immer gesetzt JTL-Wawi 1.9 1
Neu Wie lange werden alte Bestellungen aus Amazon importiert? Amazon-Anbindung - Fehler und Bugs 2
Neu Wawi 1.9. Ebayverkäufe werden nicht Ebaypayment zugeordnet JTL-Wawi - Fehler und Bugs 0
Neu [Wawi 1.7]Rechnung drucken - Vorlage fehlt / kann nicht geändert werden JTL-Wawi - Fehler und Bugs 0
JTL Wawi - Woocommerce - Stücklisten ohne Bestand werden mit viel Bestand angezeigt JTL-Wawi 1.9 0
Neu Auswertung von Artikeln die im Shop bestellt werden. JTL Ameise - Eigene Exporte 1
Neu JTL-Shop 5 nach Installation nur weiße Seiten bei Kategorien. Andere Seiten werden angezeigt Gelöste Themen in diesem Bereich 3
Neu Es werden PayPal-Bestellungen ohne PayPal-Zahlungen an Wawi übergeben JTL-Shop - Fehler und Bugs 2
Beschreibung Artikelmerkmale - Formatierungen werden nicht übernommen JTL-Wawi 1.8 2
Neu Wie werden Varianten ausgedruckt? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Artikel werden bei Hermes versendung bei ebay nicht als verschickt makiert JTL-ShippingLabels - Fehler und Bugs 1
Neu Warum werden bei gleichem Code Tabellen unterschiedlich eingerückt abgebildet / CSS Problem Templates für JTL-Shop 2
Neu Bilder werden nicht korrekt angezeigt Allgemeine Fragen zu JTL-Shop 0
Neu JTL WAWI RESTAPI Sales Order kann nicht erstellt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu Manuell eingetragene Einkaufspreise aus Angebot werden bei Auftragserstellung nicht übernommen JTL-Wawi - Fehler und Bugs 0
Neu Connectorabgleich überschreibt Einträge in Linkertabelle - Var.Kombis werden nicht unter dem Vaterartikel angelegt PrestaShop-Connector 1
Beantwortet Retouren mit Stücklistenartikeln können nicht bearbeitet werden - Kaufland [WAWI-76637] Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu WEBP Bilder werden nicht angezeigt JTL-Shop - Fehler und Bugs 2
Neu Nova einige Fontawaysome Icon werden nicht angezeigt wie Whatsapp oder Paypal Templates für JTL-Shop 0
Neu Rabattcodes (Coupons) werden im Lieferschein nicht angezeigt JTL-Wawi - Fehler und Bugs 0
Neu Wordpress Shortcodes werden falsch formatiert WooCommerce-Connector 3
Neu Bedingte Formatierungen werden nicht gespeichert JTL-Wawi - Fehler und Bugs 4
Neu JTL-WaWi 1.9.4.3 Aufträge werden nicht angezeigt JTL-Wawi - Fehler und Bugs 0
Gelöst JTL POS Sobald ein neuer Bon erstellt wird, soll auch ein Rabatt automatisch erzeugt werden Allgemeine Fragen zu JTL-POS 1
Neu artikel werden nicht zu woocommerce übertragen WooCommerce-Connector 0
In Bearbeitung Zahlungen werden nicht alle an die WAWI übertragen. JTL-POS - Fehler und Bugs 1
Neu Artikel ohne Bestandsführung sollen im Shop angezeigt werden User helfen Usern - Fragen zu JTL-Wawi 1
Neu Bug: Meta Informationen werden nicht übertragen durch veraltete Rank Math Bezeichnung (Lösung) WooCommerce-Connector 0
Neu Amazon Preisänderungen werden nicht übernommen (1.9.4.1) Amazon-Anbindung - Fehler und Bugs 0

Ähnliche Themen