Gelöst Textanker des CDK-Editors funktioniert nicht richtig

Herzog

Aktives Mitglied
2. August 2011
103
0
Wenn man einen Textanker erstellt wir man nicht zum Anker geleitet, sondern wird beim anklicken des Links immer auf die Startseite geleitet.
 

Alexander

Sehr aktives Mitglied
22. Mai 2006
2.930
0
Freital
AW: Textanker des CDK-Editors funktioniert nicht richtig

hast du einen Beispiellink oder den Quellcode aus dem Editor?

Sorry, aber es kann doch nicht so schwer sein von sich aus die nötigen Infos zu geben...

gefällt es euch, wenn eure Kunden nur sagen eh, da geht was ni, jetzt hilf ma...?
 

Herzog

Aktives Mitglied
2. August 2011
103
0
AW: Textanker des CDK-Editors funktioniert nicht richtig

Sorry ertmal ich muss lernen, wie, man richig postet.


Quellcode CKE-Editor:

<p style="margin-bottom: 0cm;">
<a href="#§ 1 Geltungsbereich "><b>§ 1 Geltungsbereich </b></a><br />
&nbsp;</p>
<p style="margin-bottom: 0cm">
<b><a name="§ 1 Geltungsbereich "></a>§ 1 Geltungsbereich </b></p>
<p style="margin-bottom: 0cm;">
&nbsp;</p>
<p style="margin-bottom: 0cm">
(1) Für die über diesen Internet- Shop begründeten Rechtsbeziehungen zwischen...

Wenn ich jetzt auf den Link in den Shop AGB´s klicke, werde ich auf die Startseite geleitet. Das Problem wurde schonmal hier behandelet, aber es wurde keine vernünftige Lösung gefunden.
 

Alexander

Sehr aktives Mitglied
22. Mai 2006
2.930
0
Freital
AW: Textanker des CDK-Editors funktioniert nicht richtig

nimm die Leerzeichen aus dem Link und em Verweisziel raus dann funktioniert das wunderbar...

am besten du nimmst einfache Ziele ohne Sonderzeichen in der Art:

Code:
<a href="#1_Geltungsbereich">Text</a>

    <a name="1_Geltungsbereich"></a>
 

Herzog

Aktives Mitglied
2. August 2011
103
0
AW: Textanker des CDK-Editors funktioniert nicht richtig

Schonmal Danke, habe es versucht:

Code:
<strong><a href="#1_Geltungsbereich">§ 1 Geltungsbereich </a></strong></p>
<p style="margin-bottom: 0cm;">
    &nbsp;</p>
<p style="margin-bottom: 0cm;">
    <a name="1_Geltungsbereich"></a><strong>§ 1 Geltungsbereich</strong></p>
hat leider nicht geklappt
 

Alexander

Sehr aktives Mitglied
22. Mai 2006
2.930
0
Freital
AW: Textanker des CDK-Editors funktioniert nicht richtig

hast du mal nen Link? hab das jetzt in drei unterschiedlichen Shops getestet, und alle haben kein Problem damit
 

ID-R

Aktives Mitglied
22. November 2007
443
0
AW: Textanker des CDK-Editors funktioniert nicht richtig

liegt daran das die anker nicht gehen: <base href="{$cBaseRefURL}/" /> im header.tpl auskommentieren, dann sollte es funktionieren.
 

Alexander

Sehr aktives Mitglied
22. Mai 2006
2.930
0
Freital
AW: Textanker des CDK-Editors funktioniert nicht richtig

ok, man sollte es auch mit nem Tiny-TPL testen ;)

wenn du also ein original Tiny TPL nutzt bzw. ein angepasstes Tiny, dann gehen Anker grundsätzlich nicht. oder nur durch die Änderung siehe Post über mir

Sorry :)
 

Herzog

Aktives Mitglied
2. August 2011
103
0
AW: Textanker des CDK-Editors funktioniert nicht richtig

Ahhh alles klar habe ich auskommentiert und funktioniert. Danke
 

Herzog

Aktives Mitglied
2. August 2011
103
0
AW: Textanker des CDK-Editors funktioniert nicht richtig

Damit wollte ich sagen das der Beitrag damit gelöst wäre. Danke für die Hilfe.
 

pikantum

Guest
AW: Textanker des CDK-Editors funktioniert nicht richtig

liegt daran das die anker nicht gehen: <base href="{$cBaseRefURL}/" /> im header.tpl auskommentieren, dann sollte es funktionieren.
Für die Erstellung eines Lexikons benötige ich Anker und bin prompt über dieses SEO-Problem gestolpert. Mit dem Auskommentieren in der header.tpl funktioniert das, aber meine Frage:
Hat das evt. negative Auswirkungen auf den Rest des Shops? Funktioniert SEO dann noch? Wofür ist der Eintrag eigentlich gut?
 

pikantum

Guest
AW: Textanker des CDK-Editors funktioniert nicht richtig

Funktioniert wunderbar mit dem Javascript :)
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Amazon - Variante konnte der SKU des übergeordneten Artikels nicht zugeordnet werden Fehler: 8801 Amazon-Lister - Fehler und Bugs 0
Voreinstellung Sprache und Währung bei Aufruf des Shops Einrichtung JTL-Shop5 4
In Bearbeitung Datevconnect Rechnungsdatenservice: Fehler beim erstellen des XML übertragungsformates [WAWI-51803] Schnittstellen Import / Export 2
Neu Komische Darstellung des Versandkostentextes JTL-Wawi - Fehler und Bugs 1
Neu Komische Darstellung des Versandkostentextes JTL-Wawi - Fehler und Bugs 0
Neu Artikel des Stücklistenartikel exportieren User helfen Usern - Fragen zu JTL-Wawi 1
Neu Kundenkonto: Kein Zugriff des Kunden möglich, Fehlfunktionen, keine Anmeldung JTL-Shop - Fehler und Bugs 0
Gelöst Antwort des EC Terminals Fehlerhaft JTL-POS - Fehler und Bugs 7
Neu DHL Versenden druckt Telefonnummer des Kunden User helfen Usern - Fragen zu JTL-Wawi 2
JTL Shop 5 unter "localhost" Fehler beim Setzen des Cookies Einrichtung JTL-Shop5 0
Neu Seo-Kategorien des Artikels Shopware-Connector 1
Neu Kein Download des Gambio-Connectors im Kundencenter möglich Allgemeines zu den JTL-Connectoren 1
Neu Problem mit der Anbindung des Connectors zu Shopify Shopify-Connector 10
Neu Fehler beim Einspielen des Backups auf neuem Rechner Installation von JTL-Wawi 7
Gelöst Fehler im Druck des Kassenbuches / Unterschiedlich für unterschiedliche Zeiträume Gelöste Themen in diesem Bereich 2
Neu Error in Formular wenn Amazon Custom Pfad nicht vorhanden ist (Der Index lag außerhalb des Bereichs...) Individuelle Listenansichten in der JTL-Wawi 0
Gelöst Gelöst: Vorlage des Versandetiketts bearbeiten Gelöste Themen in diesem Bereich 2
In Diskussion Workfow: ausbuchen des einen Artikels, aufteilen auf andere Artikel und wieder einbuchen JTL-Workflows - Ideen, Lob und Kritik 0
Neu Nachdem Einrichten des Layouts mit dem OnPage Composer ist das dargestellte Bild nicht zentriert. Allgemeine Fragen zu JTL-Shop 2
Neu Änderung des Feldes Kommentar am Ende des Bestellprozesses Allgemeine Fragen zu JTL-Shop 4
Neu Bestände werden nur noch nach Löschen des Cache richtig angezeigt! JTL-Shop - Fehler und Bugs 9
Neu Kauf des Warenbestand durch Amazon selbst - Gefahr doppelter Aufträge Amazon-Anbindung - Fehler und Bugs 3
Neu Fehler beim Erstellen des Fensterhandles. JTL-Wawi - Fehler und Bugs 0
In Bearbeitung iZettle Zahlung - und danach kein Abschluß des Bons Allgemeine Fragen zu JTL-POS 10
Gelöst JTL Shop 5 Nova Template Problem beim Einrichten des PayPal Plug-ins Einrichtung JTL-Shop5 2
In Bearbeitung Obligatorische Eingabe des Transportunternehmens und des Lieferservice/der Versandart. Amazon-Anbindung - Ideen, Lob und Kritik 12
Nova Template: Komischer Abstand des ersten Panels? Einrichtung JTL-Shop5 3
Neu Abkündigung Ihrer Jahreslizenz des MultiShop-/Zahlungsmoduls Smalltalk 9
Neu Fehlermeldung bei Aufruf des JTL-Wawi-Logbuches JTL-Wawi - Fehler und Bugs 5
Neu Wawi zeigt ganzen HTML Codes des Artikels in Übersicht User helfen Usern - Fragen zu JTL-Wawi 6
In Bearbeitung TSE Ausfall beim ersten Bon des Tages JTL-POS - Fehler und Bugs 43
Neu Herkunft des Auftrags einheitlich in allen Dokumenten bestimmen Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 3
Neu Ebay Namen des Kunden in Shop 5 anzeigen Technische Fragen zu Plugins und Templates 0
Neu Ausgabe des Sendungsgewichts auf Auftragsbestätigung - dotliquid User helfen Usern - Fragen zu JTL-Wawi 0
Neu Geschwindigkeit des Shops bei vielen Merkmalen Allgemeine Fragen zu JTL-Shop 5
Neu Wie bekomme ich das Datum des letzten Tages des letzten Monats auf der Rechnung? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Datum des Lieferscheins falsch Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 4
Neu Update des MSSQL Servers - muss ich mit Problemen rechnen? Installation von JTL-Wawi 5
In Diskussion UPS Versand über Konto des Kunden JTL-ShippingLabels - Ideen, Lob und Kritik 0
Neu DHL Wunschpaket - keine Anzeige der Services nach Aktivierung des Plugins. Technische Fragen zu Plugins und Templates 5

Ähnliche Themen