Neu Shopware 6 Connector.... ich verzweifle gleich

  • Fehler bei Bestellberichten im Amazon Seller-Central

    Soeben ging ein Newsletter an alle User heraus mit wichtigen Informationen zu diesem Fehler und dessen Beseitigung.

    Wir haben hier die Informationen noch einmal hinterlegt: Klick

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

Tino Glöckner

Aktives Mitglied
4. Mai 2018
25
0
Hallo alle zusammen...

ich verzweifle gleich am Shopware 6 Connector... Er bringt immer wieder den selben Fehler. Ich habe jetzt die Shopware schon zum 5. male neu aufgesetzt und immer wieder den Connector als Integration eingebaut.
Dann setze ich den Connector zurück und versuche abzugleichen. Es kommt immer ein duplikate key - Error beim Schreiben in die UNIT Tabelle.

Ich versuche diesen Connector schon seit über einem Jahr ans laufen zu bekommen. Das kann es doch nicht sein, das da immer irgend etwas nicht geht.

Viele Grüße

Tino
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.251
129
Küps
Hatte noch kein Problem vorallem wenn Shop und Wawi jungfräulich sind.
Lass doch mal einen Service Partner ran wenn du es nicht hinbekommst.
Warum setzt du den Connector eigentlich zurück wenn du ihn erst neu eingerichtet hast?
 

Tino Glöckner

Aktives Mitglied
4. Mai 2018
25
0
Hatte noch kein Problem vorallem wenn Shop und Wawi jungfräulich sind.
Lass doch mal einen Service Partner ran wenn du es nicht hinbekommst.
Warum setzt du den Connector eigentlich zurück wenn du ihn erst neu eingerichtet hast?
Die Wawi ist nicht neu. die läuft schon seit 2015 mit einem shopware 5 connector und da geht alles problemlos. wir hatten noch nie einen Servicepartner, da das einrichten ja eigentlich kein Problem ist.
Bei uns läuft alles ohne Supprt.. Die Kasse, die Wawi der Shopware 5 Connector... nur der Connector Shopware 6 will nicht

Es geht allerdings schon damit los, das der Abgleich sagt, das ihm ein Primary Key um die Ohren geflogen ist. ( Tabelle UNIT ) ... Wenn ich ins Log der Shopware schaue, steht dort, das er eine ID nicht finden kann. Da sind nun mal zwei völlig gegesätzliche Fehlermeldungen.

Gibt es irgendwo ein LOG des Connectors, das man da mal nachsehen kann?

De Connector habe ich noch einmal zurück gesetzt, weil ich in der WAWI einige Kategorien umgezogen habe und auch auf dem Server noch einige Änderungen an den Verzeichnisstrukturen vorgenommen habe. Ausserdem sollte das doch kein Problem sein... Zurücksetzen und neu beginnen, darf ja nun nicht in Fehlern ausarten
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.251
129
Küps
Doch das kann klar in Fehlern ausarten.

Er will sozusagen was übertragen was es schon gibt. Daher heißt es ja das die Wawi das führende System ist. Also wäre es logisch den Shop leer zu machen oder aber du lässt alles abholen vom Shop so das die beiden sich dann kennen.

Derzeit kennen sich die beiden Systeme nicht und die Wawi will was senden und der Shop sagt nein gibt es schon.

Also so verstehe ich gerade deine Probleme
 

Tino Glöckner

Aktives Mitglied
4. Mai 2018
25
0
Leider nicht ganz so.. Ich habe alleine heute die Shopware (weil die eben neu ist) 5 mal neu installiert.. die ist immer mit dem Rücksetzen des connctors neu.
Deswegen verstehe ich ja das ganze nicht. Ich mache gerade einen neuen Versuch. Ich hole mir jetzt auch eine neuer Connector Lizenz ( bisher das open Beta )
 

Tino Glöckner

Aktives Mitglied
4. Mai 2018
25
0
Hm... ich kann nicht sagen, was falsch war... An der WAWI kann ich wenig machen, da es die Produktionsvariante ist... Ich habe heute 6 mal Shopware 6 neu aufgesetzt... Also immer leer.. dann den Connector zurück gesetzt und es hat nie vernünftig synchronisiert... beim 6 mal, habe ich wieder eine leere Shopware 6 genommen.. die bekannte Wawi, aber eine neue Lizenz des connectors. Nich mehr meine OpenBeta vom Februar 2021, sondern eine für 19.99 im Monat... jetzt geht es... Man muß nicht alles verstehen :) ... und als Dipl.-Inform. schon gar nicht :)

Das einzige, was jetzt noch Probleme macht, ist die Verkaufskanal-Zuordnung. Die Haken sind immer gesetzt aber beim Übertragen trägt er den Verkaufskanal beim Artikel nicht ein. Ich habe mal einen Testweise in Shopware von Hand gesetzt... da wird der Artikel im Shop angezeigt. Aber das kann man doch am Connector gar nicht configurieren. Das sendet ja die WAWI..

Komisch.. aber auch das werde ich noch heraus bekommen :)

Falls jemand eine Tipp hat, dann nehm ich den :)

Schönes Wochenende...
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Shopware 5 Connector fehlender CDN/File System Adapter Support Shopware-Connector 0
Neu JTL-Connector für Shopware 6 Beta Version beendet? Shopware-Connector 2
Neu Shopware 5 Connector / abweichender Produkttitel Shopware-Connector 2
Verwiesen an Support Abgleich Fehler nach Shopware Connector Update Shopware-Connector 1
Neu Connector Abgleich schlägt fehlt - Shopware 5 - Exception: The EntityManager is closed - Exception: The EntityManager is closed Shopware-Connector 2
Neu Connector-Version Shopware 5 Shopware-Connector 10
Neu [JTL + Shopware] Connector löscht Suchfilter Onlineshop-Anbindung 3
Neu Entity Manager is closed - Shopware 5 Connector / Shopabgleich Shopware-Connector 2
Neu Art des Konfigurators bei Shopware 5 Shopware-Connector 0
Neu JTL 1.6 + Shopware 6 + Mollie (Zahlungen kommen als pm_mollie rein) Shopware-Connector 0
Beantwortet Shopware 6/JTL 1.5.48.2 - Neu im Sortiment seit () wird nicht zu Shopware übertragen Shopware-Connector 2
Neu Shopware 6 - neuer Versuch Shopware-Connector 0
Neu Shopware 5.7.8 Error: Current Shop has no Currency set Shopware-Connector 1
Neu Shopware Abgleich - JTL 1.6 Probleme Shopware-Connector 1
Neu JTL storniert Auftrag in Shopware? Onlineshop-Anbindung 1
Neu In Wawi gelöschte Artikel erscheinen dennoch im Shopware Shop Shopware-Connector 1
Neu Shopware 6 + Wawi: 1.6.36.0 Onlineshop-Anbindung 1
Neu Onlineshop Abgleich (zu Shopware) Fehler Artikelmerkmale Farbe, Übersetzungen und Details Shopware-Connector 0
Neu JTL FFN Kunde mit Shopware 6 anbinden User helfen Usern - Fragen zu JTL-Wawi 3
Neu JTL-Download Link wird zwar in Shopware 5 unter "Ressourcen" angezeigt, taucht aber erst im Frontend auf, wenn ich im Artikel auf Speichern drücke! Shopware-Connector 0
Neu Kunden von Shopware nicht zur WaWi übertragen ? Shopware-Connector 0
Neu Shopware Steuerklassen anlegen (Lebensmittel) syncron zur JTL Wawi Shopware-Connector 3
Neu Rechnugnsnummer & Rechnungsdatum an Shopware übertragen Onlineshop-Anbindung 2
Neu JTL Wawi - Shopware 6 Verbindung JTL-Wawi - Fehler und Bugs 4
Neu Shopware 5 Artikelsynchronisation zu JTL schlägt fehl (Exception bei product.pull: Error while encoding into JSON: Malformed UTF-8 characters...) Shopware-Connector 1
Neu Anbindung Shopware 5 mit JTL Vouchers Shopware-Connector 4
Neu OSS UST EU-Ausland bei Shopware 5 User helfen Usern 0
Neu aktualisierte Bestellung in JTL-Wawi wird in Shopware 6 nicht aktualisiert JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim hochladen von Artikeln Shopware 6 Shopware-Connector 2
Neu Maximalabnahme Shopware 5 + Wawi 1.5 Shopware-Connector 6
Neu [DHL] Label mit Anrede "Keine Angabe", Shopware JTL-ShippingLabels - Fehler und Bugs 0
Neu Neukunden werden im Shop zu Schnellbestellern Wawi 1.34.2 und Shopware 5 Onlineshop-Anbindung 0
Neu Rechnugnsnummer & Rechnungsdatum an Shopware übertragen Arbeitsabläufe in JTL-Wawi 5
Neu Umzug von Shopware 5 auf Shopware 6 Shopware-Connector 1
Neu Erfahrungen Connector mit Elementor-Paket mit direktem Google-Hosting WooCommerce-Connector 0
Neu JTL connector woocommerce Angebot/Aufträge WooCommerce-Connector 0
Neu Rey Theme kompatibel mit JTL-Connector? WooCommerce-Connector 0
Neu Connector Plugin Freigabe für SW 5.7.10 Shopware-Connector 3
Neu Wie vorgehen beim Connector Update? Modified eCommerce-Connector 0
Neu Bilder > übertragung ausstehend (Shopify connector) Shopify-Connector 0
Neu SW5 Connector bricht ab bei Lieferschein senden Shopware-Connector 0
Neu Shopkonfiguration Connector konfigurieren keine Auswahl möglich WooCommerce-Connector 0
Neu Wann funktioniert der Shopware6 Connector? Shopware-Connector 8
Neu Jtl Connector - WooCommerce / Paypal-Aufträge werden nicht importiert WooCommerce-Connector 0
Neu Connector für Konfigurator/Stücklistenartikel WooCommerce-Connector 0
Neu Connector keine Verbindung WooCommerce-Connector 1
Neu Fehler in Connector-Requestdaten nach Änderung der Kundengruppe in der Wawi Allgemeines zu den JTL-Connectoren 2
Neu JTL Connector zu Presta "Product": {"delete"} -> Exception bei product.delete: Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverf PrestaShop-Connector 1
Neu Fehler beim Verbindungsaufbau: Exception bei core.connector.auth: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert. WooCommerce-Connector 1
Neu Einstellung Liefer-Bestellstatus von JTL zu Woocommer ( JTL -WOOCOMMERCE CONNECTOR ) WooCommerce-Connector 0

Ähnliche Themen