Neu Shop 5.1.1 kann nicht installiert werden

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Hallo Leute,

habe ein Problem bei der Shop installation. Und zwar wird das Datenbankschema nicht komplett installiert. Es werden 116 Tabellen angelagt und bleibt dann in einer Endlosschleife hängen.
Alle Checks sind ohne Problem durchgelaufen, php-version 7.4.

Keine Fehlermeldung. Was kann ich da machen.

P.S.: Habe ein Error Log eingefügt und bekomme folgende Fehlermeldung:
 

Anhänge

  • Shop5.png
    Shop5.png
    39,1 KB · Aufrufe: 24
Zuletzt bearbeitet:

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
So, die Fehlermeldung aus dem obigen Post jonnte von meinem Provider behoben werden.

Leider läuft die Installation trotzdem nicht durch und bleibt beim installieren des Datenbankschemas hängen.

Keine Fehlermeldung, hat irgend jemand vielleicht eine Idee worann das liegen könnte?
 

css-umsetzung

Offizieller Servicepartner
SPBanner
6. Juli 2011
4.888
871
Berlin
Von außen her kann man da leider nichts sagen, da es wirklich alles sein kann "unter anderem auch ein fehlerhafter Upload der Dateien".
am besten ein Ticket bei JTL aufmachen wenn der Support durch einen kostenpflichtigen Shop abgedeckt wird oder einen Servicepartner beauftragen.
 

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Von außen her kann man da leider nichts sagen, da es wirklich alles sein kann "unter anderem auch ein fehlerhafter Upload der Dateien".
am besten ein Ticket bei JTL aufmachen wenn der Support durch einen kostenpflichtigen Shop abgedeckt wird oder einen Servicepartner beauftragen.
Hallo, nein ist er leider nicht.
Das Hochladen lief ganz normal durch, alle Dateinen wurden hochgeladen. Das einzige was mir aufgefallen ist, war das er eine Datei überschreiben wollte da sie schon vorhanden war.
Ich hatte den Shop 5.0.3 ja auch schon am laufen, wollte aber den 5.1.1. eben komplett neu installieren. Habe so ein Problem noch nie gehabt.
Allerdings ist die Fehlermeldung auch wieder aufgetaucht aber da ist der Provider schon dran.
 

hanlog

Aktives Mitglied
10. Februar 2013
6
0
Habe das selbe Problem, bleibe beim "Schema importieren" in einer Schleife hängen. Die Installationsfiles wurden als zip zum FTP gesendet und per unzip php befehl entpackt. Der gleiche Fehler erscheint auch wenn ich die Dateien per Filezilla im Modus Binär entpackt übertrage. Der Server erfüllt alle Anforderungen. Habe jetzt die Installation 4 bis 5 mal neu hochgeladen und gestartet ,der Fehler bleibt der gleiche.

Edit:

Die Installation hat nun funktioniert, es lag an Wartungsarbeiten vom Hoster. Daher traten Fehler in Verbindung mit der MySql Datenbank auf
 

Anhänge

  • jtl.jpg
    jtl.jpg
    100,5 KB · Aufrufe: 9
Zuletzt bearbeitet:

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Hallo Leute,
ich habe leider immer noch das oben beschriebene Problem das ich den Shop nicht installieren kann.

Laut meinem Provider liegt es an der Anwendung (Shop). Bei der Installation tritt wohl ein Fehler mit MySQL 8 auf und das müßte JTL lösen.
Leider habe ich nur die CFE-Version und kann so kein Support- Ticket eröffnen.
Ich hoffe, mir kann jemand weiterhelfen.
Die Fehlermeldung ist folgende:
 

Anhänge

  • Shop5-1.png
    Shop5-1.png
    39,2 KB · Aufrufe: 7

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Hallo Jürgen,

Kann dein Provider vlt. sogar sagen WELCHER Fehler da auftritt? Dann könnte man da mal konkreter nachschauen...
Hallo @FPrüfer ,

der Fehler liegt irgendwo beim erstellen des Datenbankschemas. Es werden ca. 114--118 Tabellen erstellt und läuft dann in eine Endlos-Schleife.
Wenn ich dann die Installation abbreche und neu starte, ohne die vorher installierten Tabellen zu löschen, werden die nächsten ca. 114--118 Tabellen erstellt. Das kann ich wiederholen bis alle Tabellen vorhanden sind, jedoch kommt dann am Schluss eine Fehlermeldung mit zig doppelten Einträgen.

Ich habe keinen Plan was ich da machen kann.
 

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Ich würde folgendes versuchen wenn der Shop Jungfräulich ist:
via phpmyadmin
1. Die Datenbank komplett leeren, alle Tabellen löschen
2. Die initial_schema.sql aus dem Installationsordner direkt in der Datenbank ausführen.
Hallo @albi123
danke für deine Antwort.

Wie mache ich das denn? Datenbank ist leer, alle Tabellen gelöscht. Wie führe ich das denn jetzt in der Datenbank aus?
 

albi123

Sehr aktives Mitglied
7. Dezember 2009
616
57
Da steht oben im Menü "SQL" --> drauf klicken, dort den Inhalt der initial_schema.sql reinkopieren und auf OK klicken.
ODER
du nutzt die "Importieren" Funktion. Durchsuchen --> initial_schema.sql auswählen und auf OK klicken.
 

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Da steht oben im Menü "SQL" --> drauf klicken, dort den Inhalt der initial_schema.sql reinkopieren und auf OK klicken.
ODER
du nutzt die "Importieren" Funktion. Durchsuchen --> initial_schema.sql auswählen und auf OK klicken.
Hmm,
importieren geht nicht. Fehlermeldung: Keine Datenbank ausgewählt

Kann ich die Datei mit Notepad öffnen, Inhalt kopieren und dann bei SQL einfügen? Oder muß ich die Datei erst auf den Server hochladen?
 

albi123

Sehr aktives Mitglied
7. Dezember 2009
616
57
Hmm,
importieren geht nicht. Fehlermeldung: Keine Datenbank ausgewählt

Kann ich die Datei mit Notepad öffnen, Inhalt kopieren und dann bei SQL einfügen? Oder muß ich die Datei erst auf den Server hochladen?
Du musst natürlich in deiner Datenbank sein. Im linken Menü die Datenbank wählen wo du das rein haben willst.

Ja du kannst die Datei mit Notepad öffnen, den Inhalt kopieren und dann unter "SQL" einfügen.
 

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Du musst natürlich in deiner Datenbank sein. Im linken Menü die Datenbank wählen wo du das rein haben willst.

Ja du kannst die Datei mit Notepad öffnen, den Inhalt kopieren und dann unter "SQL" einfügen.
Ich war in meiner Datenbank, muß ich mich ja bei php-Amin einloggen.

Habe den import nochmals probiert, jetzt kam folgende Fehlermeldung: Der Server hat einen internen Fehler oder eine Fehlkonfiguration festgestellt und konnte Ihre Anfrage nicht abschließen.

Muß ich da beim import noch irgendwas einstellen?
 

albi123

Sehr aktives Mitglied
7. Dezember 2009
616
57
Habe den import nochmals probiert, jetzt kam folgende Fehlermeldung: Der Server hat einen internen Fehler oder eine Fehlkonfiguration festgestellt und konnte Ihre Anfrage nicht abschließen.

Muß ich da beim import noch irgendwas einstellen?
Normalerweise musst du da nichts extra einstellen. Nun weißt du aber, dass es Server- und kein Shopproblem ist.
Ich an deiner Stelle würde meinen Provider bitten das einzuspielen damit es sieht und nachvollziehen kann das da was faul ist an der Konfiguration.
 

Jogi1962

Gut bekanntes Mitglied
24. März 2012
251
15
NRW
Hallo, kurze Rückmeldung.

Der Fehler ist gelöst, es war eine falsche php-Konfiguration bei meinem Hoster den sie jetzt endlich gefunden und behoben haben.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL Shop 4 - Artikel mit Pfand kann nicht in EU verschickt werden Allgemeine Fragen zu JTL-Shop 1
Neu [Shopware 6] Erstelltes Menu im JTL-Wawi kann im Shop keinem Layout zugewiesen und gespeichert werden Shopware-Connector 1
Neu Wie kann ich retournierte VarKombis in einer separaten Online-Shop Kategorie reduziert anbieten? User helfen Usern - Fragen zu JTL-Wawi 1
Neu Keine Lieferzeiten im Shop | JTL kann keine Lieferzeiten an Woocommerce übertragen und überschreibt auch jede Änderung im backend von Woocommerce WooCommerce-Connector 2
Neu Kann nur eine Sprache auswählen trotzneustart der Wawi Shop 5 JTL-Shop - Fehler und Bugs 2
Neu Einstellung JTL Shop für google bei verkauften Artikeln Allgemeine Fragen zu JTL-Shop 3
Neu Kein Zugriff auf Shop-Backend JTL-Shop - Fehler und Bugs 4
Gelöst Artikelbilder in Großansicht ohne Navigationsbuttons im JTL-Shop JTL-Wawi - Fehler und Bugs 2
Gelöst Netzwerkfehler bei Neu-Installation Shop 5.1 Installation / Updates von JTL-Shop 2
Neu Nach Update von 1.15.13.0 -> 1.5.50.1 in Gambio Shop Lieferzeit 0 Tage + Artikel inaktiv Gambio-Connector 3
Neu komplette Variablenliste für Exportformate in JTL Shop 5 Betrieb / Pflege von JTL-Shop 1
Neu JTL Shop 5 - Anpassung Nova Child Theme - Benachrichtigungsfunktion Dienstleistung, Jobs und Ähnliches 0
Neu Shop 5.1.1 Artikel werden nach Wawi Wareneingang von allen Shop Wunschlisten gelöscht JTL-Shop - Fehler und Bugs 1
Neu Shopware 6 Connector - Über die JTL-Wawi Funktionsattribute die Shop-Funktionen steuern Shopware-Connector 0
Neu JTL-Shop-Attribute bei Gambio-Artikeln Gambio-Connector 2
Neu Shop 5 extrem langsam - Back- und Frontend Allgemeine Fragen zu JTL-Shop 3
Neu Shop Connector Update, feature bzw features.json Datei Fehler Shopware-Connector 4
Neu JTL Shop 5 Systemvoraussetzung Wawi 1.6 Installation / Updates von JTL-Shop 2
Neu JTL SHOP 5 Newsletter versenden scheitert Allgemeine Fragen zu JTL-Shop 5
Neu Habt ihr schon mal einen kompletten Shop eingerichtet und dann umgezogen? Installation / Updates von JTL-Shop 10
Neu Shop zerschossen - wird nur fehlerhaft angezeigt JTL-Shop - Fehler und Bugs 0
Neu Kleiner Bestellworkflow im Shop Allgemeine Fragen zu JTL-Shop 0
Neu nova update nach Shop Update 5.1.1 Templates für JTL-Shop 1
Neu [Shop 5] Error executing query: INSERT INTO tbesucherarchiv JTL-Shop - Fehler und Bugs 6
Neu Einbindung Icecat in Shop 5 Allgemeine Fragen zu JTL-Shop 0
Neu ungewollte Anzeige von css auf Vergleichsseite im Shop JTL-Shop - Fehler und Bugs 2
Neu Update von Shop 5.0.3 auf 5.1 Installation / Updates von JTL-Shop 2
Neu Plötzlich Cache-Fehler und kein Zugang mehr zum Shop-Backend JTL-Shop - Fehler und Bugs 0
Neu 💙 Neues Plugin: Warenkorb-Button Plus (für JTL-Shop 4 und JTL-Shop 5) Plugins für JTL-Shop 2
Neu 💙 Neues Plugin: Payment & Shipping Icons Plus (für JTL-Shop 4 und JTL-Shop 5) Plugins für JTL-Shop 0
Neu Shop 5.1.1 - Warenkorb und Login im Header ausblenden / entfernen Templates für JTL-Shop 2
Neu JTL Shop 5 Kritik! Konfigurator immer noch nicht überarbeitet! JTL-Shop - Ideen, Lob und Kritik 7
Neu Neuinstallation meines Shop, nach 3 downloads aus dem Kundencenter und 4 Installationsversuche Allgemeine Fragen zu JTL-Shop 2
Neu Backup Plugin schon JTL-Shop 5 ready? Plugins für JTL-Shop 0
Neu seit JTL Shop 5 sind die Seitenladezeiten zu lang JTL-Shop - Fehler und Bugs 2
Neu Shop 4: Bilder werden nicht automatisch generiert Einrichtung von JTL-Shop4 2
Neu Metadaten werden nicht an Gambio-Shop übermittelt Gambio-Connector 3
Neu Connector hat mal wieder den Shopware Shop zerschosssen - Kotzanfall! JTL-Wawi - Fehler und Bugs 0
Neu Gibt es die Möglichkeit die Lieferzeit im JTL Shop 5 auszublenden? Betrieb / Pflege von JTL-Shop 4
Neu OSS Erfahrungen - Preise Shop/Ebay/Amazon Smalltalk 2
Neu Download JTL Shop 5.1 als Community Free Version noch nicht möglich? Installation / Updates von JTL-Shop 8
Neu Pflege der Versandkosten im Shop umständlich Betrieb / Pflege von JTL-Shop 0
Neu Verbindung Shop 5.1 mit WAWI hat bei Umlauten Probleme JTL-Wawi - Fehler und Bugs 1
Neu AUsgezeichnet.org und JTL Shop 5 Allgemeine Fragen zu JTL-Shop 0
Neu Shop 5.1.1 - Wunschzettel funktioniert überhaupt nicht JTL-Shop - Fehler und Bugs 2
Neu Shopauskunft Plugin für Shop 4 Plugins für JTL-Shop 3
Neu Nach einem Domainumzug und anschließendem Update auf Shop 5.1 werden die deutschen Umlaute nicht richtig dargestellt Installation / Updates von JTL-Shop 2
Neu Shop 5.1.1 / Umstellung auf 64 Bit, MariaDB, PHP 8: "max_execution_time" Wert zu gering Installation / Updates von JTL-Shop 4
Neu Shop Bestellnummer als Wawi Auftragsnummer User helfen Usern - Fragen zu JTL-Wawi 2
Neu Adressen - JTL Shop 5 JTL-Shop - Ideen, Lob und Kritik 2

Ähnliche Themen