Gelöst Produkte nach Attribut filtern mit dem Connector syncen

  • JTL-Connect 2022: Ihr habt noch kein Ticket? Jetzt schnell sichern! Die PreConnect ist bereits ausgebucht, auch für die After-Show-Party auf der Ocean Diva sind nur noch wenige Plätze verfügbar! HIER geht es zum Ticketverkauf

  • Das Stable Release von JTL-Wawi 1.6 ist startklar: HIER gehts zum Forenbeitrag

Mariusz

Mitglied
30. Mai 2018
10
1
Hallo zusammen,

WooCommerce Version 3.4.0
Connector Version 1.4.12
WordPress Version 4.9.6
Wawi Version 1.3.17.1

ich habe mir über WooCommerce mühsam benutzerdefinierte Produkteigenschaften eingerichtet. So sah das Ganze dann aus:

upload_2018-6-7_20-51-56.png

Nachfolgend habe ich einen kompletten Import von WooCommerce zu JTL-Wawi angestoßen. Das sah dann folgendermaßen aus:

upload_2018-6-7_20-53-4.png

Nach der Synchronisation sieht dann das Ganze in WooCommerce so aus:
upload_2018-6-7_20-54-15.png

Der JTL-Connector haut mir das kaputt. Ich habe also in JTL-Wawi einige Artikel dubliziert und die Attribute entsprechend angepasst. Z. B. von 1,75mm auf 2,85mm. Diese werden auch in WooCommerce mit den komischen pa_Bezeichnungen übertragen und sind auch unter Zusätzliche Informationen in der Artikelbeschreibung zu sehen:
upload_2018-6-7_20-56-29.png

Jedoch findet weder im Durchmesser oder in den Farbgruppen eine Aktualisierung statt. 2.85 mm und bei Farbe Gold müsste eine zwei auftauchen. Lösche ist das Gold in JTL-Wawi beim letzten Artikel mit 1,75 mm, dann taucht es unter den zusätzlichen Informationen nicht mehr auf, wird jedoch unter den Farbgruppen nach wie vor mit 1 gekennzeichnet.
upload_2018-6-7_20-57-27.png

Das Übertragen von Attributen ist eines der wichtigsten Funktionen überhaupt. Sonst hat der Connector und JTL-Wawi den Sinn des Ganzen verloren. Das Ganze wird über Widgets und "Produkte nach Attribut filtern" in WooCommerce gelöst.

Über Hilfe freue ich mich sehr.
 
Zuletzt bearbeitet:

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
35
Hallo Mariusz,

Wie du bereits den anderen Posts und der Funktionsübersicht des Connectors entnehmen kannst. Attibute werden aktuell bis einschließlich zur 1.4.12 nicht unterstützt.
Die komsichen pa_***** Attribute sind "PruductAttribute" bzw. eigentlich in der JTL-Welt Specifics/Merkmale. Unter Woocoomerce laufen diese jedoch weiterhin unter Eigenschaften.

In Zukunft wird jedoch das Problem angegangen.

mfg

Jan Weskamp
 

Mariusz

Mitglied
30. Mai 2018
10
1
Hallo Jan. Das Problem an der ganzen Sache ist ja, dass sobald der Connector die Attribute in JTL importiert, entsprechend pa_***** Attribute daraus macht. Anschließend beim Export in WooCommerce sieht es nicht mehr aus wie auf Bild 1, sondern Bild 3. Entsprechend haben die Attribute in WooCommerce kein Bezug mehr, so dass unter den Attributen auch keine Zuordnen mehr bestehen. Ich muss alles raus werfen und die Attribute in WooCommerce neu zuweisen, da die Einspielung des Backups nichts gebracht hat. Entweder werden die Attribute richtig und vollständig oder gar nicht übertragen. Eine halbfertige Lösung bereitet nur mehr Arbeit. Vielleicht ist es auch nur ein Bug.
 
  • Gefällt mir
Reaktionen: buergi-ks

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
346
35
Hallo Jan. Das Problem an der ganzen Sache ist ja, dass sobald der Connector die Attribute in JTL importiert, entsprechend pa_***** Attribute daraus macht. Anschließend beim Export in WooCommerce sieht es nicht mehr aus wie auf Bild 1, sondern Bild 3. Entsprechend haben die Attribute in WooCommerce kein Bezug mehr, so dass unter den Attributen auch keine Zuordnen mehr bestehen. Ich muss alles raus werfen und die Attribute in WooCommerce neu zuweisen, da die Einspielung des Backups nichts gebracht hat. Entweder werden die Attribute richtig und vollständig oder gar nicht übertragen. Eine halbfertige Lösung bereitet nur mehr Arbeit. Vielleicht ist es auch nur ein Bug.

Wie bereits gesagt es wird demnächst angegangen, daher gilt solange das der Connector diese Funktion nicht unterstützt.
Und nein es ist kein Bug.

mfg

Jan W.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Produkte lassen sich aus Woo (mit GermanMarket) nicht mehr nach JTL importieren wenn ein Grundpreis gesetzt ist. WooCommerce-Connector 0
Neu Nach einem Upselling Verkauf wurden nicht alle Produkte in die WaWi übermittelt, ein bekannter Bug? Shopify-Connector 0
Neu 💚 JTL Shop 5 Plugin: Artikelanzeigefilter Plus - Produkte für Kundengruppen nach Standort, Bestand oder Funktionsattribut ausblenden Plugins für JTL-Shop 0
Neu Frei wählbare Produkte im Produkt-Stream Allgemeine Fragen zu JTL-Shop 1
Neu JTL-Connector Sendet Keine Produkte an Shopify ! User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTL WAWI - Statistiken für wenig verkaufte Produkte /Abverkaufsprodukte erstellen Arbeitsabläufe in JTL-Wawi 0
Neu WAWI-62574 - JTL 1.6 Keine Bestellvorschläge für FBA Produkte Arbeitsabläufe in JTL-Wawi 13
Neu Darstellungsprobleme nach Update auf 5.1.4 JTL-Shop - Fehler und Bugs 2
Nach Umstellung auf 1.6 funktioniert der Workflow "Angebote nachhaken" nicht mehr JTL-Wawi 1.6 2
Nummernkreise definieren (Kunden) nach Entfernung von Duplikaten JTL-Wawi 1.6 1
Neu Lizenzproblem bei eigenem Nova Child nach Update auf 5.1.4 JTL-Shop - Fehler und Bugs 0
Neu Icons fehlen nach Entfernung der Suche Templates für JTL-Shop 5
Neu Statistik - Retourenquote nach Artikel sortieren. Geht das? User helfen Usern - Fragen zu JTL-Wawi 0
Beantwortet nach Update von 1.55.5.2 zu 1.6.40.0 kein Scannen des "#Verpacken" mehr möglich JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 2
1.6.40.0 Versand / Suche nach Rechnungsnummer JTL-Wawi 1.6 0
Neu Nach Shop Update (5.1.4) funzt die Theme Kompilierung nicht mehr. JTL-Shop - Fehler und Bugs 3
Neu Nova Startseite doppelt nach Zurücksetzen Templates für JTL-Shop 2
Gelöst linke Seitenliste in Artikelübersicht verschwunden, einstellen nach Update JTL-Shop - Fehler und Bugs 1
Neu PayPal Checkout :: PayPal Express leitet nach Abschluss auf Shopseite weiter mit 500er - Shop ist online Plugins für JTL-Shop 5
Neu Nach Update auf 5.1.4: Modifizierte Datei Installation / Updates von JTL-Shop 3
Neu Nach Hotfix im Shop 5.1.2 - Fehler in Dateistruktur Installation / Updates von JTL-Shop 6
Nach Update Shop4 auf Shop5 keine Neukunden Anmeldung möglich Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Automatischer Mediendatein Versand nach Bestelleingang User helfen Usern - Fragen zu JTL-Wawi 0
Neu Nach Shopupdate auf 5.1.3 Umlautprobleme JTL-Shop - Fehler und Bugs 1
Neu Fehlende Information in Positionstext nach update auf JTL Wawi 1.64 JTL-Wawi 1.6 4
Neu Artikeletiketten per Zebra ZD420 / Nach Warenannahme Druckerwarteschlange blockiert User helfen Usern 0
Neu Mehrwertsteuer nach Versandart anpassen JTL-Wawi 1.6 3
Neu Metapace T3 Bondrucker stellt sich nach 2 Wochen Urlaub tot Fragen rund um LS-POS 3
Neu Workflow startet nicht nach Angebotsimport durch Ameise JTL-Wawi 1.6 2
Neu Versand nach Österreich - Versanddatenexport: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. JTL-ShippingLabels - Fehler und Bugs 2
Issue angelegt Hinzufügen großer Artikelmengen per Touchscreen nach Update nicht mehr möglich [WAWI-62158] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 3
Unterkategorieübertragung geht nicht nach Shopware 6 Shopware-Connector 7
Beantwortet Nach update von JTL Shop4 auf 5.1 Bilder von Vaterartikel werden nicht angezeigt Betrieb / Pflege von JTL-Shop 1
Zahlungsarten abhängig nach Adresse - mit Plugin möglich? Einrichtung JTL-Shop5 1
Neu Kunden nach Umsatz über mehr als ein Jahr User helfen Usern - Fragen zu JTL-Wawi 7
Neu Nach Update auf JTL Woocommerce Connector 1.37.1 Backend extrem langsam für Order-Quickview WooCommerce-Connector 0
Neu 💙 Neues Plugin: Liefergebiete Plus (Artikelansicht nach Postleitzahl) für JTL-Shop 5 Plugins für JTL-Shop 0
Seite nach Registrierung Einrichtung JTL-Shop5 0
Neu JTL Ameise Exportvorlage nach Update fehlerhaft JTL-Ameise - Fehler und Bugs 0
Neu "in den Warenkorb" Meldung nach 5 Sek. schließen Allgemeine Fragen zu JTL-Shop 4
Neu Nach Update Linke Seitenleiste oben statt links JTL-Shop - Fehler und Bugs 1
Neu Bei Sortierung nach Preis aufsteigend werden die Sonderpreise nicht berücksichtigt Allgemeine Fragen zu JTL-Shop 4
Neu Filtern nach eigenem Feld erzeugt Fehler - WAWI 1.6.39.0 JTL-Ameise - Fehler und Bugs 3
Angebot löschen nach Auftragserstellung JTL-Wawi 1.6 2
Neu Bestand Variantenartikel nach Update 0 User helfen Usern - Fragen zu JTL-Wawi 4
Nach Update (Stunden später) keine Unterseiten mehr aufrufbar - nur Startseite Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu JTL Wawi Update fehler nach Serverumzug JTL-Wawi - Fehler und Bugs 3
Neu Nach Update auf 1.6 Artikel offline JTL-Wawi - Fehler und Bugs 4
Nach Update von 1.5 auf 1.6 Versandlabel merkwürdig trotz angepassten Einstellungen in JTL und DHL Geschäftskundenportal JTL-Wawi 1.6 10
Neu Nach Update Abos fällig Abos nicht sichtbar / teilweise beendet / unterschiedliche Ausführungszeiten / etc JTL-Wawi - Fehler und Bugs 1

Ähnliche Themen