Gelöst Produkte nach Attribut filtern mit dem Connector syncen

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

Mariusz

Neues Mitglied
30. Mai 2018
10
1
#1
Hallo zusammen,

WooCommerce Version 3.4.0
Connector Version 1.4.12
WordPress Version 4.9.6
Wawi Version 1.3.17.1

ich habe mir über WooCommerce mühsam benutzerdefinierte Produkteigenschaften eingerichtet. So sah das Ganze dann aus:

upload_2018-6-7_20-51-56.png

Nachfolgend habe ich einen kompletten Import von WooCommerce zu JTL-Wawi angestoßen. Das sah dann folgendermaßen aus:

upload_2018-6-7_20-53-4.png

Nach der Synchronisation sieht dann das Ganze in WooCommerce so aus:
upload_2018-6-7_20-54-15.png

Der JTL-Connector haut mir das kaputt. Ich habe also in JTL-Wawi einige Artikel dubliziert und die Attribute entsprechend angepasst. Z. B. von 1,75mm auf 2,85mm. Diese werden auch in WooCommerce mit den komischen pa_Bezeichnungen übertragen und sind auch unter Zusätzliche Informationen in der Artikelbeschreibung zu sehen:
upload_2018-6-7_20-56-29.png

Jedoch findet weder im Durchmesser oder in den Farbgruppen eine Aktualisierung statt. 2.85 mm und bei Farbe Gold müsste eine zwei auftauchen. Lösche ist das Gold in JTL-Wawi beim letzten Artikel mit 1,75 mm, dann taucht es unter den zusätzlichen Informationen nicht mehr auf, wird jedoch unter den Farbgruppen nach wie vor mit 1 gekennzeichnet.
upload_2018-6-7_20-57-27.png

Das Übertragen von Attributen ist eines der wichtigsten Funktionen überhaupt. Sonst hat der Connector und JTL-Wawi den Sinn des Ganzen verloren. Das Ganze wird über Widgets und "Produkte nach Attribut filtern" in WooCommerce gelöst.

Über Hilfe freue ich mich sehr.
 
Zuletzt bearbeitet:

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
136
8
#3
Hallo Mariusz,

Wie du bereits den anderen Posts und der Funktionsübersicht des Connectors entnehmen kannst. Attibute werden aktuell bis einschließlich zur 1.4.12 nicht unterstützt.
Die komsichen pa_***** Attribute sind "PruductAttribute" bzw. eigentlich in der JTL-Welt Specifics/Merkmale. Unter Woocoomerce laufen diese jedoch weiterhin unter Eigenschaften.

In Zukunft wird jedoch das Problem angegangen.

mfg

Jan Weskamp
 

Mariusz

Neues Mitglied
30. Mai 2018
10
1
#4
Hallo Jan. Das Problem an der ganzen Sache ist ja, dass sobald der Connector die Attribute in JTL importiert, entsprechend pa_***** Attribute daraus macht. Anschließend beim Export in WooCommerce sieht es nicht mehr aus wie auf Bild 1, sondern Bild 3. Entsprechend haben die Attribute in WooCommerce kein Bezug mehr, so dass unter den Attributen auch keine Zuordnen mehr bestehen. Ich muss alles raus werfen und die Attribute in WooCommerce neu zuweisen, da die Einspielung des Backups nichts gebracht hat. Entweder werden die Attribute richtig und vollständig oder gar nicht übertragen. Eine halbfertige Lösung bereitet nur mehr Arbeit. Vielleicht ist es auch nur ein Bug.
 
Zustimmungen: buergi-ks

Jan Weskamp

Moderator
Mitarbeiter
19. August 2015
136
8
#5
Hallo Jan. Das Problem an der ganzen Sache ist ja, dass sobald der Connector die Attribute in JTL importiert, entsprechend pa_***** Attribute daraus macht. Anschließend beim Export in WooCommerce sieht es nicht mehr aus wie auf Bild 1, sondern Bild 3. Entsprechend haben die Attribute in WooCommerce kein Bezug mehr, so dass unter den Attributen auch keine Zuordnen mehr bestehen. Ich muss alles raus werfen und die Attribute in WooCommerce neu zuweisen, da die Einspielung des Backups nichts gebracht hat. Entweder werden die Attribute richtig und vollständig oder gar nicht übertragen. Eine halbfertige Lösung bereitet nur mehr Arbeit. Vielleicht ist es auch nur ein Bug.
Wie bereits gesagt es wird demnächst angegangen, daher gilt solange das der Connector diese Funktion nicht unterstützt.
Und nein es ist kein Bug.

mfg

Jan W.