Neu Produkt ausverkauft, anstatt "ist bereits bestellt, am xx erwartet"

  • Wenn Ihr uns das erste Mal besucht, lest euch bitte zuerst die Foren-Regeln durch.

K3Ks

Gut bekanntes Mitglied
26. März 2008
137
3
#1
Hallo!

Folgende Situation, wenn bei JTL Shop 4, die Produkte ausverkauft sind, ist früher immer erschienen "bereits nachbestellt, am xx erwartet". So seit neuestem bei uns nur mehr "momentan nicht verfügbar".

Welche Settings und welche Gegebenheiten müssen hier passen, sowohl WAWI, Shop und Template, sodass dies angezeigt wird. Gibt ja nicht, dass es von jetzt auf gleich nicht mehr geht?!

Wawi 1.1.3.0.
Shop. 4.04

Hier ist der Artikel um den es geht. Also die Detailansicht. Artikel ist in einer Bestellung, diese in Bearbeitung, man sieht ja auch den Zulauf?!
Am Template dürfte es nicht liegen, da ich gerade das Template auf das Standard-Template (Evo) geändert hatte -> selbes Problem.

Wenn ich Überkäufe ermögliche, dann hab ich natürlich ein "sofort verfügbar" nur eben mit der längeren Lieferzeit (Lieferzeit vom Lieferanten zu uns). Das ist aber auch nicht das, was ich möchte.
Möchte, dass "Produkt bereits bestellt, am 10.10.2049 erwartet" dortsteht. Woran scheitert es?!

Wo finde ich die Settings hierfür im Admin-Backend oder in der Wawi (sofern es hier welche gibt)?

Admin Einstellung:
Hinweis Lieferantenbestandsanzeige: Ja, wenn Überverkäufe möglich


Vielen Dank,
Christian
 

Anhänge

Zuletzt bearbeitet:

Bloomtech

Aktives Mitglied
28. August 2015
3
0
#2
Ich habe das gleiche Phänomän und denke es ist ein Bug, der noch nirgendwo gelistet ist. Den Zeitpunkt seit dem es nicht mehr geht habe ich leider nicht vor Augen.
Gerne würde ich "momentan nicht verfügbar" in "bald wieder verfügbar" oder ganz konktet "Nach dem Umzug wieder verfügbar" ändern. Leider sind alle zu findenden Anleitungen veraltet.( Shop-Admin-Admin-Spracheinstellungen oder in der ger.php) Ich finde weder in der Wawi eine Einstellung, noch im Shop, noch im Template "momentan nicht verfügbar" aus der Artikelübersicht oder "Produkt vergriffen" in den Artikeldetails.

Auch von mir ein Danke für Infos
Thomas
(Wawi 1.1.3.0, Shop 4.0.3, bisherige Suchzeit zu dem Thema: 2-3 Stunden)
 

FPrüfer

Moderator
Mitarbeiter
19. Februar 2016
951
183
Halle
#3
Der Text, der bei ausverkauftem Lagerbestand angezeigt wird, findet sich unter System->Globale Einstellungen->Sprachverwaltung und dort in der Sprachvariable "ampelRot". In der Wawi kann zudem für jeden Artikel ein Atribut "ampel_text_rot" angelegt und dort ein artikelspezifischer Text angegeben werden. (Bitte beachten, dass das Attribut auch für den jeweiligen Shop akiviert ist).
 

igel-max

Sehr aktives Mitglied
3. August 2009
2.623
17
#4
Zitat: Sprachverwaltung und dort in der Sprachvariable "ampelRot

Völlig für die Katz bei Artikel die überverkäufe haben wird das Text einfach Ignoriert? und auch bei roten ampel (eigentlich LKW) steht dann grün Sofort verfügbar (woher das kommt kann aber keine erklären)
 

Mario.

Sehr aktives Mitglied
4. Dezember 2007
1.318
11
#5
K3Ks: Bist du hier schon weiter gekommen?

FPrüfer: Das ändert nur den Text oder kann ich auch Variablen einsetzen?
 

K3Ks

Gut bekanntes Mitglied
26. März 2008
137
3
#6
Support meinte es liegt an der Einstellung:
JTL- WAWI --> Admin->Globale Einstellungen->Artikel müssten Sie die Checkbox "Zulauf im Shop aktualisieren" aktivieren

Habe ich gemacht, leider kein Erfolg. :(
 

K3Ks

Gut bekanntes Mitglied
26. März 2008
137
3
#9
So, der Support hat noch mehrmaligen Teamviewer nun den Fehler gefunden -> es gab keinen.
Grund: Internet Explorer Cache. Die DB Verbindung wird immer per IE aufgebaut, und wenn hier ein falsches Datum gecached ist, kann es scheinbar zu dem Fehler kommen.
Wie sind wir drauf gekommen? Wir haben das Update direkt am Server gemacht und nicht auf der normalen Workstation.
 

stocksen

Aktives Mitglied
17. Mai 2015
48
3
#10
Das heißt nun funktioniert es immer korrekt? Ich habe habe es selbst mit neuen Artikeln probiert, dort kann noch nichts gecached sein und es funktioniert nicht.
In der Wawi ist der Haken bei bei "Zulauf im Shop aktualisieren" gesetzt... Artikel sind trotzdem "ausverkauft" obwohl Zulauf in der Wawi korrekt angezeigt wird.
Muss im Shop zusätzlich etwas aktiviert werden?
Wawi 1.1.3.0 Shop 4.04
 

mmarsching

Aktives Mitglied
2. September 2014
61
1
#11
Ich fleddere mal diese Leiche hier. Selbes Problem. Wawi 1.4.20.2, Shop 4.06 (Build: 11).

Gibt es IRGENDEINE Lösung?