Neu Probleme mit Varianteneigenschaften bei Hauptartikel

towo

Aktives Mitglied
15. April 2019
49
13
Hi

ich habe momentan das Problem, dass von Variantenartikel die Varianteneigenschaften nicht korrekt dem Hauptartikel zugeordnet werden.

Es wird sowohl die Varkombi-Gruppe als auch der Wert im Woocommerce angelegt und auch die Varianten erstellt.
Allerding ist beim "Hauptartikel" im Reiter Eigenschaften nur die Gruppe (also z.B. Größe) angelegt und aber nicht z.b. L, XL etc oder nur teilweise z.B. 2 von 4.


Somit steht im Backend bei der Variante als Wert "irgendwelche Größe". Im Frontend kann ich im Dropdown dann auch nichts wählen.
Wenn ich bei Eigenschaften die für den Artikel gültigen Werte eintrage, erscheinen sie auch direkt bei den Varianten korrekt und ich kann dies auch im Frontend wählen.

Kennt jemand das Problem und kann mir hier helfen?

Ich nutze
Woocommerce 3.7.0
JTL-Connector 1.8.2
JTL Wawi 1.5.13
 
Zuletzt bearbeitet:

alexandraciolea

Aktives Mitglied
28. September 2017
53
9
Genau dieses Problem habe ich auch.

Aber nur bei wenigen Artikeln.

Ach übrigens, update bloß nicht auf die 1.8.4. Die hat uns alle Varkombi Artikel zerschossen.
 

towo

Aktives Mitglied
15. April 2019
49
13
also bei mir war das problem, dass die verknüpfung in term_relationships nicht eingetrgen wurde.
im Haupt-Produkt selber steht es in den postmeta im meta_key "_product_attributes"

Habe mir ein Script geschrieben, welches die varianteneigenschaft von dort zieht und prüft, ob der value in der relationship-Tabelle ist und ggf. ergänzt.
dann funktioniert zumindest der shop erstmal wieder.

der Connector sollte natürlich trotzdem sauber arbeiten. Was er hier definitiv nicht macht.
 

KEEPSEVEN

Mitglied
13. Dezember 2019
69
5
Ich kenne keine Lösung. Ich würde das Thema auch ungern per Script oder ähnliches lösen und die "Standardlösung" von JTL bevorzugen. Ein Hotfix wäre echt klasse!
Da die Artikel, sobald sie auf "irgendwelche Farbe/Größe o.ä. gesetzt werden, nicht mehr im Shop erscheinen. :/
 
  • Gefällt mir
Reaktionen: alexandraciolea

Immanuel

Gesperrter Benutzer
24. August 2016
1.542
323
Hallo @towo,

wir versuchen den Umstand deines Problems nachzuvollziehen. Kannst du Schritt für Schritt erklären was nicht funktioniert und wie es funktionieren sollte? Könntest du uns zudem das Script schicken?
 

towo

Aktives Mitglied
15. April 2019
49
13
hier der script schnipsel, mit dem ich meine artikel zumindest wieder so machen konnte, dass ich sie bestellen kann. führte zum teil dazu, dass im Hauptartikel in einer Varianteneigenschaft auch Werte stehen, die nicht mehr genutzt werden. Aber eine Bereinigung wollte ich nicht auch noch machen. Aber man erkennt zumindest wo das Problem des connectors zu liegen scheint. Und wie in einigen Beiträgen hier im Forum geschrieben scheint dies ja bisher nicht gelöst zu sein
 

Anhänge

  • script_schnipsel.rtf.zip
    1,5 KB · Aufrufe: 3
Ähnliche Themen
Titel Forum Antworten Datum
Neu Shopware 6 Connector Probleme beim Abgleich der Bestellungen mit Klarna Shopware-Connector 0
Neu Probleme mit DHL Warenpost JTL-ShippingLabels - Fehler und Bugs 3
Neu Probleme mit der Pickliste User helfen Usern - Fragen zu JTL-Wawi 0
Neu Shopware 6 mit Custom Products - Probleme bei Auftragsimport Shopware-Connector 18
Neu JTL Rechnung werden nicht mehr bei amazon hochgeladen / Probleme mit OSS Amazon-Anbindung - Fehler und Bugs 1
In Bearbeitung Probleme mit Druck über JTL-Wawi (hier Gutscheine) JTL-POS - Fehler und Bugs 6
Neu Probleme mit Telekom Mails Betrieb / Pflege von JTL-Shop 4
Neu Und wieder mal Probleme mit Artikelbildern... Wer kann helfen? JTL-Wawi - Fehler und Bugs 0
In Bearbeitung Chromebox: Probleme mit Autofill bei Eingabefeldern JTL-POS - Fragen zu Hardware 6
Neu Verbindung Shop 5.1 mit WAWI hat bei Umlauten Probleme JTL-Wawi - Fehler und Bugs 1
Neu Probleme mit den Einstellungen die der Connector vornimmt (Preise) WooCommerce-Connector 1
Neu ebay Probleme mit EA Server heute? eBay-Anbindung - Fehler und Bugs 5
Neu Probleme mit Zahlungsart Klarna Sofortüberweisung Gambio-Connector 1
Neu Probleme mit Facebook Katalog Plugins für JTL-Shop 0
Offen GLS Probleme JTL-ShippingLabels - Fehler und Bugs 19
Neu Unicorn2 einrichten - welcher Aufwand steckt wirklich dahinter und gibt es ggf. Probleme? Schnittstellen Import / Export 3
Neu JTL Vouchers und seine (hoffentlich anfänglichen) Probleme Plugins für JTL-Shop 2
Neu Probleme beim importieren von Aufträgen JTL-Ameise - Fehler und Bugs 2
Neu Probleme ecoDMS (burns) 21.06 - Suche funktioniert nach gewisser Zeit nicht mehr User helfen Usern 1
In Bearbeitung Probleme Terminal zu POS JTL-POS - Fragen zu Hardware 2
Neu Probleme beim Anpassen der Facebook Export CSV Plugins für JTL-Shop 2
JTL Shop Sitemap Probleme Allgemeiner HTTP Fehler bei Google Einrichtung JTL-Shop5 20
Neu Probleme bei der Übernahme von Amazon-Bestellungen (31.08.2021) Amazon-Anbindung - Fehler und Bugs 41
Fatal Error mit Nova-Template Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Video mit schema.org wird nicht responsive Allgemeine Fragen zu JTL-Shop 0
Neu JTL Ameise Rechnungsexport mit UTF-8 Encoding JTL-Ameise - Ideen, Lob und Kritik 0
Neu Versand mit Hermes und anderen Dienstleistern - Sortierung per Workflow? JTL-Workflows - Fehler und Bugs 2
Neu Das MHD/Chargen/Seriennummern-Modul ist nicht aktiviert. Daher können Sie keine Artikel mit Seriennummer einlagern. JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 2
Neu Verwirrung mit Logins Installation von JTL-Wawi 3
Neu Nach einer Inventurdifferenzbuchung automatisiert einen Workflow mit Versandart Änderung auf Express laufen lassen JTL-Workflows - Ideen, Lob und Kritik 0
Neu OPC: Nicht durchdachte Zusammenarbeit mit Wawi Allgemeine Fragen zu JTL-Shop 0
Neu 4.06 Bestellungen im Kundenkonto mit falscher Adresse JTL-Shop - Fehler und Bugs 2
Beantwortet Versand mit UPS (API) funktioniert nicht JTL-ShippingLabels - Fehler und Bugs 1
Neu SQL Abfrage ob WMS Box mit allen Artikeln des Auftrags gefüllt ist Individuelle Listenansichten in der JTL-Wawi 0
Neu Altersabfrage für Artikel mit Altersbeschränkung Allgemeine Fragen zu JTL-Shop 0
Gelöst SWISS TSE Stick auf PC mit Android Gelöste Themen in diesem Bereich 3
Neu Kundenpreisliste mit individuelle Preise Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu JTL auf virtuellen Server installiert, es soll dann auf mehreren Rechner die mit dem Server verbunden sind genutzt werden. Individuelle Listenansichten in der JTL-Wawi 4
Neu Problem mit Fstr() beim Formatieren des Einzelstückpreises User helfen Usern - Fragen zu JTL-Wawi 1
Neu Gewinnermittlung mit EK - VK pro Auftrag Arbeitsabläufe in JTL-Wawi 5
Neu Farbe von Aufträgen mit der Ameise ändern. JTL-Ameise - Ideen, Lob und Kritik 1
Neu script für sqlcmd mit WAWi-Workflow User helfen Usern - Fragen zu JTL-Wawi 0
Neu Keine Verbindung zum Lizenzserver möglich. Kein Datenabgleich mit dem Shop !! JTL-Wawi - Fehler und Bugs 18
Neu Haken bei "Dieser Artikel ist ein Stücklistenartikel" mit der Ameise entfernen JTL-Ameise - Fehler und Bugs 3
Neu Internetmarke mit Matrixcode, wird nicht an Amazon übermittelt JTL-ShippingLabels - Ideen, Lob und Kritik 3
Neu Umzug von Server 2012R2 mit SQL-Server 2012 auf Server 2019 mit SQL-Server 2017 Fehler Collation Installation von JTL-Wawi 1
Neu Wawi 1.6 Freipositionen mit Menge 0 werden nicht mehr in der Rechnung ausgegeben JTL-Wawi - Fehler und Bugs 0
Neu Speditionsversand mit Zuschläge usw. & JTL Shop Allgemeine Fragen zu JTL-Shop 2
Neu Google Crawler mit Jugendschutz Betrieb / Pflege von JTL-Shop 1
Neu Synchronisation mit WebShop nicht möglich! Einrichtung JTL-Shop5 4

Ähnliche Themen