Neu Problem: Sysgrade ecommerce Integrator - Magento 2.4 API-Verbindung Einstellungen

mort

Mitglied
20. März 2021
5
2
Moin moin,

und ein freundliches Hallo! Bin neu hier im Universum, aber ich frage gleich mal ganz konkret. :)
Ich möchte über den Sysgrade E-Commerce Integrator meinen Magento 2.4 Shop anbinden. In der Doku finde ich dazu folgenden Absatz:
JTL: 1.5.41.3, Magento 2.4.1, ecommerce Integrator Build 5388, Version 2020.9.0)

API-Verbindung
Vervollständige nun die Informationen zur Verbindung mit der eCI-API des Webshops:

  • Shop-Adresse. Die Adresse, unter der dein Webshop erreichbar ist, also beispielsweise http://www.beispiel.de (die Angabe benötigt zwingend das Präfix http:// oder https:// an dieser Stelle). Bitte beachte, dass die Verwendung von https:// abhängig von deiner Serverkonfiguration ggf. nicht möglich ist; kontaktiere in diesem Fall bitte deinen Serveradministrator.
  • Api-Benutzer. Der Name des Benutzers zum Zugriff auf die API des Shops. Dieser Benutzer ist in den eCI Shopmodul-Einstellungen unter REST API → Nutzername zu finden und konfigurierbar.
  • Api-Schlüssel. Der Schlüssel wurde bei der Installation des eCI-Moduls in Ihrem Shop erzeugt und kann im Shop eingesehen werden. Dieser findet sich in Ihrem Magento-Backend unter dem Menüpunkt REST API → API Schlüssel

Sysgrade hat bei der Plugin Installation im Magento einen normalen User angelegt, der eine eigene Rolle hat.
1616254290905.png

Laut Beschreibung sollte mit Plugin Installation ein API User angelegt worden sein, war aber nicht.

Also habe ich selbst einen erstellt:
1616254387419.png

Dieser hat von mir auch erst einmal alle API Rechte bekommen.
Nun versuche ich, mit diesen Daten eine Verbbindung herzustellen (reale Daten mal unkenntlich gemacht).

1616254804962.png

Hat das jemand zum laufen bekommen?
Hab es mit den verschieden Usern (der angelegte Systemunser und meinem API User probiert), mit dem Access Token und auch dem User Key des generierten Magento API Users.
Egal wie - "Verbindung konnte nicht hergestellt werden"

Vielen Dank, Martin
 

Anhänge

  • 1616254621652.png
    1616254621652.png
    995,7 KB · Aufrufe: 4
Ähnliche Themen
Titel Forum Antworten Datum
Verwiesen an Support JTL Shipping - DHL Versenden 3.0 - Problem JTL-ShippingLabels - Fehler und Bugs 7
Neu Problem bei Paypal Später Zahlen über Warenkorbbutton Plugins für JTL-Shop 2
Neu Problem mit dem WooCommerce Abgleich nach Update auf 1.6.44.0 WooCommerce-Connector 0
Problem: Auftrag und Rechnung ändern geht nicht bzw. vice versa - Meldung: "Betrag Auftrag Rechnung stimmt nicht überein" JTL-Wawi 1.6 3
Neu Problem mit Auflösung in der Wawi Arbeitsabläufe in JTL-Wawi 9
Neu Routing Problem JTL-Shop - Fehler und Bugs 2
Neu Problem mit Sternebewertung Allgemeine Fragen zu JTL-Shop 2
Stücklisten Problem oder Denkfehler JTL-Wawi 1.6 3
Neu Child-Theme Megamenü Problem Allgemeine Fragen zu JTL-Shop 0
Neu jQuery-Problem nach Server-Wechsel Installation / Updates von JTL-Shop 0
Neu Hersteller Sprachshop Problem Shopware 5 Shopware-Connector 1
Neu Ein Problem in der Buchhaltung - vielleicht wisst ihr wie es geht User helfen Usern - Fragen zu JTL-Wawi 1
Neu Kopieren & Einfügen von Artikelstammdaten (Problem bei Beschreibung->Artikelname in Englisch) JTL-Wawi - Fehler und Bugs 1
Neu Problem Email Bewertungserinnerung nach Artikelkauf Allgemeine Fragen zu JTL-Shop 0
Nach Update auch 1.6 Problem mit Export-Ameise JTL-Wawi 1.6 2
Neu Rechnung & Lagerbestand Problem User helfen Usern - Fragen zu JTL-Wawi 0
Neu Sind Artikelsticker (Labels) ein SEO-Problem? Allgemeine Fragen zu JTL-Shop 1
Neu Problem mobile Ansicht erstes Bild Allgemeine Fragen zu JTL-Shop 0
Neu Abgleich Problem bei Ameise mit JTL 1.5.49.0 und Shopware Shop 5.3.7 Shopware-Connector 2
Neu Problem bei Artikelimport nach Update auf JTL-WAWI 1.6 User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen