Offen Problem mit Sortierung Artikelmerkmale

dragonfly27

Aktives Mitglied
8. Januar 2007
40
0
Hallo zusammen,

Für jedes Produkt mit Artikelmerkmalen wird in Shopware ein eigenes Produkt Eigenschaft Set angelegt, mit der Sortierung Alphabetisch. Die Artikelmerkmale sollen in Shopware genau so angezeigt werden wie wir Sie in der Wawi beim Artikel angelegt haben (Position).

Ich habe in der Wawi keine Einstellung dafür gefunden! Gibt es überhaupt dafür eine Einstellmöglichkeit oder muß der Connector dafür erweitert werden durch ein Plugin?


Ich versuche es mit ein paar Screenhots das Problem besser zu erkläre.

Aufbau der Merkmale beim Artikel in der Wawi:

http://pixmedien.com/kunden/img/Merkmale-beim-Artikel-Wawi.jpg

Die Abbildung oben zeigt den Aufbau der Artikelmerkmale in der richtigen Reihenfolge.

Im Backend von SW sieht die Reihenfolge der Artikelmerkmale anderes aus:

http://pixmedien.com/kunden/img/Abb-SW-Backend.jpg

Im Shop Frontend ist die Reihenfolge wiederum anders:

http://pixmedien.com/kunden/img/Ansicht-Eigenschaften-Shop-frontend.jpg

Die Artikelmerkmale werden nach meiner Meinung wahllos sortiert und angezeigt.
Sie sollen so in der Reihenfolge angezeigt werden, wie Sie in der Wawi beim Produkt angelegt worden sind.

Gibt es eine Lösung für dieses Problem?

Wawi Version: 1.0.11.8.
Connector Version: 1.4.8.
Shopware Version: 5.1.6.


Gruß
Markus
 
Zuletzt von einem Moderator bearbeitet:

spreemedianet

Aktives Mitglied
14. September 2016
21
0
Hi, soweit ich mich gerade aus dem Stehgreif erinnere, kann man die Eigenschaften im SW Backend per Drag&Drop sortieren, das ist natürlich etwas umständlich, wenn man wahnsinnig viele Eigenschaften hat, aber wenn es nur 10 sind, würde ich das ggf. empfehlen. :)
 

dragonfly27

Aktives Mitglied
8. Januar 2007
40
0
Hallo spreemedianet,

ja klar kann man es so machen. Wir haben ca. 2000 Artikel mit Artikel Eigenschaften und jedes mal sich bei SW Anmelden und die Sortierung händisch durchzuführen ist zu viel Arbeit, da ja für jeden Artikel ein eigenes Set angelegt beim Abgleich Wawi SW.
 

spreemedianet

Aktives Mitglied
14. September 2016
21
0
ah ok .. wenn je ein eigenes Set angelegt ist .. ist das eher nicht der Lösungsweg .. :) .. da muss ich leider ad hoc passen .. habt ihr spaßeshalber mal in JTL umsortiert und geschaut, ob das in SW auch umsortiert ankommt?
oder gibt es irgendwelche Gemeinsamkeiten in den Sets? dann könnte man abschließend die SQL Tabelle exportieren und di IDs entsprechend setzen, ist aber auch eher ein Weg für einmalig .. ..
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Hier wird die falsche Speicherungsart der Sortierung vom Connector gewählt, das ist mir letzte Woche auch aufgefallen. Hier sollte von JTL dringend bei abspeichern der Artikel Eigenschaften-Sets von "Alphabetisch" auf "Position" gewechselt werden, da die Sortierung bereits in der WAWI stattfindet und nicht nachträglich in SW.
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Hab mir das nun nochmals genauer angeschaut, es gibt ja eine Option in der WAWI wo man din der Merkmalverwaltung unter "Darstellung" eine Checkbox hat "Werte alphabetisch sortieren" wählen kann. Dies wird nur vom Connector völlig ignoriert und immer alphabetisch sortiert egal ob die checkbox selektiert ist oder nicht. Scheint also ein Bug bzw. nie implementiert worden zu sein.

Mein Vorschlag, wenn nicht "Werte alphabetisch sortieren" aktiviert ist, sollte immer "Position" in Shopware gespeichert werden! Ich werde hierzu ein Ticket aufmachen.
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Bei genauerer Betrachtung macht das Speichern / Haken setzten als " Werte alphabetisch sortieren" bei den Eigenschaften-Sets gar keinen Sinn, da es sich bei Shopware ja um Sets handelt die so in der WAWI nicht existieren (Artikeln zugeordnet werden können), daher ist hier ein generelles Speichern als "Position" die einzig richtig Lösung. Wie erwähnt findet die Sortierung ja bereits in der WAWI statt und nicht in Shopware.

Kontakt zum Support läuft.
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Bei weiteren Tests fällt auf, das wenn man die Sortierung der Sets händisch ändert und dann wieder einen Komplettabgleich macht bleiben die veränderten Werte "Position" erhalten. Scheint also so als ob hier der Connector gar nichts macht, bzw. das vergessen worden ist zu implementieren.
 

dragonfly27

Aktives Mitglied
8. Januar 2007
40
0
Mir ist auch aufgefallen, das es nicht ausreicht das Artikel Eigenbschaft-Set die Sortierung von alphabetisch auf Postion in SW umzustellen!
Die Sortierung der zugeordneten Gruppen wird im Fronted des Shops immer noch nicht so angezeigt wie sie im Backend bei SW angezeigt werden, man muß händisch in SW die zugeordneten Gruppen des jeweiligen Set sortieren.

3po gibt es schon eine Antwort vom Support?
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Nach ein paar Mails und einer längeren Teamviewer Sitzung kann ich leider nur berichten, das der Support das anderst sieht und alles so bleibt wie gehabt. Sprich es werden nur Kunden bedient, die Ihre Merkmale in den Filtern alphabetisch sortiert haben möchten, Kunden wie ich bspw. die nunmal auch Textilien verkaufen bei denen es Größenangaben gibt (XS ,S ,M, L, XL, 2XL, 3XL) die NICHT alphabetisch sind sollen sich doch an Servicepartner wenden und hier selber klar kommen. Das eine Änderung auf Position alle zufriedenstellen würde, sowohl alphabetisch als auch nicht alphabetische sortiert, da die Sortierung ja bereits in der WAWI stattfindet, drang leider nicht durch.

Argument war, da sie hier ja gar nichts speichern ändern sie auch nichts?
 

dragonfly27

Aktives Mitglied
8. Januar 2007
40
0
Danke 3po für die Informationen und deine Bemühungen!
Da müß ich wohl ein Servicepartner kontaktieren, ob man über eine Connector Anpassung das Problem lösen kann!
 

dragonfly27

Aktives Mitglied
8. Januar 2007
40
0
Bitte halte mich auf dem Laufenden 3po.

Das lasse ich gerade von einem Servicepartner prüfen und ein Angebot erstellen. Das Plugin soll lediglich alle übertragene Sets als Sortierung "Position" abspeichern.

Für unsere Zwecke wird das nicht reichen, da die Reihenfolge der zugeordneten Gruppen im Set selber auch nicht stimmt, siehe Screenshot SW Backend und SW Frontend!

Meine weiteren Test haben folgendes ergeben:
Die Reihenfolge der Gruppen in einem Set wird in der SW DB in der Tabelle s_filter_relations gespeichert, dort steht bei der Spalte position der Wert 0 .
Sortiert man nun händisch in SW bei einem Set die Reihenfolge der zugeordneten Gruppen fählt auf, das in der genannten SW DB Tabelle in Spalte postion auch andere Werte 1, 2, 3 usw. zu sehen sind.
Nun stimmt auch die Reihenfolge der zugeordneten Gruppen vom SW Backend und SW Frontend.

Der Connector müsste hierfür auch noch erweitert werden.
 

tiroled

Gut bekanntes Mitglied
27. Dezember 2015
211
22
Wir haben auch das gleiche Problem.
Unser Workaround: mit Präfix arbeiten.
Einfach eine 3-stellige Zahl vorne hinzufügen und schon werden alle Merkmale schön sortiert.
 

3po

Sehr aktives Mitglied
30. August 2011
2.555
85
Jooo, das ist mir zu viel gebastel, da musst Du überall im Shop darauf achten wo die Merkmale/Eigenschaften ausgegeben werden und das Template anpassen. (Listing Filter, Detailseite, Vergleichsseite, Warenkorb, ...) Dann doch lieber ein Connector Plugin.

Alternativ ist es auch einfacher, ein sql script alle paar min per cron anzuschmeißen und die Tabelle zu überprüfen und Werte zu ersetzen.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Händler Authorisierung klappt irgendwie nicht Problem mit einer Dauerschleife Amazon-Anbindung - Fehler und Bugs 0
Neu Mehrsprachlichkeit im Shop - Problem mit Multi-Domain Plugin von [tech]Neo Plugins für JTL-Shop 1
Neu Problem mit Versandetikett bei DHL Versenden 3.0 JTL-Wawi - Fehler und Bugs 3
Neu Kurioses Problem bei Artikeln mit Freitext Variationen Allgemeine Fragen zu JTL-Shop 1
Beantwortet Problem mit Teilversand und nicht mehr lieferbar Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 3
Neu Problem mit 1.5.47.0 JTL-Wawi - Fehler und Bugs 7
Neu Problem mit Waage CAS ER Junior User helfen Usern 0
Neu Konfigurator Problem Plugins für JTL-Shop 0
Neu JTL WAWI Umstellung | Problem beim erstellen von Amazon Prime durch Verkäufer Versandlabels Amazon-Anbindung - Fehler und Bugs 0
Neu Track & Trace Problem in der WaWi - keine gültige Lizenz User helfen Usern - Fragen zu JTL-Wawi 1
Neu PayPal IPN Problem Plugins für JTL-Shop 0
Neu Problem bei der Installation siehe Anhang Installation von JTL-Wawi 2
Neu Dropshipping Problem Arbeitsabläufe in JTL-Wawi 5
MegaMenü Problem ? Einrichtung JTL-Shop5 3
Neu Rechnungsdruck Steuerfreie innergemeinschaftliche Lieferung - Problem User helfen Usern - Fragen zu JTL-Wawi 0
Neu mal wieder ein seltsames Problem Shopware-Connector 1
Neu Problem beim Shopware Abgleich/Artikel werden nicht übertragen Shopware-Connector 0
Neu Problem beim Komplettabgleich User helfen Usern - Fragen zu JTL-Wawi 0
Neu Problem beim Hochladen von Varianten Shopware-Connector 1
In Bearbeitung Problem Bondrucker TM-T20III per USB JTL-POS - Fragen zu Hardware 2
Neu Der Artikel besitzt nicht die korrekte Anzahl von Variationen - Amazon Lister Problem Amazon-Lister - Fehler und Bugs 49
Neu Problem bei der Preisanzeige User helfen Usern - Fragen zu JTL-Wawi 1
Neu Probleme mit Telekom Mails Betrieb / Pflege von JTL-Shop 3
Neu Fehler im Logbuch + häufiger Shopabsturz mit 503-Fehler JTL-Shop - Fehler und Bugs 2
Neu On Page Composer Grid Layout mit 5 Spalten möglich? Betrieb / Pflege von JTL-Shop 2
Beantwortet Bestellvorschläge Bedarf kalkulieren mit Fullfillment Lager + Eigenem Lager Arbeitsabläufe in JTL-Wawi 1
Neu Und wieder mal Probleme mit Artikelbildern... Wer kann helfen? JTL-Wawi - Fehler und Bugs 0
Neu ein Artikel mit mehreren Versandklassen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Installation bzw. Update JTL-Wawi mit AWS RDS Installation von JTL-Wawi 0
In Bearbeitung Lastschriftverfahren mit JTL-POS Allgemeine Fragen zu JTL-POS 1
Neu JTL-Ameise CLI Verbindung zur Datenbank mit Powershell User helfen Usern - Fragen zu JTL-Wawi 0
Neu Bestandsabgleich mit Händler beide mit JTL Arbeitsabläufe in JTL-Wawi 1
Neu Servicedesk stürzt sofort ab - die insert-anweisung steht in konflikt mit der foreign key-einschränkung... JTL-Wawi - Fehler und Bugs 2
Neu Vorlagen mit Editor anpassen - Tutorial? User helfen Usern - Fragen zu JTL-Wawi 2
Neu eBay Angebote mit Variation Exportieren und Importieren JTL-Ameise - Fehler und Bugs 1
Neu Child Template HTML Code mit CSS Dateien anzeigen lassen Templates für JTL-Shop 3
Neu Mobile App startet nicht mit der 1.5.50.0 JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Zubehör direkt mit in den Warenkorb Plugins für JTL-Shop 1
Neu WMS App mit Ecomdata Installation von JTL-WMS / JTL-Packtisch+ 0
OnPage Composer mit Safari Einrichtung JTL-Shop5 0
Neu Ebay Titel/Beschreibung mit der Ameise eBay-Anbindung - Ideen, Lob und Kritik 0
Neu Warengruppe ausgeben mit Workflow - Rechnungen User helfen Usern - Fragen zu JTL-Wawi 2
Neu Auftragsimport XML mit Vorlage schlägt fehl JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Chromebox: Probleme mit Autofill bei Eingabefeldern JTL-POS - Fragen zu Hardware 2
Neu url Pfad mit Worflow erstellen in Kleinbuchstaben User helfen Usern - Fragen zu JTL-Wawi 9
Neu fehlende Amazon Rechnungen in JTL manuell anlegen mit Verknüpfung zu JTL2Datev Dienstleistung, Jobs und Ähnliches 0
Neu Retoure anlegen immer mit Häkchen bei Versandkosten setzen & Bestand Buchen deaktivieren - möglich? User helfen Usern - Fragen zu JTL-Wawi 0
Neu Verbindung Shop 5.1 mit WAWI hat bei Umlauten Probleme JTL-Wawi - Fehler und Bugs 1
Beantwortet Amazon Bestellung von Österreicher mit UST ID wird in Rechnung mit 20% erstellt Amazon-Anbindung - Fehler und Bugs 2
Neu Leistungsdatum statt Lieferdatum, mit Monat und Jahr Individuelle Listenansichten in der JTL-Wawi 0

Ähnliche Themen