Neu NOVA Template Weiß nach Update 4.06 => 5

MaxWe

Sehr aktives Mitglied
6. August 2018
301
39
Hamburg
Moin,

nach einem erfolgreichen und fehlerlosen Update unseres geklonten Originalshops, habe ich nun Probleme mit dem NOVA Template.
Daten wurden alle via FTP Binär übertragen.

Leider zeigt das NOVA Template nur eine weiße Seite und gibt nach dem Einschalten der Error Ausgabe folgende Ausgabe:
Fatal error: Uncaught Error: Call to undefined method stdClass::getIso639() in .../templates_c/NOVA/b0804d94ddc5f9c2a6e47d1cbd0d0f1f89a513f1_0.file.header.tpl.php:648 Stack trace: #0 ...e/includes/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_inheritance.php(248): Block_406021163615efe4d4592e7_24280317->callBlock() #1 .../includes/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_inheritance.php(184): Smarty_Internal_Runtime_Inheritance->callBlock() #2 .../includes/vendor/smarty/smarty/libs/sysplugins/smarty_internal_runtime_inheritance.php(156): Smarty_Internal_Runtime_Inheritance->process() #3 .../templates_c/NOVA/b0804d94ddc5f9c2a6e47d1cbd0d0f1f89a513f1_0.file.header.tpl.php(1593): Smarty_Internal_Runtime_Inheritance->instanceBlock() #4 /var/www/vhosts/elbeffekt.de/dev.elbeffekt.de/includ in
.../templates_c/NOVA/b0804d94ddc5f9c2a6e47d1cbd0d0f1f89a513f1_0.file.header.tpl.php on line 648
Domainpfad wurde durch ... ersetzt.

Hat da jemand einen Tipp? Scheinbar ist das NOVA Template beschädigt oder Smarty wurde nicht korrekt geupdatet?
template_c habe ich bereits geleert, ohne Erfolg.

Beste Grüße,
Max
 

MaxWe

Sehr aktives Mitglied
6. August 2018
301
39
Hamburg
Ich konnte den Fehler aushebeln indem ich in der header.tpl vom NOVA Template die Funktion erstmal einfach durch "DE" ersetzt habe. Allerdings ist das sicherlich nicht die Lösung.

Weiterhin sind mir folgende Logeinträge aufgefallen
07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list
Hinweis 07.10.2021 - 14:38:46
Error executing query: INSERT INTO tlinksprache (`kLink`, `cName`, `cTitle`, `cMetaTitle`, `cContent`, `kSprache`, `cISOSprache`, `cSeo`) VALUES :)kLink, :cName, :cTitle, :cMetaTitle, :cContent, :kSprache, :cISOSprache, :cSeo)
SQLSTATE[42S22]: Column not found: 1054 Unknown column kSprache in field list

Wie gesagt, beim Update wurden keinerlei Fehler angezeigt und auch im Anschluss nicht. Alles wie im Guide beschrieben.
 

csaeum

Sehr aktives Mitglied
23. Juli 2011
1.264
130
Küps
Die Templates_c Ordner komplett leeren.

Hast du dein altes EVO Template komplett im NOVA nachgebaut oder einfach in der Template.xml das EVO durch NOVA getauscht?
 

MaxWe

Sehr aktives Mitglied
6. August 2018
301
39
Hamburg
Moin,
den template_c Ordner habe ich wie geschrieben bereits ohne Erfolg geleert.

In den Templates des geupdateten Shops habe ich noch garnicht gefuscht. Lediglich im Shop Backend auf das NOVA Template geswitcht.
 

MaxWe

Sehr aktives Mitglied
6. August 2018
301
39
Hamburg
Also nach Stand jetzt habe ich folgende Codezeile in der header.tpl geändert, womit ich den Fehler scheinbar gelöst habe. Ich weiß nicht wieso kein anderer den Fehler hat..
Ab Zeile 196 in \NOVA\layout\header.tpl
Code:
{* Languages *}
{* ALT *}{if !empty($smarty.session.Sprachen) && count($smarty.session.Sprachen) > 1}
{* NEU *}{if !empty($smarty.session.Sprachen) && $smarty.session.Sprachen|@count > 1}
{foreach $smarty.session.Sprachen as $language}
<link rel="alternate"
hreflang="{$language->getIso639()}"
href="{if $language->getShopDefault() === 'Y' && isset($Link) && $Link->getLinkType() === $smarty.const.LINKTYP_STARTSEITE}{$ShopURL}/{else}{$language->getUrl()}{/if}">
{/foreach}
{/if}
Das System muss gedacht haben, dass ich mehr als eine Sprache aktiv habe und versucht haben in einer leeren Variable die function aufzurufen, daher auch der Aufruf der StdClass. Möglicherweise entsteht der Fehler auch dadurch, wenn nach dem Update des Shops keine Sprache in der Session liegt und somit die StdClass aufgerufen wird?

Grüße
 

bbfdesign

Offizieller Servicepartner
SPBanner
28. September 2013
190
20
Sprachprobleme gibt’s mit dem Shop. Hatte ich letzte Woche großen Stress bei einem Kunden von mir mit drei Top Level Domänen.
 

MaxWe

Sehr aktives Mitglied
6. August 2018
301
39
Hamburg
Also ich habe aktuell auf meinem Testsystem den gleichen Fehler. Das Evo läuft halbwegs, das Nova nicht.
Versuch mal in der header.tpl vom NOVA Template (\NOVA\layout\header.tpl) die beiden {$language->getIso639()} durch DE zu ersetzen. Das ganz hochladen und einmal in den Shop rein. Wenns klappt, dann wieder die Änderung zurück und es sollte gehen. Wenn nicht versuch auch nochmal meinen letzten Ansatz, bei uns funktionierts nun ohne Probleme.

Ich denke es liegt daran, dass bei Testshops noch keinerlei Sessions/Cookies existieren und so der Shop den Wert nicht auslesen kann. Nachdem man dann einmal händisch die Variable gesetzt hat existiert eine Session und der Shop weiß bescheid. So irgendwie für mich die Erklärung
 

Loads

Gut bekanntes Mitglied
26. Februar 2013
499
8
Ich habe den gleichen Fehler wie oben beschrieben. Habe auch schon versucht das {$language->getIso639()} durch DE zu ersetzen aber kein Erfolg gehabt.
Bei mir ist das auch nur einmal in der header.tpl drin und nicht zweimal wie geschrieben.
 

webksde

Aktives Mitglied
30. August 2012
46
4
32457 Porta Westfalica
Nachdem wir uns nun beim Xten Shop Upgrade auf JTL-Shop5 darüber ärgern mussten und ich diverse Lösungen versucht habe, nun die aus meiner Sicht einzig richtige Lösung, denn für Gäste läuft auch NOVA sofort. Das Problem hat nur der Admin-User und auch ein Ausloggen oder Wechsel der Sprache im Admin-Bereich bringt nichts!

Lösung:
Der Admin bzw. alle betroffenen User müssen die Cookies der betreffenden Domain im Browser löschen, dann neu einloggen als Admin und schon klappt es!
Hier liegt offenbar ein Session-Bug im Upgradepfad vor. Dass das zu einem SQL-Fehler führt, sollte vielleicht auch 'mal grundsätzlich bzgl. Sicherheit geprüft werden.

JTL, könnt ihr das bitte einmal untersuchen und lösen? Bisher ist es bei jedem JTL-Shop4 > 5 Upgrade bei uns aufgetreten!

Ich bitte um Bestätigung und Meldung an JTL, wenn dies bei anderen Benutzern auch die Lösung brachte!
 
Zuletzt bearbeitet:
  • Gefällt mir
Reaktionen: scoutladen

scoutladen

Sehr aktives Mitglied
7. November 2007
1.129
4
Offenburg
Nachdem wir uns nun beim Xten Shop Upgrade auf JTL-Shop5 darüber ärgern mussten und ich diverse Lösungen versucht habe, nun die aus meiner Sicht einzig richtige Lösung, denn für Gäste läuft auch NOVA sofort. Das Problem hat nur der Admin-User und auch ein Ausloggen oder Wechsel der Sprache im Admin-Bereich bringt nichts!

Lösung:
Der Admin bzw. alle betroffenen User müssen die Cookies der betreffenden Domain im Browser löschen, dann neu einloggen als Admin und schon klappt es!
Hier liegt offenbar ein Session-Bug im Upgradepfad vor. Dass das zu einem SQL-Fehler führt, sollte vielleicht auch 'mal grundsätzlich bzgl. Sicherheit geprüft werden.

JTL, könnt ihr das bitte einmal untersuchen und lösen? Bisher ist es bei jedem JTL-Shop4 > 5 Upgrade bei uns aufgetreten!

Ich bitte um Bestätigung und Meldung an JTL, wenn dies bei anderen Benutzern auch die Lösung brachte!
Danke, das war die Lösung. Bei drei Shops ging alles reibungslos. Beim vierten half mir deine Lösung.
 

mona

Gut bekanntes Mitglied
26. April 2016
241
15
Hallo

Kurz eine Frage zu hreflang="{$language->getIso639()}" wie genau muss ich da jetzt ein DE eintragen? Möchte für jeden Besucher direkt Deutsch angezeigt bekommen, obwohl die Standardsprache Englisch ist, und im Moment auch so bleiben muss.
Danke
gruss
mona
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Nova Template Mega Menue Templates für JTL-Shop 6
Neu angezeigte Tiefe des Kategoriebaums im Megamenü anpassen im NOVA Template Templates für JTL-Shop 0
Neu Update JTL 5.03 auf JTL 5.1.X möglich ohne Template-Änderungen (Nova)? Installation / Updates von JTL-Shop 0
NOVA-Template || Kategorie auf der Startseite Einrichtung JTL-Shop5 0
Neu Nova Template Product Stream Slider Bug JTL-Shop - Fehler und Bugs 4
NOVA-Template zeigt weiße Seite (HTTP 500) nach Upgrade von 4 auf 5 Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Nova Template Neue Artikel / Top Artikel / Sonderangebote anzeigen Templates für JTL-Shop 1
Neu php error log wg nova template Installation / Updates von JTL-Shop 0
Neu Core-Variablen im Nova Child Template verwenden Allgemeine Fragen zu JTL-Shop 7
Neu NOVA Template Hover Button Farbe ändern Templates für JTL-Shop 3
Neu NOVA-Template - Artikelbeschreibung in der Galerieansicht anzeigen Templates für JTL-Shop 2
Neu Bilder in Vergrösserung - Nova Template Allgemeine Fragen zu JTL-Shop 7
Neu NOVA Theme Megamenu ohne Dropdown Templates für JTL-Shop 3
Neu NOVA - Produktdetail Vorschaubilder verschieben bei mouseover JTL-Shop - Fehler und Bugs 0
Neu Nova - Wie passe ich die Scrollbar an? Templates für JTL-Shop 0
Neu Lagerampel und Anzeige von MwSt. in Artikelübersicht - NOVA Betrieb / Pflege von JTL-Shop 3
Farbe Ändern NOVA Einrichtung JTL-Shop5 2
Neu NOVA: Banner/Slider auf Startseite nur für registrierte User Templates für JTL-Shop 0
Neu JTL Shop 5 / Nova / oben feststehende Leiste mit Shop-Infos Templates für JTL-Shop 4
Neu Staffelpreise ohne Grundpreis in der Artikelübersicht ( NOVA ) JTL-Shop - Fehler und Bugs 0
Neu Automatisch Objekt und Template Cache leeren Betrieb / Pflege von JTL-Shop 0
Neu EVO Template Fehler bei abgeschalteten Kategorien im Megamenü Templates für JTL-Shop 2
Neu paypal plugin 2.1.1 für shop 5.1.2 mit evo Template Plugins für JTL-Shop 4
Neu Aviator Checkout Template Templates für JTL-Shop 1
Neu Top Bar JTL5 Template Templates für JTL-Shop 1
Neu Startseite Template Bilder Größe einheitlich Technische Fragen zu Plugins und Templates 0
Neu E-Mail Vorlagen Template für Mails die vom Shop kommen Templates für JTL-Shop 0
Neu Neues ebay Template - Probleme mit Schriftdarstellung User helfen Usern - Fragen zu JTL-Wawi 0
RDP - OSX DHL Label weiß JTL-Wawi 1.6 0

Ähnliche Themen