Offen Lieferschein Zusatzfeld Lieferadresse wird nicht im Druck übernommen.

Ahab

Gut bekanntes Mitglied
3. April 2011
263
5
Im Lieferschein habe ich die folgenden Variabeln im Adressbereich:

JTL. WaWi.Vorgang.Lieferadresse.Firma
Ltrim$(JTL.WaWi.Vorgang.Lieferadresse.Anrede + " " + JTL.WaWi.Vorgang.Lieferadresse.Titel) + " " + Ltrim$(JTL.WaWi.Vorgang.Lieferadresse.Vorname + " " + JTL.WaWi.Vorgang.Lieferadresse.Name)
JTL.WaWi.Vorgang.Lieferadresse.Zusatz
JTL.WaWi.Vorgang.Lieferadresse.Strasse
JTL.WaWi.Vorgang.Lieferadresse.Postleitzahl + " " + JTL.WaWi.Vorgang.Lieferadresse.Ort
JTL.WaWi.Vorgang.Lieferadresse.Land
Müsste meiner Meinung nach Standard sein.
Bis auf das Feld LAND ist die Darstellungsbedingung "immer anzeigen".

Das Feld JTL.WaWi.Vorgang.Lieferadresse.Zusatz wird mir aber dennoch nicht in der Adresse angezeigt.
Ein direkter Vergleich zwischen den Feldern Zusatz, Strasse und Ort hat keinerlei Unterschiede in den Bedingungen gebracht.

Wir im Formulareditor die Sichtbarkeit des Feldes noch an einer anderen Stelle beeinflusst?

Bei Druckvorschau und auch beim Druck wird der Adresszusatz nicht angezeigt / ausgedruckt.

Zusatzfrage: wie kann ich beeinflussen welchen Vorgang der Formulareditor als Datengrundlage für den Lieferschein nimmt?
Es scheint immer der letzte / neueste Vorgang zu sein. Bei Rechungs- und Auftragsformular kann ich die Vorgangsnummer vorbelegen.
Beim Lieferschein nicht. Aber gerade hier gibt es im Adressbereich die meisten Abweichungen.

Derzeit muss ich mir behelfen indem ich die Wawi 2x öffne, im Formulareditor ändere und speichere und dann im anderen Fenster die Vorschau ansehe.
Die Vorschau im Fomulareditor zeigt leider einen anderen Datensatz, dem die benötigten Infos fehlen.
 

Jörg101172

Aktives Mitglied
3. Mai 2017
41
2
hallo, scheinbar ist das ein Thema, was auch andere Sachen betrifft. Mir fiel auf, dass zum Beispiel Beschreibungen/Bezeichnungen von Freipostionen auf Packlisten im Formulareditor korrekt angezeigt wird, in der Vorschau bzw. im Druck aus der Wawi jedoch nicht. Auch ich muss wohl oder übel beim Ausgeben von Packlisten den Umweg über das Drucken aus dem Formulareditor gehen. Ich bin auch noch auf der Suche nach der Ursache für solche Abweichungen.
 

gutberle

Sehr aktives Mitglied
29. März 2011
1.271
339
@Ahab - Erstens macht es nur begrenzt Sinn, eine Frage zur JTL Wawi 1.1.3 im Forum für die JTL Wawi 0.9 zu posten und dann sagen mir diese Variablen ÜBERHAUPT nichts.

Und dann werden alle Adress- und sonstigen Variablen zum aktuellen Vorgang mindestens seit der Wawi 0.99923, mit der ich aktuell noch produktiv arbeite, in einem Variablenbaum übergeben, der mit "Vorgang" beginnt. Die "Firmenzusatz" Variable heißt zum Beispiel "Vorgang.Auftrag.Lieferadresse.Firmenzusatz" und so weiter.

Ich bin aber auch am rätseln, wie Du mit den von Dir oben berichteten Variablen überhaupt etwas ausgegeben bekommen kannst. Ich haber weder in der 0.99923, noch in der 1.0000, der 1.1.4.14, der 1.2.3.7 oder der aktuellen Wawi Beta 1.3.3.0_2 irgendwelchen Variablen entdecken können, die mit "JTL" beginnen.

Und selbst falls diese Variablen in Deinen Vorlagen noch aus asbachuralten Vorlagen lange vor der 0.99923 stammen würden, wo es vielleicht einen mit "JTL" beginnenden Variablenbaum gegeben hat, hat bei mir aber auch nicht eine der getesteten Wawi Versionen mit diesen Variablen *irgendetwas* angezeigt und *alle* haben sich über die falschen Variablen beschwert. - Bist Du Künstler, wie machst Du das???