Installation: Exception nach Test der Verbindung

luffi

Aktives Mitglied
6. November 2013
50
14
Nach erfolgreichem Test der Verbindung erhalte ich direkt im Anschluss eine Exception mit folgendem Inhalt:

Code:
Unbehandelte Ausnahme #1DC191B6ECF72BE5 vom Typ System.NullReferenceException in Boolean YKtySOPd8Y(jtlDatabase.classes.ConnectorClasses.CustomerGroupI18n)System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
   bei jtlCore.ControllerClasses.Connector.Shopkonfiguration.ShopKonfigurationHelper.YKtySOPd8Y(CustomerGroupI18n )
   bei System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable`1 source, Func`2 predicate)
   bei jtlCore.ControllerClasses.Connector.Shopkonfiguration.ShopKonfigurationHelper.GetKundengruppenFromGlobalData(List`1 customerGroups, jtlShop shop)
   bei jtlCore.ControllerClasses.Connector.Shopkonfiguration.ShopKonfigurationController.T4aIXo8XLl(GlobalData )
   bei jtlCore.ControllerClasses.Connector.Shopkonfiguration.ShopKonfigurationController.e9xIsGbgX6(GlobalData )
   bei jtlCore.ControllerClasses.Connector.Shopkonfiguration.ShopKonfigurationController.Run()
   bei jtlCore.Classes.CppConnector.CppConnector.ConnectorKonfiguration(Int32 kShop, Int32 nFormHandle, Boolean ersterAufruf)
   bei JTLwawi.CJTLwawi.JTL_ConnectorKonfiguration(String SRV, String DBN, String DBU, String DBP, Int32 kBenutzer, Int32 kShop, Int32 nErsterAufruf, Int32& result, Int32 nFormHandle)

Ich habe Kundengruppen und Kundenkategorien erstellt, sodass die gewählte Kundenkategorie aus Magento auch in JTL existiert.
 

magent

Aktives Mitglied
3. Juni 2015
14
0
AW: Installation: Exception nach Test der Verbindung

Wie hast du die Verbindung hinbekommen?! Wir bekommen immer nur die Fehlermeldung
magento.png

Magento 1.9.1.1 und JTL v999558
 

Anhänge

  • magento.png
    magento.png
    8,7 KB · Aufrufe: 26

luffi

Aktives Mitglied
6. November 2013
50
14
AW: Installation: Exception nach Test der Verbindung

Die Verbindung habe ich nach der Anleitung hergestellt, und dann das Token abgekürzt (war noch vor dem neusten Release). Ich bekomme ein "HTTP-Verbindung zum Webshop OK!" - und gleich im Anschluss dann die Fehlermeldung:

Screen Shot 2015-06-04 at 13.15.43.png

Mir ist aufgefallen, dass mit dem neuen Release nicht mehr zwischen https:// und http:// in der Meldung "HTTP-Verbindung zum Webshop OK!" unterschieden wird. Das hat für mich keine Bedeutung, da der Connector über beide Protokolle erreichbar ist, aber es könnte ein Bug sein?
 

Anhänge

  • Screen Shot 2015-06-04 at 13.15.43.png
    Screen Shot 2015-06-04 at 13.15.43.png
    71,8 KB · Aufrufe: 21

magent

Aktives Mitglied
3. Juni 2015
14
0
AW: Installation: Exception nach Test der Verbindung

Danke für die Rückmeldung. Habe ich auch alles probiert. Funkt leider nicht und ich finde bei JTL keine Logs, die eventuell mehr ausgeben...

Any ideas?!
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.845
235
AW: Installation: Exception nach Test der Verbindung

Hallo,

das sieht alles nach dem gleichen Fehler aus.
Laut der Meldung findet der Connector keine Kundengruppen im Magento- Shop.
 

magent

Aktives Mitglied
3. Juni 2015
14
0
AW: Installation: Exception nach Test der Verbindung

Ich bekomme diese Meldung beim Testen/Lizenz aktivieren. Bis zu den Kundengruppen komme ich gar nicht.
 

luffi

Aktives Mitglied
6. November 2013
50
14
AW: Installation: Exception nach Test der Verbindung

In der Magento settings-page habe ich die Customergroup "General" ausgewählt. Unmittelbar wurden hier auch die existierenden Kundengruppen korrekt angezeigt.
Gibt es eine Möglichkeit die Settings in der Datenbank zu überprüfen? Eventuell Beispieldaten?
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.845
235
AW: Installation: Exception nach Test der Verbindung

Ich habe in meinem Testshop diese Kundengruppen:


0 Not LoGGED IN
1 general
2 Wholesale
3 Retailer

Steuerklasse: Endkunden
 

magent

Aktives Mitglied
3. Juni 2015
14
0
AW: Installation: Exception nach Test der Verbindung

Ich habe ein komplett "blankes" Magento 1.9.1.1 aufgesetzt. Dann den Connector eingespielt und es klappt leider nicht. Anleitung lt. DOKU.
 

luffi

Aktives Mitglied
6. November 2013
50
14
AW: Installation: Exception nach Test der Verbindung

Ich habe identische Kundengruppen mit den gleichen IDs.
Die Steuereinstellung ist Länderspezifisch eingestellt, es gibt hier aber nur 1 Möglichkeit, die auch in Magento ausgewählt ist - und die Steuerwerte sind in JTL auch angelegt.
 

giuch

Aktives Mitglied
4. Juni 2015
1
0
AW: Installation: Exception nach Test der Verbindung

Sorry, I'll write on English because my German is not so good. I have the same problem by pressing Testen/Lizens aktivieren -> Exception: (500) internal server error.
I found these lines in the logs on the hosting (may be it can help to solve my problems):

[04/Jun/2015:15:46:22 +0200] "POST /.../jtlconnector//dbeS/mytest.php HTTP/1.1" 404 43313 "-" " JTL-Wawi" "wp....server-he.de"
[04/Jun/2015:15:46:22 +0200] "POST /.../jtlconnector/ HTTP/1.1" 500 0 "-" "-" "wp....server-he.de"

and also

Logfile für PHP 5.3:
PHP Fatal error: Using $this when not in object context in .../app/code/community/Jtl/ Connector/vendor/jms/serializer/src/JMS/Serializer/Serializer.php on line 99

Thanks in advance for any help
 

magent

Aktives Mitglied
3. Juni 2015
14
0
AW: Installation: Exception nach Test der Verbindung

JuHu, es klappt. (es lag an sqlite3).

beim Upload von Bildern kommt diese Meldung "Call to a member function getForeignKey() on a non-object /app/code/community/Jtl/ Connector/src/Mapper/Image.php".

Any Ideas?
 

Frank Busch

Moderator
Mitarbeiter
2. Juli 2012
428
5
AW: Installation: Exception nach Test der Verbindung

Nach erfolgreichem Test der Verbindung erhalte ich direkt im Anschluss eine Exception

Den Fehler muss ich mir genauer anschauen. Könntest du mir URL und Token deines Connectors (am besten per PN) geben?
Ich werde diese Daten selbstverständlich vertraulich behandeln und nach der Fehlersuche sofort wieder verwerfen.

Viele Grüße
Frank
 

Janusch

Administrator
Mitarbeiter
24. März 2006
13.845
235
AW: Installation: Exception nach Test der Verbindung

Hallo,

danke für die Rückmeldung. Normal sollte beim aktivieren des Plugins danach geprüft werden ob alle Voraussetzungen (SQLlite usw.) erfüllt sind.
Wir schauen da nach, scheint noch etwas nicht zu tun.
 

luffi

Aktives Mitglied
6. November 2013
50
14
AW: Installation: Exception nach Test der Verbindung

Mit der neuen Beta (v099959) ist dieses (Exception nach erfolgreicher Verbindung) Problem behoben! :)
 

cspoo

Aktives Mitglied
15. April 2013
145
0
AW: Installation: Exception nach Test der Verbindung


Logfile für PHP 5.3:
PHP Fatal error: Using $this when not in object context in .../app/code/community/Jtl/ Connector/vendor/jms/serializer/src/JMS/Serializer/Serializer.php on line 99

Thanks in advance for any help

Presuming that you are using Magento 1.9 you should know that this version requires PHP 5.4. You can enable it in your HostEurope KIS.
 

wrangler007

Aktives Mitglied
4. Juni 2015
4
0
AW: Installation: Exception nach Test der Verbindung

Hallo,

bekomme bei Shop - Abgleich immer diesen Fehler:

Wawi-Version: 0.9.9.960


====================


Fehler:
Exception: DeserializeObject-Error: Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path '', line 0, position 0.
bei Newtonsoft.Json.JsonTextReader.ParseValue()
bei Newtonsoft.Json.JsonTextReader.ReadInternal()
bei Newtonsoft.Json.JsonTextReader.Read()
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadForType(JsonReader reader, JsonContract contract, Boolean hasConverter)
bei Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
bei Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
bei Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
bei Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings)
bei jtlCore.ControllerClasses. Connector.Core.Json.DeserializeObject[T](String json)


Json:<br />
<b>Fatal error</b>: Call to a member function getBackend() on a non-object in <b>/www/htdocs/xxxxxxx/app/code/core/Mage/Eav/Model/Entity/Abstract.php</b> on line <b>816</b><br />
<br />
<b>Fatal error</b>: Call to a member function getBackend() on a non-object in <b>/www/htdocs/xxxxxxx//app/code/core/Mage/Eav/Model/Entity/Abstract.php</b> on line <b>816</b><br />
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Problem bei der Installation siehe Anhang Installation von JTL-Wawi 1
Neu JTL Shop 5.1 kritischer Fehler bei Installation mit Demodaten Installation / Updates von JTL-Shop 1
Neu Shop 5 Installation Fehler Keine config.JTL-Shop.ini.php gefunden. JTL-Shop - Fehler und Bugs 2
Fehler bei der Installation von JTL Shop 5 Einrichtung JTL-Shop5 3
Neu Installation der JTL Warenwirtschaft Installation von JTL-Wawi 3
Neu JTL Shop Installation Installation / Updates von JTL-Shop 11
Neu Fehler bei Installation der Community Free Version Einrichtung JTL-Shop5 2
Neu Kompilieren in lokaler Installation Allgemeine Fragen zu JTL-Shop 0
Neu Fehler beim Verbindungsaufbau: Exception bei global_data.pull: Short and Long cannot be null Modified eCommerce-Connector 0
Neu Ständig auftretend: Exception: Controller = Image Shopware-Connector 3
Testshop kann nach dem Anlegen nicht geöffnet werden Einrichtung JTL-Shop5 1
JTL-Shop 5: Nach Kaufabschluss Button "Weiter einkaufen" => Möglichkeit andere Seite als Startseite zu verlinken? Einrichtung JTL-Shop5 1
Neu Deaktivierte Länder nach Update auf 5.1 (RE-Adresse) JTL-Shop - Fehler und Bugs 2
Neu Positionen einer Pickliste nach Sortiernummer der Lagerplätz sortieren Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Gelöst Konfigurator - Komponenten Namen werden nicht angezeigt nach Update auf 5.1 JTL-Shop - Fehler und Bugs 3
Neu Nach Update auf 5.1 Springt die Startseite wenn der Cookiebanner noch nicht angeklickt wurde JTL-Shop - Fehler und Bugs 2
Neu Nach Rechnungskorrektur ist Rechnung "Bezahlt am..."-Datum = Ursprungsauftrags-Datum - Warum? JTL-Wawi - Fehler und Bugs 0
Neu Shopversion nach Patch-Update von 5.0.0 auf 5.0.3 weiterhin auf 5.0.0 Installation / Updates von JTL-Shop 8
Gelöst nur leere Seiten nach Abgleich Allgemeine Fragen zu JTL-Shop 5
Neu Je nach Artikel(-Gruppe) automatisch Hinweis auf Pickliste hinzufügen Individuelle Listenansichten in der JTL-Wawi 0
Neu Rechnung nach der letzten Teillieferung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Statistik - Auswertung alle Rechnungen nach EU Ländern User helfen Usern - Fragen zu JTL-Wawi 10
Viele Artikelbilder verschwunden nach Update auf JTL 5 Upgrade JTL-Shop4 auf JTL-Shop5 3
In Bearbeitung Keine Minusbuchung und kein "Versand" nach Zahlung Allgemeine Fragen zu JTL-POS 3
Neu Aufträge stecken nach Absturz bei Auslieferung auf der Pickliste fest JTL-Wawi - Fehler und Bugs 4
In Bearbeitung Wurzelkategorie - Artikel werden nicht nach POS übertragen Allgemeine Fragen zu JTL-POS 1
Weiße Seiten nach Update von 4 auf 5 Upgrade JTL-Shop4 auf JTL-Shop5 3
Keine Verbindung von Wawi zum Shop nach Upgrade Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Automatische Mail nach Lieferung um Feedback einzuholen User helfen Usern - Fragen zu JTL-Wawi 1
Neu Workflow zum Auslesen des Lagerstandes - Anstossen nach Uhrzeit User helfen Usern - Fragen zu JTL-Wawi 0
Neu Steuern der Darstellung eines Bildes nach Plattform Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 2
Neu Netzwerkdrucker nach Update verschwunden JTL-Wawi - Fehler und Bugs 5
Neu Aufträge Bestätigen nach Shop Abgleich Arbeitsabläufe in JTL-Wawi 0
Neu Bilder in SW5 verschwinden nach Anlegen von VarKombis Shopware-Connector 2
Neu Versandarten nach Gewicht und Warenwert gekoppelt zu unterscheiden Allgemeine Fragen zu JTL-Shop 0
Neu Varianten Bearbeitung in SW6 nach JTL Nutzung Shopware-Connector 0
Neu Update Version von 1.5.47.2 nach 1.5.48 (fehler) JTL-Wawi - Fehler und Bugs 3
Gelöst Preiseingabe funktioniert nicht mehr nach Update JTL-POS - Fehler und Bugs 3
Gelöst Preisanzeige nach Kundengruppe JTL-POS - Fehler und Bugs 8
Neu Datev Export nach Kundengruppen JTL-Ameise - Fehler und Bugs 3
Neu Versandetikett nach update auf 1.5.47.4 JTL-Wawi - Fehler und Bugs 0
Neu Amazon Aufträge, Positionen doppelt nach Picklistenlöschung Arbeitsabläufe in JTL-Wawi 6
Gelöst Nach Auftragserfassung prüfen ob externe Auftragsnummer schon vorhanden ist JTL-Workflows - Ideen, Lob und Kritik 2
Neu Nach dem Upgrade Shop4 > Shop5 - Wawi-Syncdaten müssen manuell abgespeichert werden? JTL-Shop - Fehler und Bugs 10
Neu Zugriff auf Datenbank nach Update weg? User helfen Usern - Fragen zu JTL-Wawi 2
Beantwortet Sammelumlagerungen direkt Fehler nach Umbuchung JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Wer baut Plugin Zahlungsartauswahl nach Lieferstatus Dienstleistung, Jobs und Ähnliches 2
Neu Verkauf Farbe - nach Eimer oder Liter (Gebinde nur im WMS?) Arbeitsabläufe in JTL-Wawi 3
Neu Fehler nach Server-Umzug JTL-Wawi - Fehler und Bugs 5
Neu Versandart nach dem Ausliefern ändern Arbeitsabläufe in JTL-Wawi 0

Ähnliche Themen