Neu Gambio Connector, JTL WAWI und Gambio EU-Steuersätze Modul - PROBLEM mit EU Standardsteuersatz

stones

Aktives Mitglied
9. April 2009
48
1
Ich habe bei unserem Shop seit langen den JTL Connector in Verwendung. Nun nach dem Installieren des Moduls "EU Steuersätze" habe ich das Problem, dass JTL mir bei den Produkten die "tax_class_id" von 4, wie sie zur richtigen Verwendung für das EU-Steuersätze Modul verwendet wird, beim Produktabgleich auf 1 zurück setzt. Daraus ergeben sich dann in den Orders addierte Steuersätze zB 19% + 20% für Kunden aus Deutschland, die wir von Österreich aus beliefern, sind.

Hat jemand von Euch ähnliche Probleme, oder vielleicht kennt jemand von euch eine Lösung dafür.

Im Connector kann man zwar die default Tax_Rate in der config.json definieren, aber nicht die Tax_Class.

Viele Grüße aus Wien,
Ernst

Info: Gambio Version: v4.3.3.1 JTl 1.5.52.0 Connector Version 2.14.0

PS: Dieses Problem wurde auch schon in diesem Beitrag beschrieben, aber bis jetzt finde ich auch dort keine Antwort!
EIne Lösung ist aber schon Steuerrechtlich wirklich wichtig! An JTL Mitarbeiter - BITTE reagiert auf solche Beiträge!
 

bork

Sehr aktives Mitglied
26. Januar 2007
761
56
Hier ist doch immer die aktuellste Version angekündigt:
https://forum.jtl-software.de/threads/aktuelle-connector-version-2-20-0.113798/

Also deine Connector-Version ist nicht einmal für Gambio 4.3 freigegeben.

Das letzte MwSt-bezogene Update gab es in 2.17.

Allerdings gibt es noch in 2.20 (und vielleicht auch schon früher?) einen dicken Bug im Zusammenhang mit Variationskombinationen. Den Fix würde ich noch abwarten vor einem Update.
 
  • Gefällt mir
Reaktionen: stones

bork

Sehr aktives Mitglied
26. Januar 2007
761
56
Vielleicht besteht der Fehler aber unabhängig von der Version noch. Bei uns ist auch jeder Artikel, den ich hochlade, wieder mit der Standard-Tax-ID aus Gambio hochgeladen.

Im Übertragungslog steht für den <<< global_data.pull:

"taxRates":[{"id":["",0],"countryIso":"","rate":0},{"id":["",0],"countryIso":"","rate":5},{"id":["",0],"countryIso":"","rate":7},{"id":["",0],"countryIso":"","rate":8},{"id":["",0],"countryIso":"","rate":9},{"id":["",0],"countryIso":"","rate":9.5},{"id":["",0],"countryIso":"","rate":10},{"id":["",0],"countryIso":"","rate":12},{"id":["",0],"countryIso":"","rate":13},{"id":["",0],"countryIso":"","rate":13.5},{"id":["",0],"countryIso":"","rate":14},{"id":["",0],"countryIso":"","rate":15},{"id":["",0],"countryIso":"","rate":17},{"id":["",0],"countryIso":"","rate":18},{"id":["",0],"countryIso":"","rate":19},{"id":["",0],"countryIso":"","rate":20},{"id":["",0],"countryIso":"","rate":21},{"id":["",0],"countryIso":"","rate":22},{"id":["",0],"countryIso":"","rate":23},{"id":["",0],"countryIso":"","rate":24},{"id":["",0],"countryIso":"","rate":25},{"id":["",0],"countryIso":"","rate":27}]
Also scheinbar sind alle tax rates im Shop da, aber die ISO-Codes kommen nicht über? Eine Einstellungssache?

Für den Artikel selbst wird übermittelt:

"vat": 19.0,

Im Connector habe ich die Steuerklasse auf 19% Europäische Steuersätze stehen. Das ist dann in der config.json die ID 17, die es allerdings in Gambio nicht gibt. Vielleicht die ID aus JTL? Jedenfalls weiß ich auch nicht, wie dann die passende Steuerklasse in Gambio gesetzt wird, weil 19 ja nicht eindeutig ist.
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu Abgleich Fehler (Variationen) mit Gambio 4.5.3.1 + JTL-Wawi 1.6.39.0 + JTL-Connector 2.22.0 Gambio-Connector 3
Neu Gambio Connector mit JTL hat Ebay Artikel zerschossen Gambio-Connector 0
Neu Kundendaten aus Gambio GX4.4 in JTL Shop übertragen ?! Umstieg auf JTL-Shop 1
Neu Connectoreinstellungen um nur Versandstatus an Gambio-Shop zu übertragen Gambio-Connector 3
Beantwortet Suche Workflow zur Lieferstatusänderung bei Gambio (Klarna-Versandbestätigung) JTL-Workflows - Ideen, Lob und Kritik 3
Neu JTL-Connector und SQLite3 WooCommerce-Connector 0
Shopabgleich per Connector bricht ab JTL-Wawi 1.6 2
Neu Problem / Fehler beim Update von JTL Connector 2.2.5.3 auf 2.13.0 (Shopware 5.5.10) Shopware-Connector 1
Neu Shopware Connector mehrere Sprachen Shopware-Connector 2
Neu JTL-Wawi Connector - ungültige Domain Installation / Updates von JTL-Shop 0
Neu Shopware 6 Abgleich/Connector endet nicht Onlineshop-Anbindung 0
Neu Komplettabgleich JTL 1.6 / Shopware connector 2.15.0 Shopware-Connector 8
Neu Connector 2.15.0: Feature - Added support for regulation price ?? Shopware-Connector 1
Neu Shopware 6 <> JTL Connector Beta: Individuelle Sortierung der Artikel Shopware-Connector 1
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Onlineshop via Connector (Xonic) Problem JTL-Wawi - Fehler und Bugs 0
Neu Erfahrungen Connector mit Elementor-Paket mit direktem Google-Hosting WooCommerce-Connector 0
Neu JTL connector woocommerce Angebot/Aufträge WooCommerce-Connector 0
Neu Shopware 5 Connector fehlender CDN/File System Adapter Support Shopware-Connector 0
Neu Shopware 6 Connector.... ich verzweifle gleich Shopware-Connector 5
Neu Rey Theme kompatibel mit JTL-Connector? WooCommerce-Connector 0
Neu JTL-Connector für Shopware 6 Beta Version beendet? Shopware-Connector 3
Neu Connector Plugin Freigabe für SW 5.7.10 Shopware-Connector 4
Neu Wie vorgehen beim Connector Update? Modified eCommerce-Connector 2
Neu Shopware 5 Connector / abweichender Produkttitel Shopware-Connector 2
Neu Bilder > übertragung ausstehend (Shopify connector) Shopify-Connector 0
Neu SW5 Connector bricht ab bei Lieferschein senden Shopware-Connector 0
Neu Shopkonfiguration Connector konfigurieren keine Auswahl möglich WooCommerce-Connector 0
Neu Wann funktioniert der Shopware6 Connector? Shopware-Connector 8
Neu Jtl Connector - WooCommerce / Paypal-Aufträge werden nicht importiert WooCommerce-Connector 0
Neu Connector für Konfigurator/Stücklistenartikel WooCommerce-Connector 0
Neu Connector keine Verbindung WooCommerce-Connector 1
Verwiesen an Support Abgleich Fehler nach Shopware Connector Update Shopware-Connector 1
Neu Fehler in Connector-Requestdaten nach Änderung der Kundengruppe in der Wawi Allgemeines zu den JTL-Connectoren 2
Neu JTL Connector zu Presta "Product": {"delete"} -> Exception bei product.delete: Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverf PrestaShop-Connector 1
Neu Fehler beim Verbindungsaufbau: Exception bei core.connector.auth: Der Remoteserver hat einen Fehler zurückgegeben: (401) Nicht autorisiert. WooCommerce-Connector 1
Neu Connector Abgleich schlägt fehlt - Shopware 5 - Exception: The EntityManager is closed - Exception: The EntityManager is closed Shopware-Connector 2
Neu Connector-Version Shopware 5 Shopware-Connector 10
Anonymes Feedback zu JTL-Wawi Mobile App bleibt unbeantwortet - Wirklich? JTL-Wawi 1.6 0
Neu JTL WaWi 1.6 und SurfAce Pro4 User helfen Usern - Fragen zu JTL-Wawi 0
Neu Unterschiedliche JTL Versionen auf 2 Mandanten User helfen Usern - Fragen zu JTL-Wawi 1
JTL WaWi an COBRA CRM Software - Schnittstelle JTL-Wawi 1.6 0
JTL Shop 5 Plugins lassen sich nicht installieren Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Guthaben für JTL Shop nicht möglich - Abfrage Standardbankverbindung? JTL-Wawi - Fehler und Bugs 3
Neu JTL-Wawi 1.6 --- Großbritannien hat bei EU immer noch den Haken drin User helfen Usern - Fragen zu JTL-Wawi 1
Neu Vouchers/Gutscheine. JTL-Pos und LS-Pos parallel betreiben? Allgemeine Fragen zu JTL-POS 0
Neu JTL Amazon-Account Registrierung Skript Fehler Amazon-Anbindung - Fehler und Bugs 1
Neu Kritik: Lest jemand von JTL hier mit? JTL-Wawi - Ideen, Lob und Kritik 1
JTL Wawi 1.6 Auftrag Splitten beim Auf die Pickliste packen JTL-Wawi 1.6 0
Neu JTL Worker richtig einstellen Installation von JTL-Wawi 6

Ähnliche Themen