Fehlermeldung mit Klarna Plugin, lösbar?

Holgersson

Aktives Mitglied
21. Januar 2011
49
1
Hallo Zusammen,
ich möchte das von Klarna erhaltene Plugin installieren und bekomme folgende Fehlermeldung im Bestellvorgang -> Zahlungsart

Strict Standards: Declaration of klarnaPaymentClass::init() should be compatible with PaymentMethod::init($nAgainCheckout = 0) in /var/www/vhosts/move-cycles.com/httpdocs/includes/plugins/PiKlarnaPayment/version/113/paymentmethod/KlarnaPaymentClass.php on line 163

Ich nutze:
JTL- Shop 3.19 Build 4 / Template 3.16

Laut Support wird die 3.19 Version nicht unterstützt? Ist das ein unlösbares Problem?

Vielen Dank für Eure Tipps.
Nils
move-cycles.com
 

casim

Sehr aktives Mitglied
26. Juni 2012
5.934
5
AW: Fehlermeldung mit Klarna Plugin, lösbar?

Der Fehler hat nichts mit der Shop-Version zu tun, sondern mit der php-Version.
Ich wette, du verwendest eine Version >= 5.5

Die Aussage des Klarna-Support lässt daher nicht auf sehr viel Erfahrung schließen.

Was dir aber viel mehr Sorgen mache sollte ist, dass deine Shop-Version und deine Template-Version so drastisch auseinander liegen.

Shop- und Template-Version sollten (müssen) immer identisch sein.
 

Holgersson

Aktives Mitglied
21. Januar 2011
49
1
AW: Fehlermeldung mit Klarna Plugin, lösbar?

Hallo,
Danke schon mal.
Es wäre php 5.4.4...wenn das hilft. Ist das Plugin dann grundsätzlich nicht kompatibel? Wäre das mit (meinen) Haushaltmitteln modifizierbar?

Template: Das Template läuft auf einem gekauften Template in 3.16. Da hatte mich noch nicht wieder ran getraut.
 

squip

Aktives Mitglied
16. März 2007
70
8
AW: Fehlermeldung mit Klarna Plugin, lösbar?

ich erhalte seit der 3.20 einen ähnlichen Fehler:

Strict Standards: Declaration of klarnaPaymentClass::init() should be compatible with PaymentMethod::init($nAgainCheckout = 0) in /www/htdocs/w01218e2/Webshops/Pool/includes/plugins/PiKlarnaPayment/version/113/paymentmethod/KlarnaPaymentClass.php on line 163

PHP-Version: PHP-Version 5.4.45-nmm1

Kann mir jemand helfen?