Neu Fehlermeldung: "Datenbankfehler: SQLSTATE[HY000] [1045] Access denied for user 'DBNAME'@'localhost'

IceDrake

Aktives Mitglied
17. Juni 2015
57
3
Hallöchen,

ich bin grad dabei zu versuchen den JTL- Shop zu installieren ... dabei erhalte ich die folgende Fehlermeldung, wenn ich die Zugangsdaten zur Datenbank eingegeben habe:

Datenbankfehler: SQLSTATE[HY000] [1045] Access denied for user 'DATENBANKNAME'@'localhost' (using password: YES)

Datenbankname ist dabei natürlich der entsprechende :)

Host: localhost
Socket: leer
Ben.name: "Full" als auch "R/W" schon probiert
Passwort: entsprechend dem obigen Ben.namen
DB-Name:
wie bei Hetzner erstellt

Alle obigen Einstellungen/Eingaben schon zig mal kontrolliert und neu versucht ...

Die Datenbank habe ich über die KonsoleH bei Hetzner gerade eben zuvor erstellt. Als Zugang habe ich den Full Login als auch den R/W-Login ausprobiert, erhalte aber bei beiden die gleiche Fehlermeldung.

Die ganzen Abfragen/Tests sind alle auf grün, nur max_execution_time ist aktuell noch 90 statt der geforderten 120sec und damit auf gelb ... sollte ja aber für die Installation kein Problem sein - oder?

Leider kann ich mit der Fehlermeldung so nichts anfangen ... woran also liegts?
 

IceDrake

Aktives Mitglied
17. Juni 2015
57
3
War ein Layer 8 Problem :) ... ist also gelöst.

Host musste der Datenbank-Server sein und nicht "localhost".
 

lahr-net

Gut bekanntes Mitglied
13. Oktober 2016
178
5
Hallo,
ich habe das gleiche Problem auf einem 1&1 Server. Hundert mal die Zugangsdaten kontrolliert. Zugangsdaten stimmen.

Dateirechte und alles grün.....
Server sollte funktionieren (localhost, keine socket etc)... habe auf dem gleichen Server schon einen JTL Shop laufen.

nur der "Datenbankfehler: SQLSTATE[HY000] [1045] Access denied for user....."

ich steh grad auf dem Schlauch!!! :-?
 

lahr-net

Gut bekanntes Mitglied
13. Oktober 2016
178
5
Hallo,
ich habe letze Woche den obigen Post geschrieben.... habe es Abends bis 18:30 probiert. Nix ging!!!!! Immer der Fehler, dass der Datenbank-Zugriff abgelehnt wurde.
Zugangsdaten und alles stimmte definitiv (Copy&Paste) ! Dann am nächsten morgen noch mal probiert um zu versuchen den Fehler einzugrenzen (nichts zum Abend zuvor verändert). Und dann ging es plötzlich anstandslos und der Shop lief!!! HÄÄÄÄ????
OK, gut....

Jetzt installiere ich einen zweiten shop um damit zu beginnen ihn einzurichten (wir wollen 3 Shops zu JTL migrieren). Gleicher Server, gleiches Spiel... und wieder der gleiche Fehler... tzzzz.
Die Zugangsdaten sind 100% richtig. Die Datenbank ist fertig eingerichtet etc.

Ihr werdet jetzt sagen: benutzername und datenbankname vertauscht... passwort falsch getippt usw. NÖ!!

Jemand ne Ahnung was da geht??? :-? Lotto spielen ist erfolgversprechender... ;)
 
Zuletzt bearbeitet:

lahr-net

Gut bekanntes Mitglied
13. Oktober 2016
178
5
so, da ich hier Selbstgespräche führe - die Lösung: ich habe das Passwort in der Datenbank nun verkürzt und bestimmte (erlaubte) Sonderzeichen wie Bindestriche raus genommen. Ich glaube es lag an den Sonderzeichen im Passwort.
Muss ich nicht verstehen, oder? :confused:
 
  • Gefällt mir
Reaktionen: Matchy

Matchy

Aktives Mitglied
4. Januar 2011
80
11
Hallo lahr-net,

Danke für Deinen Lösungstipp. :) Es war bei mir genauso.

Ursache war ein / (Slash) im Passwort. Dieses scheint JTL-Shop4 nicht zu verstehen.o_O

VG,
Matze
 
Ähnliche Themen
Titel Forum Antworten Datum
Beantwortet Post Fehlermeldung "AuthenticateUser failed." JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehlermeldung beim Speichern von Lieferanten - Währung geändert? JTL-Wawi - Fehler und Bugs 0
In Diskussion UPS-Einrichtung, Fehlermeldung und offene Fragen JTL-ShippingLabels - Fehler und Bugs 6
Neu Fehlermeldung wegen TSE bei jedem Kassiervorgang Fragen rund um LS-POS 0
Neu List&Label "malicious"-Fehlermeldung bei JTL_DirectQuery, was ist daran falsch? Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 1
Neu Interessante Fehlermeldung JTL-Wawi - Fehler und Bugs 7
Neu get_all_properties_by_products_id(): typeof($p_products_id) != integer Fehlermeldung Gambio-Connector 0
Fehlermeldung beim Speichern von Eigenen Seiten Einrichtung JTL-Shop5 7
Neu Artikel Import bricht ab mit folgender Fehlermeldung / Warnungen Shopware-Connector 0
Neu Fehlermeldung bei der Anlage von Variationskombinationen User helfen Usern - Fragen zu JTL-Wawi 0
Neu Typo bei Fehlermeldung Lizenzschlüsselaktivierung JTL-Wawi - Fehler und Bugs 2
Neu Fehlermeldung bei Neuinstallation Shop 5 mit Testshop auf eigenem Server Installation / Updates von JTL-Shop 0
Neu Datenimport Shopware 5.5.10 zu JTL 1.5.42.0 immer Fehlermeldung Shopware-Connector 3
Neu Fehlermeldung Online Shop Abgleich User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehlermeldung : Für die aktuelle Transaktion kann kein Commit ausgeführt werden.... WooCommerce-Connector 8
Neu Warenpost - INVALID_CONFIGURATION Fehlermeldung JTL-ShippingLabels - Fehler und Bugs 1
Gelöst Fehlermeldung Epson TM-m30 Gelöste Themen in diesem Bereich 2
Neu Fehlermeldung "Ihr Amazon Auth Token ist nicht korrekt" Error 401 Amazon-Anbindung - Fehler und Bugs 0
Neu WAWI Fehlermeldung Modified eCommerce-Connector 1
Neu Fehlermeldung beim Import "Keine Multishop Lizenz vorhanden" weil aus versehen 2 Connectoreinträge zum gleichen Shop angelegt wurden. Allgemeines zu den JTL-Connectoren 1
Neu Formularanpassung Fehlermeldung Das Designobjekt konnte nicht bezogen werden User helfen Usern - Fragen zu JTL-Wawi 2
Neu Formularanpassung Fehlermeldung Das Designobjekt konnte nicht bezogen werden User helfen Usern - Fragen zu JTL-Wawi 3
Neu Fehlermeldung bei JTL Update JTL-Wawi - Fehler und Bugs 0
Beantwortet Warenpost XS EU bringt seit heute eine Fehlermeldung JTL-ShippingLabels - Fehler und Bugs 1
Neu SQL-Fehlermeldung beim Update einer DB auf Version 1.5.30.0 bei FOREIGN KEY-Einschränkung 'FK_dbo_tMerchantVersandRef_kVersand' JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehlermeldung JTL-POS - Fehler und Bugs 2
Neu kein frontend sichtbar fehlermeldung Installation von JTL-Wawi 1
Neu Onlineshop-Abgleich bringt nach Start eine Fehlermeldung (Version 1.5.32.1) Shopware-Connector 0
Neu Fehlermeldung bei erstem Abgleich PrestaShop-Connector 1
Neu Shopabgleich mit Fehlermeldung Onlineshop-Anbindung 0
Shop 5 Exportformate - Fehlermeldung Einrichtung JTL-Shop5 2
Neu Bilderupload von WAWI auf Gambio Shop führt zu Fehlermeldung JTL-Wawi - Fehler und Bugs 1
Neu Gambio Shop Abgleich gibt immer wieder Fehlermeldung Gambio-Connector 3
Neu Fehlermeldung SQL (0x80131904): Die INSERT-Anweisung steht in Konflikt mit der FOREIGN KEY-Einschränkung 'FK_ebay_data_membermessage_out_kEbayuser' .. JTL-Wawi - Fehler und Bugs 0
Neu Fehlermeldung beim Mahnlauf JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung "Bad Login!" bei Shop-Abgleich Onlineshop-Anbindung 7
Neu 1.5.38.1 Logbuch Fehlermeldung JTL-Wawi - Fehler und Bugs 4
Neu Datenbankfehler Installation von JTL-Wawi 10
Neu Datenbankfehler beim Export User helfen Usern - Fragen zu JTL-Wawi 2
Beantwortet Update Shop 5 - SQLSTATE Fehler - diverse Installation / Updates von JTL-Shop 1
Neu SQLSTATE[HY000] [1045] Access denied for user 'xxxxxxx'@'localhost' (using password: YES) Installation / Updates von JTL-Shop 13

Ähnliche Themen