In Bearbeitung Fehlermeldung beim XML Auftragsimport

florando

Aktives Mitglied
16. Juni 2011
3
1
Hallo, wir sind in den letzten Tagen auf Wawi 1.1.4.7 umgestiegen und haben folgendes Problem: Wir möchten per XML-Export Aufträge von einem Mandanten zu einem anderen Mandanten importieren, was in der Vergangenheit mit WAWI<1 auch immer bestens geklappt hat.

Wir haben wie im Guide https://guide.jtl-software.de/jtl/K...ng#Auftr.C3.A4ge_per_CSV_oder_XML_exportieren
beschrieben eine Exportauftragsvorlage erstellt. Wenn wir die so generierte Auftrags-XML-Datei beim anderen Mandanten über Verkauf->Importieren->Aufträge(*.xml) importieren möchten, erhalten wir als Fehlermeldung:

"Der Wert NULL kann in die cVErsandlandWaehrung-Spalte, Mandant_8.dbo.tBestellung-Tabelle nicht eingefügt werden. Die spalte lässt NULL-Werte nicht zu. Fehler bei INSERT."

Wenn wir hingegen den Auftrag bei dem Mandanten, der die XML-Exportdatei erstellt hat, wiederum importieren, erhalten wir keinen Fehler.

Wir freuen uns über jede Hilfe, da wir den Austausch von Aufträgen zwischen Mandanten unbedingt benötigen.

Lieben Dank im Voraus.

Angehängt das Fehlerprotokoll
 

Anhänge

  • errorlog_20161026103955.txt
    11,9 KB · Aufrufe: 15

kowo

Aktives Mitglied
11. Dezember 2013
11
3
Hallo,

hast du die Firmennummer kontrolliert und im XML-File angepasst? Bei mir z.b. Firma 2:

--> <tBestellung kFirma="2">

Lg, Wolfgang
 

xferryx

Aktives Mitglied
1. März 2017
46
1
Hallo,

hat jemand mittlerweile eine Lösung gefunden? Wir haben das gleiche Problem. An der Firma kann es nicht liegen. Wir haben den Wert aus der Datenbank ausgelesen und eingetragen. Dennoch bekommen wir o. g. Fehlermeldung.
Gruß xferryx
 

Rico Giesler

Offizieller Servicepartner
SPBanner
10. Mai 2017
13.231
1.462
Bitte mal bei Mandant 2 prüfen wie der Export hier ausschaut:
<tBestellungen><tBestellung cRechnungsNr="" kFirma="5" cFirma="MeineFirma" cMandant="meinMandant">
Wenn man das bei dem Export von Mandant 1 anpasst sollte der Import in Mandant 2 möglich sein.

PS: Bitte auch prüfen ob die Währungen alle korrekt angelegt wurden (ISO-Codes auch prüfen)
 

xferryx

Aktives Mitglied
1. März 2017
46
1
ok, mein Fehler. Ich hab das mit den Mandanten oben überlesen. Wir haben nur einen Mandant.

Nach erneutem Versuch, jetzt mit Version 1.2.3.8, funktionierts. Danke
 
Ähnliche Themen
Titel Forum Antworten Datum
Neu WAWI 1.6.40.0 Beim Speichern von Globaler Angebotsvorlage kommt eine Fehlermeldung eBay-Designvorlagen - Fehler und Bugs 0
Neu Fehlermeldung beim Start der Wawi - manchmal mit crash. manchmal ohne JTL-Wawi - Fehler und Bugs 5
Neu Fehlermeldung "Bad-Login" bei Abgleich WAWI (Version 1.5.54.0) mit Test-Shop (Version: 5.1.2) JTL-Shop - Fehler und Bugs 0
Neu Warenpost DHL Nicht EU - Fehlermeldung wenn Premium nicht aktiviert ist JTL-ShippingLabels - Fehler und Bugs 1
Neu Paypal direkt gibt Fehlermeldung Plugins für JTL-Shop 0
Neu Paypal Checkout Fehlermeldung Technische Fragen zu Plugins und Templates 2
Neu Fehlermeldung bei manueller Kundenübernahme aus Shop JTL-Wawi 1.6 2
Rechnung storniert, Preisänderung im Auftrag Fehlermeldung JTL-Wawi 1.6 1
Neu Überverkäufe per Ameise - Fehlermeldung JTL-Ameise - Fehler und Bugs 1
Fehlermeldung bei Auftrag oder Angebot anlegen JTL-Wawi 1.6 0
Neu Fehlermeldung von Wawi 1.5.55.0 ist kein Update auf 1.6.36.0 möglich Installation von JTL-Wawi 5
Fehlermeldung Steuerschlüssel bleibt nach Update JTL-Wawi 1.6 3
Beantwortet Update auf 1.6 endet mit Fehlermeldung Installation von JTL-Wawi 7
Neu Webview Fehlermeldung bei Wawi Start 1.6 JTL-Wawi 1.6 1
Neu Fehlermeldung bei Abgleich wegen Germanized WooCommerce-Connector 2
Fehlermeldung: SLR500: Report existert nicht kaufland.de - Anbindung (SCX) 3
Neu Produktseite erstellen Fehlermeldung User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehlermeldung von Wawi 1.5.55.1 ist kein Update auf 1.6.36.0 möglich Installation von JTL-Wawi 16
Neu JTL WAWI Fehlermeldung Artikel weg Stammdaten weg im hauptfenster F2 Artikel und F5 KUNDEN in unterordnen sichtbar JTL-Wawi - Fehler und Bugs 2
Gelöst Fehlermeldung - bei manuellem +/- in EazyShipping [WAWI-61235] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 2
Neu Fehlermeldung statt Bestellseite - keine Bestellungen möglich ! Bezahlversion ! Allgemeine Fragen zu JTL-Shop 6
Neu Shop 5 / Fehlermeldung "Es steht keine Versandart zur Verfügung" JTL-Shop - Fehler und Bugs 2
Neu Fehlermeldungen beim Prime Label Kauf - InternalFailure - We encountered an internal error. Please try .... Amazon-Anbindung - Fehler und Bugs 41
Neu Fehler beim erstellen der Rechnung "LLPDF" Fragen rund um LS-POS 1
Neu Details zur Versandeinstellungsautomatisierung beim Lieferversprechen User helfen Usern - Fragen zu JTL-Wawi 0
1.6.39.0: Deadlocks beim Ausliefern JTL-Wawi 1.6 1
Neu Fehler beim Bestellvorgang JTL-Shop - Fehler und Bugs 2
JTL Wawi 1.6 Auftrag Splitten beim Auf die Pickliste packen JTL-Wawi 1.6 0
HILFE PICKLISTE WIRD GEDRUCKT BEIM AUSLIEFERN JTL-Wawi 1.6 1
Neu Fehler beim Export: Deprecated: JTL\Catalog\Currency: getter should be used to get cISO in /var/www/vhosts/ JTL-Shop - Fehler und Bugs 0
Fehler beim Update JTL-Wawi 1.6 0
Neu Probleme beim Uk-Export - Zollinhaltserklärung CN23 veraltet? Arbeitsabläufe in JTL-Wawi 2
Neu Gratisbeigabe beim Kauf bestimmter Artikel Allgemeine Fragen zu JTL-Shop 0
Neu Beim Hochladen wird die Steuerklasse auf 0 gesetzt! Gambio-Connector 5
Neu Problem / Fehler beim Update von JTL Connector 2.2.5.3 auf 2.13.0 (Shopware 5.5.10) Shopware-Connector 1
Neu WAWI 1.6.38.2: Skontosatz geht beim Erstellen der Rechnung verloren JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Shopify Abgleich Shopify-Connector 0
Neu Fehler beim senden von Rechnungen per Mail JTL-Wawi - Fehler und Bugs 1
Kopf & Fußzeile sind verschwunden bei der Rechnungsvorlage beim Drucken JTL-Wawi 1.6 1
Neu Fehler beim Bearbeiten von Vorlagen Bausteinen JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim Abgleich mit Shopware 6.4.11.1 Onlineshop-Anbindung 3
Neu Wawi 1.6 / Kommunikation aus Wawi wird beim Lieferanten (in JTL wawi) nicht abgelegt JTL-Wawi - Fehler und Bugs 2
Neu Probleme beim Update auf 1.6 - Datenbank Fehler? Ideen zur Lösung? JTL-Wawi 1.6 1
MwSt. beim Versand JTL-Wawi 1.6 6
Neu (WooCommerce) JTL Connector Aufträge lassen sich nicht bearbeiten "Fehler beim MARS-Batch" User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler beim heutigen Update von 1.6.38.1 auf 1.6.38.2 Installation von JTL-Wawi 1
Beantwortet JTL Wawi reagiert nicht mehr beim Klick auf "VCS Rechnungsduplikate" JTL-Wawi - Fehler und Bugs 2
In Bearbeitung Wawi stürzt ab beim markieren in Listen JTL-Wawi 1.6 3
Problem beim Importieren neuer Kategorien über Ameise - Kategorien Level und Interner Schlüssel gesetzt JTL-Wawi 1.6 4
Neu Individuelle Kundennachricht beim Angebot mitschicken User helfen Usern - Fragen zu JTL-Wawi 2

Ähnliche Themen