Gelöst Fehlermeldung bei Ableich mit X-Selling

saanve

Aktives Mitglied
14. Juli 2016
50
0
Hallo zusammen,

die Hilfeseiten und die Forensuche konnten mir bisher leider nicht weiterhelfen, nun hoffe ich das hier vielleicht jemand die Erleuchtung für mich hat. :)

Es geht darum das ich die Cross Selling Funktion nutzen möchte. Ich habe heraus gefunden das dies über Funktionsattribute realisiert wird (bsp. sw_similar). Da ich zu der Handhabung keine Dokumentation finden konnte habe ich einem (Test-)Artikel unter Attribute/Merkmale einfach mal das Attribut sw_similar und den Wert test1 zugewiesen. Das gleiche habe ich auch bei einem anderen (Test-)Artikel gemacht. Da die Artikel über Var-Kombs verfügen habe ich die Attribute auch entsprechend vererbt. Doch leider wird kein XSelling-Artikel im Shopware angezeigt.

Weiß jemand was ich falsch gemacht haben könnte bzw. wie man es richtig macht !? ;)
 

saanve

Aktives Mitglied
14. Juli 2016
50
0
Wenn ich unter Artikel > Sonstiges die Cross-Selling Gruppe sw_related einstelle und unter X-Selling-Artikel einen oder mehrere Artikel auswähle erscheint nun zwar der gewünschte Artikel als Zubehör im Shop aber der Abgleich hängt bei dem Schritt Cross selling Artikel senden und es erscheint eine Fehlermeldung:

 

Daniel B.

Moderator
17. Juni 2009
1.430
39
Hey,

in der JTL-Wawi unter Artikel --> Cross-Selling-Gruppen, solltest du einmal sw_related und sw_similar sehen.

Dann einen Artikel in der JTL-Wawi anklicken (Doppelklick), damit du in die Artikeldetails gelangst.
In den Artikeldetails dann auf den Reiter Sonstiges klicken und dort einmal in den Cross-Selling-Gruppen, sw_related oder sw_similar hinzufügen.
Nach dem Hinzufügen, einmal auf die Gruppe klicken (markieren).
Rechts daneben dann bei X-Selling-Artikel die gewünschten Artikel der Gruppe hinzufügen.

Danach einen Webshop-Abgleich durchführen und du solltest im Shopware Backend sowie im Frontend das gewünschte Ergebnis sehen.
 

saanve

Aktives Mitglied
14. Juli 2016
50
0
Hey,

vielen Dank für Deine Unterstützung !

Allerdings hatte ich es zum Schluss schon genauso gemacht wie Du es beschrieben hast, mit dem Ergebnis das die Cross selling Artikel zwar im SW Frontend wie gewünscht erscheinen, allerding bleibt der Ableich bei dem Punkt Cross Sellings senden hängen und nach ein paar Sekunden erscheint im Abgleichsfenster eine lange Fehlermeldung.

Das interessante dabei: Die Fehlermeldung erscheint scheinbar immer nur bei dem ersten Cross Selling den ich für einen Artikel einstelle. Wenn ich dem Artikel also beispielsweise weitere Cross Selling Artikel hinzufüge erscheint bei dem weiteren Ableich keine Fehlermeldung mehr !? Etwas kurios aber ich denke mir das die Fehlermedung ist bestimmt nicht im Sinne des Erfinders !? ;)

Gruß,
Saanve
 

saanve

Aktives Mitglied
14. Juli 2016
50
0
Die Fehlermeldung erschint im Info-Fenster während des Shop-Abgleichs:

ps: Habe von der Fehlermeldung einen Screenshot angehängt weil mir das Forensystem scheinbar nicht erlaubt Text aus der Zwischenablage einzufügen :(
 

Anhänge

  • Unbenannt-1.jpg
    Unbenannt-1.jpg
    298,6 KB · Aufrufe: 50

saanve

Aktives Mitglied
14. Juli 2016
50
0
Hey,

die X-Sellings wurden alle gerade erst angelegt, genauso wie die entsprechenden Artikel. Daran kann es (leider) nicht liegen ..
 

Daniel B.

Moderator
17. Juni 2009
1.430
39
Dann bitte mal einen Komplettabgleich der Artikeldaten machen, damit wir vielleicht Unstimmigkeiten in der Datenbank ausschließen können.
 

saanve

Aktives Mitglied
14. Juli 2016
50
0
Hallo Daniel,
ich bin leider noch nicht dazu gekommen das zu testen. Ich tue mich zugegebener Maßen auch etwas schwer damit einen Komplettabgleich zu machen weil ich mich noch waage daran erinnern kann das es Fälle gab bei denen es nach einem Komplettabgleich zu Problemen kam. Natürlich würde es ich dennoch testen wenn sich das Problem sonst nicht beseitigen lässt, müsste aber zuvor eine Testumgebung dafür einrichten. Nun habe ich aber gesehen das seit heute eine neue Connector Version 2.0.7 zum Download bereits steht und dort steht u.a. etwas von "Fixed crossselling". Kannst Du mir sagen ob das von mir geschilderte Problem damit evtl. behoben ist ?

ps: die Fehlermeldung tritt übrigens immer nur in Verbindung mit der Vererbung von Attributen von einem Vaterartikel auf Kindartikel auf.
 

Daniel B.

Moderator
17. Juni 2009
1.430
39
Hey,

die Probleme mit dem Komplettabgleich sind in der neuen Wawi Version behoben worden. Es gab ein Mapping Fehler im Connector bei Crosssellings, du könntest davon vlt. auch betroffen sein. Dieser wurde aber mit der neuen Connector Version gefixed.

Lg,
Daniel
 
  • Gefällt mir
Reaktionen: saanve
Ähnliche Themen
Titel Forum Antworten Datum
Neu InvalidShippingServieOfferId Fehlermeldung bei zwei Österreich Aufträgen (Amazon) JTL-ShippingLabels - Fehler und Bugs 12
Gelöst Wareneingang lässt sich nicht buchen Fehlermeldung: Von den Bilddaten wurde bei der Verarbeitung ein Überlauf generiert User helfen Usern - Fragen zu JTL-Wawi 1
Neu Fehlermeldung bei hinzufügen von Artikeln mit Variationen in den Warenkorb Allgemeine Fragen zu JTL-Shop 1
Neu SQL Fehlermeldung bei ebay Abruf eBay-Anbindung - Fehler und Bugs 2
Neu Servicedesk Fehlermeldung bei Versand von Rechnungen als PDF Anhang Servicedesk (Beta) 3
Neu Fehlermeldung beim Ausliefern User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehlermeldung: Ameise - Die Sequenz enthält keine Elemente JTL-Ameise - Fehler und Bugs 3
Neu Auftrag mit Fehlermeldung bearbeitet jetzt bleibt der offen. User helfen Usern - Fragen zu JTL-Wawi 0
Neu JTL-Wawi Fehlermeldung JTL-Wawi - Fehler und Bugs 7
Neu Fehlermeldung "Prime vom Verkäufer" User helfen Usern - Fragen zu JTL-Wawi 1
Neu SQL Datenbank nicht gefunden - Fehlermeldung Individuelle Listenansichten in der JTL-Wawi 7
Neu Fehlermeldung beim aktualisiseren des Angebotes eBay-Anbindung - Fehler und Bugs 0
Neu Beim Shop abgleich kommt seit gestern immer eine Fehlermeldung mmit Interneterweiterung interner Fehler Onlineshop-Anbindung 10
Neu Anbindung mit der neuen Ansicht verursacht eine Fehlermeldung Amazon-Anbindung - Fehler und Bugs 2
Neu JTL Search aus einem URL Verzeichnis führt zur 404 Fehlermeldung Allgemeine Fragen zu JTL-Shop 5
Neu Fehlermeldung dbo.tKunde Installation von JTL-Wawi 0
In Bearbeitung Fehlermeldung JTL-POS - Fehler und Bugs 3
In Bearbeitung Fehlermeldung Bon - DHCP -> Static JTL-POS - Fehler und Bugs 8
Neu DHL Fehlermeldung Code 15 Meldung :object Reference not set to an Instance of an object JTL-ShippingLabels - Fehler und Bugs 6
Neu Fehlermeldung in der Datenbankverwaltung Performanceoptimierung User helfen Usern - Fragen zu JTL-Wawi 1
Neu Fehlermeldung beim einpflegen der Kategoriebilder in Wawi User helfen Usern - Fragen zu JTL-Wawi 3
Neu Stetige Fehlermeldung beim Zuweisen von Bildern eines Stücklistenartikels JTL-Wawi - Fehler und Bugs 1
Neu Fehlermeldung beim Erstellen von Angebot im Amazon Lister Amazon-Lister - Fehler und Bugs 3
Neu Neue Fehlermeldung - "No price for default currency defined" Shopware-Connector 6
Neu Fehlermeldung beim Webshop-Abgleich JTL-Wawi - Fehler und Bugs 9
Neu Inventur mit Fehlermeldung und anschließend falschen Beständen JTL-Wawi - Fehler und Bugs 1
Neu JTL WMS EasyShipping Fehlermeldung DHL Paket International JTL-ShippingLabels - Fehler und Bugs 3
Neu Für die aktuelle Transaktion kann kein Commit ausgeführt werden. / Fehlermeldung JTL-Wawi - Fehler und Bugs 1
Neu IST Lieferzeit von WMS bei Wareneingang übernehmen Individuelle Listenansichten in der JTL-Wawi 1
Neu Diagramm bei Statistik deaktivieren! JTL-Wawi - Ideen, Lob und Kritik 2
In Diskussion Bitte um Hilfe bei Dotliquid-Abfrage JTL-Workflows - Ideen, Lob und Kritik 3
Neu Bei Angebotsimport Produktkennzeichnung einstellen/blockieren eBay-Anbindung - Fehler und Bugs 0
Neu fragwürdiges Kostenmodell bei JTL-Vouchers JTL-Shop - Ideen, Lob und Kritik 12
Neu Artikelstammdaten, Beschreibung, "Ausgabeweg löschen" (z.B. ebay), hat "keine Auswirkung" bei Artikel aktualisieren, Marktplätze > ebay - 1.5.50.2. JTL-Wawi - Fehler und Bugs 0
Neu Neu ausgewählte (andere) Designvorlage wird nicht bei ebay aktualisiert. - 1.5.50.2 JTL-Wawi - Fehler und Bugs 0
Neu Bestand bei einem Artikel wird nicht synchronisiert Shopify-Connector 6
Neu Charge und MHD abrfage nur bei B2B Arbeitsabläufe in JTL-WMS / JTL-Packtisch+ 1
Neu JTL Rechnung werden nicht mehr bei amazon hochgeladen / Probleme mit OSS Amazon-Anbindung - Fehler und Bugs 1
Neu Shop 5.0.1: 301-Loop bei leerem Suchergebnis JTL-Shop - Fehler und Bugs 0
Neu Retoure - Häkchen bei "Versandkosten" vergessen Arbeitsabläufe in JTL-Wawi 0
Neu Bei Amazon plötzlich ohne Zutun auf falsche ASIN aufgeschaltet Amazon-Anbindung - Fehler und Bugs 4
Neu Bei FFN Lieferadresse ändern, nachdem der Auftrag schon übertragen wurde Arbeitsabläufe in JTL-Wawi 3
Neu ACHTUNG bei allen WF*s für den Versand ... User helfen Usern - Fragen zu JTL-Wawi 2
Neu Globale Vorlage den Artikelnamen bei Attribute für Modell und Produktlinie aus der JTL Wawi übernehmen Arbeitsabläufe in JTL-Wawi 6
Neu Überweisung - Bei der Kommunikation mit MoneyBookers ist ein Fehler aufgetreten Allgemeine Fragen zu JTL-Shop 0
Neu Shopify Connector Problem bei Variantenartikel wird nur eine Variation an Shopify übergeben Shopify-Connector 2
Neu Rabatt bei Lieferantenbestellung Arbeitsabläufe in JTL-Wawi 0
Neu Connector löscht Streichpreise bei Preis-Abgleich Shopware-Connector 2
Bei beiträge Speichern, Weißer Bildschirm Einrichtung JTL-Shop5 2
Neu maximale Anzahl bei Artikelbilder je Plattform über Ameise User helfen Usern - Fragen zu JTL-Wawi 0

Ähnliche Themen