Offen Fehler beim Webshopabgleich.... Hilfe

fleeko

Aktives Mitglied
30. Januar 2013
5
0
Hallo erstmal zusammen !

Ich habe seid kurzem ein Problem mit dem Webshopabgleich. Ich benutze das Shopsystem Modified eCommerce und die aktuellste Version der Wawi. Folgendes Problem tritt ein, sobald ich den Abgleich starte.

Warning: Creating default object from empty value in /pfad/zum/webspace/admin/includes/modules/jtwawi_connector/dbeS/Artikel.php on line 26

durch bestätigen durch ok kommt danach folgende Meldung

Warning: Creating default object from empty value in /pfad/zum/webspace/admin/includes/modules/jtwawi_connector/dbeS/KategorieArtikel.php on line 21

wieder ok gedrückt und nu kommt

Warning: Creating default object from empty value in /pfad/zum/webspace/admin/includes/modules/jtwawi_connector/dbeS/Attribute.php on line 23

Folgendes habe ich ohne erfolg versucht:
Neuinstallation von Wawi und SQL Server
Neuinstalltion der Shopdatenbank
Aus zwei verschiedenen Rechner versucht und auch immer das gleiche Problem.
Bide Rechner laufen mit Win7 , aber daran wird es wohl nicht liegen, da es vorher ja einwandfrei funktionierte! Kann mir vielleicht jemand weiterhelfen, bin echt Ratlos

MFG
Carsten
 

Anhänge

fleeko

Aktives Mitglied
30. Januar 2013
5
0
AW: Fehler beim Webshopabgleich.... Hilfe

Hat denn keiner ne Ahnung woran es auf einmal liegen könnte ??
 

fleeko

Aktives Mitglied
30. Januar 2013
5
0
AW: Fehler beim Webshopabgleich.... Hilfe

Selbst bei der Installation des Connectors kommt die erste Fehlermeldung. Siehe Bild

jtl-inst.jpg

Könnte mir da jemand weiterhelfen?

MFG Carsten
 

Anhänge

imageworker

Offizieller Servicepartner
SPBanner
11. Dezember 2012
1
0
Hamburg
AW: Fehler beim Webshopabgleich.... Hilfe

Ich tippe generell auf ein Kompatibilitäts- und / oder Konfigurationsproblem von PHP...
 

web-seo-consulting

Sehr aktives Mitglied
23. Juli 2011
879
69
Küps
AW: Fehler beim Webshopabgleich.... Hilfe

hmm scheinbar ist es die PHP Version.

Wenn ich php5.4.9 nehme dann kommt der Fehler.
gerade habe ich php5.2.17 hier mach ich eine komplett übertragung ohne Fehler
mal schauen wie es mit 5.3.10 läuft

Gruß
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Glaube also dass man hier wirklich mehr info posten soll.
Wie version PHP?
Version Connector, welche connector von wo weil modified hat sein eigene!

Welche shopsysteem mit welche version / updates und und.

Dan gibt es den Forum und google Suche weiter auch den WIKI's ,

Beim JTL aber auch beim Shopsysteme selbst. ;)\

Liegt naturlich nicht an php version selbst ;)

Aber ob den Shop und oder den connector fertig ist für dieser version! ?

Hier ins Forum hat man von jtl ein anpassung gemacht irgendwo zum download ins Forum php 5.4
 

web-seo-consulting

Sehr aktives Mitglied
23. Juli 2011
879
69
Küps
AW: Fehler beim Webshopabgleich.... Hilfe

Da gebe ich dir recht testjo. Aber wie du siehst habe ich mir zu helfen gewusst. In meinen 2ten Post habe ich ja dann die PHP Version geschrieben damit andere wissen das es daran hängen kann.

Gerade eben habe ich 2 komplett Übertragungen gemacht und dies alles ohne irgendwelche Fehlermeldungen. Somit denke ich war es bei mir nur die PHP Version.
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Hallo CSAEUM

Meine es so: wirklich ursache ist nicht die PHP version.
Ursache ist dass die Connector und oder Shop nicht geeignet / angepasst sind für dieser version, das ist ein wichtige unterschied die man sich merken soll, weil so einige Hoster machen ein umstellung nur auf minimal 5.4
 

charlyhahn

Sehr aktives Mitglied
1. Oktober 2009
1.665
21
Augsburg
AW: Fehler beim Webshopabgleich.... Hilfe

kannste wahrscheinlich Kippen
Fehler auch in dieser Version
Ist wahrscheinlich Php Versionsproblem
Ich schaue mir das evtl. morgen mal näher an
 

Christian Hoffmann

Aktives Mitglied
1. Juni 2013
1
0
AW: Fehler beim Webshopabgleich.... Hilfe

Hallo, bin neu hier und habe auf einmal exakt das gleiche Problem.
Nur muß ich zugeben, daß ich keine Ahnung habe wovon hier alle reden und was ich zu tun habe, um die Fehler zu beseitigen.
Kann mir da vielleicht jemand im Klartext etwas dazu sagen?
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Die connector ins download xtc (auf/von jtlsoftware.de) hat einige kleine anpassungen vielleicht nochmal downloaden und vergleichen ob es hilft weis ich so nicht, immer backups!
( weil wir benuzten andere mit utf8

Dieser anpassungen sind zum beispiel drin:
list($Kunde->billing_firstname, $Kunde->billing_lastname) = preg_split(" ",$Kunde->billing_name);
nach
list($Kunde->billing_firstname, $Kunde->billing_lastname) = explode(" ", $Kunde->billing_name);
 

Borgi

Aktives Mitglied
22. Oktober 2006
70
0
AW: Fehler beim Webshopabgleich.... Hilfe

Moin,

jetzt hat es mich auch erwischt!
Heute Nacht Umzug auf neuen Server und seither die exakt gleichen Fehlermeldungen wie oben beschrieben!

Wechsel war von PHP 5.3 auf PHP 5.4.9 und seither diese Fehlermeldungen.

Habe auch den Tipp von ag-websolutions "stelle oder bitte deinen webhoster den server so ein....dass php-warnings nicht ausgegeben werden " probiert und in die htaccess "php_flag display_errors off" eintragen lassen.
Bringt aber keine Veränderung.

Beim Connector kann ich keine Versionshinweise finden....

Benutze JTLWAWI 099894 mit nem XTmodified Shop.

Es kann nur an der PHP-Version liegen, habe sonst nix geändert und habe auch das Multishopmodul im Betrieb. Beim zweiten Shop mit identischen Artikeln und alter PHP Version kommen die Fehlermeldungen nicht.

Hat schon jemand eine brauchbare Lösung dazu gefunden?

LG

Borgi
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Sehe mal in den Forum modified wo man connector anpassungen hat glaube auch wegen php 5.4 ob 5.4.9 lauft weis ich so nicht.

OJA Connector hier from jtl hat ein erneuerung aber kein versions info dass stimt!
 

Borgi

Aktives Mitglied
22. Oktober 2006
70
0
AW: Fehler beim Webshopabgleich.... Hilfe

Hallo testjo,

danke für den Hinweis!
Hab beim modified Forum leider nichts im Zusammenhang mit dem Connector gefunden, scheint aber eine Problem mit dem modified Shop 1.5 und PHP 5.4. zu geben. Obwohl der Shop läuft einwandfrei, und der Abgleich funktioniert auch, nur kommen eben ständig diese Fehlermeldungen.
Ich melde mich nochmal wenn ich die Ursache gefunden habe.

Gruß Borgi
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Weis nicht ob die fehlermeldungen wen alles wirklich richtig lauft dan noch wichtig sein?

Nimmt er alles in in/von den atribute.php???

Suche dafür hier ins Forum wie Meldungen man die abstellen kan vielleicht.
 

Borgi

Aktives Mitglied
22. Oktober 2006
70
0
AW: Fehler beim Webshopabgleich.... Hilfe

Hallo kleines Update.... an der Shopversion lags nicht.
Habe jetzt die neuste Version 1.6 des modified installiert und die Fehlermeldung kommt noch immer.
An den Connector will ich nicht so recht ran, da hatte ich mal was geändert (glaube auch utf8 Anpassung) und habe Angst dass wenn ich da was neu installiere er mir wieder alle 3000 Artikel erneut hochlädt.
Habe auch nirgens eine anständige Anleitung gefunden wie man den aktualisieren kann, nur immer Neuinstallation.
Frustrierend weil immer irgendwas nicht funktioniert und JTL da auch kein Interesse hat was an den Connectoren zu tun.

Gruß Borgi
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Habe auch nirgens eine anständige Anleitung gefunden wie man den aktualisieren kann, nur immer Neuinstallation.
Alte Version den Forumsuche benutzen, WIKI und auch Forum suche Modified Forum selbst weil dort haben die den Connector angepasst, also wirklich support bezuglich den Kombi mit den Shopsysteem ist dort ins Modified Forum!

Und
Frustrierend weil immer irgendwas nicht funktioniert und JTL da auch kein Interesse hat was an den Connectoren zu tun.
Weiter ja connector ist alt sehe hier info's bezüglich neue JTL WAWI Connector.
http://forum.jtl-software.de/webshopanbindung/54885-shopware-anbindung-connector.html#post346109

Weiter mit den PHP da sprichst Du über den 5.4.x dafür ist den Connector angepasst worden ( JTL Connectoren download, vielleich auch den beim Modified), wen es aber noch einiges an eigene anpassungen drin gibt die nicht mit den php 5.4 laufen soll man die auch anpasssen auf die PHP version.

Dafür hat man zum beispiel al die info aus den fehler meldungen und auch error log / logs dein Hostspace womit man anfangen kan wo es ....
 

testjo

Sehr aktives Mitglied
AW: Fehler beim Webshopabgleich.... Hilfe

Zum allen die hier mitlesen den PHP 5.2.x ist eigentlich ohne Update und not supported.
Den PHP 5.3.x ist den letzte Update den 5.3.27 weiter soll es nur noch 1 Jahr lang sicherheits Updates geben, dan auch end of life.

Den PHP Version 5.5. ist aber auch drausen, also besser nicht solange warten bis es muss , vorher nachsehen testen was lauft und dieser abändern gibt weniger stress, wie auch immer man zum ende den Alte Versionen ( gezwungen, wegen hackers, oder Hoster, oder so) komt