Fehler bei Klick auf Anhang-Link in Forumsbenachrichtigung

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
372
Die Verlinkung von Anhängen in Forumsbenachrichtigungen scheint nicht richtig zu funktionieren.

Jedes Mal wenn ich in einer Benachrichtung auf einem Anhang-Link klicke, komme ich auf die Forums-Login Seite, was sicherlich der Erwartungswert ist, da Anhänge ja nur für eingeloggte Mitglieder sichtbar sind und sein sollen.

Aber nachdem ich mich einlogge und die seltsame (?) Cookie Meldung bestätige, wird mir NICHT der Anhang angezeigt, sondern ich lande jedes Mal auf einer Suchergebnis-Seite, die behauptet, ich hätte nach "Login" gesucht und die mir konsequenterweise auch viele, viele Suchergebnisse für "login" anzeigt, siehe hier...

Das Ergebnis der Suchanfrage: login

Woran kann da liegen?
 

exe

Administrator
Mitarbeiter
4. Juni 2016
493
197
Hallo gutberle !

Danke für die Rückmeldung. Ich gehe davon aus, das ich noch ein Fehler in der Webserver-Konfiguration habe. Kannst du mir bitte einen
Foren Link schicken, wo das von dir geschilderte Problem auftritt ? Ich behebe es dann schnellst möglich :)
 

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
372
Hallo exe,

zum Beispiel der Link hier. - ich habe mir das aber auch selbst noch einmal angeschaut und das Problem gefunden. Es tritt immer dann und zuverlässig auf, wenn im Browser Cookie- Cache kein JTL Cookie gespeichert ist. Ich lösche aber aus Sicherheitsgründen bei jedem Schließen des Browsers auch die komplette Historie inklusive Cookies. Soll heißen ...

a) bin ich aktuell im Forum eingelogged, wird mir beim Klick auf einen Link in einer Email-Benachrichtigung sofort der Anhang angezeigt - korrekt.
b) war ich während der laufenden Browser Session schon einmal im Forum eingelogged, muß ich mich bei Klick auf den Link anmelden und es wird mir dann der Anhang angezeigt - korrekt.
c) Ist die Browser Session neu oder nachdem ich selbst probeweise den JTL Cookie entfernt habe, tritt zuverlässig die Kaskade "Login > Cookie Bestätigung > Login-Suche..." auf. - inkorrekt.

Hoffe, das hilft...

Gruß,
Ingmar
 

exe

Administrator
Mitarbeiter
4. Juni 2016
493
197
Hallo gutberle !

Danke für das ganze Feedback. Das Plugin hat wohl Probleme mit seinem Cookie-Management :) Es sollte nun behoben sein, kannst du es bitte nochmals ausprobieren ?!

Gruß
Exe
 

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
372
Hallo Exe,

hab's jetzt mit einigen Artikel- und Anhangslinks probiert und alles funktioniert einwandfrei. Danke für die schnelle Abhilfe!

Gruß,
Ingmar
 
  • Gefällt mir
Reaktionen: exe
Ähnliche Themen
Titel Forum Antworten Datum
Neu Fehler bei Exportvorgang User helfen Usern - Fragen zu JTL-Wawi 4
Nach upgrade auf shop 5: Fehler "#account data.yourDataDesc#" bei Anlegen Kundendaten Upgrade JTL-Shop4 auf JTL-Shop5 1
Neu Fehler bei der Amazon Einrichtung Amazon-Anbindung - Fehler und Bugs 1
Neu Eigene Fehler bei Artikel duplizieren werden nicht übernommen JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehler bei Rabatt-Einzelposition JTL-POS - Fehler und Bugs 1
Neu Fehler bei Update 16.32.0 auf 1.6.32.1: Datenbank-Sortierungskonflikt JTL-Wawi - Fehler und Bugs 4
Neu Fehler bei Authentifizierung - Das Passwort in den Onlinshopeinstellungen ist falsch Allgemeines zu den JTL-Connectoren 0
Fehler bei Update: "" is not a valid SemVer Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Fehler bei Artikeldetailseite auf der Startseite Betrieb / Pflege von JTL-Shop 0
Neu Fehler bei der Auftragserstellung: Für die aktuelle Transaktion kann kein Commit ausgeführt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu HTTP 500 Fehler bei Newsbeiträgen! User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler bei Update von 1.35 auf neueste Version JTL-Wawi - Fehler und Bugs 2
Neu Überweisung - Bei der Kommunikation mit MoneyBookers ist ein Fehler aufgetreten Allgemeine Fragen zu JTL-Shop 0
Neu Fehler bei Update bei 1.5.30 JTL-Wawi - Fehler und Bugs 1
Neu Nach Update auf JTL-Wawi 1.6.33.1 - Fehler beim Onlineshopabgleich JTL-Wawi - Fehler und Bugs 1
Neu JTL Connector zu Shopware 6 gibt Fehler aus Onlineshop-Anbindung 0
Gelöst JTL POS stürzt beim Starten ab und Zeigt Fehler: JTL POS muss beendet werden 1.0.5.17 (4390) JTL-POS - Fehler und Bugs 4
Gelöst Fehler: Sie besitzen keine Lizenz für JTL-WMS JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
In Bearbeitung Fehler beim Bon Druck mit Sunmi T2 lite JTL-POS - Fehler und Bugs 2
Neu Fehler Lagerwertung Der objektverweis wurde nicht auf eine objektinstanz festgelegt JTL-Wawi - Fehler und Bugs 1
Neu Amazon VCS RE-Anschrift ohne PLZ - Datev Export Fehler Amazon-Anbindung - Fehler und Bugs 0
Neu DHL 3.0, Versandart ändern -> Retoure -> Fehler JTL-ShippingLabels - Fehler und Bugs 0
Neu ecoDMS / ecoWorkz Fehler User helfen Usern 0
Neu Shopware - Fehler beim Senden von Artikeln Shopware-Connector 0
Fehler wegen der Kompirimierung von css und js?? Upgrade JTL-Shop4 auf JTL-Shop5 10
Neu Onlineshopabgleich mit Shopify Store - Fehler JTL-Wawi - Fehler und Bugs 0
Neu DHL Express GWS Fehler Bug ( /shipreq:ShipmentRequest/RequestedShipment/ShipmentInfo/Currency) JTL-ShippingLabels - Fehler und Bugs 2
Neu Abgleich wegen Fehler nicht mehr möglich Shopware-Connector 3
Neu Fehler Update 5.0.1 auf 5.0.4 Installation / Updates von JTL-Shop 1
Neu Fehler beim Erstellen des GoogleShopping.xml (Plugin) JTL-Shop - Fehler und Bugs 0
Neu Fehler beim FTP Import User helfen Usern - Fragen zu JTL-Wawi 4
Neu Update von 5.1 auf 5.11 Fehler Installation / Updates von JTL-Shop 3
Neu Update Fehler 1.6.33.1 - Collations JTL-Wawi - Fehler und Bugs 5
Beantwortet Fehler in Shop 5 JTL-Shop - Fehler und Bugs 4
Neu Connector Fehler beim Verbindungsaufbau WooCommerce-Connector 0
Neu Fehler HTTP ERROR 500 JTL-Wawi - Fehler und Bugs 0
Neu DB-Fehler beim Update von 1.5 auf 1.6: Foreign Key in tBestellung JTL-Wawi - Fehler und Bugs 0
Verwiesen an Support 3400 Fehler im Logbuch vom Shop 5 JTL-Shop - Fehler und Bugs 2
Neu Ebay - Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler eBay-Anbindung - Fehler und Bugs 2
Verwiesen an Support Fehler beim Verpacken JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Umzug von Server 2012R2 mit SQL-Server 2012 auf Server 2019 mit SQL-Server 2017 Fehler Collation Installation von JTL-Wawi 1
Neu UPDATE Fehler von 1.5.36.2 auf 1.5.51.1 Installation von JTL-Wawi 0
Neu Exec Direct, es ist ein Fehler aufgetreten, Aufträge öffnen und bearbeiten JTL-Wawi - Fehler und Bugs 0
Neu Fehler: #959190594F6282F Shopware-Connector 2
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Onlineshop-Anbindung 0
Neu Plugin: "JTL Theme Editor" in Shop 5 - Fehler beim Speichern der Datei. Allgemeine Fragen zu JTL-Shop 6
Neu [DHL] Erstellen von Versandetiketten kommt zum Fehler - die Ausgewählte Abrechnungsnummer steht nicht zur Verfügung JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Installation / Updates von JTL-Shop 3
Verwiesen an Support In der Aktion '50' ist ein Fehler aufgetreten .. JTL-Workflows - Fehler und Bugs 2
Neu WooCommerce Artikel Synchronisation bringt Fehler WooCommerce-Connector 0

Ähnliche Themen