Fehler bei Klick auf Anhang-Link in Forumsbenachrichtigung

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
369
Die Verlinkung von Anhängen in Forumsbenachrichtigungen scheint nicht richtig zu funktionieren.

Jedes Mal wenn ich in einer Benachrichtung auf einem Anhang-Link klicke, komme ich auf die Forums-Login Seite, was sicherlich der Erwartungswert ist, da Anhänge ja nur für eingeloggte Mitglieder sichtbar sind und sein sollen.

Aber nachdem ich mich einlogge und die seltsame (?) Cookie Meldung bestätige, wird mir NICHT der Anhang angezeigt, sondern ich lande jedes Mal auf einer Suchergebnis-Seite, die behauptet, ich hätte nach "Login" gesucht und die mir konsequenterweise auch viele, viele Suchergebnisse für "login" anzeigt, siehe hier...

Das Ergebnis der Suchanfrage: login

Woran kann da liegen?
 

exe

Administrator
Mitarbeiter
4. Juni 2016
493
197
Hallo gutberle !

Danke für die Rückmeldung. Ich gehe davon aus, das ich noch ein Fehler in der Webserver-Konfiguration habe. Kannst du mir bitte einen
Foren Link schicken, wo das von dir geschilderte Problem auftritt ? Ich behebe es dann schnellst möglich :)
 

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
369
Hallo exe,

zum Beispiel der Link hier. - ich habe mir das aber auch selbst noch einmal angeschaut und das Problem gefunden. Es tritt immer dann und zuverlässig auf, wenn im Browser Cookie- Cache kein JTL Cookie gespeichert ist. Ich lösche aber aus Sicherheitsgründen bei jedem Schließen des Browsers auch die komplette Historie inklusive Cookies. Soll heißen ...

a) bin ich aktuell im Forum eingelogged, wird mir beim Klick auf einen Link in einer Email-Benachrichtigung sofort der Anhang angezeigt - korrekt.
b) war ich während der laufenden Browser Session schon einmal im Forum eingelogged, muß ich mich bei Klick auf den Link anmelden und es wird mir dann der Anhang angezeigt - korrekt.
c) Ist die Browser Session neu oder nachdem ich selbst probeweise den JTL Cookie entfernt habe, tritt zuverlässig die Kaskade "Login > Cookie Bestätigung > Login-Suche..." auf. - inkorrekt.

Hoffe, das hilft...

Gruß,
Ingmar
 

exe

Administrator
Mitarbeiter
4. Juni 2016
493
197
Hallo gutberle !

Danke für das ganze Feedback. Das Plugin hat wohl Probleme mit seinem Cookie-Management :) Es sollte nun behoben sein, kannst du es bitte nochmals ausprobieren ?!

Gruß
Exe
 

gutberle

Sehr aktives Mitglied
29. März 2011
1.280
369
Hallo Exe,

hab's jetzt mit einigen Artikel- und Anhangslinks probiert und alles funktioniert einwandfrei. Danke für die schnelle Abhilfe!

Gruß,
Ingmar
 
  • Gefällt mir
Reaktionen: exe
Ähnliche Themen
Titel Forum Antworten Datum
Fehler bei Update: "" is not a valid SemVer Upgrade JTL-Shop4 auf JTL-Shop5 0
Neu Fehler bei Artikeldetailseite auf der Startseite Betrieb / Pflege von JTL-Shop 0
Neu Fehler bei der Auftragserstellung: Für die aktuelle Transaktion kann kein Commit ausgeführt werden User helfen Usern - Fragen zu JTL-Wawi 0
Neu HTTP 500 Fehler bei Newsbeiträgen! User helfen Usern - Fragen zu JTL-Wawi 0
Neu Fehler bei Update von 1.35 auf neueste Version JTL-Wawi - Fehler und Bugs 2
Neu Überweisung - Bei der Kommunikation mit MoneyBookers ist ein Fehler aufgetreten Allgemeine Fragen zu JTL-Shop 0
Neu Fehler bei Update bei 1.5.30 JTL-Wawi - Fehler und Bugs 1
Neu WAWI Fehler bei Statistik - eigene Vorlage JTL-Wawi - Fehler und Bugs 1
Neu Fehler in der Konfiguration bei Artikel in Warenkorb Allgemeine Fragen zu JTL-Shop 0
Neu JTL Shop 5.1 kritischer Fehler bei Installation mit Demodaten Installation / Updates von JTL-Shop 1
Neu Fehler bei Kommunikation mit Server - Repricer funktioniert nicht JTL-Repricer für JTL-Wawi und Web 0
JTL Shop Sitemap Probleme Allgemeiner HTTP Fehler bei Google Einrichtung JTL-Shop5 11
Neu Fehler bei der Migration auf InnoDB - tzahlungslog Upgrade JTL-Shop4 auf JTL-Shop5 6
Neu Fehler beim Verbindungsaufbau: Exception bei global_data.pull: Short and Long cannot be null Modified eCommerce-Connector 0
Neu Fehler bei der Synchronisierung mit Shopware Starten mit JTL: Projektabwicklung & Migration 2
Fehler bei der Installation von JTL Shop 5 Einrichtung JTL-Shop5 3
Einstellen von Schrift und Farbe & Fehler bei Anzeigen von Bildern Einrichtung JTL-Shop5 3
Neu DB-Fehler beim Update von 1.5 auf 1.6: Foreign Key in tBestellung JTL-Wawi - Fehler und Bugs 0
Verwiesen an Support 3400 Fehler im Logbuch vom Shop 5 JTL-Shop - Fehler und Bugs 1
Neu Ebay - Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler eBay-Anbindung - Fehler und Bugs 2
Neu Fehler beim Verpacken JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Neu Umzug von Server 2012R2 mit SQL-Server 2012 auf Server 2019 mit SQL-Server 2017 Fehler Collation Installation von JTL-Wawi 1
Neu UPDATE Fehler von 1.5.36.2 auf 1.5.51.1 Installation von JTL-Wawi 0
Neu Exec Direct, es ist ein Fehler aufgetreten, Aufträge öffnen und bearbeiten JTL-Wawi - Fehler und Bugs 0
Neu Fehler: #959190594F6282F Shopware-Connector 2
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Onlineshop-Anbindung 0
Neu Plugin: "JTL Theme Editor" in Shop 5 - Fehler beim Speichern der Datei. Allgemeine Fragen zu JTL-Shop 5
Neu [DHL] Erstellen von Versandetiketten kommt zum Fehler - die Ausgewählte Abrechnungsnummer steht nicht zur Verfügung JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehler beim Anlegen von Verkaufskanal Shop5 im Testsystem Installation / Updates von JTL-Shop 3
Verwiesen an Support In der Aktion '50' ist ein Fehler aufgetreten .. JTL-Workflows - Fehler und Bugs 2
Neu WooCommerce Artikel Synchronisation bringt Fehler WooCommerce-Connector 0
Neu Fehler beim Shopware Shopabgleich JTL-Wawi - Fehler und Bugs 0
Neu Kein Amazon Token mehr in Einstellungen vorhanden - Fehler PrimeSeller Versand Amazon-Anbindung - Fehler und Bugs 2
Beantwortet Plugin entfernen? SEO-Cleaner [35 Fehler: XML-Version entspricht nicht der Konvention.] Betrieb / Pflege von JTL-Shop 2
Neu Update Fehler auf JTL-Wawi Open Beta 1.6.31.2 Installation von JTL-Wawi 2
Neu Update auf Open Beta Fehler Installation von JTL-Wawi 2
Gelöst Pos verbindungs Fehler Einrichtung / Updates von JTL-POS 2
Gelöst Fehler Warenpost International (Kilotarif) JTL-ShippingLabels - Fehler und Bugs 1
Neu Servicedesk verusacht Fehler "zu wenig Arbeitsspeicher" Servicedesk (Beta) 1
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu eBay Abgleich Fehler "Error calling EaEbay" eBay-Anbindung - Fehler und Bugs 4
Neu JTL-WAWI 1.6.31.2 Ebay Abgleich Fehler eBay-Anbindung - Fehler und Bugs 4
Issue angelegt UstID Fehler beim Import über Ameise - Wawi V1.5.49.1 User helfen Usern - Fragen zu JTL-Wawi 2
Neu Fehler WMS "Ohne Fehlmengenbehandlung nicht erlaubt" JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
Backend Fehler 500 nach Upgrade von Vers. 4.6.17 auf 5.1.1 Upgrade JTL-Shop4 auf JTL-Shop5 8
Neu Plugin für DHL Wunschpaket Standort Fehler? Plugins für JTL-Shop 24
Neu Fehler beim Anlegen einer Umlagerung / Amazon-SKU Fehler Amazon-Lister - Fehler und Bugs 0
Neu Fehler nach upload zu Ebay eBay-Anbindung - Fehler und Bugs 0
Neu Fehler im Logbuch + häufiger Shopabsturz mit 503-Fehler JTL-Shop - Fehler und Bugs 2
Neu INSERT Fehler beim Duplizieren von Artikeln JTL-Wawi - Fehler und Bugs 1

Ähnliche Themen