Neu Fehler 404 bei Magento Connector

binary-artworks.com

Aktives Mitglied
21. September 2016
27
2
Hallo zusammen,

leider bekomme ich den Connector nicht zum Laufen, obwohl ich exakt nach Anleitung (https://guide.jtl-software.de/jtl/Kategorie:JTL-Connector:Magento) vorgegangen bin.

JTL Wawi: 1.1.4.7 (vorher mit Version 1.1.4.3 ebenfalls Fehlschlag)
Magento: 1.9.3.0 (frisch installiert, sonstige Plugins nur FireGento_MageSetup, Locale_Mage_community_de_DE)
Connector: 1.4.5.0 (auch im Kundencenter mit richtiger URL hinterlegt)

Unter https://URLZumShop/jtlconnector (Testsystem) erhalte ich wie im Forum beschrieben ein JSON als Fehlermeldung zurück, was korrektes Verhalten zu sein scheint:
{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception: RpcException - File: \/var\/www\/path\/to\/dev\/customerX-webshop\/lib\/jtlconnector\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php - Line: 173"},"jtlrpc":"2.0","id":null}
(Ja, auch mit Backslash und Slash vor den Bestandteilen des Pfades)

Laut Apache Log versucht die WaWi, einen POST an /jtlconnector/dbeS/mytest.php" abzusetzen:
192.168.200.21 - - [19/Oct/2016:10:51:46 +0200] "POST /jtlconnector/dbeS/mytest.php HTTP/1.1" 404 23110 "-" "JTL-Wawi"
und erhält dabei eine 404-Fehlermeldung von Magento. Diese Seite selbst via Browser ebenfalls nicht erreichbar, ich erhalte nur eine Magento-Fehlerseite. Shop und Admin-Backend sind vom WaWi-Testsystem problemlos erreichbar.

Wenn ich diesen POST abfange, enthält er folgende Daten:
[uID] =>
[uPWD] => API_KEY_AUS_MAGENTO_JTL_CONFIG_PAGE
[kKunde] => 0
[kBestellung] => 1
[kLieferadresse] => 0
[kZahlungseingang] => 0
[wawiversion] => 114700

uPWD entspricht dabei dem API-Key aus der Config-Seite im Magento.

Laut Connectorcheck (installiert unter https://URLZumShop/connectorcheck/) sind alle Voraussetzungen erfüllt.

Hat jemand eine zündende Idee, woran es liegen könnte?

Vielen Dank schon einmal!
 

b4u

Aktives Mitglied
13. November 2016
1
0
Hi binary-artworks,

wir haben derzeit das gleiche Problem mit fast dem gleichen Setup.

Konntest du das Problem mittlerweile lösen?

LG
 

binary-artworks.com

Aktives Mitglied
21. September 2016
27
2
Hallo b4u,

Ja, konnte ich. Das Problem lag daran, dass der Connector offenbar nach dem o.g. HTTPS-Request (siehe Log) auch HTTP-Requests absetzt, während er den verwendeten Shop durchprobiert. Die kamen natürlich nicht an, wenn nur Port 443 frei ist. Dabei war egal, ob man in der WaWi "https" oder einen anderen Port angibt. Offenbar ist das fest gecodet.

Die (vorläufige) Lösung war, den Shop auch via HTTP erreichbar zu machen. Bei Bedarf kann ich dir auch die Apache-Config zukommen lassen.
Noch ausstehend:
- Test mit Rewrite
- Reaktivierung der SSL-only-Konfiguration

Es wäre natürlich wünschenswert, wenn nicht nur der Checkout-Prozess über eine gesicherte Verbindung läuft...
 

yanni

Aktives Mitglied
28. Mai 2013
7
0
Ich weiß nicht wo bei Dir der 404er genau auftritt. Ich habe ihn im Backend beim Aufruf der Extensions unter Konfiguration. Cache geleert, ausgeloggt und wieder eingeloggt. Magento 1.9.2.4. Connector 1.4.5.0. Laut Systemcheck alle Voraussetzungen erfüllt.

Dies erhalte ich im Frontend
{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception: RpcException - File: \/www\/htdocs\/v123703\/xxx\/lib\/jtlconnector\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php - Line: 173"},"jtlrpc":"2.0","id":null}
 

bjt

Aktives Mitglied
14. Dezember 2016
2
1
@yanni

Habe das gleiche Problem wie du. Im Backend lässt sich der config bereich nicht aufrufen da kommt 404 Page Not Found.

Das ganze muss ein Konfigurationsspezifisches Problem sein. Entweder vom Shop oder vom Server.

Ich habe die Version 1.4.5.0 auf 2 unterschiedlichen Servern mit unterschiedlichen Magento 1.9.x Versionen probiert. Auf dem einen geht es. Auf dem anderen nicht.
Ich versuchs mal rauszufinden was da dran schuld ist.
 

bjt

Aktives Mitglied
14. Dezember 2016
2
1
i found the problem.

the problem is located in the file:
/app/code/community/Jtl/ Connector/Block|SynchronizationUrl.php
Line: 6
Mage::app()->getStore(1)->getBaseUrl(Mage_Core_Model_Store::URL_TYPE_LINK);
Mage::app()->getStore(1) can only work if you have a store with the id 1. if not you get an 404 error from magento
change Line 6 to
Mage::app()->getStore(0)->getBaseUrl(Mage_Core_Model_Store::URL_TYPE_LINK);
store 0 is everytime avaiable because its the admin storeview
 
  • Gefällt mir
Reaktionen: D.Basist
Ähnliche Themen
Titel Forum Antworten Datum
Neu Beim Shop abgleich kommt seit gestern immer eine Fehlermeldung mmit Interneterweiterung interner Fehler JTL-Shop - Fehler und Bugs 0
Neu Open Vpn mit JTL Wawi - Netzlaufwerke Fehler Installation von JTL-Wawi 4
Neu Netzwerkdrucker gehen nicht mehr Fehler 0x0000011b User helfen Usern 4
Neu Ameise Import Fehler - Falsche Formatierung JTL-Ameise - Fehler und Bugs 3
In Bearbeitung Fehler "Typ " 'Decimal' für Eigenschaft 'Anzahl' konvertiert werden. " in Worflow mit DotLiquid JTL-Workflows - Ideen, Lob und Kritik 3
Neu Der Remoteserver hat einen Fehler zurückgegeben: (500) Interner Serverfehler. WooCommerce-Connector 0
Gelöst Picklistenerstellung Fehler @kAmazonUser... [WAWI-57509] JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 4
Neu (!) JTL Shop 5 Fehler "Struktur-Migration" Installation / Updates von JTL-Shop 3
Neu Artikel duplizieren erzeugt immer diesen Fehler User helfen Usern - Fragen zu JTL-Wawi 7
Neu Woocomerce Shop Ablgeich Fehler JTL-Plugin : CustomerTrait.php:68 WooCommerce-Connector 1
Neu Fehler beim Update auf 5.1 JTL-Shop - Fehler und Bugs 2
Neu Allgemeiner Fehler wenn DHL Labels gleichzeitig erstellt werden JTL-ShippingLabels - Fehler und Bugs 0
Neu JTL Shop 5.1 kritischer Fehler bei Installation mit Demodaten Installation / Updates von JTL-Shop 1
Neu Fehler bei Kommunikation mit Server - Repricer funktioniert nicht JTL-Repricer für JTL-Wawi und Web 0
Neu Amazon Fehler Code 99001 - Maße Kopf bis Fuss, Seite zu Seite und Boden bis Unterkante Amazon-Lister - Fehler und Bugs 2
Neu DHL Express GWS Fehler JTL-ShippingLabels - Fehler und Bugs 0
Neu Fehler mit Sonderzeichen in den Metadaten der Artikel. JTL-Wawi - Fehler und Bugs 0
Neu Fehler beim laden des Projektbausteins JTL-Wawi - Fehler und Bugs 1
Neu Fehler beim Shopabgleich Modified eCommerce-Connector 0
Neu WMS Mobile immer wieder Fehler JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 0
JTL Shop Sitemap Probleme Allgemeiner HTTP Fehler bei Google Einrichtung JTL-Shop5 10
Neu Feld "image" fehlt Google Search Console Fehler JTL Shop 4 Allgemeine Fragen zu JTL-Shop 1
Neu Fehler bei der Migration auf InnoDB - tzahlungslog Upgrade JTL-Shop4 auf JTL-Shop5 6
Neu Ungültige Backend-Antwort. Ein serverseitiger Fehler trat auf. HTTP error 500 Installation / Updates von JTL-Shop 0
Neu Fehler beim Verbindungsaufbau: Exception bei global_data.pull: Short and Long cannot be null Modified eCommerce-Connector 0
PHP Version 7.4 + 8 generiert Fehler 500 (shop5) Einrichtung JTL-Shop5 1
Neu Fehler bei der Synchronisierung mit Shopware Starten mit JTL: Projektabwicklung & Migration 2
Neu Fehler beim Update -kein Update möglich User helfen Usern - Fragen zu JTL-Wawi 1
Neu 26.08.2021 16:30 Uhr - ABGLEICH FEHLER eBay-Anbindung - Fehler und Bugs 2
Neu Shop 5 Installation Fehler Keine config.JTL-Shop.ini.php gefunden. JTL-Shop - Fehler und Bugs 2
Neu Passwort es ist ein Fehler aufgetreten Allgemeine Fragen zu JTL-Shop 2
Fehler bei der Installation von JTL Shop 5 Einrichtung JTL-Shop5 3
Einstellen von Schrift und Farbe & Fehler bei Anzeigen von Bildern Einrichtung JTL-Shop5 3
Neu Fehler "Mehrere Stammelemente vorhanden in Zeile.." beim Versuch Shopdaten zu updaten Arbeitsabläufe in JTL-Wawi 0
Neu Fehler beim Onlineshop-Abgleich (Bilder Synchronisation) Onlineshop-Anbindung 0
Neu Fehler beim Artikel duplizieren seit Wawi 1.5.48.1 JTL-Wawi - Fehler und Bugs 2
Neu Ständig amazon worker Abgleich Fehler JTL-Wawi - Fehler und Bugs 4
Neu Fehler bei Account xxxx [Amazon.de]: Ihr Account ist nicht aktiv. Amazon-Anbindung - Fehler und Bugs 1
Neu Fehler bei erster Anbindung eBay-Anbindung - Fehler und Bugs 2
Neu Fehler aus der Amazon Schnittstelle Amazon-Anbindung - Fehler und Bugs 1
Neu Abgleich schlägt fehler - wp_jtl_connector_link_tax_class existiert nicht WooCommerce-Connector 0
Fehler bei Update: "SQLSTATE[42S01]: Base table or view already exists Upgrade JTL-Shop4 auf JTL-Shop5 4
Neu Backup nicht möglich, Fehler. Hilfe! JTL-Wawi - Fehler und Bugs 3
Neu Fehler-Anzeige beim duplizieren von Artikel Wawi 1.5.48.0 JTL-Wawi - Fehler und Bugs 4
Neu Update Version von 1.5.47.2 nach 1.5.48 (fehler) JTL-Wawi - Fehler und Bugs 3
Neu Backend>System>Weiterleitungen - Fehler oder ignorieren? Betrieb / Pflege von JTL-Shop 0
Neu Fehler beim ausführen des shop5 Testskript (Systemcheck) Installation / Updates von JTL-Shop 7
Neu Probleme beim Import / Abgleich von Amazon Bestellungen (Fehler / Das angegebene Argument liegt außerhalb des gültigen Wertebereichs ) User helfen Usern - Fragen zu JTL-Wawi 1
Neu Wawi/Versand/Pakete "Fehler beim Laden der Daten" Wawi 1.5.47.3 mit remote DB JTL-Wawi - Ideen, Lob und Kritik 1
Neu Fehler bei Bildübertragung Gambio-Connector 6

Ähnliche Themen