Neu Fehler 404 bei Magento Connector

binary-artworks.com

Aktives Mitglied
21. September 2016
27
2
Hallo zusammen,

leider bekomme ich den Connector nicht zum Laufen, obwohl ich exakt nach Anleitung (https://guide.jtl-software.de/jtl/Kategorie:JTL-Connector:Magento) vorgegangen bin.

JTL Wawi: 1.1.4.7 (vorher mit Version 1.1.4.3 ebenfalls Fehlschlag)
Magento: 1.9.3.0 (frisch installiert, sonstige Plugins nur FireGento_MageSetup, Locale_Mage_community_de_DE)
Connector: 1.4.5.0 (auch im Kundencenter mit richtiger URL hinterlegt)

Unter https://URLZumShop/jtlconnector (Testsystem) erhalte ich wie im Forum beschrieben ein JSON als Fehlermeldung zurück, was korrektes Verhalten zu sein scheint:
{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception: RpcException - File: \/var\/www\/path\/to\/dev\/customerX-webshop\/lib\/jtlconnector\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php - Line: 173"},"jtlrpc":"2.0","id":null}
(Ja, auch mit Backslash und Slash vor den Bestandteilen des Pfades)

Laut Apache Log versucht die WaWi, einen POST an /jtlconnector/dbeS/mytest.php" abzusetzen:
192.168.200.21 - - [19/Oct/2016:10:51:46 +0200] "POST /jtlconnector/dbeS/mytest.php HTTP/1.1" 404 23110 "-" "JTL-Wawi"
und erhält dabei eine 404-Fehlermeldung von Magento. Diese Seite selbst via Browser ebenfalls nicht erreichbar, ich erhalte nur eine Magento-Fehlerseite. Shop und Admin-Backend sind vom WaWi-Testsystem problemlos erreichbar.

Wenn ich diesen POST abfange, enthält er folgende Daten:
[uID] =>
[uPWD] => API_KEY_AUS_MAGENTO_JTL_CONFIG_PAGE
[kKunde] => 0
[kBestellung] => 1
[kLieferadresse] => 0
[kZahlungseingang] => 0
[wawiversion] => 114700

uPWD entspricht dabei dem API-Key aus der Config-Seite im Magento.

Laut Connectorcheck (installiert unter https://URLZumShop/connectorcheck/) sind alle Voraussetzungen erfüllt.

Hat jemand eine zündende Idee, woran es liegen könnte?

Vielen Dank schon einmal!
 

b4u

Aktives Mitglied
13. November 2016
1
0
Hi binary-artworks,

wir haben derzeit das gleiche Problem mit fast dem gleichen Setup.

Konntest du das Problem mittlerweile lösen?

LG
 

binary-artworks.com

Aktives Mitglied
21. September 2016
27
2
Hallo b4u,

Ja, konnte ich. Das Problem lag daran, dass der Connector offenbar nach dem o.g. HTTPS-Request (siehe Log) auch HTTP-Requests absetzt, während er den verwendeten Shop durchprobiert. Die kamen natürlich nicht an, wenn nur Port 443 frei ist. Dabei war egal, ob man in der WaWi "https" oder einen anderen Port angibt. Offenbar ist das fest gecodet.

Die (vorläufige) Lösung war, den Shop auch via HTTP erreichbar zu machen. Bei Bedarf kann ich dir auch die Apache-Config zukommen lassen.
Noch ausstehend:
- Test mit Rewrite
- Reaktivierung der SSL-only-Konfiguration

Es wäre natürlich wünschenswert, wenn nicht nur der Checkout-Prozess über eine gesicherte Verbindung läuft...
 

yanni

Aktives Mitglied
28. Mai 2013
7
0
Ich weiß nicht wo bei Dir der 404er genau auftritt. Ich habe ihn im Backend beim Aufruf der Extensions unter Konfiguration. Cache geleert, ausgeloggt und wieder eingeloggt. Magento 1.9.2.4. Connector 1.4.5.0. Laut Systemcheck alle Voraussetzungen erfüllt.

Dies erhalte ich im Frontend
{"result":null,"error":{"code":-32600,"message":"Invalid Request","data":"Exception: RpcException - File: \/www\/htdocs\/v123703\/xxx\/lib\/jtlconnector\/jtl\/connector\/src\/jtl\/Connector\/Core\/Rpc\/RequestPacket.php - Line: 173"},"jtlrpc":"2.0","id":null}
 

bjt

Aktives Mitglied
14. Dezember 2016
2
1
@yanni

Habe das gleiche Problem wie du. Im Backend lässt sich der config bereich nicht aufrufen da kommt 404 Page Not Found.

Das ganze muss ein Konfigurationsspezifisches Problem sein. Entweder vom Shop oder vom Server.

Ich habe die Version 1.4.5.0 auf 2 unterschiedlichen Servern mit unterschiedlichen Magento 1.9.x Versionen probiert. Auf dem einen geht es. Auf dem anderen nicht.
Ich versuchs mal rauszufinden was da dran schuld ist.
 

bjt

Aktives Mitglied
14. Dezember 2016
2
1
i found the problem.

the problem is located in the file:
/app/code/community/Jtl/ Connector/Block|SynchronizationUrl.php
Line: 6
Mage::app()->getStore(1)->getBaseUrl(Mage_Core_Model_Store::URL_TYPE_LINK);
Mage::app()->getStore(1) can only work if you have a store with the id 1. if not you get an 404 error from magento
change Line 6 to
Mage::app()->getStore(0)->getBaseUrl(Mage_Core_Model_Store::URL_TYPE_LINK);
store 0 is everytime avaiable because its the admin storeview
 
  • Gefällt mir
Reaktionen: D.Basist
Ähnliche Themen
Titel Forum Antworten Datum
Neu JTL Fulfillment Artikeldaten senden und aktualisieren FEHLER " Product not found" Arbeitsabläufe in JTL-Wawi 1
Onpage Composer Rich Text Editor Fehler Einrichtung JTL-Shop5 1
Neu Fehler - weiße seite bei sprach wechsel auf englisch JTL-Shop - Fehler und Bugs 3
Beantwortet Sammelumlagerungen direkt Fehler nach Umbuchung JTL-WMS / JTL-Packtisch+ - Fehler und Bugs 1
Neu Fehler beim Update in Version 1.5.47.3 (1.5.47.0) JTL-Wawi - Fehler und Bugs 1
Neu 1.5.38.1 Rechnung Email Vorlage Variablen Fehler JTL-Wawi - Fehler und Bugs 2
Neu Bestandsabgleich funktioniert nicht - Fehler Code 99001 A value is required for the "fullfillment_center_id" Amazon-Anbindung - Fehler und Bugs 19
Neu Lieferschein Exportvorlagen Fehler Druck-/ E-Mail-/ Exportvorlagen in JTL-Wawi 0
Neu Variantebilder werden nicht angezeigt / SQL Fehler Shopware-Connector 0
Neu Fehler nach Server-Umzug JTL-Wawi - Fehler und Bugs 5
In Bearbeitung Barcodeschema-Fehler JTL-POS - Fehler und Bugs 4
Gelöst Fehler beim Druck der Pickliste Arbeitsabläufe in JTL-Wawi 2
Neu Amazon Variation Fehler Amazon-Anbindung - Ideen, Lob und Kritik 0
Neu Fehler beim Upload von Bildern mit OPC JTL-Shop - Fehler und Bugs 1
In Bearbeitung Was macht man, wenn beim Kassiervorgang ein Fehler passiert? Allgemeine Fragen zu JTL-POS 4
Neu JTL-Wawi startet nicht mehr. Es ist ein Fehler aufgetreten. Der Wert darf nicht NULL sein. JTL-Wawi - Fehler und Bugs 8
Neu nach Anmeldung kommt Fehler: Der Wert darf nicht NULL sein. Parametername: key JTL-Wawi - Fehler und Bugs 2
Neu Warenkorb - Variations -if-Abfrage - wo habe ich den Fehler gemacht?????????? User helfen Usern 1
Neu JTL-Wawi Fehler bei der Anmeldung JTL-Wawi - Fehler und Bugs 3
In Bearbeitung Fehler bei mehreren gleichen Produkten Allgemeine Fragen zu JTL-POS 3
Neu Fehler bei Übertragung (413) Request Entity Too Large + The EntityManger is closed Shopware-Connector 7
Neu Woo Connector connector.identify "Der Remoteserver hat einen Fehler zurückgegeben: (403) Unzulässig. WooCommerce-Connector 1
Neu Fehler im Update 1.5.46.1 auf 1.5.46.4 Installation von JTL-Wawi 11
In Bearbeitung Swissbit TSE , Fehler seit Update JTL-POS - Fehler und Bugs 23
Neu Shopabgleich Fehler "uncaught error call to a member function" Jtl Shop JTL-Wawi - Fehler und Bugs 1
JTL Shop 5: Warenkorb - Fehler bei Steuer B2B-Kunden? Ausblenden der Versandkosten, wenn 0,00 € möglich? Einrichtung JTL-Shop5 2
Neu Anbindung Script Fehler Amazon-Anbindung - Fehler und Bugs 0
Neu Update von 4.05 auf 4.06.17 Fehler - weiße Seite nach Bestellabschluss JTL-Shop - Fehler und Bugs 1
Neu Fehler nach Update auf Shop 5.0.3 Installation / Updates von JTL-Shop 1
Bilder in News und Header löschen - Fehler noch existent Einrichtung JTL-Shop5 3
Neu Fehler bei Wareneingang JTL-Wawi - Fehler und Bugs 1
Neu Emailbestätigung Shop - LocalizedEinzelpreis - Bedingung - Wo liegt der Fehler? Betrieb / Pflege von JTL-Shop 2
In Bearbeitung Es ist ein Fehler aufgetreten JTL-POS - Fehler und Bugs 2
Neu Fehler OPC Produktstream Kategorien JTL-Shop - Fehler und Bugs 1
Neu Fehler beim Abgleich WooCommerce-Connector 0
Neu Fehler bei der Suche in der Version 4.05 geht nicht JTL-Shop - Fehler und Bugs 2
Gelöst Wawi 1.5.45 - Formulare - Rechnung - Email - Variantenwert ausgeben - wo liegt mein Fehler? O_O Gelöste Themen in diesem Bereich 1
Neu Leider gibt es nach wie vor Fehler bei der Ausgabe von Adressetiketten JTL-Wawi - Fehler und Bugs 0
Neu Fehler bei Installation der Community Free Version Einrichtung JTL-Shop5 2
Neu Fehler beim Abgleich des Shops Shopware-Connector 0
Neu Google Search Console Fehler auf Kategorieseiten Allgemeine Fragen zu JTL-Shop 6
Neu FTP / Media Fehler JTL-Shop - Fehler und Bugs 2
Neu Fehler aus der Amazon Schnittstelle Amazon-Anbindung - Fehler und Bugs 1
Neu Zahlungsmodul Fehler nach Update 1.5.34.0 auf 1.5.45.1 - Keine Liste erlaubter TAN-Verfahren erhalten JTL-Wawi - Fehler und Bugs 0
Neu Fehler nach dem Template-Cache leeren JTL-Shop - Fehler und Bugs 2
Neu Fehler bei starten von JTL Client JTL-Wawi - Fehler und Bugs 5
Neu Fehler im Header auf meiner Seite Allgemeine Fragen zu JTL-Shop 2
Neu Google Core Web Vitals - CLS Fehler JTL-Shop - Ideen, Lob und Kritik 3
Neu Connector Fehler "getTaxClassId()" Shopify-Connector 2
Neu Fehler 403 und keine Bildübertragung WooCommerce-Connector 0

Ähnliche Themen